Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 1091323 vezes)

josé roberto dos santos

  • Visitante
Modem smartilink no Ubuntu 6.06 alpha 6
« Resposta #135 Online: 20 de Maio de 2006, 10:54 »
:lol:  Caros amigos do forum alguem já conseguiu colocar o modem smartilink pra rodar no ubuntu 6 :?:



Se alguem conseguir fovor me notificar.

Grato pelas futuras informações

José Roberto.

alarcon

  • Visitante
Re: Ainda tenho uns pequenos problemas....
« Resposta #136 Online: 20 de Maio de 2006, 14:02 »
Citação de: "bgarber"
Olá!

Eu vi o tópico aqui no fórum e segui os passos indicados. Meu modem é o PCTel HSP56 AMR (clássico!).
Well, first thing: quando executo "modprobe slamr", o terminal me retorna um erro "Invalid module format".
Alguém pode me dizer o que eh isso?

second thing: ateh o problema anterior naum interfere muito (eu acho) na minha conexão. O certo eh que
eu consigo me conectar usando o gnome-ppp depois de reiniciar o micro. O problema eh que a conexão fica
caindo muito seguidamente. Tipo, conecta uns 10 min e cai. Às vezes o gnome-ppp nem se dah conta de que
a conexão caiu. Eu executo /sbin/ifconfig e ele não mostra mais o ppp0 e o gnome-ppp ainda diz que estou
conectado.

Muito Obrigado!


Bom algo de errado aconteceu na hora de gerar o módulo slamr.ko, vc seguiu exatamente como falei sem esquecer de nada?

Você usou o driver mais recente da Smartlink que disponibilizei o link no meu texto?

Veja direitinho se não ficou faltando fazer algum passo relatado por mim e se vc instalou todos os pacotes necessário para se compilar o driver do modem ou pegue o arquivo compactado que criei com tudo que é necessário para o modem e que instala tudo de uma forma automática.

Atenção que tudo que falei aqui é para o Ubuntu 5.10 Ok.

alarcon

  • Visitante
Re: instalação
« Resposta #137 Online: 20 de Maio de 2006, 14:06 »
Citação de: "matrix"
No final do script ele exibe uma menssagem slmodem... como comando não reconhecido, mas exibe a menssgem instalação concluida. Até ai esta correto?


Bom ninguém que já usou este pacote que fiz relatou algum tipo de erro com o mesmo.

você depois de usá-lo reiniciou o PC e tentou usar o modem para ver se estava funcionando?

Você poderia ser mais preciso na informação sobre as mensagens de erro que aparece para que eu possa avaliar o que aconteceu?

Veja se o arquivo baixado não chegou corrompido e se vc respondeu direitnho ao que é perguntado no momento da instalação Ok.

Offline csilva

  • Usuário Ubuntu
  • *
  • Mensagens: 125
    • Ver perfil
Modem hsp56 sis funcionando ubuntu5.10
« Resposta #138 Online: 20 de Maio de 2006, 18:42 »
Olá Alarcom,
Tô postando para dizer q seguindo seu tutorial estou conectando pelo ubuntu.
Embora acusou um erro na instalação manual, fiz a instalação pelo pocote deb. e foi sem problemas. Apenas tive que localizar o modem, não foi criado o link /dev/modem.
Tbm a conexão não estava muito estável, porém acho que isto é outro papo...

Valeu pelo seu bom (e incansável) trabalho!
Grato.
Conhecendo o Linux...

Offline bgarber

  • Usuário Ubuntu
  • *
  • Mensagens: 16
  • A Vida, O Universo e Tudo Mais
    • Ver perfil
Re: Ainda tenho uns pequenos problemas....
« Resposta #139 Online: 21 de Maio de 2006, 12:10 »
Citação de: "alarcon"
Bom algo de errado aconteceu na hora de gerar o módulo slamr.ko, vc seguiu exatamente como falei sem esquecer de nada?

Você usou o driver mais recente da Smartlink que disponibilizei o link no meu texto?

Veja direitinho se não ficou faltando fazer algum passo relatado por mim e se vc instalou todos os pacotes necessário para se compilar o driver do modem ou pegue o arquivo compactado que criei com tudo que é necessário para o modem e que instala tudo de uma forma automática.

Atenção que tudo que falei aqui é para o Ubuntu 5.10 Ok.


olá, meu amigo alarcon!

eu conferi tudinho! ateh o que eu usei para instalar foi o pacote por ti disponibilizado aqui no fórum. usei o script installl-modem e tudo o que deveria ser feito. Sinceramente, eu também não entendi por que aconteceu isso....

Obrigado

alarcon

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #140 Online: 21 de Maio de 2006, 12:18 »
Se alguém tentou usar o pacote que fiz cujo nome é modem-arquivos-v2.tar.gz e não obteve sucesso com o mesmo, eu resolvi fazer outro que agora usa o script chamado de sl-modem-daemon e também tem o ungrab-winmodem para aqueles casos que possam necessitar, portanto está mais abrangente.

o link é esse para quem quiser tentar com este outro:

http://prdownloads.sourceforge.net/projeto-messias/modem-arquivos-v4.tar.gz?download

Lembrando que caso vc já tenha usado o anterior sem sucesso, primeiro vc deverá fazer o seguinte:

abra um terminal e vire root:

sudo su

depois digite:

dpkg -r smartlink-ubuntu

isso irá desisntalar o driver antigo e depois reinicie o seu PC para que as alterações tenha efeito.

agora é só baixar o novo pacote que fiz descompactá-lo e seguir o que diz o arquivo Leia-me que tem nele.

Os passos são os mesmos do pacote antigo só mudando alguns nomes.

alarcon

  • Visitante
Re: Ainda tenho uns pequenos problemas....
« Resposta #141 Online: 21 de Maio de 2006, 12:23 »
Citação de: "bgarber"
olá, meu amigo alarcon!

eu conferi tudinho! ateh o que eu usei para instalar foi o pacote por ti disponibilizado aqui no fórum. usei o script installl-modem e tudo o que deveria ser feito. Sinceramente, eu também não entendi por que aconteceu isso....

Obrigado


Usa este novo pacote que fiz  logo aí em cima, que talvez seja melhor para vc.

Offline bgarber

  • Usuário Ubuntu
  • *
  • Mensagens: 16
  • A Vida, O Universo e Tudo Mais
    • Ver perfil
Re: Ainda tenho uns pequenos problemas....
« Resposta #142 Online: 21 de Maio de 2006, 12:48 »
Citação de: "alarcon"
Usa este novo pacote que fiz  logo aí em cima, que talvez seja melhor para vc.


valeu, kra!

vou testar o novo pacote e qualquer coisa que eu encontrar (tanto se der erro ou funcionar) eu posto aqui com todas as informações para ajudar o restante do pessoal que ainda não conseguiu...

Obrigado.
ps.: o sourceforge tah dando uns erros agora (não tou achando o arquivo para baixar). O sourceforge diz que eh um arquivo que foi upado recentemente e que pode naum ter em todos os mirrors, vou tentar mais tarde....  :)

alarcon

  • Visitante
Re: Ainda tenho uns pequenos problemas....
« Resposta #143 Online: 21 de Maio de 2006, 15:06 »
Citação de: "bgarber"
valeu, kra!

vou testar o novo pacote e qualquer coisa que eu encontrar (tanto se der erro ou funcionar) eu posto aqui com todas as informações para ajudar o restante do pessoal que ainda não conseguiu...

Obrigado.
ps.: o sourceforge tah dando uns erros agora (não tou achando o arquivo para baixar). O sourceforge diz que eh um arquivo que foi upado recentemente e que pode naum ter em todos os mirrors, vou tentar mais tarde....  :)


bom testando os mirrors encontrei este aqui que já tá funcionando:

http://superb-east.dl.sourceforge.net/sourceforge/projeto-messias/modem-arquivos-v4.tar.gz

Offline Servo

  • Usuário Ubuntu
  • *
  • Mensagens: 80
    • Ver perfil
    • eu e Cristo
Tutorial para HSP56 MR driver Smartlink
« Resposta #144 Online: 27 de Maio de 2006, 10:38 »
Caro Alarcon, uso Kubuntu, tenho seguido suas dicas e aconteram duas coisas interessantes. A primeira é que baixei os seus pacotes, fiz todo o recomendado, mas na hora de rodar o script ./nome do script.sh a resposta que tenho é que isso é um comando desconhecido. Ai tenho q fazer aquela instalação "padrão". A segunda coisa estranha é que tenho que fazer a instalação padrão + instalação do ungrab. Ai o moden pega , chega até a discar mas cai. Fui ver o q era, pois o kppp dizia ser um problema com o provedor e o estranho é q quanto clico no botão  "perguntar ao moden" meu moden está configurado com os padrões USA. O q faço?

Offline Servo

  • Usuário Ubuntu
  • *
  • Mensagens: 80
    • Ver perfil
    • eu e Cristo
Tutorial para HSP56 MR driver Smartlink
« Resposta #145 Online: 27 de Maio de 2006, 12:56 »
Alarcon, reinstalei o Kubuntu e alidado a um outro tutorial consegui fazer o danado funcionar, mas surgiu um outro problema. Configurei o kppp como faço no Kuruma, ele abre o moden, começa a discar, mas ele não conecta e aparece uma janela de erro dizendo q não pode conectar pq a senha não estava segura...Sempre acontece isso. E também acusa (quando em root) a falta de um aequivo chamado de resolv.conf ( este arquivo copiei o do kuruma e colei na devida pasta do Kubuntu e deu certo). O q devo fazer? A mensagem de erro é a seguinte:

May 27 13:29:58 localhost pppd[26168]: The remote system is required to authenticate itself
May 27 13:29:58 localhost pppd[26168]: but I couldn't find any suitable secret (password) for it to use to do so.
May 27 13:29:58 localhost pppd[26168]: (None of the available passwords would let it use an IP address.)

alarcon

  • Visitante
Tutorial para HSP56 MR driver Smartlink
« Resposta #146 Online: 27 de Maio de 2006, 14:38 »
Citação de: "Servo"
Alarcon, reinstalei o Kubuntu e alidado a um outro tutorial consegui fazer o danado funcionar, mas surgiu um outro problema. Configurei o kppp como faço no Kuruma, ele abre o moden, começa a discar, mas ele não conecta e aparece uma janela de erro dizendo q não pode conectar pq a senha não estava segura...Sempre acontece isso. E também acusa (quando em root) a falta de um aequivo chamado de resolv.conf. O q devo fazer?


Olha só os meus pacotes foram feitos para o Ubuntu com o Gnome e nele é usado o gdialog e/ou zenity nos scripts usados nos meus pacotes, ou seja, nas janelas gráficas que aparecem para vc ou informando algo ou pedindo uma certa informação  e como vc usa o Kubuntu que usa o KDE não sei se nele o gdialog e/ou zenity funciona e talvez o erro esteja aí pq já testei os pacotes várias vezes e outros usuários já usaram o mesmo sem problemas, mas lembre-se que vc tem de dar permissão de execução para o script e rodá-lo como root.

Com relação ao resolv.conf abra um terminal e faça isso:

sudo su

para virar root e depois isso:

chmod 666 /etc/resolv.conf
cp -f /etc/ppp/resolv.conf /etc/resolv.conf
chmod 666 /etc/resolv.conf

Também veja este dois arquivos chap-secrets e pap-secrets, ambos se encontram em /etc/ppp/ e vc deve colocar no final deles, se já não estiver,  o seguinte:

Citar
"fulano@provedor.com.br" * "abcdef"


Onde o nome em vermelho vc deve mudar para o seu nome de usuário do provedor e o nome em verde para a sua senha de acesso do provedor.

Atenção que vc deve digitar exatamente do jeito que está escrito (com as aspas, com o asterisco , com espaços e etc) só mudando o que falei à pouco.

Por fim lembre-se que vc deverá fazer todas estas alterações descritas aqui como usuário root e não como usuário comum. Caso vc não sabia como virar root dê o comando sudo su em um terminal.

Você usou o script sl-modem-daemon?

se a resposta for afirmativa en faça mais o seguinte:

sudo su

gedit /etc/default/sl-modem-daemon

e procure pelas seguintes linhas:

SLMODEMD_COUNTRY=USA

e

OPTS=" "

E mude-as para:

SLMODEMD_COUNTRY=BRAZIL

e

OPTS="--perm=0666"

Salve e saia e veja se agora o kppp funciona, mas mude lá nas configurações do kppp na parte sobre modem de /dev/modem para /dev/ttySL0

Offline bgarber

  • Usuário Ubuntu
  • *
  • Mensagens: 16
  • A Vida, O Universo e Tudo Mais
    • Ver perfil
Outros erros....
« Resposta #147 Online: 28 de Maio de 2006, 16:54 »
Olá amigo alarcon!

Kra, uma coisa eu consegui resolver: fazer com que o módulo slamr seja carregado. Antes ele acusava "Invalid Module Format". O que eu fiz: compilei o driver com o gcc 3.4! Eu tava compilando ele com o gcc 4.0 e (acho) que é por isso que ele acusava "Invalid Module Format". Já fica aqui o aviso para outros desavisados...  :D

Agora, minha conexão continua caindo muito! Eu baixei e instalei o nvo pacote que você disponibilizou aqui no fórum (o modem-arquivos-v4) com o ungrab_winmodem. Depois de reiniciar (como é pedido) eu percebi as seguinte coisas:

bgarber@dreamer:~$ cat /var/log/messages | grep slamr
[4294714.954000] slamr: module license 'Smart Link Ltd.' taints kernel.
[4294714.971000] slamr: SmartLink AMRMO modem.
[4294714.971000] slamr: device 1106:3068 is grabbed by another driver

Como pode ver, o modem continua "grabbed" por outro driver, que é o:
bgarber@dreamer:~$ lsmod | grep snd_via82xx_modem
snd_via82xx_modem      14500  5
snd_ac97_codec             72188  2 snd_via82xx_modem,snd_via82xx
snd_pcm                        78344  6 snd_via82xx_modem,snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_page_alloc               10120  3 snd_via82xx_modem,snd_via82xx,snd_pcm
snd                                48644  22 snd_via82xx_modem,snd_seq_oss,snd_seq,snd_via82xx,snd_ac97_codec

Como se percebe, o módulo que dah conflito com o slamr (snd_via82xx_modem) continua sendo carregado, ainda por cima o módulo slamr também é carregado:
bgarber@dreamer:~$ lsmod | grep slamr
slamr                 434088  0

Ao que me parece, ele é carregado mas naum é usado por ninguém (acho q seja isso)....

Ainda tem mais essa:
bgarber@dreamer:~$ lsmod | grep ungrab_winmodem
bgarber@dreamer:~$

O módulo ungrab_winmodem naum é carregado!

HELP ME!!!!!!!!!

alarcon

  • Visitante
Re: Outros erros....
« Resposta #148 Online: 28 de Maio de 2006, 17:42 »
Citação de: "bgarber"
Olá amigo alarcon!

Kra, uma coisa eu consegui resolver: fazer com que o módulo slamr seja carregado. Antes ele acusava "Invalid Module Format". O que eu fiz: compilei o driver com o gcc 3.4! Eu tava compilando ele com o gcc 4.0 e (acho) que é por isso que ele acusava "Invalid Module Format". Já fica aqui o aviso para outros desavisados...  :D

Agora, minha conexão continua caindo muito! Eu baixei e instalei o nvo pacote que você disponibilizou aqui no fórum (o modem-arquivos-v4) com o ungrab_winmodem. Depois de reiniciar (como é pedido) eu percebi as seguinte coisas:

bgarber@dreamer:~$ cat /var/log/messages | grep slamr
[4294714.954000] slamr: module license 'Smart Link Ltd.' taints kernel.
[4294714.971000] slamr: SmartLink AMRMO modem.
[4294714.971000] slamr: device 1106:3068 is grabbed by another driver

Como pode ver, o modem continua "grabbed" por outro driver, que é o:
bgarber@dreamer:~$ lsmod | grep snd_via82xx_modem
snd_via82xx_modem      14500  5
snd_ac97_codec             72188  2 snd_via82xx_modem,snd_via82xx
snd_pcm                        78344  6 snd_via82xx_modem,snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_page_alloc               10120  3 snd_via82xx_modem,snd_via82xx,snd_pcm
snd                                48644  22 snd_via82xx_modem,snd_seq_oss,snd_seq,snd_via82xx,snd_ac97_codec

Como se percebe, o módulo que dah conflito com o slamr (snd_via82xx_modem) continua sendo carregado, ainda por cima o módulo slamr também é carregado:
bgarber@dreamer:~$ lsmod | grep slamr
slamr                 434088  0

Ao que me parece, ele é carregado mas naum é usado por ninguém (acho q seja isso)....

Ainda tem mais essa:
bgarber@dreamer:~$ lsmod | grep ungrab_winmodem
bgarber@dreamer:~$

O módulo ungrab_winmodem naum é carregado!

HELP ME!!!!!!!!!


Olha só este ultimo pacote aí faz tudo, ou seja, se for o caso do ALSA ele usa ele se não for ele, usa a forma tradicional de instalação do driver não precisa mais se preocupar com os módulos que eu falo no meu texto principal.

Com relação ao ungrab-winmodem ele não tá ativo pq vc não precisa dele ativado pois só seria necessário usá-lo no caso de aparecer um mensagem assim:

Citar
...is grabbed by driver serial


e não assim:

Citar
....is grabbed by another driver


Este segundo caso indica que um dos módulos falados por mim está presente no seu sistema e aí vc teria de usar a forma ALSA, mas o script chamado de sl-modem-daemon que tem neste pacote faz esta verificação ok.

Vc pode ver se usa a forma ALSA digitando:

ps -aux | grep slmodemd

e se retorna algo assim(por exemplo):

slmodemd -c BRAZIL --alsa --perm=0666 modem:1

é a forma alsa caso contrário se for assim:

slmodemd -c BRAZIL --perm=0666 /dev/slamr0

é a forma tradicional de instalação do driver Smartlink

Offline bgarber

  • Usuário Ubuntu
  • *
  • Mensagens: 16
  • A Vida, O Universo e Tudo Mais
    • Ver perfil
Re: Outros erros....
« Resposta #149 Online: 28 de Maio de 2006, 18:32 »
Citação de: "alarcon"
Este segundo caso indica que um dos módulos falados por mim está presente no seu sistema e aí vc teria de usar a forma ALSA, mas o script chamado de sl-modem-daemon que tem neste pacote faz esta verificação ok.

Vc pode ver se usa a forma ALSA digitando:

ps -aux | grep slmodemd

e se retorna algo assim(por exemplo):

slmodemd -c BRAZIL --alsa --perm=0666 modem:1

é a forma alsa caso contrário se for assim:

slmodemd -c BRAZIL --perm=0666 /dev/slamr0

é a forma tradicional de instalação do driver Smartlink


Olá amigo Alarcon!

kra, eu verifiquei aqui como você recomendou e ele me retorna isto:
slmodemd -c BRAZIL --alsa --perm=0666 modem:1

no caso, ele usa a forma ALSA.