Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 978728 vezes)

Offline Chao

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #255 Online: 29 de Outubro de 2006, 21:00 »
Eu segui o tutorial à risca, mas quando tento me comunicar com o modem
recebo a mensagem de que ele está ocupado.
Vou tentar instalar o ungrab-winmodem pra ver se eh isso...
O que pode ser??

Offline Chao

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #256 Online: 29 de Outubro de 2006, 21:32 »
Eu segui o tutorial à risca, mas quando tento me comunicar com o modem
recebo a mensagem de que ele está ocupado.
Vou tentar instalar o ungrab-winmodem pra ver se eh isso...
O que pode ser??

Pelo jeito não é problema de outros drivers.
Vai aí meus arquivos:

o init do modem:
Código: [Selecionar]
#!/bin/bash

. /lib/lsb/init-functions

case "$1" in
start)
log_begin_msg "Iniciando o modem SmartLink..."
ln -sf /dev/slamr0 /dev/modem
slmodemd --country=BRAZIL --perm=0666 /dev/slamr0 &
;;
stop)
log_begin_msg "Parando o modem SmartLink..."
killall slmodemd
;;
restart)
$0 stop
$0 start
;;
esac
exit 0
O módulo eu carrego no /etc/modules

O dmesg parece normal...
Código: [Selecionar]
[4295355.663000] slamr: SmartLink AMRMO modem.
[4295355.674000] slamr: probe 2000:2800 SL2800 card...
[4295355.675000] slamr: slamr0 is SL2800 card.

Esse é o erro que da quando tento comunicar com o modem:
Código: [Selecionar]
--> WvDial: Internet dialer version 1.54.0
--> Warning: section [Dialer Defaults] does not exist in wvdial.conf.
--> Cannot open /dev/modem: Device or resource busy
--> Cannot open /dev/modem: Device or resource busy
--> Cannot open /dev/modem: Device or resource busy

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #257 Online: 29 de Outubro de 2006, 22:05 »
Eu segui o tutorial à risca, mas quando tento me comunicar com o modem
recebo a mensagem de que ele está ocupado.
Vou tentar instalar o ungrab-winmodem pra ver se eh isso...
O que pode ser??

Pelo jeito não é problema de outros drivers.
Vai aí meus arquivos:

o init do modem:
Código: [Selecionar]
#!/bin/bash

. /lib/lsb/init-functions

case "$1" in
start)
log_begin_msg "Iniciando o modem SmartLink..."
ln -sf /dev/slamr0 /dev/modem
slmodemd --country=BRAZIL --perm=0666 /dev/slamr0 &
;;
stop)
log_begin_msg "Parando o modem SmartLink..."
killall slmodemd
;;
restart)
$0 stop
$0 start
;;
esac
exit 0
O módulo eu carrego no /etc/modules

O dmesg parece normal...
Código: [Selecionar]
[4295355.663000] slamr: SmartLink AMRMO modem.
[4295355.674000] slamr: probe 2000:2800 SL2800 card...
[4295355.675000] slamr: slamr0 is SL2800 card.

Esse é o erro que da quando tento comunicar com o modem:
Código: [Selecionar]
--> WvDial: Internet dialer version 1.54.0
--> Warning: section [Dialer Defaults] does not exist in wvdial.conf.
--> Cannot open /dev/modem: Device or resource busy
--> Cannot open /dev/modem: Device or resource busy
--> Cannot open /dev/modem: Device or resource busy

Bom qual é a versão do Ubuntu que vc usa?

Vc tem instalado o gnome-ppp?

Por que vc não usa algum dos pacotes que fiz (desde que vc use no máximo até o ubuntu dapper)

nunca falei nada sobre este init-functions que vc postou anteriormente, mas vejo algo errado nele.

esta linha:

ln -sf /dev/slamr0 /dev/modem

na verdade o que vc faz o link é disto aqui:

ln -sf /dev/ttySL0 /dev/modem


na verdade o dispositivo usado por qualquer discador deve ser o /dev/ttySL0 se não for possível usar ele aí vc faz o link /dev/modem apontar pra ele.

Para finalizar a ordem é essa:

slmodemd --country=BRAZIL --perm=0666 /dev/slamr0 &
ln -sf /dev/ttySL0 /dev/modem

e não o contrário.
« Última modificação: 29 de Outubro de 2006, 22:08 por alarcon »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #258 Online: 29 de Outubro de 2006, 22:14 »
Bom vamos lá, como eu ainda tenho fortes raizes com o (RUINDOWS) baixo tudo q

Desculpe-me a ignorância mais não entendi nada do que você quis dizer no seu texto aí de cima.

Offline raci0nal

  • Usuário Ubuntu
  • *
  • Mensagens: 15
  • Marcos Jordão''
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #259 Online: 30 de Outubro de 2006, 00:04 »
Para quem já está mudando para o Edgy Eft (6.10), eu consegui fazer o meu funcionar com este procedimento:
http://ubuntuforum-pt.org/index.php?topic=12420.0

Abraços

Marcos Antonio Campos Jordão''

Offline Chao

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #260 Online: 30 de Outubro de 2006, 01:49 »
Citar
Bom qual é a versão do Ubuntu que vc usa?

Vc tem instalado o gnome-ppp?

Por que vc não usa algum dos pacotes que fiz (desde que vc use no máximo até o ubuntu dapper)

nunca falei nada sobre este init-functions que vc postou anteriormente, mas vejo algo errado nele.

esta linha:

ln -sf /dev/slamr0 /dev/modem

na verdade o que vc faz o link é disto aqui:

ln -sf /dev/ttySL0 /dev/modem


na verdade o dispositivo usado por qualquer discador deve ser o /dev/ttySL0 se não for possível usar ele aí vc faz o link /dev/modem apontar pra ele.

Para finalizar a ordem é essa:

slmodemd --country=BRAZIL --perm=0666 /dev/slamr0 &
ln -sf /dev/ttySL0 /dev/modem

e não o contrário.

Estou com o Ubuntu 5.10.
Usei o mesmo estilo dos arquivos em /etc/init.d, pra ficar mais padrão :)
Troquei a ordem e funcionou!
Valeu mesmo! Muito bom o tutorial!

Só estou com um problema que a conexão cai toda hora, tipo a cada 2 minutos mais ou menos...
Alguém tem o mesmo problema?

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #261 Online: 02 de Novembro de 2006, 08:58 »
Citar
Bom qual é a versão do Ubuntu que vc usa?

Vc tem instalado o gnome-ppp?

Por que vc não usa algum dos pacotes que fiz (desde que vc use no máximo até o ubuntu dapper)

nunca falei nada sobre este init-functions que vc postou anteriormente, mas vejo algo errado nele.

esta linha:

ln -sf /dev/slamr0 /dev/modem

na verdade o que vc faz o link é disto aqui:

ln -sf /dev/ttySL0 /dev/modem


na verdade o dispositivo usado por qualquer discador deve ser o /dev/ttySL0 se não for possível usar ele aí vc faz o link /dev/modem apontar pra ele.

Para finalizar a ordem é essa:

slmodemd --country=BRAZIL --perm=0666 /dev/slamr0 &
ln -sf /dev/ttySL0 /dev/modem

e não o contrário.

Estou com o Ubuntu 5.10.
Usei o mesmo estilo dos arquivos em /etc/init.d, pra ficar mais padrão :)
Troquei a ordem e funcionou!
Valeu mesmo! Muito bom o tutorial!

Só estou com um problema que a conexão cai toda hora, tipo a cada 2 minutos mais ou menos...
Alguém tem o mesmo problema?

Bom se vc usa o gnome-ppp então faça o seguinte:

abra um terminal e digite

gedit .wvdial.conf

isto irá abrir o arquivo de configuração do gnome-ppp e então na linha que contém isso:

Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0

vc muda pra isso:

Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=34

e veja se agora sua conexão está mais estável.

Se continuar ruim tente esta outra opção:

Init2 = ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0

Obs: alguns modem requerem que a opção verificar portadora esteja desmarcada na configuração do gnome-ppp ( Configuração > aba opções).

Offline rafael###

  • Usuário Ubuntu
  • *
  • Mensagens: 154
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #262 Online: 02 de Novembro de 2006, 23:10 »
Gente eu consegui instalar meu modem normalz no Dapper agora no Edgy ta difícil... não consigo "makear" meu drive:

Citar
rafael@zion:/media/hdb1/.MeuModemD/slmodem-2.9.11-20051101$ make
make -C modem all
make[1]: Entrando no diretório `/media/hdb1/.MeuModemD/slmodem-2.9.11-20051101/modem'
make[1]: Saindo do diretório `/media/hdb1/.MeuModemD/slmodem-2.9.11-20051101/modem'
make -C drivers KERNEL_DIR=/lib/modules/2.6.17-10-generic/build
make[1]: Entrando no diretório `/media/hdb1/.MeuModemD/slmodem-2.9.11-20051101/drivers'
cc -I/lib/modules/2.6.17-10-generic/build/include -o kernel-ver kernel-ver.c
make all KERNEL_VER=2.6.17-10-generic
make[2]: Entrando no diretório `/media/hdb1/.MeuModemD/slmodem-2.9.11-20051101/drivers'
make modules -C /lib/modules/2.6.17-10-generic/build SUBDIRS=/media/hdb1/.MeuModemD/slmodem-2.9.11-20051101/drivers
make[3]: Entrando no diretório `/usr/src/linux-headers-2.6.17-10-generic'
  CC [M]  /media/hdb1/.MeuModemD/slmodem-2.9.11-20051101/drivers/amrmo_init.o
/media/hdb1/.MeuModemD/slmodem-2.9.11-20051101/drivers/amrmo_init.c:704: error: expected ) before string constant
make[4]: ** [/media/hdb1/.MeuModemD/slmodem-2.9.11-20051101/drivers/amrmo_init.o] Erro 1
make[3]: ** [_module_/media/hdb1/.MeuModemD/slmodem-2.9.11-20051101/drivers] Erro 2
make[3]: Saindo do diretório `/usr/src/linux-headers-2.6.17-10-generic'
make[2]: ** [all] Erro 2
make[2]: Saindo do diretório `/media/hdb1/.MeuModemD/slmodem-2.9.11-20051101/drivers'
make[1]: ** [all] Erro 2
make[1]: Saindo do diretório `/media/hdb1/.MeuModemD/slmodem-2.9.11-20051101/drivers'
make: ** [drivers] Erro 2

Alguém ae sabe como resolver isso???

PS: Instalei todos os pacotes necessários na versão do Edgy é claro, mas uma mudança notável que percebi é que o pacote build-essential do Edgy não precisa do pacote linux-kernel-headers para funcionar, ele não tem ligação com esse pacote e quando tento instalá-lo ele entra em conflito com outro pacote dependente do build-essential, ressaltando que o meu pacote build-essential jah está instalado e funcional o comando:

#dpkg -C

Não retorna nenhum pacote quebrado!


Obrigado!!



GNU/Linux e SL um novo estilo de vida!!!!!!!!!!

Offline rafael###

  • Usuário Ubuntu
  • *
  • Mensagens: 154
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #263 Online: 03 de Novembro de 2006, 10:50 »
Já resolvi quem quiser ajuda com isso me mande mensagens !!!
To conectado pelo edgy agora!

flws!!



GNU/Linux e SL um novo estilo de vida!!!!!!!!!!

Offline hugleo

  • Usuário Ubuntu
  • *
  • Mensagens: 49
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #264 Online: 04 de Novembro de 2006, 14:18 »
Pode explicar como conseguiu? Os passos de compilação são os mesmos do alarcon, certo? E pra configurar o arquivo "secrets" como você disse? Se pude explicar com mais detalhes eu e mais um colega aqui agradeceríamos.

Offline aleksandre

  • Usuário Ubuntu
  • *
  • Mensagens: 92
  • The future is open
    • Ver perfil
    • Google Profile
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #265 Online: 04 de Novembro de 2006, 17:11 »
Hugleo,

O Raci0nal abriu um tópico descrevendo os passos para o Edgy. Veja em http://ubuntuforum-pt.org/index.php?topic=12420.0!
Não estou usando o Edgy, ainda, mas passei as dicas do Raci0nal para uns amigos bolivianos e todos reportaram sucesso!
Até!

Offline rafael###

  • Usuário Ubuntu
  • *
  • Mensagens: 154
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #266 Online: 07 de Novembro de 2006, 19:53 »
Pode explicar como conseguiu? Os passos de compilação são os mesmos do alarcon, certo? E pra configurar o arquivo "secrets" como você disse? Se pude explicar com mais detalhes eu e mais um colega aqui agradeceríamos.

Seguinte hugleo ... tem um arquivo chamado /etc/ppp/pap-secrets e outro chamado /etc/ppp/chap-secrets

Vc tem q configurá-los assim na última linha:

Citar
"user@provedor" * "senha"

Nos dois!!! E lembrando q no exemplo acima é apenas um mero modo de demonstrar como ficará a última linha no meu caso ficou assim:

Citar
"rafael_henriqu@itelefonica.com.br" * "minhasenha"

E para o Ubuntu Edgy Eft eu compilei esse drive aki:

http://linmodems.technion.ac.il/packages/smartlink/slmodem-2.9.11-20060727.tar.gz

para subir o slmodemd, e este outro:

http://linmodems.technion.ac.il/packages/smartlink/ungrab-winmodem.tar.gz

para subir o ungrab_winmodem!!

Se vc seguir o tutorial do alarcon e trocar os pacotes dele por estes q te digo dará certinho sem problemas!!! Eu até não sei c o alarcon jah atualizou o tutorial para esses pacotes, não tive tempo de ver, mas c vc seguir o tutorial do cara c chega lá, ta mt bem escrito, parabéns alarcon novamente!


flw!! t mais!!


PS: Qualquer dúvida pode contar comigo, é só joga a resposta ae!!



GNU/Linux e SL um novo estilo de vida!!!!!!!!!!

Offline gaucho.online

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #267 Online: 12 de Novembro de 2006, 14:26 »
E a versão 6.10como ela é em relação a isso? não evolui nada?


Essas informações você deixa em todos os sites que visita.

Offline rafael###

  • Usuário Ubuntu
  • *
  • Mensagens: 154
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #268 Online: 14 de Novembro de 2006, 15:07 »
Citar
E a versão 6.10como ela é em relação a isso? não evolui nada?

Bom gaucho.online se o "isso" q vc se refere é aos arquivos pap-secrets e chap-secrets não muda em nada no 6.10!

flws



GNU/Linux e SL um novo estilo de vida!!!!!!!!!!

Offline karamazov

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #269 Online: 15 de Novembro de 2006, 01:40 »
Colegas..

Como todos aqui eu sofri para instalar essa bost@ de modem design for windows ...aargh !

Mas agora tento instalar em uma outra máquina:
cujo o comando lspci -d  1039:7013 no dá ->

 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller

Tentei o script "Projeto Messias" do Alarcon.
e tudo ocorre "bem", mas na hora de conectar aparece: No Dial Tone

não sei o que pode ser ... não é modem ...nem linha....porque pelo win é possível conectar....

Pelo GnomePPP > Configurações > Detectar Modem : Acha o modem...
mas como disse sempre dá No Dial Tone...

só me resta agora recorrer ao Santo Alarcon....
por favor alguêm pode me ajudar ?