Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 1169905 vezes)

Offline Sergio Morgado

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #480 Online: 08 de Agosto de 2007, 22:11 »
OK!! Alarcon,

Vou fazer isso pra ver se resolve.

Offline Sergio Morgado

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #481 Online: 09 de Agosto de 2007, 16:28 »
Alarcon,

Continuou a dar os mesmos erros.  ???

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #482 Online: 09 de Agosto de 2007, 16:34 »
Alarcon,

Continuou a dar os mesmos erros.  ???

Faz o seguinte abre um terminal e copia e cola isso aqui:

kdialog --title "Configuração do Kppp" --inputbox "Entre com o número de acesso do seu Provedor, separe por dois pontos se tiver mais de um
Ex: 1500200:15002808:15002800"


depois tecle ENTER e veja se aparece uma janela. Atenção que estas 3 linhas em negrito acima é como se fosse uma linha só por issso o copie e cole (as três linhas ao mesmo tempo) ok.

Agora com o terminal aberto digite:

sudo su

depois sua senha e copie e cole novamente isso:

kdialog --title "Configuração do Kppp" --inputbox "Entre com o número de acesso do seu Provedor, separe por dois pontos se tiver mais de um
Ex: 1500200:15002808:15002800"


depois tecle ENTER e veja se aparece uma janela. Atenção que estas 3 linhas em negrito acima é como se fosse uma linha só por issso o copie e cole (as três linhas ao mesmo tempo) ok.

Se tudo ocorrer bem com o terminal aberto como usuário comum e ocorrer alguma falha como root é por que no kubuntu tem alguma restrição ao rodar algo gráfico via termianl como root e este meu script precisa ser rodado como root.
« Última modificação: 09 de Agosto de 2007, 16:41 por alarcon »

Offline POTIGUAR_

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #483 Online: 09 de Agosto de 2007, 23:05 »
opa! faz uns 2 meses q eu luto p/ funcionar meu modem no linux e nunca consigo! da esse erro qnd vou compilar o driver!

ebian:/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101# make
make -C modem all
make[1]: Entrando no diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/modem'
rebuild profile...
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_main.o -c modem_main.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_cmdline.o -c modem_cmdline.cgcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem.o -c modem.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_datafile.o -c modem_datafile.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_at.o -c modem_at.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_timer.o -c modem_timer.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_pack.o -c modem_pack.c
modem_pack.c: In function ‘modem_async_get_bits’:
modem_pack.c:100: warning: pointer targets in passing argument 2 of ‘m->get_chars’ differ in signedness
modem_pack.c: In function ‘modem_async_put_bits’:
modem_pack.c:148: warning: pointer targets in passing argument 2 of ‘m->put_chars’ differ in signedness
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_ec.o -c modem_ec.c
modem_ec.c: In function ‘tx_info’:
modem_ec.c:723: warning: pointer targets in passing argument 2 of ‘l->modem->get_chars’ differ in signedness
modem_ec.c: In function ‘push_rest_data’:
modem_ec.c:811: warning: pointer targets in passing argument 2 of ‘l->modem->put_chars’ differ in signedness
modem_ec.c: In function ‘rx_info’:
modem_ec.c:860: warning: pointer targets in passing argument 2 of ‘l->modem->put_chars’ differ in signedness
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_comp.o -c modem_comp.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_param.o -c modem_param.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_debug.o -c modem_debug.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o homolog_data.o -c homolog_data.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o dp_sinus.o -c dp_sinus.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o dp_dummy.o -c dp_dummy.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o sysdep_common.o -c sysdep_common.cgcc  -o slmodemd modem_main.o modem_cmdline.o modem.o modem_datafile.o modem_at.o modem_timer.o modem_pack.o modem_ec.o modem_comp.o modem_param.o modem_debug.o homolog_data.o dp_sinus.o dp_dummy.o dsplibs.o sysdep_common.o
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_test.o -c modem_test.c
gcc  -o modem_test modem_test.o modem_cmdline.o modem.o modem_datafile.o modem_at.o modem_timer.o modem_pack.o modem_ec.o modem_comp.o modem_param.o modem_debug.o homolog_data.o dp_sinus.o dp_dummy.o dsplibs.o sysdep_common.o
make[1]: Saindo do diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/modem'
make -C drivers KERNEL_DIR=/lib/modules/2.6.17-2-k7/build
make[1]: Entrando no diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers'
cc -I/lib/modules/2.6.17-2-k7/build/include -o kernel-ver kernel-ver.c
make all KERNEL_VER=2.6.18
make[2]: Entrando no diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers'
make modules -C /lib/modules/2.6.17-2-k7/build SUBDIRS=/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers
make: Entering an unknown directory
make: *** /lib/modules/2.6.17-2-k7/build: Arquivo ou diretório não encontrado. Pare.
make: Leaving an unknown directory
make[2]: ** [all] Erro 2
make[2]: Saindo do diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers'
make[1]: ** [all] Erro 2
make[1]: Saindo do diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers'
make: ** [drivers] Erro 2
debian:/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101#



Meu Modem é - Smart Link Ltd.: Unknown device 2800 (rev 02) (lspci)

OBS - Me animei pq um amigo do forum conseguiu com esse modem! e com esse tutorial...!

me ajudem por favor! t+!



alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #484 Online: 10 de Agosto de 2007, 10:51 »
opa! faz uns 2 meses q eu luto p/ funcionar meu modem no linux e nunca consigo! da esse erro qnd vou compilar o driver!

ebian:/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101# make
make -C modem all
make[1]: Entrando no diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/modem'
rebuild profile...
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_main.o -c modem_main.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_cmdline.o -c modem_cmdline.cgcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem.o -c modem.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_datafile.o -c modem_datafile.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_at.o -c modem_at.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_timer.o -c modem_timer.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_pack.o -c modem_pack.c
modem_pack.c: In function ‘modem_async_get_bits’:
modem_pack.c:100: warning: pointer targets in passing argument 2 of ‘m->get_chars’ differ in signedness
modem_pack.c: In function ‘modem_async_put_bits’:
modem_pack.c:148: warning: pointer targets in passing argument 2 of ‘m->put_chars’ differ in signedness
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_ec.o -c modem_ec.c
modem_ec.c: In function ‘tx_info’:
modem_ec.c:723: warning: pointer targets in passing argument 2 of ‘l->modem->get_chars’ differ in signedness
modem_ec.c: In function ‘push_rest_data’:
modem_ec.c:811: warning: pointer targets in passing argument 2 of ‘l->modem->put_chars’ differ in signedness
modem_ec.c: In function ‘rx_info’:
modem_ec.c:860: warning: pointer targets in passing argument 2 of ‘l->modem->put_chars’ differ in signedness
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_comp.o -c modem_comp.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_param.o -c modem_param.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_debug.o -c modem_debug.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o homolog_data.o -c homolog_data.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o dp_sinus.o -c dp_sinus.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o dp_dummy.o -c dp_dummy.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o sysdep_common.o -c sysdep_common.cgcc  -o slmodemd modem_main.o modem_cmdline.o modem.o modem_datafile.o modem_at.o modem_timer.o modem_pack.o modem_ec.o modem_comp.o modem_param.o modem_debug.o homolog_data.o dp_sinus.o dp_dummy.o dsplibs.o sysdep_common.o
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_test.o -c modem_test.c
gcc  -o modem_test modem_test.o modem_cmdline.o modem.o modem_datafile.o modem_at.o modem_timer.o modem_pack.o modem_ec.o modem_comp.o modem_param.o modem_debug.o homolog_data.o dp_sinus.o dp_dummy.o dsplibs.o sysdep_common.o
make[1]: Saindo do diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/modem'
make -C drivers KERNEL_DIR=/lib/modules/2.6.17-2-k7/build
make[1]: Entrando no diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers'
cc -I/lib/modules/2.6.17-2-k7/build/include -o kernel-ver kernel-ver.c
make all KERNEL_VER=2.6.18
make[2]: Entrando no diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers'
make modules -C /lib/modules/2.6.17-2-k7/build SUBDIRS=/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers
make: Entering an unknown directory
make: *** /lib/modules/2.6.17-2-k7/build: Arquivo ou diretório não encontrado. Pare.
make: Leaving an unknown directory
make[2]: ** [all] Erro 2
make[2]: Saindo do diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers'
make[1]: ** [all] Erro 2
make[1]: Saindo do diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers'
make: ** [drivers] Erro 2
debian:/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101#



Meu Modem é - Smart Link Ltd.: Unknown device 2800 (rev 02) (lspci)

OBS - Me animei pq um amigo do forum conseguiu com esse modem! e com esse tutorial...!

me ajudem por favor! t+!




Qual distribuição linux você usa e em que versão?

Mas o que aparentemente é o seu erro é o seguinte, na pasta /lib/modules/2.6.17-2-k7/ deveria ter um link build, por sua vez este link direcionaria para o linux-headers ou linux source (vai depender da sua distro) de mesma versão do seu kernel (2.6.17-2-k7) na pasta /usr/src/.

Note que o meu pacote modem-arquivos-v16.tar.gz (ou as outras versões) só pode ser usado por quem usa o Ubuntu.
« Última modificação: 10 de Agosto de 2007, 10:54 por alarcon »

Offline Sergio Morgado

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #485 Online: 10 de Agosto de 2007, 11:36 »
Alarcon,

Como usuário comum, deu o seguinte erro (mas apareceu a janela):

Citar
X Error: BadDevice, invalid or uninitialized input device 169
   Major opcode:  145
   Minor opcode:   3
   Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
   Major opcode:  145
   Minor opcode:  3
   Resource id:  0x0
Failed to pone device

Já como Root deu o seguinte erro (e não apareceu a janela):

Citar
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kdialog: canoot connect to X server :0.0

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #486 Online: 10 de Agosto de 2007, 11:51 »
Alarcon,

Como usuário comum, deu o seguinte erro (mas apareceu a janela):

Citar
X Error: BadDevice, invalid or uninitialized input device 169
   Major opcode:  145
   Minor opcode:   3
   Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
   Major opcode:  145
   Minor o

pcode:  3
   Resource id:  0x0
Failed to pone device

Já como Root deu o seguinte erro (e não apareceu a janela):

Citar
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kdialog: canoot connect to X server :0.0

Isso que apareceu como usuário comum não é erro não, é só o terminal trabalhando com a interface gráfica.

Já como root é o que eu suspeitava. Veja: digite kwrite no terminal como usuário comum e depois como root. Como root irá falhar também, pois parece que pelo usuário comum você não tem permissão de executar algo gráfico via terminal.


Veja se o que falei aqui:

http://ubuntuforum-pt.org/index.php/topic,23247.msg132701.html#msg132701

resolve o seu problema.
« Última modificação: 10 de Agosto de 2007, 11:54 por alarcon »

Offline POTIGUAR_

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #487 Online: 10 de Agosto de 2007, 16:26 »
opa! faz uns 2 meses q eu luto p/ funcionar meu modem no linux e nunca consigo! da esse erro qnd vou compilar o driver!

ebian:/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101# make
make -C modem all
make[1]: Entrando no diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/modem'
rebuild profile...
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_main.o -c modem_main.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_cmdline.o -c modem_cmdline.cgcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem.o -c modem.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_datafile.o -c modem_datafile.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_at.o -c modem_at.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_timer.o -c modem_timer.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_pack.o -c modem_pack.c
modem_pack.c: In function ‘modem_async_get_bits’:
modem_pack.c:100: warning: pointer targets in passing argument 2 of ‘m->get_chars’ differ in signedness
modem_pack.c: In function ‘modem_async_put_bits’:
modem_pack.c:148: warning: pointer targets in passing argument 2 of ‘m->put_chars’ differ in signedness
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_ec.o -c modem_ec.c
modem_ec.c: In function ‘tx_info’:
modem_ec.c:723: warning: pointer targets in passing argument 2 of ‘l->modem->get_chars’ differ in signedness
modem_ec.c: In function ‘push_rest_data’:
modem_ec.c:811: warning: pointer targets in passing argument 2 of ‘l->modem->put_chars’ differ in signedness
modem_ec.c: In function ‘rx_info’:
modem_ec.c:860: warning: pointer targets in passing argument 2 of ‘l->modem->put_chars’ differ in signedness
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_comp.o -c modem_comp.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_param.o -c modem_param.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_debug.o -c modem_debug.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o homolog_data.o -c homolog_data.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o dp_sinus.o -c dp_sinus.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o dp_dummy.o -c dp_dummy.c
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o sysdep_common.o -c sysdep_common.cgcc  -o slmodemd modem_main.o modem_cmdline.o modem.o modem_datafile.o modem_at.o modem_timer.o modem_pack.o modem_ec.o modem_comp.o modem_param.o modem_debug.o homolog_data.o dp_sinus.o dp_dummy.o dsplibs.o sysdep_common.o
gcc -Wall -g -O -I. -DCONFIG_DEBUG_MODEM   -o modem_test.o -c modem_test.c
gcc  -o modem_test modem_test.o modem_cmdline.o modem.o modem_datafile.o modem_at.o modem_timer.o modem_pack.o modem_ec.o modem_comp.o modem_param.o modem_debug.o homolog_data.o dp_sinus.o dp_dummy.o dsplibs.o sysdep_common.o
make[1]: Saindo do diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/modem'
make -C drivers KERNEL_DIR=/lib/modules/2.6.17-2-k7/build
make[1]: Entrando no diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers'
cc -I/lib/modules/2.6.17-2-k7/build/include -o kernel-ver kernel-ver.c
make all KERNEL_VER=2.6.18
make[2]: Entrando no diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers'
make modules -C /lib/modules/2.6.17-2-k7/build SUBDIRS=/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers
make: Entering an unknown directory
make: *** /lib/modules/2.6.17-2-k7/build: Arquivo ou diretório não encontrado. Pare.
make: Leaving an unknown directory
make[2]: ** [all] Erro 2
make[2]: Saindo do diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers'
make[1]: ** [all] Erro 2
make[1]: Saindo do diretório `/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101/drivers'
make: ** [drivers] Erro 2
debian:/home/dennis/Desktop/tutu-final/slmodem-2.9.11-20051101#



Meu Modem é - Smart Link Ltd.: Unknown device 2800 (rev 02) (lspci)

OBS - Me animei pq um amigo do forum conseguiu com esse modem! e com esse tutorial...!

me ajudem por favor! t+!




Qual distribuição linux você usa e em que versão?

Mas o que aparentemente é o seu erro é o seguinte, na pasta /lib/modules/2.6.17-2-k7/ deveria ter um link build, por sua vez este link direcionaria para o linux-headers ou linux source (vai depender da sua distro) de mesma versão do seu kernel (2.6.17-2-k7) na pasta /usr/src/.

Note que o meu pacote modem-arquivos-v16.tar.gz (ou as outras versões) só pode ser usado por quem usa o Ubuntu.


bem eu nao uso ubuntu.. ja migrei pro debian(etch4.0) p/ ve se dava p/ instalar... o kernel é 2.6.17-2-k7

espero resposta. t+

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #488 Online: 10 de Agosto de 2007, 17:12 »
Citar
bem eu nao uso ubuntu.. ja migrei pro debian(etch4.0) p/ ve se dava p/ instalar... o kernel é 2.6.17-2-k7

espero resposta. t+

Bom antes de se compilar algo você tem de ter os pacotes necessário para o processo de compilação, tipo: make, gcc, build-essential, linux-headers-2.6.17-2-k7 (veja se existe isso aí no debian) e mais outros como o libasound, libasound-dev e o gnome-ppp (o discador, caso use Gnome). Só depois é que você deve usar o driver Smartlink para se compilar.

Não posso falar muito do Debian por que nunca instalei ele aqui e portanto meu pacote não é adequado para o mesmo, entretanto se você entende de shell script pode ver como é que eu faço no meu script install-modem.sh e fazer as adaptações para instalar os pacotes .deb equivalentes no Debian e para executar a compilação do driver Smartlink .

OBS: Se você instalar o Ubuntu 7.04 e seu modem for realmente um que usa o driver Smartlink, suas chances de fazer o mesmo funcionar com o meu pacote chamado de modem-arquivos-v16.tar.gz são grandes. Outra coisa há usuário no qual para o seu modem basta instalar o pacote .deb sl-modem-daemon, por tanto veja se não é este o seu caso.
« Última modificação: 12 de Agosto de 2007, 17:19 por alarcon »

Offline POTIGUAR_

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #489 Online: 12 de Agosto de 2007, 17:09 »
Citar
bem eu nao uso ubuntu.. ja migrei pro debian(etch4.0) p/ ve se dava p/ instalar... o kernel é 2.6.17-2-k7

espero resposta. t+

Bom antes de se compilar algo você tem de ter os pacotes necessário para o processo de compilação, tipo: make, gcc, build-essential, linux-headers-2.6.17-2-k7 (veja se existe isso aí no debian) e mais outros como o libasound, libasound-dev e o gnome-ppp (o discador, caso use Gnome). Só depois é que você deve usar o driver Smartlink para se compilar.

Não posso falar muito do Debian por que nunca instalei ele aqui e portanto meu pacote não é adequado para o mesmo, entretanto se você entende de shell script pode ver com que faço no meu script install-modem.sh e fazer as adaptações para instalar os pacotes .deb equivalentes no Debian e para executar a compilação do driver Smartlink .

OBS: Se você instalar o Ubuntu 7.04 e seu modem for realmente um que usa o driver Smartlink, suas chances de fazer o mesmo funcionar com o meu pacote chamado de modem-arquivos-v16.tar.gz são grandes. Outra coisa há usuário no qual para o seu modem basta instalar o pacote .deb sl-modem-daemon, por tanto veja se não este o seu caso.


cara!!! consegui instalar o modem e adivinha de onde to acessando? aki de casa via discada no debian! seu tutorial me ajudou muito!

vlw mesmo! qualquer informaçao q alguem precizar estou disposto a ajudar pq é muito xato conf isso, foi 2 meses de "luta"...

Modem: Smart Link Ltd. Unknown device 2800 (rev 02) (LSPCI)

Driver = sl-modem-daemon_2.9.9d+e-pre2-7etch2_i386.deb

conectei pelo wvdial! ... arquivo de configuraçao "/etc/wvdial.conf"

[Dialer Defaults]

ISDN = 0

Modem Type = Analog Modem

Phone = 17001442

Username = dennisfmedeiros@ibest.com.br

Password = ******

New PPPD = yes

Modem = /dev/ttySL0

Baud = 460800

Stupid Mode = 1

Modem Type = Analog Modem

p/ conectar digite no console = wvdial&

finish!!! =D

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #490 Online: 12 de Agosto de 2007, 17:13 »
Citar
bem eu nao uso ubuntu.. ja migrei pro debian(etch4.0) p/ ve se dava p/ instalar... o kernel é 2.6.17-2-k7

espero resposta. t+

Bom antes de se compilar algo você tem de ter os pacotes necessário para o processo de compilação, tipo: make, gcc, build-essential, linux-headers-2.6.17-2-k7 (veja se existe isso aí no debian) e mais outros como o libasound, libasound-dev e o gnome-ppp (o discador, caso use Gnome). Só depois é que você deve usar o driver Smartlink para se compilar.

Não posso falar muito do Debian por que nunca instalei ele aqui e portanto meu pacote não é adequado para o mesmo, entretanto se você entende de shell script pode ver com que faço no meu script install-modem.sh e fazer as adaptações para instalar os pacotes .deb equivalentes no Debian e para executar a compilação do driver Smartlink .

OBS: Se você instalar o Ubuntu 7.04 e seu modem for realmente um que usa o driver Smartlink, suas chances de fazer o mesmo funcionar com o meu pacote chamado de modem-arquivos-v16.tar.gz são grandes. Outra coisa há usuário no qual para o seu modem basta instalar o pacote .deb sl-modem-daemon, por tanto veja se não este o seu caso.


cara!!! consegui instalar o modem e adivinha de onde to acessando? aki de casa via discada no debian! seu tutorial me ajudou muito!

vlw mesmo! qualquer informaçao q alguem precizar estou disposto a ajudar pq é muito xato conf isso, foi 2 meses de "luta"...

Modem: Smart Link Ltd. Unknown device 2800 (rev 02) (LSPCI)

Driver = sl-modem-daemon_2.9.9d+e-pre2-7etch2_i386.deb

conectei pelo wvdial! ... arquivo de configuraçao "/etc/wvdial.conf"

[Dialer Defaults]

ISDN = 0

Modem Type = Analog Modem

Phone = 17001442

Username = dennisfmedeiros@ibest.com.br

Password = ******

New PPPD = yes

Modem = /dev/ttySL0

Baud = 460800

Stupid Mode = 1

Modem Type = Analog Modem

p/ conectar digite no console = wvdial&

finish!!! =D


Que bom que você conseguiu resolver seu problema de conexão. Realmente tem alguns usuários no qual basta instalar o pacote sl-modem-daemon_2.9.9d+e-pre2-7etch2_i386.deb. Já outros tem de instalar outras coisa e até compilar o driver Smartlink mesmo.

Agora se você usar Gnome instala o gnome-ppp que ele nada mais é do que uma interface gráfica para o wvdial.
« Última modificação: 12 de Agosto de 2007, 17:16 por alarcon »

Offline POTIGUAR_

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #491 Online: 12 de Agosto de 2007, 17:43 »
Citar
bem eu nao uso ubuntu.. ja migrei pro debian(etch4.0) p/ ve se dava p/ instalar... o kernel é 2.6.17-2-k7

espero resposta. t+

Bom antes de se compilar algo você tem de ter os pacotes necessário para o processo de compilação, tipo: make, gcc, build-essential, linux-headers-2.6.17-2-k7 (veja se existe isso aí no debian) e mais outros como o libasound, libasound-dev e o gnome-ppp (o discador, caso use Gnome). Só depois é que você deve usar o driver Smartlink para se compilar.

Não posso falar muito do Debian por que nunca instalei ele aqui e portanto meu pacote não é adequado para o mesmo, entretanto se você entende de shell script pode ver com que faço no meu script install-modem.sh e fazer as adaptações para instalar os pacotes .deb equivalentes no Debian e para executar a compilação do driver Smartlink .

OBS: Se você instalar o Ubuntu 7.04 e seu modem for realmente um que usa o driver Smartlink, suas chances de fazer o mesmo funcionar com o meu pacote chamado de modem-arquivos-v16.tar.gz são grandes. Outra coisa há usuário no qual para o seu modem basta instalar o pacote .deb sl-modem-daemon, por tanto veja se não este o seu caso.


cara!!! consegui instalar o modem e adivinha de onde to acessando? aki de casa via discada no debian! seu tutorial me ajudou muito!

vlw mesmo! qualquer informaçao q alguem precizar estou disposto a ajudar pq é muito xato conf isso, foi 2 meses de "luta"...

Modem: Smart Link Ltd. Unknown device 2800 (rev 02) (LSPCI)

Driver = sl-modem-daemon_2.9.9d+e-pre2-7etch2_i386.deb

conectei pelo wvdial! ... arquivo de configuraçao "/etc/wvdial.conf"

[Dialer Defaults]

ISDN = 0

Modem Type = Analog Modem

Phone = 17001442

Username = dennisfmedeiros@ibest.com.br

Password = ******

New PPPD = yes

Modem = /dev/ttySL0

Baud = 460800

Stupid Mode = 1

Modem Type = Analog Modem

p/ conectar digite no console = wvdial&

finish!!! =D


Que bom que você conseguiu resolver seu problema de conexão. Realmente tem alguns usuários no qual basta instalar o pacote sl-modem-daemon_2.9.9d+e-pre2-7etch2_i386.deb. Já outros tem de instalar outras coisa e até compilar o driver Smartlink mesmo.

Agora se você usar Gnome instala o gnome-ppp que ele nada mais é do que uma interface gráfica para o wvdial.


qndo eu mando conectar por ele, ele simplesmente fecha. =/ ai tinha um tutorial do wvdial ai neim quiz mais kebrar kbça...!

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #492 Online: 12 de Agosto de 2007, 18:16 »


qndo eu mando conectar por ele, ele simplesmente fecha. =/ ai tinha um tutorial do wvdial ai neim quiz mais kebrar kbça...!

Só uma observação, você teria de instalar o gnome-ppp dos repositórios do Debian que você usa e não o do meu pacote ok. Se você tiver feito isso, usado o do meu pacote, pode ter sido a causa do bug.

Offline Sergio Morgado

  • Usuário Ubuntu
  • *
  • Mensagens: 12
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #493 Online: 12 de Agosto de 2007, 19:24 »
Alarcon,

digitei xhost local:root e apareceu o seguinte:

Citar
non-network local connections being added to access control list


Offline POTIGUAR_

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #494 Online: 13 de Agosto de 2007, 08:43 »


qndo eu mando conectar por ele, ele simplesmente fecha. =/ ai tinha um tutorial do wvdial ai neim quiz mais kebrar kbça...!

Só uma observação, você teria de instalar o gnome-ppp dos repositórios do Debian que você usa e não o do meu pacote ok. Se você tiver feito isso, usado o do meu pacote, pode ter sido a causa do bug.

blz depois vou tentar o q vc falou! =D