Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 992453 vezes)

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1335 Online: 30 de Novembro de 2010, 11:52 »
De vez em quando quando desconecto a internet é quando cai não consigo conectar novamente até desligar o computador é ligar novamente.



Alguem sabe como reiniciar o modem alguma coisa para conectar sem precisar desligar o computador?

O comando:

sudo /etc/init.d/sl-modem-daemon restart

não funciona nesse caso?

Offline raimundo1

  • Usuário Ubuntu
  • *
  • Mensagens: 111
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1336 Online: 02 de Dezembro de 2010, 22:35 »
TEnto concectar a minha  internet discada com o modem encore com chip motorola e aparece a seguinte mensagem no log.

--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L1DT17001000
--> Waiting for carrier.
ATM1L1DT17001000
CONNECT 50667
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Thu Dec  2 19:09:19 2010
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 6237
--> Disconnecting at Thu Dec  2 19:09:20 2010
--> The PPP daemon has died: pppd options error (exit code = 2)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 2)

Agradeço se alguém puder me explicar o que está acontkecendo e o se puderem me dá uma solução...

Obrigado.

Meu kernel é 2.6.24-28 (hardy)
gnome 2.22.3

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1337 Online: 10 de Dezembro de 2010, 21:19 »
TEnto concectar a minha  internet discada com o modem encore com chip motorola e aparece a seguinte mensagem no log.

--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L1DT17001000
--> Waiting for carrier.
ATM1L1DT17001000
CONNECT 50667
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Thu Dec  2 19:09:19 2010
--> Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
--> --> PAP (Password Authentication Protocol) may be flaky.
--> Warning: Could not modify /etc/ppp/chap-secrets: Permission denied
--> --> CHAP (Challenge Handshake) may be flaky.
--> Pid of pppd: 6237
--> Disconnecting at Thu Dec  2 19:09:20 2010
--> The PPP daemon has died: pppd options error (exit code = 2)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 2)

Agradeço se alguém puder me explicar o que está acontkecendo e o se puderem me dá uma solução...

Obrigado.

Meu kernel é 2.6.24-28 (hardy)
gnome 2.22.3


Você usou o pacote que faço para esta versão do Ubuntu?

Pergunto isso porque esse problema não deveria acontecer, mas é de fácil solução, então abra o terminal e digite:

sudo gedit /etc/ppp/pap-secrets

e no final do arquivo que abrir coloque isso:

"seu_nome_de_acesso@provedor.com.br" * "sua_senha"

onde os valores entre duas aspas mude para o seu nome de acesso e sua senha respectivamente.

sudo gedit /etc/ppp/chap-secrets

e no final do arquivo que abrir coloque isso:

"seu_nome_de_acesso@provedor.com.br" * "sua_senha"

onde os valores entre duas aspas mude para o seu nome de acesso e sua senha respectivamente.

Offline Rodrigo-live

  • Usuário Ubuntu
  • *
  • Mensagens: 161
  • faz o que tu queres , pois é tudo da lei
    • Ver perfil
    • Dicas, tecnologia, tutoriais, vídeos e etc...
smartlink ubuntu lucid , kernel 2.6.32
« Resposta #1338 Online: 13 de Dezembro de 2010, 18:21 »
instalei o ubuntu perfeito com o kernel 2.6.32-24.
Alarcon você poderia editar o script ? pq quando vou instalar ele diz que não foi feito para o meu sistema , mas eu uso o Lucid mesmo , e baixei o pacote certo versão 32 , se poder me manda esses drivers , estou acessando de uma lan , abraços !
"apt-get is currently not installed. You can install it by typing 'apt-get install apt'"

alarcon

  • Visitante
Re: smartlink ubuntu lucid , kernel 2.6.32
« Resposta #1339 Online: 13 de Dezembro de 2010, 18:52 »
instalei o ubuntu perfeito com o kernel 2.6.32-24.
Alarcon você poderia editar o script ? pq quando vou instalar ele diz que não foi feito para o meu sistema , mas eu uso o Lucid mesmo , e baixei o pacote certo versão 32 , se poder me manda esses drivers , estou acessando de uma lan , abraços !

Isso eu já comentei lá no link do pacote v32 (http://ubuntuforum-br.org/index.php/topic,4204.msg368678.html#msg368678) que é o seguinte, como os usuários insistiam em instalar um pacote feito para uma determinada versão em outra versão eu adicionei ao meu script um verificador de versão e ele procura pelo nome da versão que no caso ele procura por Ubuntu 10.04, mas essa informação muda com as atualizações e eu não sabia e agora essa versão do Ubuntu se chama Ubuntu 10.04.1, então para resolver isso criei outro pacote (v33) que ao invés de procurar por Ubuntu 10.04 procura pelo nome da versão (lucid) que esta sim não muda, portanto para baixar o v33 veja este link:

http://ubuntuforum-br.org/index.php/topic,4204.msg390387.html#msg390387


PS: Você deve estar se perguntando, mas por que eu não editei apenas o script do v32 para corrigir isso? Simples, por que no v33 eu aproveitei e coloquei o driver smartlink mais recente na época de sua criação e como eu não sabia se ele iria funcionar no lucid, preferi deixar o v32, que sabia que funcionava, como o padrão e fornecer lá no link dele o outro link para o v33 para aqueles que tivesse esse erro que vc comenta. Esse erro não ocorreria para aqueles que tem o ISO/CD do Ubuntu 10.04 no momento do seu lançamento, somente para quem baixou a ISO/CD muito depois que passou a ser Ubuntu 10.04.1. Com as atualizações do sistema o Ubuntu 10.04 também passa para Ubuntu 10.04.1.
« Última modificação: 13 de Dezembro de 2010, 18:57 por alarcon »

Offline Rodrigo-live

  • Usuário Ubuntu
  • *
  • Mensagens: 161
  • faz o que tu queres , pois é tudo da lei
    • Ver perfil
    • Dicas, tecnologia, tutoriais, vídeos e etc...
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1340 Online: 13 de Dezembro de 2010, 19:47 »
Muito obrigado mais uma vez alarcon! você é dez ,  eu achava que a versão 33 éra para ubuntu 10.10, (erro meu) .
"apt-get is currently not installed. You can install it by typing 'apt-get install apt'"

Offline livre1

  • Usuário Ubuntu
  • *
  • Mensagens: 650
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1341 Online: 14 de Dezembro de 2010, 17:09 »
alarcon posso usar a versão v33 no Ubuntu 10.04?


Na versão antiga?


E sem ter instalado nenhuma atualização?

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1342 Online: 14 de Dezembro de 2010, 18:54 »
alarcon posso usar a versão v33 no Ubuntu 10.04?


Na versão antiga?


E sem ter instalado nenhuma atualização?

Pode sim, não há impedimento algum quanto a isso, ou seja, o v33 tanto pode ser usado por quem tem o Ubuntu 10.04 como o Ubuntu 10.04.1, somente o v32 é que só pode ser usado no Ubuntu 10.04 por uma pequena falha no verificador de versão no seu script de instalação. Ele (v33) só não serve para o Ubuntu 10.10 que no caso vai ser usado o v34 ok.
« Última modificação: 14 de Dezembro de 2010, 18:57 por alarcon »

Offline leoxis

  • Usuário Ubuntu
  • *
  • Mensagens: 139
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1343 Online: 19 de Dezembro de 2010, 23:33 »
pessoal,

existe como instalar o modem sem  o live CD ou existe algum pacote .deb que faça td isso??
Também ñ sei qual é meu modem. Segue o lspci
leo@leo-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
02:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
leo@leo-laptop:~$

Offline Sol Badguy

  • Usuário Ubuntu
  • *
  • Mensagens: 3
  • Debian & Ubuntu 4ever
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1344 Online: 29 de Dezembro de 2010, 01:39 »
Olá Alarcon gostaria de saber quais são as dependências necessárias para a instalação desses pacotes:
sl-modem-daemon
ppp
build-essential
gcc (todos do repositório)
libasound2 (todos do repositório)
linux-headers  - (versão do kernel)

No kubuntu 10.10,se possível poderia criar um pacote com todas as dependências necessárias,o meu modem é Motorola sm56
e pretendo usar o kppp como discador espero que você possa me ajudar.

Obrigado...
« Última modificação: 29 de Dezembro de 2010, 02:35 por Sol Badguy »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1345 Online: 29 de Dezembro de 2010, 21:58 »
pessoal,

existe como instalar o modem sem  o live CD ou existe algum pacote .deb que faça td isso??
Também ñ sei qual é meu modem. Segue o lspci
leo@leo-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
02:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
leo@leo-laptop:~$

Neste comando não foi apresentado um modem, mas provavelmente o seu caso seja a de uma placa de som especial que também faz o papel de modem, veja:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

por essa informação, muito provavelmente seu modem seja um do tipo HDA e o driver smartlink presente nos pacotes que faço e disponibilizo neste tópico é muito difícil fazer este modem funcionar.

O melhor mesmo seria vc usar o script scanModem que deve indicar qual caminho seguir, pois o driver conexant também pode dá suporte a modems HDA e é menos difícil fazer esse tipo de modem funcionar com esse driver conexant.

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1346 Online: 29 de Dezembro de 2010, 21:59 »
Olá Alarcon gostaria de saber quais são as dependências necessárias para a instalação desses pacotes:
sl-modem-daemon
ppp
build-essential
gcc (todos do repositório)
libasound2 (todos do repositório)
linux-headers  - (versão do kernel)

No kubuntu 10.10,se possível poderia criar um pacote com todas as dependências necessárias,o meu modem é Motorola sm56
e pretendo usar o kppp como discador espero que você possa me ajudar.

Obrigado...

Todos os .deb que estão presentes no pacote modem-arquivos-v34.tar.gz, a exceção do pacote gnome-ppp que como o nome já informa é exclusivo para o gnome/Ubuntu, seram usados no Kubuntu 10.10. Agora caso o kppp não esteja instalado no seu kubuntu procure pelo .deb dele e suas possíveis dependências para instalar antes de ativar o modem.

Antigamente, ou melhor, nos pacotes mais antigos que eu fazia, tinha um script de instalação para o Ubuntu e outro para o Kubuntu, entretanto devido ao kde ser mais chato para executar scripts com janelas gráficas como root feitas com o kdialog, resolvi retirar e deixar só o script do Ubuntu que como usa o zenity para apresentar as janelas gráficas e ele é exclusivo do gnome, não vai funcionar se vc rodar esse script no kde.

A alternativa seria você observar o script e fazer os passos manualmente aí pelo terminal no seu kubuntu ou então ler esse tópico aqui para entender como se procede de maneira manual:

http://ubuntuforum-br.org/index.php/topic,48619.0.html

só fique atento que os passos relatados nesse link são para uma versão antiga do Ubuntu ,mas funcionará se vc mudar o nome das pastas e etc.

Offline Sol Badguy

  • Usuário Ubuntu
  • *
  • Mensagens: 3
  • Debian & Ubuntu 4ever
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1347 Online: 30 de Dezembro de 2010, 01:49 »
Esse procedimento eu já sabia,utilizei os comandos manualmente no terminal do linux mint 10 e tá funcionando perfeitamente.
O problema é que o kubuntu não vem com todos os pacotes necessários para a instalação do modem Motorola sm56.
A única solução que eu vejo é atualizar o kubuntu 10.10 e instalar os pacotes necessários para a instalação do modem na casa de algum conhecido e utilizar o aptoncd para fazer uma ".iso" com todas as atualizações e dependências necessárias...
De qualquer forma obrigado pela ajuda... 8)
« Última modificação: 30 de Dezembro de 2010, 02:48 por Sol Badguy »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1348 Online: 30 de Dezembro de 2010, 18:01 »
Esse procedimento eu já sabia,utilizei os comandos manualmente no terminal do linux mint 10 e tá funcionando perfeitamente.
O problema é que o kubuntu não vem com todos os pacotes necessários para a instalação do modem Motorola sm56.
A única solução que eu vejo é atualizar o kubuntu 10.10 e instalar os pacotes necessários para a instalação do modem na casa de algum conhecido e utilizar o aptoncd para fazer uma ".iso" com todas as atualizações e dependências necessárias...
De qualquer forma obrigado pela ajuda... 8)

Foi o que eu já falei você pega o pacote modem-arquivos-v34.tar.gz, descompacta ele e instala pelo terminal (sudo dpkg nome_do_aplicativo.deb) os seguintes pacotes:

libasound2-dev_1.0.23-1ubuntu2_i386.deb
libuniconf4.6_4.6.1-1ubuntu1_i386.deb
libwvstreams4.6-base_4.6.1-1ubuntu1_i386.deb
libwvstreams4.6-extras_4.6.1-1ubuntu1_i386.deb
sl-modem-daemon_2.9.11~20100718-2_i386.deb
wvdial_1.60.4_i386.deb


E se o seu Kubuntu não tiver o discador kppp já instalado você deve instalar ele (e quem sabem suas dependências, se tiver), talvez baixando daqui:

http://packages.ubuntu.com/maverick/kppp

Lembrando também que é necessário ter instalado os compiladores para compilar o driver smartlink que são:

- make
- gcc
- build-essential
- linux-headers (esse de mesma versão do kernel em uso que vc pode obter com o comando "uname -r")


Tudo vc pode encontrar aqui:

http://packages.ubuntu.com/maverick/allpackages
« Última modificação: 30 de Dezembro de 2010, 18:03 por alarcon »

Offline Sol Badguy

  • Usuário Ubuntu
  • *
  • Mensagens: 3
  • Debian & Ubuntu 4ever
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1349 Online: 01 de Janeiro de 2011, 01:32 »
Ok alarcon e Feliz Ano Novo  8)