Autor Tópico: 3G no Ubuntu - Instalação e configuração (s/ problema com DNS)  (Lida 4447 vezes)

Offline lunga

  • Usuário Ubuntu
  • *
  • Mensagens: 366
  • Visitem: www.mundolunga.com
    • Ver perfil
    • O mundo de lunga
3G no Ubuntu - Instalação e configuração (s/ problema com DNS)
« Online: 05 de Novembro de 2008, 07:58 »
Vou deixar aqui uma dica para a instalação e configuração no Ubuntu de modems 3G.

As dicas valem para o Ubuntu 8.04. O 8.10 já detecta automaticamente quase todos os modems e, se não detectar, siga as dicas do 8.04

Instalação e configuração:

- Inclusive para os modems que se detectam como pendrive (tipo Sony md300);

Link: http://www.mundolunga.com/2008/10/claro-3g-no-ubuntu-804-modem-sony-d300.html

Problema com DNS:


Tem alguns modems (tipo o e226, e220, qse todos da huawei) pegam um DNS com inicio 10.x.x.x. Portanto gera aquele problema do "conecta mas não navega". No link acima, foi mostrado uma forma tosca de resolver isso, sobrescrevendo o /etc/resolv.conf, depois de cada conexão.

Aqui tem a dica para resolver isso:

Link: http://www.mundolunga.com/2008/11/conxexo-3g-soluo-para-problema-com-dns.html

Espero que as dicas sirvam. Abraços.
Se sua dúvida foi resolvida, por favor,  edite o título do tópico para indicar isso!

"Na União Soviética, a rosca é que queima você!!!

Offline EvandroArêdes

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: 3G no Ubuntu - Instalação e configuração (s/ problema com DNS)
« Resposta #1 Online: 07 de Novembro de 2008, 00:32 »
Comigo funcionou uma beleza até agora.

Porém agora pouco caiu e não conecta mais.

Ele tá criando cópias do options e nomeando de options~, options~~, sempre com # na linha de código inserida.

Removi os arquivos e agora tá pedindo senha...

Aconteceu contigo?

O que pode ser?

Valeu,

Evandro
« Última modificação: 07 de Novembro de 2008, 00:35 por EvandroArêdes »

Offline EvandroArêdes

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: 3G no Ubuntu - Instalação e configuração (s/ problema com DNS)
« Resposta #2 Online: 07 de Novembro de 2008, 00:43 »
Aí velhinho,

Valeu, já resolvi.

Obrigado.

PS: Excluí a conexão e incluí novamente.

Abraço.

Offline lunga

  • Usuário Ubuntu
  • *
  • Mensagens: 366
  • Visitem: www.mundolunga.com
    • Ver perfil
    • O mundo de lunga
Re: 3G no Ubuntu - Instalação e configuração (s/ problema com DNS)
« Resposta #3 Online: 07 de Novembro de 2008, 07:46 »
Eu acho q esse problema é por causa da instabilidade da  conexao. As vezes cai e se tentar reconectar varias vezes pede ateh uma senha loca.

Mas blz..     abs
Se sua dúvida foi resolvida, por favor,  edite o título do tópico para indicar isso!

"Na União Soviética, a rosca é que queima você!!!

Offline leobarros

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Obrigado
« Resposta #4 Online: 08 de Novembro de 2008, 22:22 »
Ultimamente estava tendo certos desabores com outras distros e quando li que essa versão era perfeita para a conexão 3g. Baixei e instalei e agora escrevo nela.

Obrigado pela ajuda e pelo esclarecimento sobre o bug do dns desse modem.
Vlw

Offline glauco.ubuntu

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: 3G no Ubuntu - Instalação e configuração (s/ problema com DNS)
« Resposta #5 Online: 16 de Dezembro de 2008, 01:23 »
Tem alguns modems (tipo o e226, e220, qse todos da huawei) pegam um DNS com inicio 10.x.x.x. Portanto gera aquele problema do "conecta mas não navega". No link acima, foi mostrado uma forma tosca de resolver isso, sobrescrevendo o /etc/resolv.conf, depois de cada conexão.

Aqui tem a dica para resolver isso:

Link: http://www.mundolunga.com/2008/11/conxexo-3g-soluo-para-problema-com-dns.html

Espero que as dicas sirvam. Abraços.

Vim aqui só pra te agradecer. Sua dica foi perfeita e resolveu o meu problema aqui. Fiz uma pesquisa no fórum e cheguei até você.

Glauco

bloglauco.blogspot.com