Autor Tópico: Configurar ADSL - Não carrega sites  (Lida 24163 vezes)

Offline Klaar

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
Configurar ADSL - Não carrega sites
« Online: 08 de MAR?O de 2006, 16:00 »
Tudo tranquilo pessoal?? Bom, esse é o meu 1° post e eu me registrei justamente para ver se consigo resolver esse probleminha.

Bom, tenho um modem router, D-Link 500T, bom, ele funciona normalmente no winXP e funcionava tranquilo no Slack 10.0. Bom, nesse momento no winxp eu coloquei para ele reconhecer IP e DNS tudo automático e está funcionando a internet, mas já não consigo essa proeza no Ubuntu, não sei mais o que fazer :(, parece que ele conecta pois abre a página do modem 10.1.1.1, mas não consegue entrar nos sites, muito de vez em quando ele entra em algum, e ainda não carrega inteiro. O que será que pode ser?? Já tentei usar o pppoeconf e deu erro... eu uso 1 placa de rede apenas mas assim como o winxp o ubuntu tbem identificou 2 placas.

Alguma coisa para resolver o meu problema??

temp.

  • Visitante
Configurar ADSL - Não carrega sites
« Resposta #1 Online: 08 de MAR?O de 2006, 16:05 »
Se ele é roteado então você deveria colocar um ip fixo não? Checa no seu windows como estão os IPs e dpois vai em Sistema -> Administração -> Redes(eu acho q é assim, em ingles eh networking) e configura teu IP.

Aqui em casa eu roteio o modem e no meu fica assim.
Gateway -> 10.0.0.1
Outros pcs -> 10.0.0.x
DNS -> 10.0.0.1

o x é qualquer numero maior que 1

Offline Klaar

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
Configurar ADSL - Não carrega sites
« Resposta #2 Online: 08 de MAR?O de 2006, 16:15 »
Bom, como estou aqui usando o DHCP acho que não precisa colocar IP fixo, mas bem, digitando ipconfig apareceu

Endereço ip: 10.0.0.3
márcara de sub-rede: 255.0.0.0
gateway padrão: 10.1.1.1

Como descobrir o DNS que estou usando no momento??

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.369
  • @Ceará
    • Ver perfil
Configurar ADSL - Não carrega sites
« Resposta #3 Online: 08 de MAR?O de 2006, 16:31 »
Citação de: "Klaar"
Como descobrir o DNS que estou usando no momento??

Código: [Selecionar]
cat /etc/resolv.conf

Teu IP tá meio estranho. Eu tenho um modem ADSL roteado que fica com 10.1.1.1 e o meu fica com 10.1.1.3 (e não 10.0.0.3)
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline Klaar

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
Configurar ADSL - Não carrega sites
« Resposta #4 Online: 08 de MAR?O de 2006, 16:52 »
Citação de: "agente100gelo"
Código: [Selecionar]
cat /etc/resolv.conf

Teu IP tá meio estranho. Eu tenho um modem ADSL roteado que fica com 10.1.1.1 e o meu fica com 10.1.1.3 (e não 10.0.0.3)


Foi mal ae amigo, é isso mesmo 10.1.1.3  :wink:  :wink:
Será que apenas colocando esses dados já vai conectar?? ou vou precisar colocar DNS??

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.369
  • @Ceará
    • Ver perfil
Configurar ADSL - Não carrega sites
« Resposta #5 Online: 08 de MAR?O de 2006, 17:13 »
O DHCP já deveria pegar tudo.
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline Klaar

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
Configurar ADSL - Não carrega sites
« Resposta #6 Online: 08 de MAR?O de 2006, 17:18 »
Citação de: "agente100gelo"
O DHCP já deveria pegar tudo.

No slack eu só dava um ipconfig e ativava o DHCP e já funcionava a internet. Mas no ubuntu está difícil, já tentei deixar apenas DHCP, já coloquei IP fixo e coloquei as configurações, já tentei de tudo :( não sei mais o que fazer, será que é alguma configuração no modem??

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.369
  • @Ceará
    • Ver perfil
Configurar ADSL - Não carrega sites
« Resposta #7 Online: 08 de MAR?O de 2006, 17:29 »
Tá pegando o IP, deve ser algum problema no DHCP.
Posta o que tem no teu arquivo /etc/resolv.conf

Pra testar a internet, eu uso um traceroute com um número IP (sudo apt-get install traceroute) pra ver por onde o tráfego passa:

Citar
glaydson@glaydson:~$ traceroute 200.221.2.45
traceroute to 200.221.2.45 (200.221.2.45), 30 hops max, 38 byte packets
 1  10.0.0.254 (10.0.0.254)  29.298 ms  7.026 ms  2.707 ms
 2  200-184-243-189.intelignet.com.br (200.184.243.189)  22.357 ms  24.033 ms  1 9.353 ms
 3  200-184-243-189.intelignet.com.br (200.184.243.189)  22.945 ms  15.685 ms  4 0.714 ms
(...)


O 10.0.0.254 é meu roteador no trabalho e 200.221.2.45 é o home do UOL. Como o traceroute não vem por padrão no Ubuntu, vc pode baixar o arquivo .deb.
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline Klaar

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
Configurar ADSL - Não carrega sites
« Resposta #8 Online: 08 de MAR?O de 2006, 17:38 »
Citação de: "agente100gelo"
Tá pegando o IP, deve ser algum problema no DHCP.
Posta o que tem no teu arquivo /etc/resolv.conf

Pra testar a internet, eu uso um traceroute com um número IP (sudo apt-get install traceroute) pra ver por onde o tráfego passa:

Citar
glaydson@glaydson:~$ traceroute 200.221.2.45
traceroute to 200.221.2.45 (200.221.2.45), 30 hops max, 38 byte packets
 1  10.0.0.254 (10.0.0.254)  29.298 ms  7.026 ms  2.707 ms
 2  200-184-243-189.intelignet.com.br (200.184.243.189)  22.357 ms  24.033 ms  1 9.353 ms
 3  200-184-243-189.intelignet.com.br (200.184.243.189)  22.945 ms  15.685 ms  4 0.714 ms
(...)


O 10.0.0.254 é meu roteador no trabalho e 200.221.2.45 é o home do UOL. Como o traceroute não vem por padrão no Ubuntu, vc pode baixar o arquivo .deb.


Pelo que entendi tenho que fazer download do programa, tem como colocar o link para download?? E outra coisa porque colocou traceroute 200.221.2.45?? é o seu DNS?? Eu não estou usando nenhum DNS o que eu devo pôr??

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.369
  • @Ceará
    • Ver perfil
Configurar ADSL - Não carrega sites
« Resposta #9 Online: 09 de MAR?O de 2006, 11:46 »
Esquece por enquanto.

Posta o conteúdo dos teus arquivos /etc/resolv.conf e /etc/network/interfaces
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline Klaar

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
Configurar ADSL - Não carrega sites
« Resposta #10 Online: 09 de MAR?O de 2006, 14:29 »
/etc/resolv.conf
_

domain ubuntu
nameserver 10.1.1.1
_

/etc/network/interfacer
_

#This file describes the network interfaces available on tour system
#and how activate them. For more information, see interfaces(5).

#The loopback network interface
auto lo
iface lo inet loopback

#This is a list of hotpluggable network interfaces.
#They will be activated automatically by the hotplug subsystem.
mapping hotplug
             script grep
             map eth0

#The primary network interface
iface eth0 inet static
adress 10.1.1.3
netmask 255.0.0.0
gateway 10.1.1.1

auto eth0

iface dsl-provider inet ppp
provider dsl-provider
_

E então, alguma coisa errada?? :roll:

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.369
  • @Ceará
    • Ver perfil
Configurar ADSL - Não carrega sites
« Resposta #11 Online: 09 de MAR?O de 2006, 14:37 »
Citar
E então, alguma coisa errada??


Aparentemente não. Você já testou ver se consegue acessar o modem (http://10.1.1.1)?

Acrescenta este texto abaixo no /etc/resolv.conf (são os DNS que eu uso).

Código: [Selecionar]
nameserver 200.184.127.26
nameserver 200.184.127.25
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline Klaar

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
Configurar ADSL - Não carrega sites
« Resposta #12 Online: 09 de MAR?O de 2006, 14:49 »
Citação de: "agente100gelo"
Citar
E então, alguma coisa errada??


Aparentemente não. Você já testou ver se consegue acessar o modem (http://10.1.1.1)?

Acrescenta este texto abaixo no /etc/resolv.conf (são os DNS que eu uso).

Código: [Selecionar]
nameserver 200.184.127.26
nameserver 200.184.127.25


Sim, eu consigo acessar o modem, mas não consigo entrar em nenhum site...!!!

Offline Klaar

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
Configurar ADSL - Não carrega sites
« Resposta #13 Online: 09 de MAR?O de 2006, 15:27 »
:D consegui algum avanço, consegui entrar em alguns sites como forumgdh e globo.com, mas em outros como google, gmail e furacao.com eu nao consegui acessar...
Eu coloquei adicionei os endereços DNS que você me passou, mas depois de um tempo eles sumiram.
Então ficou o seguinte, /etc/resolv.conf ficou a mesma coisa e /etc/network/interfaces ficou assim:

#This file describes the network interfaces available on tour system
#and how activate them. For more information, see interfaces(5).

#The loopback network interface
auto lo
iface lo inet loopback

#This is a list of hotpluggable network interfaces.
#They will be activated automatically by the hotplug subsystem.
mapping hotplug
script grep
map eth0

#The primary network interface
iface eth0 inet dhcp

auto eth0

iface dsl-provider inet ppp
provider dsl-provider
_

Bom, então já conseguimos um avanço, agora só preciso saber porque não consigo acessar os outros site ;)

Offline Klaar

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
Configurar ADSL - Não carrega sites
« Resposta #14 Online: 10 de MAR?O de 2006, 15:45 »
UP....está entrando em alguns sites, mas ainda em vários outros não consigo entrar, o que pode ser agora??