Autor Tópico: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!  (Lida 31252 vezes)

Offline ursaosededesangue

  • Usuário Ubuntu
  • *
  • Mensagens: 21
  • Espírito Livre
    • Ver perfil
Re: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!
« Resposta #30 Online: 21 de Junho de 2009, 20:25 »
só tem um problema, fazem +- 20 minutos e nenhuma msg, e já tem o comando clocksource=jiffies no boot, na linha referente ao kernel, parece que a tela do note tá morta e não levanta... tento novamente e posto os resultados, ainda bem que tenho 2 pcs nessas horas...
2011, o ano do Soberano. Uma paixão em preto, branco e vermelho.
Dim terim bebim...
6-3-3

Offline Eucassio

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!
« Resposta #31 Online: 21 de Junho de 2009, 21:30 »
Cara, o meu note piscou rapidamente as msg nesse momento é que dei um ALT+F2 depois ficou morta mesmo.

Offline ursaosededesangue

  • Usuário Ubuntu
  • *
  • Mensagens: 21
  • Espírito Livre
    • Ver perfil
Re: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!
« Resposta #32 Online: 21 de Junho de 2009, 23:03 »
relaxa cara, agora sei o que houve, é que eu tentei fazer no kubuntu, mas algo não deixa ele carregar, creio eu que seja os módulos de bluetooth do kernel, conforme li em algum lugar na internê, mas consegui, hehehe! agora sim sou feliz por ter a aceleração funcionando, beleza!
2011, o ano do Soberano. Uma paixão em preto, branco e vermelho.
Dim terim bebim...
6-3-3

Offline Eucassio

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!
« Resposta #33 Online: 22 de Junho de 2009, 07:45 »
Agora o problema é com  o flash q tá muito baixo o som, não aumenta de nenhuma forma é só com ele em qualquer site. Alguém já teve esse problema?

Offline StealthC

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!
« Resposta #34 Online: 24 de Junho de 2009, 07:30 »
Por aqui, o flash tá com som normal, testei no YouTube...
O que tenho enfrentado são alguns problemas de sincronia com músicas/vídeos, as vezes parece que estão passando muito mais rápido que o normal...

Offline Eucassio

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!
« Resposta #35 Online: 24 de Junho de 2009, 10:51 »
Pessoal eu percebi que o driver da ATI nao instalou o OPENGL, alguém saberia informar se foi instalado nos PCs de vocês? Alguns programas que fazem uso do opengl nao estão rodando. A informação pode ser visto pelo ->catalyst>informações->opengl

Offline StealthC

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!
« Resposta #36 Online: 24 de Junho de 2009, 13:02 »
aqui diz que tá instalado a versão 2.1.8673 do OpenGL... só pra constar, eu instalei o Jaunty via upgrade do 8.10, então não sei se a versão do OpenGL que está instalada é a antiga.

Offline ursaosededesangue

  • Usuário Ubuntu
  • *
  • Mensagens: 21
  • Espírito Livre
    • Ver perfil
Re: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!
« Resposta #37 Online: 24 de Junho de 2009, 13:18 »
Gostaria de testar agora, mas vou fazê-lo à noite e posto o que acontecer; se interessar, testei o glxgears e a renderização direta e tudo funcionando, apesar do baixo fps, mas acho que foi por ter esquecido de desativar o compiz...
2011, o ano do Soberano. Uma paixão em preto, branco e vermelho.
Dim terim bebim...
6-3-3

Offline StealthC

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!
« Resposta #38 Online: 24 de Junho de 2009, 13:22 »
Me parece que o OpenGL se desinstala se você usar o kernel mais novo... muito esquisito...

Offline StealthC

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!
« Resposta #39 Online: 24 de Junho de 2009, 13:39 »
atualizei o kernel e ficou constando que o OpenGL não estava instalado, agora, para resolver, eu reinstalei o driver 9.6 depois de ter atualizado o kernel, e voltou a ter OpenGL.

Offline Eucassio

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!
« Resposta #40 Online: 27 de Junho de 2009, 14:26 »
Valeu pessoal parece que é só reinstalar o driver após atualizações de kernel e do Xorg.

Offline Zefonseca

  • Usuário Ubuntu
  • *
  • Mensagens: 57
    • Ver perfil
Re: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!
« Resposta #41 Online: 01 de Julho de 2009, 12:16 »
Olá pessoal,

Também uso um note da Kennex com o Mobility HD2400, e troquei o Hardy pelo Jaunty recentemente. Passei pelos problemas no Hardy de tela piscando como vocês e resolvia desativando o compiz quando queria assistir a algum vídeo.
O modo com o qual eu instalo o meu driver ATI é manual, seguindo os passos da wiki não oficial do catalyst http://wiki.cchtml.com/index.php/Ubuntu_Jaunty_Installation_Guide (sigo as dicas a partir de "Installing the drivers manually") e sempre dá certo. Estou com o catalyst 9.6.

A diferença entre o Hardy e o Jaunty que notei é que as piscadelas na tela pararam, com o compiz ativado, porém os vídeos ficam lentos. Quando o compiz está ativado perde-se muito do desempenho 3D da máquina e no Jaunty a coisa está mais feia, apesar de ter melhorado no quesito 'pisca-pisca'. Achei que as cores estão mais nítidas, vídeos mais bonitos, fotos mais vistosas, mas o rendimento, com o compiz ativado está muito ruim. Se assisto a um DVD e arrasto uma janela, por exemplo, o vídeo trava e só rola de novo se eu soltar a janela. Outros formatos de vídeo, do tipo avi, dvix, wmv, mov (incluíndo DVDs), com o compiz ativado, além de rodar lento como falei, o resolução do vídeo fica desproporcional à janela do reprodutor de vídeo, causando perda de imagens. Se desativar o compiz, o vídeo rola blz e a resolução fica certinha com a janela do player de vídeo.

Como está aí com vocês que tem o mesmo note da Kennex, o desempenho 3D? Abaixo coloco um teste que fiz, primeiro rodando as engrenagens sem o compiz e depois com o compiz ativado:

jubuntu@JR-Ubuntu-Laptop:~$ glxinfo | grep direct
direct rendering: Yes
jubuntu@JR-Ubuntu-Laptop:~$ glxgears
10641 frames in 5.0 seconds = 2128.179 FPS
14713 frames in 5.0 seconds = 2942.563 FPS
14701 frames in 5.0 seconds = 2940.062 FPS
14745 frames in 5.0 seconds = 2948.893 FPS
14760 frames in 5.0 seconds = 2951.941 FPS
14748 frames in 5.0 seconds = 2949.596 FPS
^C
jubuntu@JR-Ubuntu-Laptop:~$ glxgears
2779 frames in 5.0 seconds = 555.592 FPS
2861 frames in 5.0 seconds = 572.092 FPS
2831 frames in 5.0 seconds = 565.854 FPS
2856 frames in 5.0 seconds = 571.199 FPS
2740 frames in 5.0 seconds = 548.000 FPS
2807 frames in 5.0 seconds = 560.958 FPS
^C
jubuntu@JR-Ubuntu-Laptop:~$

Será que dá pra resolver de alguma forma, na unha quero dizer?
Apesar de tudo, gostaria de ficar no Jaunty, mas se não resolver esses problemas (entre alguns outros), terei que voltar ao Hardy.

É isso, abraço a todos.

Offline Zefonseca

  • Usuário Ubuntu
  • *
  • Mensagens: 57
    • Ver perfil
Re: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!
« Resposta #42 Online: 02 de Julho de 2009, 14:28 »
Instalei o Hardy de novo no meu Kennex com HD2400 e os resultados foram os seguintes, sendo que os primeiros resultados foram com o compiz desativado e os segundos resultados com o compiz ativado:

Detalhe para o driver (9.6) e procedimentos que foram os mesmos feitos no Jaunty (resultados no post anterior)

jubuntu@jubuntu-laptop:~$ glxgears
8589 frames in 5.0 seconds = 1717.215 FPS
8673 frames in 5.0 seconds = 1734.600 FPS
8693 frames in 5.0 seconds = 1738.600 FPS
8700 frames in 5.0 seconds = 1740.000 FPS
8699 frames in 5.0 seconds = 1739.688 FPS
8681 frames in 5.0 seconds = 1736.103 FPS
8493 frames in 5.0 seconds = 1698.585 FPS

jubuntu@jubuntu-laptop:~$ glxgears
3257 frames in 5.0 seconds = 651.377 FPS
3222 frames in 5.0 seconds = 644.284 FPS
3202 frames in 5.0 seconds = 640.347 FPS
3246 frames in 5.0 seconds = 649.163 FPS
3295 frames in 5.0 seconds = 658.978 FPS
3229 frames in 5.0 seconds = 645.193 FPS
3249 frames in 5.0 seconds = 649.772 FPS

jubuntu@jubuntu-laptop:~$

Resultados um pouco diferentes entre Hardy e Jaunty. No Hardy sem o compiz ativado o desempenho 3D é pior que no Jaunty. Já com o compiz ativado o desempenho 3D no Hardy foi melhor que no Jaunty. Estranho!!!!
Isso quer dizer que, nesse caso, usar o compiz com um fps melhor, o Hardy é o SO recomendado. Não sei se isso é devido ao driver 9.6, ou se são os pacotes secundários que prejudicam o trabalho do driver (xorg-driver-fglrx_8.620-0ubuntu1_i386.deb fglrx-kernel-source_8.620-0ubuntu1_i386.deb fglrx-amdcccle_8.620-0ubuntu1_i386.deb).

Os problemas de vídeo relatados no post anterior, com o Jaunty, continua no Hardy; os vídeos não piscam mas ficam lentos com o compiz ativado.

Offline StealthC

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: ATI Mobility Radeon HD 2400 - qualquer vídeo fica piscando e dá pau!
« Resposta #43 Online: 21 de Outubro de 2009, 00:37 »
Alguem já obteve sucesso com algum driver mais novo?