Autor Tópico: [Resolvido] Internet 3g BrT com modem ZTE MF636, alguém consegiu conectar?  (Lida 72120 vezes)

Offline LeoArt

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
 ???
olá pessoal...
tenho um notebook hp pavillion dv2000 e gostaria de conectar
a internet usando um modem 3g da brasil telecom ZTE modelo
MF636.
Meu ubuntu é o 8.10.
Já tentei os tutoriais para instalação da claro mas não deu certo!
Primeiro q meu ubuntu não detecta o modem usb nem como
unidade de armazenamento.
O máximo q consegui foi carregar os módulos para o modem
usando o usbserial...como mostra esse tutorial aqui:
http://www.vivaolinux.com.br/topico/vivaolinux/modem-3g
logicamente q usei as configurações para o meu modem:

leonardo@leo:~$ sudo lsusb -v | grep -i vendor
[sudo] password for leonardo:
  idVendor           0x1d6b Linux Foundation
  idVendor           0x062a Creative Labs
  idVendor           0x1d6b Linux Foundation
  idVendor           0x1d6b Linux Foundation
  idVendor           0x04f2 Chicony Electronics Co., Ltd
  idVendor           0x19d2
  idVendor           0x1d6b Linux Foundation

leonardo@leo:~$ sudo lsusb -v | grep -i product
  idProduct          0x0001 1.1 root hub
  iProduct                2 OHCI Host Controller
  idProduct          0x0000 Optical mouse
  iProduct                0
  idProduct          0x0001 1.1 root hub
  iProduct                2 OHCI Host Controller
  idProduct          0x0002 2.0 root hub
  iProduct                2 EHCI Host Controller
  idProduct          0xb016
  iProduct                1 HP Webcam
  idProduct          0x2000
  iProduct                2 ZTE CDMA Technologies MSM
  idProduct          0x0002 2.0 root hub
  iProduct                2 EHCI Host Controller

leonardo@leo:~$ sudo modprobe -r usbserial

Retirei o modem da porta usb depois fiz o q diz no manual

leonardo@leo:~$ sudo rmmod usb_storage

Coloquei novamente o modem na porta usb e:

leonardo@leo:~$ sudo modprobe usbserial vendor=0x19d2 product=0x2000

leonardo@leo:~$ dmesg | tail
[ 2802.470689]  =======================
[ 2802.470700] usb-storage: device ignored
[ 2802.470855] usbcore: registered new interface driver usb-storage
[ 2802.470864] USB Mass Storage support registered.
[ 2857.026725] usbcore: registered new interface driver usbserial
[ 2857.028908] usbserial: USB Serial support registered for generic
[ 2857.031527] usbserial_generic 1-1:1.0: generic converter detected
[ 2857.034052] usb 1-1: generic converter now attached to ttyUSB0
[ 2857.034111] usbcore: registered new interface driver usbserial_generic
[ 2857.034119] usbserial: USB Serial Driver core

leonardo@leo:~$ sudo ls /dev/ttyUSB*
/dev/ttyUSB0

leonardo@leo:~$

Usando o wvdial para discar não consegui conexão...diz q o modem
não responde.

Alguém tem idéia de como conectar com esse modem??????
Obrigado!


 
« Última modificação: 11 de Fevereiro de 2009, 13:03 por LeoArt »
.........................................................
O Brasil tem futuro! Ubuntu e Java!
.........................................................

Offline Chucknoris

  • Usuário Ubuntu
  • *
  • Mensagens: 131
  • Linux for human beings!
    • Ver perfil
Re: Internet 3g Brasil Telecom com modem ZTE MF636, alguém consegiu conectar?????
« Resposta #1 Online: 03 de Janeiro de 2009, 02:58 »
estou com o mesmo modem aqui, e tudo indica que ele seja esta linha aqui: 


 
Citar
idVendor           0x19d2

com o modem conectado na porta usb

Citar
luis@servidor:~$ lsusb
Bus 002 Device 008: ID 19d2:2000 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 062a:0001 Creative Labs Notebook Optical Mouse
Bus 001 Device 003: ID 0566:3107 Monterey International Corp.
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
luis@servidor:~$

sem o modem conectado na porta usb 

Citar
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 062a:0001 Creative Labs Notebook Optical Mouse
Bus 001 Device 003: ID 0566:3107 Monterey International Corp.
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


Estou perdido no meio de tantos tutoriais e tantos modelos de modem até agora não consegui muita coisa ......

Alguém pode nos ajudar???
« Última modificação: 03 de Janeiro de 2009, 03:00 por Chucknoris »
Ubuntu user Number 15679
Linux User Number 448603

Offline 0tacon

  • Usuário Ubuntu
  • *
  • Mensagens: 439
    • Ver perfil
Re: Internet 3g Brasil Telecom com modem ZTE MF636, alguém consegiu conectar?????
« Resposta #2 Online: 03 de Janeiro de 2009, 03:21 »
Dei uma bizoiada por aí e vi que não tem muito sobre esse modem. O que mais tem é gente insatisfeita. O que eu achei foi:
http://ubuntuforums.org/showthread.php?t=1005617
Vou dar uma "relida" rápida:

1: baixe: http://www.draisberghof.de/usb_modeswitch/usb_modeswitch-0.9.5.tar.bz2

2: descompactar e copiar o binário para /usr/sbin/

tar xjf usb_modeswitch-0.9.5.tar.bz2
cd usb_modeswitch-0.9.5/
sudo cp usb_modeswitch /usr/sbin/


3:  Biblioteca necessária:
sudo apt-get install libusb-dev

4: Fazer o arquivo /etc/usb_modeswitch.conf
 sudo gedit /etc/usb_modeswitch.conf

Código: [Selecionar]
########################################################
# ZTE MF628
#
# Captured with "usbmon". Has a micro SD slot which can be
# activated alternatively
#
# Contributor: Alvaro Lopes <alvieboy at alvie dot com>

DefaultVendor=  0x19d2
DefaultProduct= 0x2000

# To modem mode:

TargetVendor=   0x19d2
TargetProduct=  0x0015

MessageEndpoint=0x08
MessageContent="5553424312345678000000000000061b000000030000000000000000000000"

5: O próximo arquivo de configuração a ser editado (ou criado) é:
sudo gedit /etc/udev/rules.d/65-zte-mf628-modem.rules
 Com o conteúdo:
Código: [Selecionar]
SUBSYSTEM=="usb", ATTR{idVendor}=="19d2", ATTR{idProduct}=="2000", RUN+="/usr/sbin/usb_modeswitch"
6. Agora é só editar o /etc/wvdial.conf

sudo gedit /etc/wvdial.conf
Conteúdo:

Código: [Selecionar]
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1,"IP","<put ur APN here>"
Modem Type = Analog Modem
ISDN = 0
New PPPD = yes
Modem = /dev/ttyUSB0
Baud = 9600
Phone = <value here depends on ISP>
Username = <value here depends on ISP>
Password = <value here depends on ISP>
Stupid Mode = yes

 Eu realmente não entendo muito do assunto, nem tenho um modem USB. Só dei uma procurada por aí para passar o tempo XD. O que eu sei é que pode haver a necessidade de intalar outras coisas, como o wvdial, que não vem originalmente com o ubuntu. E para conectar à internet, o comando é sudo wvdial no terminal.


Offline Chucknoris

  • Usuário Ubuntu
  • *
  • Mensagens: 131
  • Linux for human beings!
    • Ver perfil
Re: Internet 3g Brasil Telecom com modem ZTE MF636, alguém consegiu conectar?????
« Resposta #3 Online: 04 de Janeiro de 2009, 03:55 »
Parece que esse modelo ninguem conseguiu usar ainda....

0tacon eu testei este software ai que voce sugeriu, mas não tem o ZTE MF636 na lista para descomentar, testei outros modelos mas da um erro acusando não encontrar o modem, acho que por ser modelo diferente.....

Valeu pela ajuda, o modem nem é para mim, se fosse meu eu teria pesquisado antes de comprar....
Ubuntu user Number 15679
Linux User Number 448603

Offline idarlesom

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Internet 3g Brasil Telecom com modem ZTE MF636, alguém consegiu conectar?????
« Resposta #4 Online: 04 de Janeiro de 2009, 14:08 »
tambem estou com o mesmo problema, o tentei usar as dicas citadas acima!!

mais nao deu certo no maximo consegui fazer com que ele nao seje mais reconhecido com disco usb

se alguem conseguir posta a soluçao ai pra nóis!!

...

Offline fabricio.1983

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Internet 3g Brasil Telecom com modem ZTE MF636, alguém consegiu conectar?????
« Resposta #5 Online: 05 de Janeiro de 2009, 12:22 »
to com o mesmo problema quero usa o linux mas sem net nao da

tenho o mesmo modem ZTE MF636 Brasil Telecom

Offline lunga

  • Usuário Ubuntu
  • *
  • Mensagens: 366
  • Visitem: www.mundolunga.com
    • Ver perfil
    • O mundo de lunga
Re: Internet 3g Brasil Telecom com modem ZTE MF636, alguém consegiu conectar?????
« Resposta #6 Online: 07 de Janeiro de 2009, 16:25 »
Eu tenho este modem e consigo conectar. O unico problema eh que o ubuntu soh reconhece ele somente se ele estiver conectado antes de iniciar o sistema.

Se sua dúvida foi resolvida, por favor,  edite o título do tópico para indicar isso!

"Na União Soviética, a rosca é que queima você!!!

Offline jonata

  • Usuário Ubuntu
  • *
  • Mensagens: 30
  • Jonatã Bolzan
    • Ver perfil
Re: Internet 3g Brasil Telecom com modem ZTE MF636, alguém consegiu conectar?????
« Resposta #7 Online: 08 de Janeiro de 2009, 14:47 »
Olá a todos

Tenho esse modem e estou escrevendo numa conexão dele o Ubuntu Intrepid 8.10. Os passos que fiz para ter esse modem funcionando são relativamente simples

1 - instale o usb_modeswitch

Antes de instalá-lo, ele vai precisar do libusb-dev, pegue aqui: http://mirrors.kernel.org/ubuntu/pool/main/libu/libusb/libusb-dev_0.1.12-12_i386.deb

Como citado acima, é fácil e você pode até pegar o arquivo em deb aqui: http://www.draisberghof.de/usb_modeswitch/usb-modeswitch_0.9.5_i386.deb

2 - configure o usb_modeswitch

no terminal, digite isso:
Código: [Selecionar]
sudo gedit /etc/usb_modeswitch.conf
e insira as seguintes linhas no arquivo
Código: [Selecionar]
########################################################
# ZTE MF636
#

DefaultVendor=  0x19d2
DefaultProduct= 0x2000

TargetVendor=   0x19d2
TargetProduct=  0x0031

MessageEndpoint=0x01
MessageContent="55534243123456782000000080000c85010101180101010101000000000000"

Então, dê mais esse comando:
Código: [Selecionar]
/etc/udev/rules.d/15-zte-mf636.rules
e coloque esse texto no arquivo
Código: [Selecionar]
ACTION!="add", GOTO="ZTE_End"
# Is this the ZeroCD device?
SUBSYSTEM=="usb", SYSFS{idProduct}=="2000",
SYSFS{idVendor}=="19d2", GOTO="ZTE_ZeroCD"
# Is this the actual modem?
SUBSYSTEM=="usb", SYSFS{idProduct}=="0031",
SYSFS{idVendor}=="19d2", GOTO="ZTE_Modem"
LABEL="ZTE_ZeroCD"
# This is the ZeroCD part of the card, remove
# the usb_storage kernel module so
# it does not get treated like a storage device
#RUN+="/sbin/rmmod usb_storage"
RUN+="/usr/sbin/usb_modeswitch"
LABEL="ZTE_Modem"
# This is the Modem part of the card, let's
# load usbserial with the correct vendor
# and product ID's so we get our usb serial devices
RUN+="/sbin/modprobe usbserial vendor=0x19d2 product=0x0031",
# Make users belonging to the dialout group
# able to use the usb serial devices.
MODE="660", GROUP="dialout"
#MODE="660", GROUP="tty"
LABEL="ZTE_End"

Salve e vá para o próximo passo

3 - Instale o discador

Se você recebeu um cd de instalação, dê uma olhada se não tem software para Linux. Nesse modelo a Brasil Telecom mandou um software para Linux (ponto para ela!)

Instale conforme as instruções do manual impresso que veio junto do modem. Ela mandou um script de instalação que tenta compilar o driver da zte, mas sem sucesso no nosso kernel. Ela manda junto alguns drivers pré-compilados, mas para versões anteriores do Ubuntu. Então, não se importe com as mensagens de erro que aparecem. Caso você não encontrou no ou o CD, pegue esse programinha da VIVO:
http://www.aiko.com.br/telefonia_detalhes.asp?idProduto=80&sessao=suporte

Configure uma nova conexão, caso use esse último da vivo:
Nome: BrasilTelecom
Número de telefone: *99***1#
Usuário: brt
Senha: brt
endereço de APN: brt.br
todos os outros itens, deixe o primeiro selecionado


e tente conectar. Aqui deu certo. Não sei fazer a conexão de outro modo, tentei pelo gnome-ppp e por wvdial, mas nao consegui. Talvez por pppconfig dê certo, mas daí não posso confirmar.

Obrigado...
« Última modificação: 08 de Janeiro de 2009, 14:51 por jonata »

Offline LeoArt

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Internet 3g Brasil Telecom com modem ZTE MF636, alguém consegiu conectar?????
« Resposta #8 Online: 08 de Janeiro de 2009, 21:15 »
Jonata

vou ver se funciona aqui...!!!
.........................................................
O Brasil tem futuro! Ubuntu e Java!
.........................................................

Offline LeoArt

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Internet 3g Brasil Telecom com modem ZTE MF636, alguém consegiu conectar?????
« Resposta #9 Online: 08 de Janeiro de 2009, 22:15 »
Cara ainda não funcionou....

Quando abro o discador, o drive de cd abre...

ou seja, ele ejecta minha unidade de CDRW/DVDRW.

Sigo precisando de ajuda!!!

vou tentando aqui e se conseguir algo, aviso!!!
.........................................................
O Brasil tem futuro! Ubuntu e Java!
.........................................................

Offline jonata

  • Usuário Ubuntu
  • *
  • Mensagens: 30
  • Jonatã Bolzan
    • Ver perfil
Re: Internet 3g Brasil Telecom com modem ZTE MF636, alguém consegiu conectar?????
« Resposta #10 Online: 08 de Janeiro de 2009, 23:25 »
Pois então, aqui também acontece isso, mas com o usb_modeswitch configurado e funcionando, o modem apenas liga, apaga e liga novamente.

Me diz uma coisa, aqui eu quebrei a cabeça por não perceber algo tão óbvio: você desbloqueou o chip? a luz do modem, em estado normal, é verde-e-amarela ou verde ou vermelha?

Obrigado, até mais...

Offline LeoArt

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Internet 3g Brasil Telecom com modem ZTE MF636, alguém consegiu conectar?????
« Resposta #11 Online: 09 de Janeiro de 2009, 11:29 »
Bingo!!!!!!
Funcionou...estou conectado!!!

Cara o negócio é o seguinte...quando eu entrava no discador (Mobile Connection) q vc me passou o link,
o meu drive de cd ficava abrindo (ejectando). Então fiz o seguinte. Fechei o discador, conectei o modem
na porta usb. Esperei ele fazer as checagens (luz amarela, depois verde, depois azul - meu chip está
desbloqueado sim, já usei esse modem no Ruwindows.), depois entrei no discador novamente e esperei.
Esperei uns 3 minutos....
Fiquei observando:  tail -f /var/log/messages  e deu isso aqui:

Jan  9 11:07:57 leo kernel: [  675.001074] usb 1-5: new high speed USB device using ehci_hcd and address 10
Jan  9 11:07:57 leo kernel: [  675.147684] usb 1-5: configuration #1 chosen from 1 choice
Jan  9 11:07:57 leo kernel: [  675.156598] usb-storage: device ignored
Jan  9 11:09:34 leo kernel: [  772.044984] usb 1-5: USB disconnect, address 10
Jan  9 11:09:39 leo kernel: [  777.005149] usb 1-5: new high speed USB device using ehci_hcd and address 11
Jan  9 11:09:39 leo kernel: [  777.141646] usb 1-5: configuration #1 chosen from 1 choice
Jan  9 11:09:39 leo kernel: [  777.144262] usbserial_generic 1-5:1.0: generic converter detected
Jan  9 11:09:39 leo kernel: [  777.145351] usb 1-5: generic converter now attached to ttyUSB0
Jan  9 11:09:39 leo kernel: [  777.146497] usbserial_generic 1-5:1.1: generic converter detected
Jan  9 11:09:39 leo kernel: [  777.147276] usb 1-5: generic converter now attached to ttyUSB1
Jan  9 11:09:39 leo kernel: [  777.148508] usbserial_generic 1-5:1.2: generic converter detected
Jan  9 11:09:39 leo kernel: [  777.149411] usb 1-5: generic converter now attached to ttyUSB2
Jan  9 11:09:39 leo kernel: [  777.150758] usbserial_generic 1-5:1.3: generic converter detected
Jan  9 11:09:39 leo kernel: [  777.151722] usb 1-5: generic converter now attached to ttyUSB3
Jan  9 11:10:04 leo kernel: [  801.849905] PPP generic driver version 2.4.2
Jan  9 11:10:04 leo pppd[10632]: pppd 2.4.4 started by leonardo, uid 1000
Jan  9 11:10:04 leo pppd[10632]: Using interface ppp0
Jan  9 11:10:04 leo pppd[10632]: Connect: ppp0 <--> /dev/ttyUSB3
Jan  9 11:10:04 leo pppd[10632]: PAP authentication succeeded
Jan  9 11:10:06 leo pppd[10632]: Could not determine remote IP address: defaulting to 10.64.64.64
Jan  9 11:10:06 leo pppd[10632]: local  IP address 200.219.80.224
Jan  9 11:10:06 leo pppd[10632]: remote IP address 10.64.64.64
Jan  9 11:10:06 leo pppd[10632]: primary   DNS address 201.10.120.2
Jan  9 11:10:06 leo pppd[10632]: secondary DNS address 201.10.128.2
Jan  9 11:12:45 leo kernel: [  962.892610] usb 3-1: USB disconnect, address 2
Jan  9 11:13:06 leo kernel: [  984.329074] usb 3-1: new low speed USB device using ohci_hcd and address 3
Jan  9 11:13:06 leo kernel: [  984.539727] usb 3-1: configuration #1 chosen from 1 choice
Jan  9 11:13:06 leo kernel: [  984.548978] input: HID 062a:0000 as /devices/pci0000:00/0000:00:02.0/usb3/3-1/3-1:1.0/input/input12
Jan  9 11:13:06 leo kernel: [  984.569527] input,hidraw0: USB HID v1.10 Mouse [HID 062a:0000] on usb-0000:00:02.0-1


Bingo!!! A luz do modem agora é Azul e piscando, ou seja, estou conectado...
O Firefox é q nao quiz acessar de primeira, mas aí tirei ele do modo off-line...
e tentei acessar outra página qualquer... Funcionou filé....

Valeu aí Jonata.
Vou até imprimir teu tutorial sobre como conectar com esse modem...hehehe
Vai q amanhã ou depois precisarei de novo...
Se eu puder ajudar com o teu aí também...manda q a gente tenta resolver...
Valeu!!!
.........................................................
O Brasil tem futuro! Ubuntu e Java!
.........................................................

Offline jonata

  • Usuário Ubuntu
  • *
  • Mensagens: 30
  • Jonatã Bolzan
    • Ver perfil
Re: Internet 3g Brasil Telecom com modem ZTE MF636, alguém consegiu conectar?????
« Resposta #12 Online: 09 de Janeiro de 2009, 12:50 »
Bah q bom saber q conseguiu!!! Apenas tenho inveja tua, sabe por que?

Tua luzinha aí é azul e a minha é verde... :P

Conecto de dia a uns 4 kb/s, muito lenta... aqui a cobertura é 2G (Tapejara/RS)

Eu vou testar de madrugada, andei lendo por aí que é mais rápida...

Mas me diga a quanto vc consegue conectar aí? Onde tu mora? É sempre 3G?

Offline Lucianofarias

  • Usuário Ubuntu
  • *
  • Mensagens: 25
    • Ver perfil
Re: Internet 3g Brasil Telecom com modem ZTE MF636, alguém consegiu conectar?????
« Resposta #13 Online: 09 de Janeiro de 2009, 12:57 »
Bom, estamos largados aqui, mas vamos tocando o barco. Com certeza eu postarei aqui a solução do problema, caso eu consiga me virar sozinho, afinal, é pra isso que estamos aqui.  :'(

Mas vamos la:

Usei o script do morimoto para conexão com modem huawei E156 para vivo zap, e correu bem ate a metade.

O script começa a fazer as perguntas, e :

...

Ativar o firewall para a conexão da Internet? (s/n)
n

Usar os servidores DNS do provedor? (s/n)
s
Desativando rota padrão (para que seja usada a conexão 3G)
route del default
SIOCDELRT: Não existe o processo
discando…

Pressione Ctrl+C para encerrar a conexão.

wvdial 3g
--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/ttyUSB0: Invalid argument
--> Cannot open /dev/ttyUSB0: Invalid argument
--> Cannot open /dev/ttyUSB0: Invalid argument
root@LucianoFarias:/home/luciano/vivozap# conectar-vivozap: 757: /etc/init.d/NetworkManager: not found
* Reconfiguring network interfaces… /usr/bin/poff: No pppd is running. None stopped.
ppp0: ERROR while getting interface flags: No such device



Antes tinha dado que nao tinha o resolv.config. Criei, correu normal, mas agora deu isso.

Ta dificil ter uma net no linux.

Agradeço quem puder ajudar.
« Última modificação: 09 de Janeiro de 2009, 12:59 por Lucianofarias »

Offline LeoArt

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Internet 3g Brasil Telecom com modem ZTE MF636, alguém consegiu conectar?????
« Resposta #14 Online: 09 de Janeiro de 2009, 13:37 »
Cara...
estou aqui em Brasília e pega 3g filé...
mas tem uma coisa q um colega falou nesse post aqui:

http://ubuntuforum-br.org/index.php/topic,39439.0.html

ele disse o seguinte:
############################
O último detalhe. Inicialmente estava acessando a uma velocidade em torno de 20% do serviço contratado (250Kbps), uma navegação horrível de 40 ou 50 Kbps.

Fiz alguns testes no Windows/Linus e após alguns dias percebi que existia uma opção no software da Brasiltelecom (do windows) para se escolher a rede de acesso. Neste caso meu modem estava
selecionando uma rede 2G e assim que alterei para a 3G a velocidade dobrou (400Kbps pra mais).

Como havia feito muitos testes e mudanças de configuração pensei que havia cometido o erro por engano configurando a conexão para a 2G no windows. Porém, tenho dúvidas quanto se esse engano foi meu.

Uma colega de trabalho trouxe um modem igual o nosso e pediu que fizesse alguns testes pois ela estava tendo uma conexão muito ruim. A primeira configuração a verificar foi exatamente a escolha da rede de conexão, e acredite lá estava selecionada a rede 2G. Uma vez que alterei para a 3G no windows a velocidade quase dobrou em ambos os sistemas!

O modem grava essa configuração e quando você for acessar na próxima vez do Linux ou Windows  a conexão é feita na rede correta (3G). Ao que parece esse aparelho ZTE está saindo
das lojas com a configuração padrão de acesso 2G.

Então outra dica é verificar qual rede o modem está configurado, infelizmente só consegui verificar e alterar isso utilizando o software do windows.

Espero que ajude.

Grande abraço,
Guilherme Machado
Curitiba / Pr
##########################

dá uma olhada nisso...será q teu modem tem alguma configuração gravada
nele para acessar só 2g??????
Se tiver muda para 3g usando o software da brt no RuWindows!!!
.........................................................
O Brasil tem futuro! Ubuntu e Java!
.........................................................