Autor Tópico: Jdk só funciona a hora que quer.  (Lida 8108 vezes)

Offline lfernandosg

  • Usuário Ubuntu
  • *
  • Mensagens: 477
    • Ver perfil
Jdk só funciona a hora que quer.
« Online: 27 de MAR?O de 2006, 11:07 »
baixei o jdk e o jre 1,5 da sun , o jre está normal e o jdk só funciona o hora que quer, entào vamos lá:

1)executei  o jdk dentro de /usr/local
2)despoi descompctei o doc.zip dentro de /usr/local/jdk1.5.0_06
3)criei um link simbólico para /usr/local/java para poder usar o java direto
4)entrei no etc/profile e coloquei essas linhas :

JAVA_HOME="/usr/local/java"

JRE_HOME="/usr/local/java/jre"

CLASSPATH="$JAVA_HOME:$JAVA_HOME/lib:$JRE_HOME/lib:."

MANPATH="$MANPATH:$JAVA_HOME/man"

JAVA_DOC="$JAVA_HOME/docs"

PATH="$PATH:$JAVA_HOME/bin:$JRE_HOME/bin"

export JAVA_HOME JRE_HOME CLASSPATH MANPATH JAVA_DOC PATH


depois dei o comando $ source/etc/profile para atualizar o profile aí funciona mas só basta fechar o terminal e abrir outro que a configuraçà que eu fiz some,então toda vez para fucnionar tenho que dar o source /etc/profile, porque? emesmo assim para escolher qual java estou usando dá um erro dizendo que não tem nenhum(está no final desse texto).e ainda tentei alterar meu /etc/profile para:
JAVA_HOME=/usr/local/jdk1.5.0_06
CLASSPATH=.:$CLASSPATH
PATH=$JAVA_HOME/bin:$PATH


depois source /etc/profile e depois export JAVA_HOME=/usr/local/jdk1.5.0_06 ,export CLASSPATH=.:$CLASSPATH, PATH=$JAVA_HOME/bin:$PATH no terminal para nào ter que ficar logando toda hora mas só é abrir outro terminal que o java some de novo.




$ java version
bash: java: command not found
$ java -version
bash: java: command not found
fernando@debian:~$ source /etc/profile
$ java -version
java version "1.5.0_06"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_06-b05)
Java HotSpot(TM) Client VM (build 1.5.0_06-b05, mixed mode, sharing)
$ javac -version
javac 1.5.0_06
javac: no source files
Usage: javac <options> <source files>
where possible options include:
  -g                         Generate all debugging info
  -g:none                    Generate no debugging info
  -g:{lines,vars,source}     Generate only some debugging info
  -nowarn                    Generate no warnings
  -verbose                   Output messages about what the compiler is doing
  -deprecation               Output source locations where deprecated APIs are used
  -classpath <path>          Specify where to find user class files
  -cp <path>                 Specify where to find user class files
  -sourcepath <path>         Specify where to find input source files
  -bootclasspath <path>      Override location of bootstrap class files
  -extdirs <dirs>            Override location of installed extensions
  -endorseddirs <dirs>       Override location of endorsed standards path
  -d <directory>             Specify where to place generated class files
  -encoding <encoding>       Specify character encoding used by source files
  -source <release>          Provide source compatibility with specified release  -target <release>          Generate class files for specific VM version
  -version                   Version information
  -help                      Print a synopsis of standard options
  -X                         Print a synopsis of nonstandard options
  -J<flag>                   Pass <flag> directly to the runtime system


e seu der um #update-alternatives --config java
aparece;
There are 0 alternatives which provide `java'.

  Selection    Alternative



sem opção nenhuma?
Dell Xps M1330/c2d 2.0Ghz/4GB ddr2/320GB sata/etc...

denisbr

  • Visitante
Jdk só funciona a hora que quer.
« Resposta #1 Online: 27 de MAR?O de 2006, 15:22 »
Coloca no arquivo /home/SEU_USUARIO/.bashrc (senão tiver crie)
export JAVA_HOME=/usr/local/java/
export PATH=$PATH:$JAVA_HOME/bin/
export CLASSPATH=$CLASSPATH:.

Offline lfernandosg

  • Usuário Ubuntu
  • *
  • Mensagens: 477
    • Ver perfil
Jdk só funciona a hora que quer.
« Resposta #2 Online: 27 de MAR?O de 2006, 15:34 »
mandaram eu criar um script, é lá no /.bashrc? e não serria export CLASSPATH=.:$CLASSPATH  ao invés de export CLASSPATH=$CLASSPATH:.  ?

obs.: vc me ajudou da última vez e ficou tudo legal mas tive que formatar o notebook e instalar tudo de novo e agora tá com esse pau.


agradeço desde já.

EDITADO:
ficou assim meu ./bash

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
#export HISTCONTROL=ignoredups

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" -a -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
xterm-color)
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
    ;;
*)
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
    ;;
esac

# Comment in the above and uncomment this below for a color prompt
#PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}: ${PWD/$HOME/~}\007"'
    ;;
*)
    ;;
esac

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

#if [ -f ~/.bash_aliases ]; then
#    . ~/.bash_aliases
#fi

# enable color support of ls and also add handy aliases
if [ "$TERM" != "dumb" ]; then
    eval "`dircolors -b`"
    alias ls='ls --color=auto'
    #alias dir='ls --color=auto --format=vertical'
    #alias vdir='ls --color=auto --format=long'
fi

# some more ls aliases
#alias ll='ls -l'
#alias la='ls -A'
#alias l='ls -CF'

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
#if [ -f /etc/bash_completion ]; then
#    . /etc/bash_completion
#fi


export JAVA_HOME=/usr/local/java/
export PATH=$PATH:$JAVA_HOME/bin/
export CLASSPATH=$CLASSPATH:.



se for assim deu o mesmo erro, s'o aceita java quando dou um source /etc/profile.
Dell Xps M1330/c2d 2.0Ghz/4GB ddr2/320GB sata/etc...

Offline lfernandosg

  • Usuário Ubuntu
  • *
  • Mensagens: 477
    • Ver perfil
Jdk só funciona a hora que quer.
« Resposta #3 Online: 28 de MAR?O de 2006, 16:05 »
estou agora no laboratório da faculdade onde estudo e aqui é usado o debian CDD-BR e aproveitei para testar as configurações Java pois estudo programação neles e vi que dentro da pasta /etc/profile está tudo original(sem nenhuma alteração que vc pediu), dentro da pasta /home/usuário/.bash também  não tem o /etc/profile.d e o Java está fucnionando normal pois acabei de fazer um programa nele dá uma lhada quandoi dou Java -version:

aula@debian-br-cdd:~$ Java -version
SableVM version 1.11.3
- compile date and time: 2005-04-12 06:26:04 UTC
- gcc version: 3.3.5 (Debian 1:3.3.5-Cool
- 'real life brokenness' features enabled
- signal based exception detection
- copying garbage collection
- bidirectional object layout
- inline-threaded interpreter


eu particulamente desconhecia essa versão, mas voltando o assunto o que posso pfazer já fiz o que vc pediu,criei um script que vi em outro fórum e nada, o Java só funciona temporariamente quando dou um source /etc/profile mas só é entrar no anjuta que ele diz que o jaca não existe, quando volto para o terminal o Java sumiu.
Aguardo notícias
Dell Xps M1330/c2d 2.0Ghz/4GB ddr2/320GB sata/etc...

denisbr

  • Visitante
Jdk só funciona a hora que quer.
« Resposta #4 Online: 28 de MAR?O de 2006, 16:35 »
Não lembro se faz diferença, mas eu uso o arquivo .bashrc

O fato de ser
CLASSPATH=.:$CLASSPATH  ou CLASSPATH=$CLASSPATH:. não importa.

Lembre-se que depois de alterar o .bashrc você deve reiniciar o terminal ou efetuar os comandos
import ... manualmente

Offline lfernandosg

  • Usuário Ubuntu
  • *
  • Mensagens: 477
    • Ver perfil
Jdk só funciona a hora que quer.
« Resposta #5 Online: 28 de MAR?O de 2006, 17:17 »
eu reiniciei o computador depois que fiz isso no .bashrc  mas continuou sem funcionar.vi que nos computadores da faculdade tem esse SableVM version 1.11.3  e o free-java-sdk instalados, será que é isso? o meu note não tem isso instalado.
Dell Xps M1330/c2d 2.0Ghz/4GB ddr2/320GB sata/etc...

denisbr

  • Visitante
Jdk só funciona a hora que quer.
« Resposta #6 Online: 28 de MAR?O de 2006, 17:51 »

Offline lfernandosg

  • Usuário Ubuntu
  • *
  • Mensagens: 477
    • Ver perfil
Jdk só funciona a hora que quer.
« Resposta #7 Online: 28 de MAR?O de 2006, 23:14 »
Eu configurei por aí mesmo...
Dell Xps M1330/c2d 2.0Ghz/4GB ddr2/320GB sata/etc...

denisbr

  • Visitante
Jdk só funciona a hora que quer.
« Resposta #8 Online: 29 de MAR?O de 2006, 08:46 »
Mas você deve ter errado em alguma coisa, eu ja usei aquele tutorial  funcionou, nos comentários do tutorial todos dizem que funcionou.
Remove tudo (j2sdk, linhas nos arquivos de configuração) e recomeça de novo.

Ou então adiciona essa linha
Código: [Selecionar]
deb http://www.tux.org/pub/java/debian sid main non-free

no arquivo /etc/apt/sources.list e executa sudo apt-get update e sudo apt-get install j2sdk1.4 1.4.2.03-1

Offline lfernandosg

  • Usuário Ubuntu
  • *
  • Mensagens: 477
    • Ver perfil
Jdk só funciona a hora que quer.
« Resposta #9 Online: 29 de MAR?O de 2006, 09:29 »
tentei pelo repositório que vc falou mas deu esse erro:
Lendo Lista de Pacotes... Pronto
W: Não foi possível checar a lista de pacotes fonte http://www.tux.org sid/main Packages (/var/lib/apt/lists/www.tux.org_pub_java_debian_dists_sid_main_binary-i386_Packages) - stat (2 Arquivo ou diretório não encontrado)
W: Você terá que executar apt-get update para corrigir esses arquivos faltosos


tem algum outro? e quando eu instalar pelo apt-get como vou saber o caminho para o java tipo :
export JAVA_HOME=/usr/local/java/  <----
export PATH=$PATH:$JAVA_HOME/bin/
export CLASSPATH=$CLASSPATH:.
Dell Xps M1330/c2d 2.0Ghz/4GB ddr2/320GB sata/etc...

Offline lfernandosg

  • Usuário Ubuntu
  • *
  • Mensagens: 477
    • Ver perfil
Jdk só funciona a hora que quer.
« Resposta #10 Online: 29 de MAR?O de 2006, 10:17 »
Olha consegui colocar para rodar seguindo esse tutorial http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=2019  mas só está rodando como root  então ele pede para colocar a mesma linha de comando dentro do ~/.bashrc e do /etc/bashrc do uauário então fiz assim:

#gedit  ~/.bashrc
export PATH:/usr/local/java/jdk1.5.0_06/bin:$PATH
#source  ~/.bashrc

até nesse ponto tudo bem ficou tudo funcionando mas só como root então:
#gedit  /home/fernando/.bashrc
export PATH:/usr/local/java/jdk1.5.0_06/bin:$PATH
#source /home/fernando/.bashrc
nesse caso dá esse erro:
bash: export: `PATH:/usr/local/java/jdk1.5.0_06/bin:/usr/local/bin:/usr/bin:/bin :/usr/bin/X11:/usr/games': not a valid identifier


#gedit /etc/bashrc
export PATH:/usr/local/java/jdk1.5.0_06/bin:$PATH

dá o mesmo erro

como faço para execura como usuário normal?
Dell Xps M1330/c2d 2.0Ghz/4GB ddr2/320GB sata/etc...