Autor Tópico: Aceleração 3D no Note Itautec w7635 via chrome 9....Tutoriais não funcionaram!!!  (Lida 11035 vezes)

Offline manu_nuk

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
oi gente, eu to usando o ubuntu8.10, eu tentei de tudo para ativar a bendita aceleração 3D, meu xorg fikou bunitinho, mais meu ubuntu soh roda quando coloco no xorg a opção de driver o openchrome, não sei o que acontece segui todos os passos do Tutorial - Note Itautec W7635 (VN896/Chrome9 HC IGP) com 3D ativado no Ubuntu!!!, porem com o kernel 2.6.27 com as opções 9 e 7 de generic, meu pc é um itautec w7635, e a placa de video eh essa: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] (rev 01), alguem me ajuda to desesperada por uma resposta.

Ah tem outra coisa, eu baixei um driver mais novo da via e instala-lo seguindo este tutorial http://guide.ubuntuforums.org/showthread.php?p=6386897 e quando eu usei este xorg abaixo, o ubuntu fez os barulhos de quando ele inicia eu coloquei usuario a senha e ateh entrei mais meu monitor parecia estar desligado ou algo assim:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, and then by hand by Who
# Thanks to mikez's docs and examples for teaching me!


Section "Device"
Driver "via"
VendorName "VIA Tech"
BoardName "via"
Identifier "Configured Video Device"

Option "ActiveDevice" "LCD" #required to make the resolution correct without RandR
Option "DPMS"
Option "PanelID" "3" #SUSE uses this, seems not to be reqd

Option "UseRandR12" # I WANT to use this (it works, almost)
#Option "HWCursor" # Doesn't restore cursor
Option "SWCursor" # Does restore cursor
EndSection

Section "Monitor"
Identifier "Monitor"
ModeLine "720x480" 26.7 720 736 808 896 480 481 484 497
ModeLine "720x576" 32.7 720 744 816 912 576 577 580 597
ModeLine "800x480" 29.58 800 816 896 992 480 481 484 497
ModeLine "848x480" 31.5 848 864 952 1056 480 481 484 497
ModeLine "856x480" 31.7 856 872 960 1064 480 481 484 497
ModeLine "960x600" 45.98 960 1000 1096 1232 600 601 604 622 -HSync +Vsync
ModeLine "1000x600" 48.07 1000 1040 1144 1288 600 601 604 622 -HSync +Vsync
ModeLine "1024x512" 41.3 1024 1056 1160 1296 512 513 516 531
ModeLine "1088x612" 52.95 1088 1128 1240 1392 612 613 616 634 -HSync +Vsync
ModeLine "1152x720" 67.32 1152 1208 1328 1504 720 721 724 746 -HSync +Vsync
ModeLine "1200x720" 70.18 1200 1256 1384 1568 720 721 724 746 -HSync +Vsync
ModeLine "1280x600" 61.50 1280 1336 1464 1648 600 601 604 622 -HSync +Vsync
ModeLine "1280x720" 74.6 1280 1341 1474 1688 720 721 724 746
ModeLine "1280x768" 80.1 1280 1344 1480 1680 768 769 772 795
ModeLine "1360x768" 85.50 1360 1392 1712 1744 768 783 791 807 +HSync +Vsync
ModeLine "1366x768" 85.86 1366 1440 1584 1800 768 769 772 795 -HSync +Vsync
ModeLine "1440x900" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync
ModeLine "1440x1050" 126.2 1440 1536 1688 1936 1050 1051 1054 1087
ModeLine "1600x900" 119.00 1600 1696 1864 2128 900 901 904 932 -HSync +Vsync
ModeLine "1600x1024" 136.36 1600 1704 1872 2144 1024 1025 1028 1060 -HSync +Vsync
ModeLine "1792x1344" 202.97 1792 1920 2112 2432 1344 1345 1348 1391 -HSync +Vsync
ModeLine "1856x1392" 218.57 1856 1992 2192 2528 1392 1393 1396 1441 -HSync +Vsync
ModeLine "1920x1080" 172.9 1920 2043 2249 2578 1080 1081 1084 1118
ModeLine "2048x1536" 266.95 2048 2200 2424 2800 1536 1537 1540 1589 -HSync +Vsync
ModeLine "720x480" 34.9 720 752 824 928 480 481 484 502
ModeLine "720x576" 42.6 720 760 832 944 576 577 580 602
ModeLine "848x480" 41.0 848 880 968 1088 480 481 484 502
ModeLine "856x480" 41.3 856 888 976 1096 480 481 484 502
ModeLine "1024x512" 53.3 1024 1072 1176 1328 512 513 516 535
ModeLine "1280x768" 103.0 1280 1360 1496 1712 768 769 772 802
ModeLine "1440x1050" 160.0 1440 1536 1696 1952 1050 1051 1054 1096
ModeLine "1280x768" 118.5 1280 1368 1504 1728 768 769 772 807
ModeLine "1440x1050" 184.5 1440 1544 1704 1968 1050 1051 1054 1103
ModeLine "848x480" 47.4 848 888 976 1104 480 481 484 505
EndSection

Section "Screen"
Monitor "Monitor"
SubSection "Display"
Modes "1280x768"
Virtual 1280 768
Depth 24
EndSubSection
Identifier "Default Screen"
Device "Configured Video Device"
Option "ForceLCD" "true"
Option "ActiveDevice" "LCD"
Option "VideoOnDevice" "LCD"
Option "SetMpegFBNumber" "true"
EndSection

Section "Module"
Load "glx"
Load "dri"
Load "extmod"
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Section "ServerLayout"
#Option "RandR" "False"
Identifier "main"
Screen "Default Screen"
EndSection

muito obrigada antecipadamente!!!
« Última modificação: 29 de Janeiro de 2009, 11:13 por manu_nuk »

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 723
    • Ver perfil
    • LinuxUserVlog
O tutorial citado é para o Ubuntu 8.04 (HARDY).

Ainda não tive notícias de que alguém tenha conseguido ativar o 3D neste Note usando o 8.10.


...

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 723
    • Ver perfil
    • LinuxUserVlog
Com relação à aceleração 3D no 8.10 eu também obtive os mesmos resultados que você. Realmente dá a impressão que o LCD é desligado ao iniciar o X (meu Note é o mesmo que o seu).

Tentei várias opções de configuração e nada...

Instalei este driver: http://linux.via.com.tw/support/beginDownload.action?eleid=221&fid=482

E instalei esta atualização: http://linux.via.com.tw/support/beginDownload.action?eleid=262&fid=502

Ainda não tive sucesso...

Sintomas atuais: O sistema inicia normalmente. Ao carregar o GDM, a tela fica completamente preta, como se o LCD estivesse desligado (aparentemente ele desliga ao carregar o X). É possível ouvir o som do GDM, e do sistema sendo carregado após a digitação do login e da senha ("no escuro"). Mas nada de imagem, apenas som...

Vou deixar aqui documentado a última tentativa de configuração do xorg que utilizei:

Código: [Selecionar]
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, and then by hand by Who
# Thanks to mikez's docs and examples for teaching me!


Section "Device"
Driver "via"
VendorName "VIA Tech"
   BoardName   "via"
   Busid "PCI:1:0:0"
   Option "LCDPort" "DFP_HIGHLOW"
   Identifier   "Configured Video Device"
   
   Option "ActiveDevice" "LCD"          #required to make the resolution correct without RandR
   Option "DPMS"
   Option "PanelID" "3"             #SUSE uses this, seems not to be reqd

   Option "UseRandR12"  # I WANT to use this (it works, almost)
   #Option "HWCursor" # Doesn't restore cursor
   Option "SWCursor" # Does restore cursor
EndSection

Section "Monitor"
   Identifier "Monitor"
   
   Modeline "1280x800_70.00"  98.89  1280 1352 1488 1696  800 801 804 833  -HSync +Vsync

   ModeLine "720x480" 26.7 720 736 808 896 480 481 484 497
   ModeLine "720x576" 32.7 720 744 816 912 576 577 580 597
   ModeLine "800x480" 29.58 800 816 896 992 480 481 484 497
   ModeLine "848x480" 31.5 848 864 952 1056 480 481 484 497
   ModeLine "856x480" 31.7 856 872 960 1064 480 481 484 497
   ModeLine "960x600" 45.98 960 1000 1096 1232  600 601 604 622 -HSync +Vsync
   ModeLine "1000x600" 48.07 1000 1040 1144 1288 600 601 604 622 -HSync +Vsync
   ModeLine "1024x512" 41.3 1024 1056 1160 1296 512 513 516 531
   ModeLine "1088x612" 52.95 1088 1128 1240 1392 612 613 616 634 -HSync +Vsync
   ModeLine "1152x720" 67.32 1152 1208 1328 1504 720 721 724 746 -HSync +Vsync
   ModeLine "1200x720" 70.18 1200 1256 1384 1568 720 721 724 746 -HSync +Vsync
   ModeLine "1280x600" 61.50 1280 1336 1464 1648 600 601 604 622 -HSync +Vsync
   ModeLine "1280x720" 74.6 1280 1341 1474 1688 720 721 724 746
   ModeLine "1280x768" 80.1 1280 1344 1480 1680 768 769 772 795
   ModeLine "1360x768" 85.50 1360 1392 1712 1744 768 783 791 807 +HSync +Vsync
   ModeLine "1366x768" 85.86 1366 1440 1584 1800 768 769 772 795 -HSync +Vsync
   ModeLine "1440x900" 106.47 1440 1520 1672 1904 900 901 904 932 -HSync +Vsync
   ModeLine "1440x1050" 126.2 1440 1536 1688 1936 1050 1051 1054 1087
   ModeLine "1600x900" 119.00 1600 1696 1864 2128 900 901 904 932 -HSync +Vsync
   ModeLine "1600x1024" 136.36 1600 1704 1872 2144 1024 1025 1028 1060 -HSync +Vsync
   ModeLine "1792x1344" 202.97 1792 1920 2112 2432 1344 1345 1348 1391 -HSync +Vsync
   ModeLine "1856x1392" 218.57 1856 1992 2192 2528 1392 1393 1396 1441 -HSync +Vsync
   ModeLine "1920x1080" 172.9 1920 2043 2249 2578 1080 1081 1084 1118
   ModeLine "2048x1536" 266.95 2048 2200 2424 2800 1536 1537 1540 1589 -HSync +Vsync
   ModeLine "720x480" 34.9 720 752 824 928 480 481 484 502
   ModeLine "720x576" 42.6 720 760 832 944 576 577 580 602
   ModeLine "848x480" 41.0 848 880 968 1088 480 481 484 502
   ModeLine "856x480" 41.3 856 888 976 1096 480 481 484 502
   ModeLine "1024x512" 53.3 1024 1072 1176 1328 512 513 516 535
   ModeLine "1280x768" 103.0 1280 1360 1496 1712 768 769 772 802
   ModeLine "1440x1050" 160.0 1440 1536 1696 1952 1050 1051 1054 1096
   ModeLine "1280x768" 118.5 1280 1368 1504 1728 768 769 772 807
   ModeLine "1440x1050" 184.5 1440 1544 1704 1968 1050 1051 1054 1103
   ModeLine "848x480" 47.4 848 888 976 1104 480 481 484 505
EndSection

Section "Screen"
   Monitor  "Monitor"
   SubSection "Display"
      Modes  "1280x768"
      Virtual 1280 768
      Depth  24
   EndSubSection
   Identifier   "Default Screen"
   Device      "Configured Video Device"
   Option      "ForceLCD"      "true"
   Option      "ActiveDevice"      "LCD"
   Option      "VideoOnDevice"      "LCD"   
   Option      "SetMpegFBNumber"   "true"
EndSection

Section "Module"
   Load  "glx"
   Load  "dri"
   Load  "extmod"
EndSection

Section "DRI"
   Group 0
   Mode 0666
EndSection

Section "ServerLayout"
   #Option "RandR" "False"
   Identifier "main"
   Screen "Default Screen"
EndSection

OBS: tentei várias opções que acompanham o pacote do driver (viax.conf). O máximo que consegui foi carregar o sistema com o LCD desligado (conforme relatado acima).


...
« Última modificação: 30 de Janeiro de 2009, 15:51 por rodrigo.miguel »

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 723
    • Ver perfil
    • LinuxUserVlog
Alguém tentou compilar o GFX Stable Chrome9 DRM source for kernel 2.6.27(12Dec08) (31.2K), para o 8.10, que está disponível emdisponível em http://linux.via.com.tw/support/beginDownload.action?eleid=262&fid=502 ??

Não lembro se tentei este...

Ainda não há nem sinal de uma versão para o 9.04... Então, vale a pena testar este. Eu ando meio sem tempo...  :(

Quem quiser tentar, siga as instruções do readme (a 2), no pacote:

2. For VIA CN896/VN896/VX800 chipset
(1) Copy drm-via_chrome9-2.6.27-85a-44411-src.tar.gz to your working directory
(2) Extract the package
    # tar -zxf drm-via_chrome9-2.6.27-85a-44411-src.tar.gz
(3) Enter the directory and build the source
    # cd drm-via_chrome9-2.6.27-85a-44411-src
    # make
(4) Backup the VIA chrome9 DRM module
    # cd /lib/modules/'uname -r'/kernel/ubuntu/via_chrome9
    # mv via_chrome9.ko via_chrome9.ko.bak
(5) Replace VIA DRM module by the new one
    # cp ~/drm-via_chrome9-2.6.27-85a-44411-src/via_chrome9.ko /lib/modules/'uname -r'/kernel/ubuntu/via_chrome9/
    # depmod -a
(6) Restart
    # reboot

Offline 666porcondissaum

  • Usuário Ubuntu
  • *
  • Mensagens: 49
    • Ver perfil
Alguém tentou compilar o GFX Stable Chrome9 DRM source for kernel 2.6.27(12Dec08) (31.2K), para o 8.10, que está disponível emdisponível em http://linux.via.com.tw/support/beginDownload.action?eleid=262&fid=502 ??

Não lembro se tentei este...


e para o jaunty 9.04????

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 723
    • Ver perfil
    • LinuxUserVlog
Alguém tentou compilar o GFX Stable Chrome9 DRM source for kernel 2.6.27(12Dec08) (31.2K), para o 8.10, que está disponível emdisponível em http://linux.via.com.tw/support/beginDownload.action?eleid=262&fid=502 ??

Não lembro se tentei este...


e para o jaunty 9.04????

Um usuário me relatou que conseguiu instalar o driver do 8.04 no 9.04, mas com travamentos no Compiz.

Mas não consegui confirmar a informação (tentei e não funcionou).

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 723
    • Ver perfil
    • LinuxUserVlog
Documentando...


Tutorial interessante. Pode ajudar:

http://sites.google.com/site/sti1462/xorg-conf

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.061
    • Ver perfil
    • Alexsandro Felix
Movido de Dicas e Truques para Notebooks e Handhelds por se adequar melhor a este último.

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 723
    • Ver perfil
    • LinuxUserVlog
Novidades

Pacote novo disponível no http://linux.via.com.tw (para o 9.04/Jaunty, inclusive!):

Unified 2D/DRM driver source version 86a-50283 (21Aug09) (570K)
« Última modificação: 01 de Novembro de 2009, 11:16 por rodrigo.miguel »

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 723
    • Ver perfil
    • LinuxUserVlog
Re: Aceleração 3D no Note Itautec w7635 via chrome 9....Tutoriais não funcionaram!!!
« Resposta #9 Online: 01 de Novembro de 2009, 11:32 »
O site http://linux.via.com.tw disponibilizou uma nova versão do driver de vídeo para o Ubuntu 9.04:

Unified GFX driver Ver 86a-50937 for Ubuntu 9.04(26Oct09) (3.4M)

http://linux.via.com.tw/support/beginDownload.action?eleid=342&fid=643

Eu testei, mas não tive sucesso na instalação. O máximo que consegui foi iniciar o sistema com uma tela muito escura, com os gráficos quase imperceptíveis.

Vou deixar aqui os passos básicos para aqueles que quiserem tentar.
Mas, antes, faça backup do xorg.conf!

Para descompactar:

Código: [Selecionar]
tar -xvvf 5.74.33.86a-u904-50937.tgz
Para instalar:

Código: [Selecionar]
cd 5.74.33.86a-u904-50937
sudo ./vinstall

Reinicie o sistema!

Se der pau, restaure o xorg anterior (lembre-se do backup).

A última configuração (do xorg) que tentei foi esta (a que resultou numa tela muito escura, com os gráficos quase imperceptíveis):

Código: [Selecionar]
Section "ServerLayout"
Identifier     "X.org Configured"
option        "RandR" "false"
Screen      0  "Screen0" 0 0
EndSection

Section "Files"
ModulePath   "/usr/lib/xorg/modules"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Module"
      Load  "glx"
      Load  "dri"
      Load  "extmod"
EndSection

Section "Device"
BusID "PCI:01:00:0"
Identifier  "Card0"
Driver      "via"
VendorName  "VIA Technologies, Inc."


Option "ActiveDevice"  "LCD"
Option "LCDPort"       "DFP_HIGHLOW"

Option "XaaNoImageWriteRect"

# Option "AccelMethod" "EXA"
# Option "ExaNoComposite" "True"
# Option "MigrationHeuristic" "greedy"
# Option "ExaScratchSize" "8192"
# Option "MaxDRIMem" "16384"

EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
      SubSection "Display"
        Depth      24
        Modes      "1280x800"
      EndSubSection
EndSection

Section "DRI"
       Group 0
       Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Offline juliocampa

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Aceleração 3D no Note Itautec w7635 via chrome 9....Tutoriais não funcionaram!!!
« Resposta #10 Online: 22 de Novembro de 2009, 13:19 »
Este problema da tela escura é porque a placa não está ligando as luzes do LCD, como se a tampa estivesse fechada (a ddp ainda está sendo aplicada nos pixels mas as luzes do fundo não são ligadas, assim só vemos a luz externa, da sala, refletindo onde era pra estar o conjunto de luzes do monitor). Tive este problema tanto com o drive do Hardy, como no da openchrome e agora no drive do Jaunty (mas nos dois primeiros o problema horas ocorria, horas não) e até o pessoal da assistência técnica que eu fui me fez trocar o inverter achando que o problema era nele.

Creio que deve haver algum problema no módulo que administra isso ou ele nem mesmo deve estar sendo carregado.

Quanto à solução disso, nem faço idéia por onde começar.

Valeu
« Última modificação: 24 de Novembro de 2009, 09:39 por juliocampa »

Offline juliocampa

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Aceleração 3D no Note Itautec w7635 via chrome 9....Tutoriais não funcionaram!!!
« Resposta #11 Online: 24 de Novembro de 2009, 09:37 »
Procurando achei isso:

http://www.hpminiguide.com/forums/viewtopic.php?p=17276&sid=641dcf7f49157a70bd50de63c4ef04ee#17276

Aparentemente conseguiram fazer funcionar a aceleração 3D na placa Chrome9 HC no 9.10. Tentei aqui mas não consegui compilar os drives do kernel ( disponíveis não-oficialmente aqui: http://ubuntuforums.org/showpost.php?p=8176141&postcount=275

Por causa disso nem tentei instalar o drive já que com certeza não iria funcionar sem os drives do kernel compilados.

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 723
    • Ver perfil
    • LinuxUserVlog
Re: Aceleração 3D no Note Itautec w7635 via chrome 9....Tutoriais não funcionaram!!!
« Resposta #12 Online: 04 de Dezembro de 2009, 21:38 »
Apenas pra registrar

Gerei o xorg.conf no 9.10, para verificar se o openchrome estava sendo carregado como driver de vídeo.

Usei os comandos:

Código: [Selecionar]
sudo /etc/init.d/gdm stop
sudo X -configure

Talvez possa auxiliar na configuração do xorg para o driver 3D (os parâmetros devem ser praticamente os mesmos, ou não...  ;D).

Código: [Selecionar]
Section "ServerLayout"
Identifier     "X.org Configured"
Screen      0  "Screen0" 0 0
InputDevice    "Mouse0" "CorePointer"
InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath   "/usr/lib/xorg/modules"
FontPath     "/usr/share/fonts/X11/misc"
FontPath     "/usr/share/fonts/X11/cyrillic"
FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath     "/usr/share/fonts/X11/Type1"
FontPath     "/usr/share/fonts/X11/100dpi"
FontPath     "/usr/share/fonts/X11/75dpi"
FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath     "built-ins"
EndSection

Section "Module"
Load  "glx"
Load  "dri"
Load  "record"
Load  "dri2"
Load  "extmod"
Load  "dbe"
EndSection

Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
EndSection

Section "InputDevice"
Identifier  "Mouse0"
Driver      "mouse"
Option     "Protocol" "auto"
Option     "Device" "/dev/input/mice"
Option     "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Monitor Vendor"
ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "PrintVGARegs"        # [<bool>]
        #Option     "PrintTVRegs"        # [<bool>]
        #Option     "I2CScan"            # [<bool>]
        #Option     "VBEModes"            # [<bool>]
        #Option     "NoAccel"            # [<bool>]
        #Option     "AccelMethod"        # <str>
        #Option     "ExaNoComposite"      # [<bool>]
        #Option     "ExaScratchSize"      # <i>
        #Option     "SWCursor"            # [<bool>]
        #Option     "ShadowFB"            # [<bool>]
        #Option     "Rotate"              # [<str>]
        #Option     "VideoRAM"            # <i>
        #Option     "ActiveDevice"        # [<str>]
        #Option     "BusWidth"            # [<str>]
        #Option     "Center"              # [<bool>]
        #Option     "PanelSize"          # [<str>]
        #Option     "ForcePanel"          # [<bool>]
        #Option     "TVDotCrawl"          # [<bool>]
        #Option     "TVDeflicker"        # <i>
        #Option     "TVType"              # [<str>]
        #Option     "TVOutput"            # [<str>]
        #Option     "DisableVQ"          # [<bool>]
        #Option     "DisableIRQ"          # [<bool>]
        #Option     "EnableAGPDMA"        # [<bool>]
        #Option     "NoAGPFor2D"          # [<bool>]
        #Option     "NoXVDMA"            # [<bool>]
        #Option     "VbeSaveRestore"      # [<bool>]
        #Option     "DisableXvBWCheck"    # [<bool>]
        #Option     "MaxDRIMem"          # <i>
        #Option     "AGPMem"              # <i>
Identifier  "Card0"
Driver      "openchrome"
VendorName  "VIA Technologies, Inc."
BoardName   "CN896/VN896/P4M900 [Chrome 9 HC]"
BusID       "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device     "Card0"
Monitor    "Monitor0"
SubSection "Display"
Viewport   0 0
Depth     1
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     4
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     8
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     15
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     16
EndSubSection
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

Interessante é que, ao rodar o comando glxinfo | grep render, eu tenho o seguinte resultado:

direct rendering: Yes
OpenGL renderer string: Software Rasterizer

Porém, nada de Compiz. Google Earth é até usável. Mas o desempenho no Foobillard (jogo de sinuca 3D) é terrível...