Autor Tópico: Apache simplismente parou  (Lida 4691 vezes)

Offline etapombas

  • Usuário Ubuntu
  • *
  • Mensagens: 361
    • Ver perfil
    • Baixar.info
Apache simplismente parou
« Online: 22 de Junho de 2008, 02:37 »
Galera meu servidor apache retorna essa mensagem quando executo o comando apache2 -k restart

apache2: bad user name ${APACHE_RUN_USER}

já mudei no /etc/apache2/apache.conf  para www-data

mas dai tenho a seguinte mensagem de retorno

apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
httpd not running, trying to start
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Offline ricardofantin

  • Usuário Ubuntu
  • *
  • Mensagens: 105
    • Ver perfil
Re: Apache simplismente parou
« Resposta #1 Online: 08 de Julho de 2008, 19:27 »
Você não esta com o usuário correto e o apache já esta rodando, você precisa estar com o usuário root tente assim:
sudo /etc/init.d/apache2 restart

Reiniciar o computador não resolve o problema?

Eu tentei aqui em casa em uma máquina virtual, na imagem você encontra o erro quando eu tentei rodar com o usuário normal (ricardo) e com o www-data.



usando o comando su e depois digitando /etc/init.d/apache2 restart funcionou aqui.

Offline etapombas

  • Usuário Ubuntu
  • *
  • Mensagens: 361
    • Ver perfil
    • Baixar.info
Re: Apache simplismente parou
« Resposta #2 Online: 08 de Julho de 2008, 22:18 »
vlw cara... mas eu descobri que o problema nas permissoes na pasta www
na verdade ela é um link para uma pasta Sites na minha home e com isso gerou um conflito

mas vlw pela forca

Offline Evandro Abu Kamel

  • Usuário Ubuntu
  • *
  • Mensagens: 202
  • Ubuntu Jaunty
    • Ver perfil
    • Fórum Sistemas de Imformação PUC Minas
Re: Apache simplismente parou
« Resposta #3 Online: 26 de Abril de 2009, 01:55 »
Olá, estive com o mesmo problema, mas resolvi logo com o comando que o "ricardofantin" passou.
Mas quando acesso um arquivo PHP o Firefox tenta baixar o arquivo.   :(

Quais devem ser as permissões do diretório /var/www e seus arquivos? E quem deve/pode ser o dono e o grupo?
Existe alguma configuração a ser feita nos arquivos do Apache2 ou do PHP5?

Agradeço.


Offline sistematico

  • Usuário Ubuntu
  • *
  • Mensagens: 576
  • Sistematico
    • Ver perfil
    • Sistematico.org
Re: Apache simplismente parou
« Resposta #4 Online: 26 de Abril de 2009, 02:00 »
Uso o Lighttpd ao invés de Apache, então desculpa se eu falar bobeira.
Aqui o Lighttpd roda sob usuario e grupo www-data mas lê a minha home com usuario e grupo lucas normalmente.

A pasta /home, /home/lucas e /home/lucas/html tem permissões de escrita-leitura-execução pro dono e apenas execução para outros.
Ou seja: drwx-----x

Ok?
Lucas Saliés Brum
Ubuntu User #27150
http://sistematico.org

Offline Evandro Abu Kamel

  • Usuário Ubuntu
  • *
  • Mensagens: 202
  • Ubuntu Jaunty
    • Ver perfil
    • Fórum Sistemas de Imformação PUC Minas
Re: Apache simplismente parou
« Resposta #5 Online: 26 de Abril de 2009, 17:41 »
Ih cara, resolveu não. Eu desinstalei tudo (Apache2, PHP5, MySQL5) e instalei de novo, mantendo os arquivos de configuração. Mas agora quando o navegador abre um arquivo PHP, ele tenta baixar o arquivo.  =/


Offline roan

  • Usuário Ubuntu
  • *
  • Mensagens: 37
    • Ver perfil
Re: Apache simplismente parou
« Resposta #6 Online: 29 de Abril de 2009, 11:41 »
Ih cara, resolveu não. Eu desinstalei tudo (Apache2, PHP5, MySQL5) e instalei de novo, mantendo os arquivos de configuração. Mas agora quando o navegador abre um arquivo PHP, ele tenta baixar o arquivo.  =/

Isso acontece quando o suporte ao php não está instalado ou configurado para o apache2. Tem que verificar se você instalou a libapache2-mod-php5 junto com o apache2 e o php5, e se ela está ativa nas configurações do apache2. Em /etc/apache2/mods-enabled deve ter um arquivo php5.conf e php5.load configurados.
« Última modificação: 29 de Abril de 2009, 11:45 por roan »