Autor Tópico: cpu sem motivo a 100% (resolvido)  (Lida 15089 vezes)

Offline lekitus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
cpu sem motivo a 100% (resolvido)
« Online: 02 de Maio de 2009, 08:54 »
Já procurei aqui no fórum e no google mas ainda não encontrei nada que resolva meu problema. minha cpu fica sempre com 100% de uso assim que eu faço o login e não sai disso. O mais engraçado é que se olharmos no monitor do sistema ou no terminal (top) não aparece nada que justifique os 100% de uso.

top - 08:48:06 up  5:54,  2 users,  load average: 2.85, 3.50, 3.58
Tasks: 135 total,   5 running, 129 sleeping,   0 stopped,   1 zombie
Cpu(s): 69.7%us, 23.0%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.0%hi,  7.3%si,  0.0%st
Mem:   1026540k total,   898332k used,   128208k free,   291140k buffers
Swap:  2441872k total,      500k used,  2441372k free,   207336k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND           
 3262 root      20   0  111m  69m 7620 R 21.6  6.9  36:38.12 Xorg               
 4029 leco      20   0 64688  41m 5232 S  7.0  4.2   8:46.80 compiz.real       
32457 leco      20   0  267m 131m  24m S  4.3 13.1   3:41.49 firefox           
 3715 leco      20   0 27244 7504 5808 R  3.7  0.7  11:58.28 x-session-manag   
 3776 leco      20   0  5124 3288  644 S  2.3  0.3  11:03.02 dbus-daemon       
 3784 leco      20   0  8644 5148 2208 S  2.0  0.5   8:01.22 gconfd-2           
 3893 leco      20   0 57260  24m 8692 S  2.0  2.5   5:08.92 cairo-dock         
10204 leco      20   0 32828  13m 9832 R  2.0  1.3   0:07.81 gnome-terminal     
 4148 leco      20   0 17264 2968 1696 S  1.7  0.3   3:00.01 gnome-screensav   
29855 leco      20   0     0    0    0 Z  1.7  0.0   0:00.05 vino-serv <defunct>
 3811 leco      20   0 34112  10m 6632 S  1.0  1.1   4:37.63 gnome-settings-   
 3879 leco      20   0 53172  22m  11m S  1.0  2.2   2:57.90 gnome-panel       
 3982 leco      20   0 26352  11m 8160 S  0.7  1.1   2:06.82 multiload-apple   
29856 leco      20   0 22728 5980 4700 R  0.7  0.6   0:00.02 vino-server       
 2082 root      15  -5     0    0    0 S  0.3  0.0   0:01.62 kjournald         
 3798 leco      20   0  5688 2080 1744 S  0.3  0.2   0:53.16 gvfsd             
 3890 leco      20   0 33068  16m 9260 S  0.3  1.7   0:58.05 update-notifier   

Alguem tem ideia do que pode ser isso?
meu computer é um AMD 64 com 1gb de memoria. Instalei essa semana o jaunty32 do zero (exceto minha home) e desde o começo ta dando isso.
« Última modificação: 21 de Maio de 2009, 21:45 por lekitus »

Offline ubu4ever

  • Usuário Ubuntu
  • *
  • Mensagens: 695
    • Ver perfil
Re: cpu sem motivo a 100%
« Resposta #1 Online: 02 de Maio de 2009, 12:21 »
Tive um problema semelhante, mas o meu caso era o Tracker Index. Executei o comando:

sudo tracker-processes -r

para terminar todos os processos de indexação, pois além de consumirem muito processamento, estava dando uma mensagem de erro toda hora.
Execute este comando, vá em Sistema>>Aplicativos de Sessão e desabilite o "Tracker". Depois vá em Sistema>>Administração>>Pesquisa e Indexação e desabilite as opções de indexar.

Reinicie o computador e verifique quanto de cpu está sendo usado.

Offline lekitus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: cpu sem motivo a 100%
« Resposta #2 Online: 02 de Maio de 2009, 13:31 »
valeu pela ajuda! mas no meu caso o tracker nem ta instalado! deve ser alguma outra coisa...

Offline lekitus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: cpu sem motivo a 100%
« Resposta #3 Online: 06 de Maio de 2009, 06:07 »
será que adianta reinstalar o sistema? não consigo descobrir qual o problema!...

Offline niitsu

  • Usuário Ubuntu
  • *
  • Mensagens: 62
    • Ver perfil
Re: cpu sem motivo a 100%
« Resposta #4 Online: 06 de Maio de 2009, 08:44 »
Tive o mesmo problema que você amigo. No meu caso era o Evolution que iniciava um serviço junto com o Ubuntu, e aparentemente sem motivos deixava o processador a 100%.
Como só uso webmail, desinstalei o Evolution e meu problema foi resolvido.

Abraços!

Offline lekitus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: cpu sem motivo a 100%
« Resposta #5 Online: 10 de Maio de 2009, 22:10 »
Não adiantou reinstalar!....o problema continua :(

Offline lunga

  • Usuário Ubuntu
  • *
  • Mensagens: 366
  • Visitem: www.mundolunga.com
    • Ver perfil
    • O mundo de lunga
Re: cpu sem motivo a 100%
« Resposta #6 Online: 13 de Maio de 2009, 10:13 »
Eu estava com esse problema e vi q era o firefox.

Era um problema com o controle de phishing dele.

Eu desabilitei e funcionou. Depois entrei no about:config e botei tudo como padrao na chave safebrownsing.
Se sua dúvida foi resolvida, por favor,  edite o título do tópico para indicar isso!

"Na União Soviética, a rosca é que queima você!!!

Offline lekitus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: cpu sem motivo a 100%
« Resposta #7 Online: 13 de Maio de 2009, 20:21 »
mas o meu problema surge logo q o sistema carrega, nem preciso abrir programa algum! :(

Offline lunga

  • Usuário Ubuntu
  • *
  • Mensagens: 366
  • Visitem: www.mundolunga.com
    • Ver perfil
    • O mundo de lunga
Re: cpu sem motivo a 100%
« Resposta #8 Online: 18 de Maio de 2009, 22:29 »
eu fiz o  lance no firefox. Mas depois comecou de novo esse lance de ficar a100%, mas nao ter processos que justifiquem isso.

Estou a procura de alguma explicaçao. Se nao terei de voltar para o 8.10 :(
Se sua dúvida foi resolvida, por favor,  edite o título do tópico para indicar isso!

"Na União Soviética, a rosca é que queima você!!!

Offline ubu4ever

  • Usuário Ubuntu
  • *
  • Mensagens: 695
    • Ver perfil
Re: cpu sem motivo a 100%
« Resposta #9 Online: 18 de Maio de 2009, 23:08 »
Execute o comando

Código: [Selecionar]
top -d 2 -cEle irá lista todos os processos que estão rodando e informará a % de CPU de cada um deles a cada 2 segundos.

Veja qual o processo está "consumindo" mais CPU e anote o PID (número do processo) ou o nome do programa. Depois poste o nome do programa ou processo.

Para sair do programa tecle

Código: [Selecionar]
q

Offline lekitus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: cpu sem motivo a 100%
« Resposta #10 Online: 19 de Maio de 2009, 09:22 »
blz! vou tentar hoje a noite quando chegar em casa e posto o resultado aqui.

Offline lunga

  • Usuário Ubuntu
  • *
  • Mensagens: 366
  • Visitem: www.mundolunga.com
    • Ver perfil
    • O mundo de lunga
Re: cpu sem motivo a 100%
« Resposta #11 Online: 19 de Maio de 2009, 12:50 »
olha.. atualizei o kernel para o 2.6.28-12-generic

Tenho um note com placa intel e retirei da blacklist do compiz o driver e tava usando assim mesmo.
Pus novamente na black list e atualizei o kernel.
Parou de dar os lags e o driver foi habilitado novamente para o compiz.



Aparentemente era isso.
Se sua dúvida foi resolvida, por favor,  edite o título do tópico para indicar isso!

"Na União Soviética, a rosca é que queima você!!!

Offline lekitus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: cpu sem motivo a 100%
« Resposta #12 Online: 19 de Maio de 2009, 22:54 »
gcclt ai vai o que vc falou:

top - 22:51:01 up 5 min,  2 users,  load average: 4.65, 3.23, 1.45
Tasks: 132 total,  10 running, 122 sleeping,   0 stopped,   0 zombie
Cpu(s): 58.8%us, 25.5%sy,  1.5%ni,  0.0%id,  0.0%wa,  2.0%hi, 12.3%si,  0.0%st
Mem:   1026540k total,   749868k used,   276672k free,    41180k buffers
Swap:  2441872k total,        0k used,  2441872k free,   281128k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                       
 3045 root      20   0  111m  54m  11m R 13.9  5.4   0:43.14 /usr/X11R6/bin/X :0 -br -audit
 3748 leco      20   0 68812  47m  10m S 10.4  4.7   0:19.98 compiz.real --replace --sm-dis
 5122 leco      20   0  257m 123m  23m R  3.0 12.3   0:38.64 /usr/lib/firefox-3.0.10/firefo
 3448 leco      20   0 27292 7728 6008 R  2.5  0.8   0:06.56 x-session-manager             
 3517 leco      20   0  8456 5136 2288 S  2.0  0.5   0:05.24 /usr/lib/libgconf2-4/gconfd-2
 7621 leco      20   0 23296 7884 6360 R  2.0  0.8   0:00.04 /usr/lib/vino/vino-server --sm
 3509 leco      20   0  4044 2304  752 R  1.5  0.2   0:05.71 //bin/dbus-daemon --fork --pri
 7080 root      39  19 35792  31m 2708 R  1.5  3.2   0:01.07 /usr/bin/python /usr/lib/updat
 7231 leco      20   0 33448  13m 9.8m S  1.5  1.4   0:00.86 gnome-terminal               
 3612 leco      20   0 53472  26m  15m S  1.0  2.7   0:04.42 gnome-panel --sm-config-prefix
 3637 leco      20   0 98.8m  40m  14m S  1.0  4.1   0:07.26 cairo-dock -o                 
 3712 leco      20   0 22676 8836 7212 S  1.0  0.9   0:01.71 /usr/lib/gnome-applets/multilo
 3547 leco      20   0 34236  13m 8976 S  0.5  1.3   0:03.23 /usr/lib/gnome-settings-daemon
 3650 leco      20   0 26160 9544 6488 S  0.5  0.9   0:00.79 gnome-power-manager --sm-confi
 6167 leco      20   0 68260  12m 9.9m S  0.5  1.2   0:00.44 /usr/lib/evolution/2.26/evolut
    1 root      20   0  3084 1884  564 S  0.0  0.2   0:01.13 /sbin/init                   
    2 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 [kthreadd]                   
    3 root      RT  -5     0    0    0 S  0.0  0.0   0:00.00 [migration/0]                 
    4 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 [ksoftirqd/0]                 
    5 root      RT  -5     0    0    0 S  0.0  0.0   0:00.00 [watchdog/0]                 
    6 root      15  -5     0    0    0 R  0.0  0.0   0:00.06 [events/0]                   
    7 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 [khelper]                     
    8 root      RT  -5     0    0    0 S  0.0  0.0   0:00.00 [kstop/0]                     
    9 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 [kintegrityd/0]               
   10 root      15  -5     0    0    0 S  0.0  0.0   0:00.10 [kblockd/0]                   
   11 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 [kacpid]                     
   12 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 [kacpi_notify]               
   13 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 [cqueue]                     
   14 root      15  -5     0    0    0 S  0.0  0.0   0:00.00 [ata/0]

Offline ubu4ever

  • Usuário Ubuntu
  • *
  • Mensagens: 695
    • Ver perfil
Re: cpu sem motivo a 100% (Atualizado)
« Resposta #13 Online: 20 de Maio de 2009, 01:46 »
Pelo que vi em fóruns estrangeiros o problema é do kernel que não é "compatível" com alguns tipos de hardware. Entretanto, vi pessoas que fizeram o procedimento abaixo e resolveram o problema:

Abra o terminal e faça um backup (por segurança) do seu arquivo /etc/rc.local

Código: [Selecionar]
sudo cp /etc/rc.local /etc/rc.local.backup
Abra o arquivo

Código: [Selecionar]
sudo gedit /etc/rc.local
Depois adicione a linha abaixo no final do arquivo antes do código "exit 0"

Código: [Selecionar]
echo 1 > /sys/module/processor/parameters/max_cstate
Salve e reinicie o computador.
« Última modificação: 20 de Maio de 2009, 14:48 por gcclt »

Offline Bentomath

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: cpu sem motivo a 100%
« Resposta #14 Online: 20 de Maio de 2009, 10:46 »
Pelo que vi em fóruns estrangeiros o problema é do kernel que não é "compatível" com alguns tipos de hardware. Entretanto, vi pessoas que fizeram o procedimento abaixo e resolveram o problema:

Abra o terminal e faça um backup (por segurança) do seu arquivo /etc/rc.local

Código: [Selecionar]
sudo cp /etc/rc.local /etc/rc.local.backup
Abra o arquivo

Código: [Selecionar]
sudo gedit /etc/rc.local
Depois adicione a linha abaixo no final do arquivo

Código: [Selecionar]
echo 1 > /sys/module/processor/parameters/max_cstate
Salve e reinicie o computador.


A dica funcionou vlw, eu tbm coloquei o codigo pra ver a lista de processos tava 99% em 
/usr/game/... xboard <- mais ou menos isso ^^. Pelo que eu entendi e incompatibilidade com a
placa de video estou correto?

PS: Quando abri o Firefox a CPU chegou a ir pra 100% e deu um pequeno travamento, mas logo após ficou normal.
« Última modificação: 20 de Maio de 2009, 10:48 por Bentomath »