Autor Tópico: (RESOLVIDO)Configuração do Video-Nvidia!  (Lida 14696 vezes)

Offline prestrelo

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
(RESOLVIDO)Configuração do Video-Nvidia!
« Online: 07 de Maio de 2009, 11:00 »
Olá Pessoal,

Tenho um PC com a seguinte configuração:

Processador AMD Athlon(tm) 64 X2 Dual Core Processor 4000+
SO Ubuntu 9.04 (jaunty)
kernel 2.6.28-11-generic
GNOME 2.26.1
Placa de Video VGA compatible controller: nVidia Corporation G72 [GeForce 7300 SE] (rev a1)
Drive NVIDIA 180.44 (instalado pelo synaptic)

Problema 1:
Ao iniciar o ubuntu eu configuro para resolução 1280x1024 salvo, porém ao reiniciar a configuração volta a anterior 1024x768.

Meu xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Sun Feb  1 20:21:04 UTC 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder63)  Mon Mar 23 15:33:27 PST 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG L1753T"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7300 SE/7200 GS"
EndSection

Section "Screen"

# Removed Option "metamodes" "1152x864 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1280x1024 +0+0; 1152x864 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Meu linux-restricted-modules-common

# This file is sourced from the linux-restricted-modules-common init
# script and is used to disable the link-on-boot feature, one module
# at a time.  This can be useful if you want to use hand-compiled
# versions of one or more modules, but keep linux-restricted-modules
# installed on your system, or just to disable modules you don't use
# and speed up your boot process by a second or two.
#
# Use a space-separated list of modules you wish to not have linked
# on boot.  The following example shows a (condensed) list of all
# modules shipped in the linux-restricted-modules packages:
#
# DISABLED_MODULES="madwifi ltm wl"
#
# Note that disabling "madwifi" disables all madwifi drivers, "ltm"
# disables ltmodem and ltserial. You can also name each module
# individually, if you prefer a subset.

DISABLED_MODULES="nv"

Problema 2:

Após uns 10 minutos de inicio o ubuntu "TRAVA" isso mesmo "TRAVA"

Alguem tem alguma dica?

Abraço a todos.

Prestrelo
« Última modificação: 13 de Maio de 2009, 09:00 por prestrelo »
Acer Spire 1100, Processador-AMD Turio X2 Ran-3Gb Video-ATI Radeon Xpress 1100, HD-120Gb

Offline theoldpunk

  • Usuário Ubuntu
  • *
  • Mensagens: 108
    • Ver perfil
Re: Configuração do Video-Nvidia (travando) !
« Resposta #1 Online: 07 de Maio de 2009, 15:27 »
bom...  primeiro eu recomendo que baixe o driver pelo site da NVIDIA e instale manualmente, mas antes tente isso

 -Abra o terminal e digite

sudo nvidia-settings

 -Vá na aba "X Server Display Configuration" e mude a resolução por ali
 -Clique em "Apply" e "Save to X Configuration File"

pronto! =]
http://img141.imageshack.us/img141/6601/infobomblogo.png http://info-bomb.blogspot.com/ [off] | Ubuntu 9.10 Karmic Koala - Kernel 2.6.31-14-generic

Offline prestrelo

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: Configuração do Video-Nvidia (travando) !
« Resposta #2 Online: 08 de Maio de 2009, 10:28 »
bom...  primeiro eu recomendo que baixe o driver pelo site da NVIDIA e instale manualmente, mas antes tente isso

 -Abra o terminal e digite

sudo nvidia-settings

 -Vá na aba "X Server Display Configuration" e mude a resolução por ali
 -Clique em "Apply" e "Save to X Configuration File"

pronto! =]

Olá theoldpunk,

eu ja tentei configurar pelo X server Display Configuration como super usuario e salvei, porém quando reinicio a maquina a configuração volta a anterior. Irei tentar instalar o drive manualmente, porém não encontrei ainda drive para AMD 64 bits.

vlw
Acer Spire 1100, Processador-AMD Turio X2 Ran-3Gb Video-ATI Radeon Xpress 1100, HD-120Gb

Offline prestrelo

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: Configuração do Video-Nvidia (travando) !
« Resposta #3 Online: 08 de Maio de 2009, 10:46 »
bom...  primeiro eu recomendo que baixe o driver pelo site da NVIDIA e instale manualmente, mas antes tente isso

 -Abra o terminal e digite

sudo nvidia-settings

 -Vá na aba "X Server Display Configuration" e mude a resolução por ali
 -Clique em "Apply" e "Save to X Configuration File"

pronto! =]
Olá theoldpunk,

Baixei o driver NVIDIA-Linux-x86_64-180.51-pkg2.run pelo site da nvidia. E tentei instalar da seguinte forma:

CTrl + Alt + F1
loguei com usuario e senha
"sudo /etc/init.d/gdm stop"
"sudo sh NVIDIA-Linux-x86_64-180.51-pkg2.run"

ai deu erro:

erro:this .run file is intended for the Linux-x86_64 plataform, but you appear to be running on Linux-x86.
Aborting installation.

Porém no site da nvidia fala q este drive serve para AMD ou pelo menos foi o  que eu entendi:

Linux x64 (AMD64/EM64T) Display Driver

Version: 180.51
Operating System: Linux x64 (AMD64/EM64T)
Release Date: April 21, 2009


como não deu certo continuo sem conseguir manter a configuração de video.

vlw
Acer Spire 1100, Processador-AMD Turio X2 Ran-3Gb Video-ATI Radeon Xpress 1100, HD-120Gb

Offline socioambiental

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Configuração do Video-Nvidia (travando) !
« Resposta #4 Online: 08 de Maio de 2009, 11:40 »
tenta instalar pelo terminal...

Código: [Selecionar]
sudo apt-get install nvidia-glx-180

Offline theoldpunk

  • Usuário Ubuntu
  • *
  • Mensagens: 108
    • Ver perfil
Re: Configuração do Video-Nvidia (travando) !
« Resposta #5 Online: 08 de Maio de 2009, 13:05 »
1 - se vc instalar pelo terminal ele não instalará a ultima verção


2 - o que acontece é que ele apesar do seu processado ser 64, o seu sistema pode ser 32 então baixe a verção para este


3 - Você disse que mudou a configuração pelo nvidia-settings, mas vc clicou para salvar no Xorg (Save to X Configuration File)?
http://img141.imageshack.us/img141/6601/infobomblogo.png http://info-bomb.blogspot.com/ [off] | Ubuntu 9.10 Karmic Koala - Kernel 2.6.31-14-generic

Offline prestrelo

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: Configuração do Video-Nvidia (travando) !
« Resposta #6 Online: 08 de Maio de 2009, 15:41 »
1 - se vc instalar pelo terminal ele não instalará a ultima verção


2 - o que acontece é que ele apesar do seu processado ser 64, o seu sistema pode ser 32 então baixe a verção para este


3 - Você disse que mudou a configuração pelo nvidia-settings, mas vc clicou para salvar no Xorg (Save to X Configuration File)?
Olá theoldpunk,

Realmente você tinha razão como eu tenho dois sistemas um instalado no notebook e outro no desktop cabei confundindo. O drive correto para meu pc eh 32bits e não 64 como estava tentando anteriormente.

Baixei o driver e instalei. Modifiquei as configurações através do nvidia-settings salvei no xorg e reiniciei porém as configurações voltarão novamente.

ou seja não deu certo.

vlw.
Acer Spire 1100, Processador-AMD Turio X2 Ran-3Gb Video-ATI Radeon Xpress 1100, HD-120Gb

Offline theoldpunk

  • Usuário Ubuntu
  • *
  • Mensagens: 108
    • Ver perfil
Re: Configuração do Video-Nvidia (travando) !
« Resposta #7 Online: 08 de Maio de 2009, 18:43 »
infelizmente não sei o que está acontecendo..  você já tentou reinstalar o Ubuntu?
http://img141.imageshack.us/img141/6601/infobomblogo.png http://info-bomb.blogspot.com/ [off] | Ubuntu 9.10 Karmic Koala - Kernel 2.6.31-14-generic

Offline prestrelo

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Re: Configuração do Video-Nvidia (travando)!
« Resposta #8 Online: 13 de Maio de 2009, 09:00 »
infelizmente não sei o que está acontecendo..  você já tentou reinstalar o Ubuntu?

Olá a todos,

Inicialmente consegui resolver o problema da manutenção da configuração através do tópico do Bio-Gen http://ubuntuforum-br.org/index.php/topic,49834.0.html só para deixar marcado os passos foram o seguite:

Código: [Selecionar]
sudo nvidia-settings
X Server Display Configuration escolhi a resolução que eu queria 1280x1024 apliquei (Apply)e depois salvei Save to X Configuration file dessa forma ela salvará essa resolução no xorg.conf feito isso o proxímo passo é:

Sistema>Preferências>Video ou no caso de alguns Sistema>Preferências>Resolução de Tela no meu caso depois disso aparece uma menssagem :

Parece que o drive de video não suporta a extensão para usar esta ferramenta. VocÊ quer usar o drive de video do fabricante no lugar?

Eu clico em NÃO e ai sim aparece a janela de resolução de tela, Aplico a resolução que eu quero depois clico em manter resolução

Dessa forma ao reiniciar a resolução que eu escolhi permanecerá.

PS. Meu video continua travando. Porém acredito que isso seja outro problema por isso considero meu tópico RESOLVIDO. Valeu a todos que ajudaram.
Acer Spire 1100, Processador-AMD Turio X2 Ran-3Gb Video-ATI Radeon Xpress 1100, HD-120Gb

Offline joaoleite

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Configuração do Video-Nvidia (travando) !
« Resposta #9 Online: 21 de Maio de 2009, 00:18 »
infelizmente não sei o que está acontecendo..  você já tentou reinstalar o Ubuntu?

...................................
boa noite,eu tive esse mesmo problema,ate que me orientaram a desinstalar a versao amd64 e instalar i386,e foi o que fiz,mesmo meu pc sendo um amd athlon64 5200+,e instalei e consegui configurar minha resoluçao sem mais problema.

Offline andinhocp

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: Configuração do Video-Nvidia (travando)!
« Resposta #10 Online: 17 de Julho de 2009, 22:05 »
infelizmente não sei o que está acontecendo..  você já tentou reinstalar o Ubuntu?

Olá a todos,

Inicialmente consegui resolver o problema da manutenção da configuração através do tópico do Bio-Gen http://ubuntuforum-br.org/index.php/topic,49834.0.html só para deixar marcado os passos foram o seguite:

Código: [Selecionar]
sudo nvidia-settings
X Server Display Configuration escolhi a resolução que eu queria 1280x1024 apliquei (Apply)e depois salvei Save to X Configuration file dessa forma ela salvará essa resolução no xorg.conf feito isso o proxímo passo é:

Sistema>Preferências>Video ou no caso de alguns Sistema>Preferências>Resolução de Tela no meu caso depois disso aparece uma menssagem :

Parece que o drive de video não suporta a extensão para usar esta ferramenta. VocÊ quer usar o drive de video do fabricante no lugar?

Eu clico em NÃO e ai sim aparece a janela de resolução de tela, Aplico a resolução que eu quero depois clico em manter resolução

Dessa forma ao reiniciar a resolução que eu escolhi permanecerá.

PS. Meu video continua travando. Porém acredito que isso seja outro problema por isso considero meu tópico RESOLVIDO. Valeu a todos que ajudaram.

Otima dica do amigo "prestrelo" depois de quebrar muito a cabeça efetuei esse passos e funcionou perfeitamente.
tenho um notebook hp pavilom procesador amd x2 placa de video Nvidea GeForce 7150M / nForce 630M (GPU 0)

Offline aalberto

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: (RESOLVIDO)Instalacão e configuracão da nvidia 7200 gs!
« Resposta #11 Online: 20 de Julho de 2009, 21:57 »
ola pessoal! eu resouvi todos meus problemas com a nvidia assim; http://penguincommunity.forumeiros.org/tutorialand-f5/instalar-drivers-da-nvida-no-ubuntu-e-derivados-t97.htm   é so seguir passo a passo e a nvidia 7200 gs vai funcionar de prima. Meu pc: intel core 2 duo e4400 2,0 ghz, video nvidia geforce 7200 gs(256mb), hd sata II 120gb, placa-mae gigabyte vm900m, 2 gb ram.... ;D ubuntu 9.04 64 bits :D
« Última modificação: 20 de Julho de 2009, 22:04 por aalberto »

Offline Everton.01

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: (RESOLVIDO)Configuração do Video-Nvidia!
« Resposta #12 Online: 24 de Abril de 2010, 13:45 »
Olá pessoal,
Sou iniciante no Linux e estou com o mesmo problema que o andinhocp, ou seja, instalei o nvdia no Ubuntu 9.10 e configurei a resolução para 1024x768 e clico em aplicar, até aí blz. Só que quando clico em "save to X configuration file" aparece a seguinte mensagem de erro: Failed to parse existing X config file '/etc/X11/xorg.conf'!
A partir daí, mesmo seguindo os outros passos que o andinhocp indicou, quando reinicio o pc a resolução volta para 800x600. Alguém poderia me ajudar a descobrir porque não estou conseguido salvar essas configurações?

Abraços.

Offline Everton.01

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: (RESOLVIDO)Configuração do Video-Nvidia!
« Resposta #13 Online: 24 de Abril de 2010, 18:02 »
Consegui resolver o problema, galera. Segui as instruções do site gentoo http://www.gentoo.org/doc/pt_br/xorg-config.xml
Resumindo, entrei no consola como root, digitei gedit /etc/X11/xorg.conf para configurar o arquivo xorg e acrescentei as linhas abaixo na seção "screen":

SubSection "Display"
    Depth   24
    Modes   "1024x768"
  EndSubSection

Fazendo isso, minha resolução permaneceu do jeito que eu queria mesmo depois de ter reiniciado o pc.

Offline piquen0

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Configuração do Video-Nvidia (travando)!
« Resposta #14 Online: 15 de MAR?O de 2012, 20:03 »
infelizmente não sei o que está acontecendo..  você já tentou reinstalar o Ubuntu?

Olá a todos,

Inicialmente consegui resolver o problema da manutenção da configuração através do tópico do Bio-Gen http://ubuntuforum-br.org/index.php/topic,49834.0.html só para deixar marcado os passos foram o seguite:

Código: [Selecionar]
sudo nvidia-settings
X Server Display Configuration escolhi a resolução que eu queria 1280x1024 apliquei (Apply)e depois salvei Save to X Configuration file dessa forma ela salvará essa resolução no xorg.conf feito isso o proxímo passo é:

Sistema>Preferências>Video ou no caso de alguns Sistema>Preferências>Resolução de Tela no meu caso depois disso aparece uma menssagem :

Parece que o drive de video não suporta a extensão para usar esta ferramenta. VocÊ quer usar o drive de video do fabricante no lugar?

Eu clico em NÃO e ai sim aparece a janela de resolução de tela, Aplico a resolução que eu quero depois clico em manter resolução

Dessa forma ao reiniciar a resolução que eu escolhi permanecerá.

PS. Meu video continua travando. Porém acredito que isso seja outro problema por isso considero meu tópico RESOLVIDO. Valeu a todos que ajudaram.

Muito bom. Esta dica resolveu meu problema