Autor Tópico: Kanguru no Ubuntu 8.10  (Lida 2267 vezes)

Offline lads

  • Usuário Ubuntu
  • *
  • Mensagens: 16
  • Há anos à procura do Linux perfeito
    • Ver perfil
Kanguru no Ubuntu 8.10
« Online: 15 de Maio de 2009, 04:20 »
Viva,

Comprei uma máquina há pouco tempo e instalei-lhe o 8.10. Por razões profissionais vou precisar de acesso à net em diferentes locais. Depois de um pouco de pesquisa de mercado optei pelo Kanguru. Experimentei numa máquina com XP e funcionou.

Quando tentei na minha máquina foi tudo muito fácil, ligar a pen chamar o assistente de ligação (que até já sabia que o Kanguru existia) e depois ligar. Porreiro pá, a luzinha da pen acendeu e assistente deu sinal de ligado.

O problema foi quando tentei abrir uma página no Firefox ... not found. Experimentei outras páginas, pings para o Google e afins, nada, zero. É como se continuasse desligado. O que acho estranho é o assitente de ligação não me ter pedido as credenciais (nem sequer nº da placa) tal como fez o XP.

Alguma idea? Obrigado.

Offline lads

  • Usuário Ubuntu
  • *
  • Mensagens: 16
  • Há anos à procura do Linux perfeito
    • Ver perfil
Re: Kanguru no Ubuntu 8.10
« Resposta #1 Online: 16 de Maio de 2009, 12:19 »
Continuo sem conseguir usar o Kanguru com o Ubuntu, experimentei também no Vista e funciona.

Enrtetanto tentei verificar a configuração e descobri que os ficheiros /etc/resolv.conf, /etc/ppp/peers/provider e /etc/chatscript/pap estão intactos, o assitente nunca os alterou. Isto é anormal? Acho que pelo menos os servidores de nomes deveriam ter sido registados no resolv.conf.

Se alguém me poder ajudar agradeço.

Offline VB5

  • Usuário Ubuntu
  • *
  • Mensagens: 3.564
  • Liga dos Dinos
    • Ver perfil
Re: Kanguru no Ubuntu 8.10
« Resposta #2 Online: 16 de Maio de 2009, 23:46 »
Nem conheço o programa, mas...

Citar
Acho que pelo menos os servidores de nomes deveriam ter sido registados no resolv.conf.

Tente "pingar" um endereço qualquer pelo IP, não pelo nome: se funcionar, é o DNS.

VB5
Ubuntu 10.04 - Semprom 2600+/Asus K8N/1.5 GB RAM DDR 400/GeForce 6200/HDs: 80MB + 320 GB

Offline lads

  • Usuário Ubuntu
  • *
  • Mensagens: 16
  • Há anos à procura do Linux perfeito
    • Ver perfil
Re: Kanguru no Ubuntu 8.10
« Resposta #3 Online: 18 de Maio de 2009, 05:41 »
VB5, obrigado pela dica, mas parece-me que o serviço de nomes não é o problema. Se enviar um ping a um IP o resultado é: x pacotes enviados, 0 recebidos.

Tentei configurar manualmente a placa usando o pppconfig e dando os seguintes parâmetros:

Dynamic DNS
PAP Protocol
Number to dial *99***1#
device /dev/ttyUSB0

Usei também as credenciais que a Optimus forneceu (número e pin). Usei o tail para capturar o resultado do comando pon:

May 16 22:25:27 MDK pppd[6898]: pppd 2.4.4 started by root, uid 0
May 16 22:25:28 MDK chat[6900]: abort on (BUSY)
May 16 22:25:28 MDK chat[6900]: abort on (NO CARRIER)
May 16 22:25:28 MDK chat[6900]: abort on (VOICE)
May 16 22:25:28 MDK chat[6900]: abort on (NO DIALTONE)
May 16 22:25:28 MDK chat[6900]: abort on (NO DIAL TONE)
May 16 22:25:28 MDK chat[6900]: abort on (NO ANSWER)
May 16 22:25:28 MDK chat[6900]: abort on (DELAYED)
May 16 22:25:28 MDK chat[6900]: send (ATZ^M)
May 16 22:25:28 MDK chat[6900]: expect (OK)
May 16 22:25:28 MDK chat[6900]: TZ^M^M
May 16 22:25:28 MDK chat[6900]: OK
May 16 22:25:28 MDK chat[6900]: -- got it
May 16 22:25:28 MDK chat[6900]: send (ATDT*99***1#^M)
May 16 22:25:28 MDK chat[6900]: expect (CONNECT)
May 16 22:25:28 MDK chat[6900]: ^M
May 16 22:25:28 MDK chat[6900]: ATDT*99***1#^M^M
May 16 22:25:28 MDK chat[6900]: CONNECT
May 16 22:25:28 MDK chat[6900]: -- got it
May 16 22:25:28 MDK chat[6900]: send (\d)
May 16 22:25:29 MDK pppd[6898]: Serial connection established.
May 16 22:25:29 MDK pppd[6898]: Using interface ppp0
May 16 22:25:29 MDK pppd[6898]: Connect: ppp0 <--> /dev/ttyUSB0
May 16 22:25:30 MDK pppd[6898]: PAP authentication succeeded
May 16 22:25:34 MDK pppd[6898]: Could not determine remote IP address: defaulting to 10.64.64.64
May 16 22:25:34 MDK pppd[6898]: local IP address 78.130.71.128
May 16 22:25:34 MDK pppd[6898]: remote IP address 10.64.64.64

Alguma idea? Obrigado.

Offline VB5

  • Usuário Ubuntu
  • *
  • Mensagens: 3.564
  • Liga dos Dinos
    • Ver perfil
Re: Kanguru no Ubuntu 8.10
« Resposta #4 Online: 19 de Maio de 2009, 00:16 »
lads,
infelizmente creio não poder ajudar mais, pois tenho conexão a cabo, que é muito diferente. O problema parece estar na configuração da conexão... não encontrou nada aqui no forum? por exemplo, sobre 3G, ou em

http://ubuntuforum-br.org/index.php/topic,4731.0.html           

ou algo semelhante?

Boa sorte!...  ;)

VB5

Ubuntu 10.04 - Semprom 2600+/Asus K8N/1.5 GB RAM DDR 400/GeForce 6200/HDs: 80MB + 320 GB

Offline lads

  • Usuário Ubuntu
  • *
  • Mensagens: 16
  • Há anos à procura do Linux perfeito
    • Ver perfil
Re: Kanguru no Ubuntu 8.10
« Resposta #5 Online: 19 de Maio de 2009, 18:46 »
Viva VB5, obrigado pelo link. Tentei seguir as instrucções mas encontrei problemas logo quando corri o comando pppoeconf:

Código: [Selecionar]
Sorry, I scanned 3 interfaces, but the Access Concentrator of your provider did not respond. Please check your network and modem cables. Another reason for the scan failure may also be another running pppoe process which controls the modem.
Seguindo instrucções noutro forum, corri os seguintes comandos:

dmesg

Código: [Selecionar]
[  331.552104] usb 8-2: new high speed USB device using ehci_hcd and address 5
[  331.700144] usb 8-2: configuration #1 chosen from 1 choice
[  331.716551] scsi5 : SCSI emulation for USB Mass Storage devices
[  331.720789] usb 8-2: USB disconnect, address 5
[  331.731189] usb-storage: device found at 5
[  331.731202] usb-storage: waiting for device to settle before scanning
[  338.244109] usb 8-2: new high speed USB device using ehci_hcd and address 6
[  338.388156] usb 8-2: configuration #1 chosen from 1 choice
[  338.406179] usb-storage: probe of 8-2:1.0 failed with error -5
[  338.413996] usb-storage: probe of 8-2:1.1 failed with error -5
[  342.412279] scsi8 : SCSI emulation for USB Mass Storage devices
[  342.412917] usb-storage: device found at 6
[  342.412929] usb-storage: waiting for device to settle before scanning
[  346.412477] scsi9 : SCSI emulation for USB Mass Storage devices
[  346.413786] usb-storage: device found at 6
[  346.413799] usb-storage: waiting for device to settle before scanning
[  346.414929] usbcore: registered new interface driver usbserial
[  346.415182] usbserial: USB Serial support registered for generic
[  346.416219] usbcore: registered new interface driver usbserial_generic
[  346.416234] usbserial: USB Serial Driver core
[  346.455970] usbserial: USB Serial support registered for GSM modem (1-port)
[  346.456051] option 8-2:1.0: GSM modem (1-port) converter detected
[  346.456333] usb 8-2: GSM modem (1-port) converter now attached to ttyUSB0
[  346.456358] option 8-2:1.1: GSM modem (1-port) converter detected
[  346.456562] usb 8-2: GSM modem (1-port) converter now attached to ttyUSB1
[  346.456600] usbcore: registered new interface driver option
[  346.456607] option: USB Driver for GSM modems: v0.7.2
[  347.413572] usb-storage: device scan complete
[  347.415455] scsi 8:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
[  347.436425] sr1: scsi-1 drive
[  347.436642] sr 8:0:0:0: Attached scsi CD-ROM sr1
[  347.436842] sr 8:0:0:0: Attached scsi generic sg2 type 5
[  351.413617] usb-storage: device scan complete
[  351.416033] scsi 9:0:0:0: Direct-Access     HUAWEI   MMC Storage      2.31 PQ: 0 ANSI: 2
[  351.444598] sd 9:0:0:0: [sdb] Attached SCSI removable disk
[  351.444819] sd 9:0:0:0: Attached scsi generic sg3 type 0

lsusb

Código: [Selecionar]
Bus 008 Device 006: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E270 HSDPA/HSUPA Modem
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 05ca:183d Ricoh Co., Ltd
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 003: ID 044e:3017 Alps Electric Co., Ltd
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 002: ID 046d:c016 Logitech, Inc. M-UV69a/HP M-UV96 Optical Wheel Mouse
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

ls /dev/ttyUSB*

Código: [Selecionar]
/dev/ttyUSB0  /dev/ttyUSB1
Isto para mim é mais ou menos chinês. Alguma ideia? Obrigado.

Offline VB5

  • Usuário Ubuntu
  • *
  • Mensagens: 3.564
  • Liga dos Dinos
    • Ver perfil
Re: Kanguru no Ubuntu 8.10
« Resposta #6 Online: 19 de Maio de 2009, 23:06 »
lads,

Citar
Código:
Sorry, I scanned 3 interfaces, but the Access Concentrator of your provider did not respond. Please check your network and modem cables. Another reason for the scan failure may also be another running pppoe process which controls the modem.

O mais provável, até onde sei, é a última frase; deve haver um processo 'pppoe' rodando que precisa ser parado antes de mais nada. Tente isso e continue com as instruções que estava seguindo.

VB5
Ubuntu 10.04 - Semprom 2600+/Asus K8N/1.5 GB RAM DDR 400/GeForce 6200/HDs: 80MB + 320 GB

Offline lads

  • Usuário Ubuntu
  • *
  • Mensagens: 16
  • Há anos à procura do Linux perfeito
    • Ver perfil
Re: Kanguru no Ubuntu 8.10
« Resposta #7 Online: 20 de Maio de 2009, 17:51 »
Caros, escrevo-vos do Ubuntu!

Este problema foi resolvido no Forum em inglês, com a ajuda de um utilizador da Grécia:

http://ubuntuforums.org/showthread.php?p=7316823&posted=1#post7316823

A configuração que vem por defeito com o Ubuntu 8.10 para o Kanguru é suficiente para criar correctamente a ligação. Acontece que, com a placa Wireless ligada não me era possível ligar, de algum modo estava a interferir com a ligação 3G.

A minha máquina é um Sony Vaio VGN-FW31, sugiro aos administradores do Forum que adicionem ao título da thread o modelo para facilitar referência futura.

Muito obrigado ao VB5 e quem mais tenha perdido tempo a tentar ajudar.

Offline VB5

  • Usuário Ubuntu
  • *
  • Mensagens: 3.564
  • Liga dos Dinos
    • Ver perfil
Re: Kanguru no Ubuntu 8.10
« Resposta #8 Online: 20 de Maio de 2009, 23:53 »
lads,

fico feliz em haver de algum modo participado da solução do seu problema... espero que fique tudo bem!

( ),

VB5
Ubuntu 10.04 - Semprom 2600+/Asus K8N/1.5 GB RAM DDR 400/GeForce 6200/HDs: 80MB + 320 GB