Autor Tópico: Python e Pygame  (Lida 4117 vezes)

Offline Ymor

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Python e Pygame
« Online: 28 de Maio de 2009, 09:06 »
Tentei instalar o pygame, na instalação diz que é necessario o python 2.5, só que eu estou usando o ubuntu 9.04 que já vem com o python 2.6 e tem como dependencia o proprio python, tem como eu fazer downgrade do python ? ou existe algum pygame para python 2.6 ?

Offline RODRIGOBL25

  • Usuário Ubuntu
  • *
  • Mensagens: 33
  • www.linuxjpa.blogspot.com
    • Ver perfil
    • LINUX JOÃO PESSOA - PB
Re: Python e Pygame
« Resposta #1 Online: 31 de Maio de 2009, 23:19 »
Cara nuca fiz nem sei se é possivel mas acho que seja, desinstala o python 2.6 e instala o 2.5 dai o pygame instala normalmente.
Divulgando o Linux em João Pessoa - Paraíba - Brasil
www.linuxjpa.blogspot.com

Offline Legendario

  • Usuário Ubuntu
  • *
  • Mensagens: 176
  • "Ipod de pobre é violeiro no trem"
    • Ver perfil
    • Linux Legal
Re: Python e Pygame
« Resposta #2 Online: 31 de Maio de 2009, 23:57 »
Tentei instalar o pygame, na instalação diz que é necessario o python 2.5, só que eu estou usando o ubuntu 9.04 que já vem com o python 2.6 e tem como dependencia o proprio python, tem como eu fazer downgrade do python ? ou existe algum pygame para python 2.6 ?

Queridão,

pode instalar sem medo, pois se você olhar direitinho (tente visualizar as propriedades do pacote pelo synaptic) e verá que essa é a versão mínima da dependência (vai aparecer um sinal de maior ou igual), ou seja, para que ela seja compatível, deverá ter como dependência o python à partir da versão 2.5.

Normalmente os pacotes dos repositórios são testados e geralmente não apresentam bugs, principalmente ligados a dependências.

Abraços
« Última modificação: 31 de Maio de 2009, 23:59 por Legendario »