Autor Tópico: [Resolvido]Problema para abrir o Tibia  (Lida 5056 vezes)

Offline jmonteiro

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
[Resolvido]Problema para abrir o Tibia
« Online: 17 de Junho de 2009, 15:25 »
Antes de escrever este tópico li alguns outros...
Tentei resolvei o meu problema com as dicas que encontrei, mas não consegui.

Quando tento abrir o Tibia, pelo terminal, aparece a seguinte mensagem:
Citar
./Tibia: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory


Vou deixar aqui tudo o que escrevi para instalar o Tibia.
Citar
jmonteiro@jmonteiro-laptop:~$ ls
Desktop     examples.desktop  Modelos  Programas  Vídeos
Documentos  Imagens           Músicas  Pública
jmonteiro@jmonteiro-laptop:~$ cd Programas
jmonteiro@jmonteiro-laptop:~/Programas$ ls
tibia842.tgz
jmonteiro@jmonteiro-laptop:~/Programas$ tar xfz tibia842.tgz
jmonteiro@jmonteiro-laptop:~/Programas$ ls
Tibia  tibia842.tgz
jmonteiro@jmonteiro-laptop:~/Programas$ cd tibia
bash: cd: tibia: No such file or directory
jmonteiro@jmonteiro-laptop:~/Programas$ cd Tibia
jmonteiro@jmonteiro-laptop:~/Programas/Tibia$ ls
libc6  Showerror      Tibia      Tibia.pic  Tibia.xpm
Patch  StartTibia.sh  Tibia.dat  Tibia.spr
jmonteiro@jmonteiro-laptop:~/Programas/Tibia$ Tibia
bash: Tibia: command not found
jmonteiro@jmonteiro-laptop:~/Programas/Tibia$ ./Tibia
./Tibia: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory
jmonteiro@jmonteiro-laptop:~/Programas/Tibia$

Pelo que intendi falta instalar algo no Ubunu, mas não sei o que é.
Estou usando o Ubuntu 9.04 64bits.
Minha placa de vídeo é onboard, da intel, mas tem 3D.
Estou rodando o Compiz Fuzion numa boa.

Se precisarem de mais informações é só pedir.

Grato pela atenção,
JMonteiro

----

Achei no site do Tibia os requerimentos:

System Requirements:

    * Linux with libc version 6 or later
    * X-Window system installed
    * Hardware accelerated graphics driver
    * 44 MB free hard disk space
    * A connection to the internet

Como posso saber se tenho o X-Window e o libc 6 ?

----

Em outro tópico parecido um cara pedio para usar o comando  fglrxinfo e lshw pra ver se a placa de video é 3D.
Vou posta os resultados aqui, pois não sei o que significam.

lshw
Citar
       *-display:0 UNCLAIMED
             description: VGA compatible controller
             product: Mobile GM965/GL960 Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 03
             width: 64 bits
             clock: 33MHz
             capabilities: bus_master cap_list
             configuration: latency=0

fglrxinfo
Citar
display: :0.0  screen: 0
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 965GM GEM 20090326 2009Q1 RC2
OpenGL version string: 1.4 (2.0 Mesa 7.4)
« Última modificação: 18 de Junho de 2009, 17:10 por jmonteiro »

Offline hiti-su

  • Usuário Ubuntu
  • *
  • Mensagens: 17
  • Stefan Yohansson, Nice to Meet You;
    • Ver perfil
    • Philosophae Doctors
Re: Problema para abrir o Tibia
« Resposta #1 Online: 17 de Junho de 2009, 20:57 »
Tirado da resposta no vivaolinux.com.br do usuario gesousa

Checar as permissões para libGL.so.1.2 file com comando:

ls -l /usr/lib/libGL*

o arquivo libGL.so.1.2 deve estar como "-rw-rw-r--". se estiver como "-rw-rw----", então use o comando

sudo chmod o+r /usr/lib/libGL.so.1.2

se a permissão estiver correta, refaça o link da libGL com o comando:

sudo ln -s /usr/lib/libGL.so.1.2 /usr/lib/libGL.so.1

isso deve resolver seu problema.
And Don't Deny Me. ~
Usuario n°:

Offline jmonteiro

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Problema para abrir o Tibia
« Resposta #2 Online: 18 de Junho de 2009, 02:06 »
Tive um problema aqui e formatei o notbook.

Refiz a instalação, só que agora a mensagem de erro mudou:
Citar
jmonteiro@jmonteiro-laptop:~/Programas/Tibia$ ls
libc6  Showerror      Tibia      Tibia.pic  Tibia.xpm
Patch  StartTibia.sh  Tibia.dat  Tibia.spr
jmonteiro@jmonteiro-laptop:~/Programas/Tibia$ ./Tibia
bash: ./Tibia: No such file or directory
jmonteiro@jmonteiro-laptop:~/Programas/Tibia$

----

Tentei fazer o que o cara ai de cima me indicou, mas nada.

----

Desisti, instalei a versão 32bits e rodou numa boa.
« Última modificação: 18 de Junho de 2009, 17:09 por jmonteiro »