Autor Tópico: duvida com instalaçao  (Lida 7435 vezes)

Offline fskate

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: duvida com instalaçao
« Resposta #15 Online: 26 de Junho de 2009, 09:34 »
aonde fica ess programa?



eu fui tentar recuperar o grub pr live cd e deu essa mensagem

grub> find /boot/grub/stage1

Error 15: File not found

grub>



abraços

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: duvida com instalaçao
« Resposta #16 Online: 26 de Junho de 2009, 10:36 »
Detalhes são importantes, senão como ajudá-lo?

Qual a versão do seu Ubuntu?

Formatou as partições como?

Porque precisa recuperar o GRUB?
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline fskate

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: duvida com instalaçao
« Resposta #17 Online: 26 de Junho de 2009, 14:48 »
uubuntu 9.04
 o windows tinha dado problema , toda vez que eu o iniciava aparecia aquela tela azul e reiniciava. Ai dei o boot pelo cd do windows pedi pra intalar novamente na partição do windows a c: que eu havia colocado num post anterior, quando ele vai instalar pede pra formatar a unidade e tal, ficou um tempo pra formata e deu um erro dizendo que o disco estava danificado. agora ele nao da o boot pelo cd do windows e nem carrega o ubuntu que eu estava usando.

nao sei se e nesseçario recuperar o GruB se apaguei o windows, mas queria voltar a iniciar o meu ubuntu que ja esta instalado, pois quando deixa o pc iniciar sem nenhum disco fica somente um underline _ piscando no começo da tela.


bom acho que falei tudo o que aconteceu


Obrigado pela atenção e abraços!!

Offline fskate

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: duvida com instalaçao
« Resposta #18 Online: 28 de Junho de 2009, 13:57 »
sera que tem solução? gostaria de formatar ele por algum sistema operacional aki pois so estou com o live cd sera que tem alguma dica ai?


abraços!!!

Lunik

  • Visitante
Re: duvida com instalaçao
« Resposta #19 Online: 28 de Junho de 2009, 15:16 »
Já tentou as instruções desse tópico?

http://ubuntuforum-br.org/index.php/topic,25000.0.html

Você diz que o windows tá com defeito, e o linux sumiu do menu do grub...
Se eu entendi bem, basta você entrar com o livecd e seguir as informações daquele topico.

Mais um: http://www.vivaolinux.com.br/dica/Como-recuperar-o-Grub-do-seu-Ubuntu/
« Última modificação: 28 de Junho de 2009, 15:22 por Lunik »

Offline fskate

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: duvida com instalaçao
« Resposta #20 Online: 28 de Junho de 2009, 16:27 »
tentei fazer isso mas nao sei se fiz corretamente olha o que deu

ubuntu@ubuntu:~$ sudo fdisk -l
omitting empty partition (5)

Disco /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cilindros of 16065 * 512 = 8225280 bytes
Disk identifier: 0x24672466

Dispositivo Boot Início Fim Blocos Id Sistema
/dev/sda1   *           1        3713    29824641    7  HPFS ou NTFS
/dev/sda2            3714        9403    45704925    f  Win95 (LBA) Partição Extendida
/dev/sda3            6375        9403    24330442+   b  W95 FAT32
/dev/sda5            3714        6257    20434617   83  Linux
/dev/sda6            6258        6373      931738+  82  Linux swap / Solaris
ubuntu@ubuntu:~$ sudo mount /dev/sda5 /mnt
ubuntu@ubuntu:~$  sudo grub-install --root-directory=/mnt /dev/sda5
grub-probe: error: Cannot open `/boot/grub/device.map'
[: 494: =: unexpected operator
The file /mnt/boot/grub/stage1 not read correctly.

Lunik

  • Visitante
Re: duvida com instalaçao
« Resposta #21 Online: 28 de Junho de 2009, 22:54 »
Segunda tentativa:

Não sei se vai fazer alguma diferença, mas como eu não consegui identificar esse erro estranho aí, então tenta fazer desse jeito:

- Entra com o livecd novamente, depois no terminal e:
- Cria um diretorio proprio pra montar e monta o sd5
$ sudo mkdir /mnt/system
$ sudo mount /dev/sda5 /mnt/system

- Pra executar todos os comandos como su:
$ sudo -i

- Associar o /dev no teu mount
# mount -o bind /dev /mnt/system/dev

- Mudar o chroot pro diretorio montado
# chroot /mnt/system

- Rodar o instalador do grub
# grub-install /dev/sda

Peguei as instruções desse post, que parece ser bem recente, então espero que funcione agora.
http://fosswire.com/post/2009/5/restoring-overwritten-grub/

Offline fskate

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: duvida com instalaçao
« Resposta #22 Online: 29 de Junho de 2009, 11:20 »
cara acho q descobri o problema, acho q meu hd que foi pro espaço mesmo, pq ontem tentei reistalar o ubuntu e quando estava intalando deu um erro disendo que a unidade estava comum erro irreparavel e talz e nao podia continuar  a instalaçao, tem algum jeito de eu confirmar isso? pq agora ja era ja apagou todos os tados que eu tinha antes do ubuntu antigo
abraços

Lunik

  • Visitante
Re: duvida com instalaçao
« Resposta #23 Online: 29 de Junho de 2009, 21:50 »
Meus pesames pelo seu hd, cara... =/

Eu sei que existe um comando pra procurar por badblocks no hd, e provavelmente o livecd tem ele:
sudo badblocks -v /dev/sdX

(X - partição que quer checar)

Mas aí o problema pode ser outra coisa além de badblocks...

Offline fskate

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: duvida com instalaçao
« Resposta #24 Online: 30 de Junho de 2009, 01:43 »
cara, digitei o comando que vc indico e deu isso, nao sei se e normal nem o quer dizer, de uma olha ai

abracos!!



ubuntu@ubuntu:~$ sudo badblocks -v /dev/sd1
badblocks: No such file or directory while trying to determine device size
ubuntu@ubuntu:~$ sudo badblocks -v /dev/sda1
Checking blocks 0 to 75144005
Checking for bad blocks (read-only test):   0.00% done, 0:00 elapsed
448.00% done, 3:26 elapsed

452.00% done, 16:10 elapsed
453.00% done, 19:16 elapsed
454
455
456.00% done, 24:05 elapsed
457.00% done, 24:36 elapsed
458
459
460.00% done, 26:09 elapsed
461
462
463
464.00% done, 27:42 elapsed
465
466
467
468.00% done, 30:48 elapsed
469
470
471
472.00% done, 34:04 elapsed
473.00% done, 37:10 elapsed
474.00% done, 37:41 elapsed
475
476.00% done, 38:43 elapsed
477
478
479
480.00% done, 41:49 elapsed
481.00% done, 42:20 elapsed
482
483
484.00% done, 45:26 elapsed
485
486
487
488.00% done, 48:32 elapsed
489.00% done, 51:38 elapsed
490
491
492.00% done, 56:17 elapsed
493.00% done, 58:52 elapsed
494
495
496.00% done, 1:01:37 elapsed
497
498
499
500.00% done, 1:04:43 elapsed
501.00% done, 1:07:18 elapsed
502
503
504.00% done, 1:10:34 elapsed
505.00% done, 1:12:38 elapsed
506
507
508
509
510
511
512.00% done, 1:14:11 elapsed
513
514
515
516
517
518
519
520.00% done, 1:15:44 elapsed
521
522
523
524
525
526
527
528
529
530
531
532
533
534
535
536
537
538
539
540.00% done, 1:21:04 elapsed
541.00% done, 1:22:06 elapsed
542
543
544.00% done, 1:24:41 elapsed
545
546
547
548
549
550
551
552
553
554
555
556
557
558
559
560
561
562
563
564
565
566
567
568
569
570
571
572
573
574
575
576
577
578
579


Lunik

  • Visitante
Re: duvida com instalaçao
« Resposta #25 Online: 30 de Junho de 2009, 04:20 »
Eu não entendi porque você colou a saída desse jeito...
No meu mostra apenas o "Checking for bad blocks (read-only test):   0.00% done, 0:00 elapsed" e a porcentagem fica mudando, mas na mesma linha...

Se chegou em 100% sem mostrar mais nada na tela, é porque não encontrou problema nenhum.

Offline fskate

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: duvida com instalaçao
« Resposta #26 Online: 30 de Junho de 2009, 13:23 »
tabem nao sei pq apareceu assim, agora vou deixar ele completar ai posto o resultado.

Abraços

Offline fskate

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: duvida com instalaçao
« Resposta #27 Online: 30 de Junho de 2009, 17:28 »
putz cara, hoje ja deixei quase o dia todo e aparceu isso, acho q quase o mesmo resustado da outra



To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

ubuntu@ubuntu:~$ sudo badblocks -v /dev/sda1
Checking blocks 0 to 75144005
Checking for bad blocks (read-only test): 531201% done, 13:41 elapsed
556001% done, 26:11 elapsed
556101% done, 27:13 elapsed
5562
5563
5564
5565
5566
5567
556801% done, 27:44 elapsed
5569
5570
5571
575201% done, 33:14 elapsed
587201% done, 39:36 elapsed
599201% done, 44:55 elapsed
617601% done, 53:40 elapsed
629601% done, 59:19 elapsed
641601% done, 1:09:27 elapsed
653601% done, 1:17:52 elapsed
672001% done, 1:22:09 elapsed
684001% done, 1:25:55 elapsed
696001% done, 1:32:26 elapsed
778401% done, 1:57:25 elapsed
796801% done, 2:02:23 elapsed
808801% done, 2:06:09 elapsed
820801% done, 2:10:26 elapsed
832801% done, 2:18:10 elapsed
836401% done, 2:21:16 elapsed
8365
8366
8367
836801% done, 2:25:24 elapsed
836901% done, 2:27:59 elapsed
8370
8371
845201% done, 2:43:39 elapsed
8453
8454
8455
846801% done, 2:49:51 elapsed
8469
8470
8471
854001% done, 3:08:06 elapsed
8541
8542
8543
859601% done, 3:23:15 elapsed
859701% done, 3:23:46 elapsed
8598
8599
860001% done, 3:26:52 elapsed
860101% done, 3:28:56 elapsed
8602
8603
860401% done, 3:32:02 elapsed
860501% done, 3:34:06 elapsed
8606
8607
860801% done, 3:37:12 elapsed
860901% done, 3:41:30 elapsed
8610
8611
861601% done, 3:50:27 elapsed
8617
8618
8619
863601% done, 3:56:39 elapsed
8637
8638
8639
^C0.01% done, 3:59:45 elapsed

Offline VB5

  • Usuário Ubuntu
  • *
  • Mensagens: 3.564
  • Liga dos Dinos
    • Ver perfil
Re: duvida com instalaçao
« Resposta #28 Online: 30 de Junho de 2009, 23:02 »
fskate,

Acho que não vale a pena você perder mais tempo com esse HD. Pelo que vi, é melhor investir num novo. Os preços estão bem razoáveis, comprei semana passada um de 320 GB, SATA II, por R$ 165,00 - ~R$ 0,50/GB. IDE, e de menos de 100 GB, pode ser difícil de encontrar e até mais caro. Sua placa-mãe suporta SATA?

VB5

Ubuntu 10.04 - Semprom 2600+/Asus K8N/1.5 GB RAM DDR 400/GeForce 6200/HDs: 80MB + 320 GB

Offline fskate

  • Usuário Ubuntu
  • *
  • Mensagens: 66
    • Ver perfil
Re: duvida com instalaçao
« Resposta #29 Online: 30 de Junho de 2009, 23:45 »
sim, o meu eh um samsumg sata de 80 gigas, dei uma olhada nos preço por aki ae encontrei esses

Samsung      HD200HJ     HD 200GB 7200rpm, Serial ATA, 8M                      R$ 110,99

Samsung      HD161HJ     Hard Disk 160GB SATA2 7200 rpm, 8MB Buffer   R$ 110,50

qual do dois seria o melhor? sata2 a entrada eh diferente do sata normal?

abraços!!!