Autor Tópico: dpkg foi interrompido. Você deve executar o comando 'sudo dpkg --configure -a' p  (Lida 25401 vezes)

Offline Jean Rodrigo

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
não consigo mais instalar programas no terminal, e nem plugins e muito menos atualizações, no ubuntu 8.10 eu não tinha esses problemas, como eu resolvo?
Ubuntu 12.04 LTS - X64
Memoria RAM: 4GB
Processador AMD Turion II Ultra Dual-Core Mobile M620 × 2

Offline ubu4ever

  • Usuário Ubuntu
  • *
  • Mensagens: 695
    • Ver perfil
não consigo mais instalar programas no terminal, e nem plugins e muito menos atualizações, no ubuntu 8.10 eu não tinha esses problemas, como eu resolvo?

1)Qual a versão do Ubuntu você usa?
2)Poste as mensagens de erro que estão aparecendo.
3)Tente executar no terminal:
Citar
sudo aptitude install -f && sudo dpkg --configure -a
e veja se resolve.

Offline Jean Rodrigo

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Pois é, eu to usando o ubuntu 9.04
e quando eu digito este comando (sudo aptitude install -f && sudo dpkg --configure -a') no terminal
acontece isso:
>

E qnd eu tento instalar no sudo aptitude install aparece esta mensagem:

E: dpkg foi interrompido. Você deve executar o comando 'sudo dpkg --configure -a' para corrigir o problema.
Ubuntu 12.04 LTS - X64
Memoria RAM: 4GB
Processador AMD Turion II Ultra Dual-Core Mobile M620 × 2

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Tentou digitar só sudo dpkg --configure -a?
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline Jean Rodrigo

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
consegui arrumar, acho q eu estava digitando o comando errado,
isso aconteceu porcausa do
limewire  q ficou corompido ao apresentar um erro na instalação
valeu gente mto obrigado
Ubuntu 12.04 LTS - X64
Memoria RAM: 4GB
Processador AMD Turion II Ultra Dual-Core Mobile M620 × 2

Offline winsucks

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: dpkg foi interrompido. Você deve executar o comando 'sudo dpkg --configure -a' p
« Resposta #5 Online: 22 de Dezembro de 2009, 12:23 »
Bom galera, sou meio fraco no ubuntu ainda então resolvi colocar minha duvida aqui :)

tenho esse mesmo problema acima, so que é mais dificil de resolver, e quando saio dessa tela, vai diretamente para uma de instalação onde não tem como fazer mais nada com o terminal :(

Código: [Selecionar]
sudo dpkg --configure -a
dpkg: problemas de dependência impedem a configuração de sun-java6-plugin:
 sun-java6-plugin depende de sun-java6-bin (= 6-15-1); porém:
  Pacote sun-java6-bin não está instalado.
dpkg: erro processando sun-java6-plugin (--configure):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 sun-java6-plugin

é isso, espero que vcs consigam me ajudar,
desde ja obrigado pela atenção!

Offline maxturboxr

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: dpkg foi interrompido. Você deve executar o comando 'sudo dpkg --configure -a' p
« Resposta #6 Online: 22 de Fevereiro de 2011, 18:03 »
boa tarde a todos, to mandando essa mensagem nesse tópico porque já foi criado e com certeza quero evita a replicação. to com o mesmo problema e ainda não consegui resolver podem me dar uma ajuda?
 da a seginte mensagem de erro quando ativo o gerenciador de pacotes da synaptic:

E: dpkg foi interrompido. Você deve executar o comando 'sudo dpkg --configure -a' para corrigir o problema.
E: _cache->open() failed, please report.

ja tentei de quase tudo em todos os fórum e nada. to com ubuntu 10.4 e sou novo com ubuntu

Offline cesargcomp

  • Usuário Ubuntu
  • *
  • Mensagens: 545
    • Ver perfil
Re: dpkg foi interrompido. Você deve executar o comando 'sudo dpkg --configure -a' p
« Resposta #7 Online: 22 de Fevereiro de 2011, 23:02 »
boa tarde a todos, to mandando essa mensagem nesse tópico porque já foi criado e com certeza quero evita a replicação. to com o mesmo problema e ainda não consegui resolver podem me dar uma ajuda?
 da a seginte mensagem de erro quando ativo o gerenciador de pacotes da synaptic:

E: dpkg foi interrompido. Você deve executar o comando 'sudo dpkg --configure -a' para corrigir o problema.
E: _cache->open() failed, please report.

ja tentei de quase tudo em todos os fórum e nada. to com ubuntu 10.4 e sou novo com ubuntu
maxturboxr,
Feche todos os programas inclusive o Synaptic. Abra um terminal (Ctrl+Alt+t).
Digite o que foi pedido no terminal:
Código: [Selecionar]
sudo dpkg --configure -aAgora vou lhe passar 3 comandos mas digite um de cada vez e dê enter:
Código: [Selecionar]
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get clean
Use Ubuntu. Segurança, facilidade e gratuidade em suas mãos.

Offline marcelodapapa

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Ok. Obrigado pela ajuda!
Problema resolvido.
Acredito que algum não havia concluído a instalação.

Offline bobthepanda

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: dpkg foi interrompido. Você deve executar o comando 'sudo dpkg --configure -a' p
« Resposta #9 Online: 11 de Outubro de 2012, 11:53 »
 Obrigado, cesargcomp!
 Acabo de ter o mesmo problema que deu origem ao tópico e sua resposta resolveu a situação aqui também  ;D