Autor Tópico: [RESOLVIDO]E: Não foi possível obter trava /var/cache/apt/archives/lock -  (Lida 22161 vezes)

Offline princess_br

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Cada dia é um erro novo no Ubuntu! O último é que ñ consigo baixar nada pelo Synaptic (queria baixar o driver da nvidia e o gstreamer),aparece o seguinte erro:

E: Não foi possível obter trava /var/cache/apt/archives/lock - open (11 Recurso temporariamente indisponível)
E: Não foi possível trancar o diretório de download


O que é isso de trancar diretório de download? :-\

Ai,ai...um  dia irei usar o ubuntu sem qq problemas,né???
« Última modificação: 07 de Julho de 2009, 13:30 por princess_br »

Offline jomafras

  • Usuário Ubuntu
  • *
  • Mensagens: 2.009
  • 17.04 Zesty Zapus
    • Ver perfil
Ou vc está abrindo o Terminal junto com o Synaptic ou está esquecendo o sudo antes do comando.
Mas, no caso do driver da nVidia é melhor instalar pelos Drivers de Hardware (Sistema > Administração)  e o gstreamer pelo pacote ubuntu-restricted-extras (Synaptic).
O Ubuntu sem dúvida é a melhor Distro.
Pesquise primeiro... só depois abra um tópico.
Canal do YouTube - Blog

Offline princess_br

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Obrigada,Pintinho! Consegui instalar o pacote que citou!
Mas qto ao driver da placa de vídeo,qdo tento instalar pelo Drivers de Hardware dá o erro:

Desculpe, a infra-estrutra do jóquei quebrou. Por favor envie o erro para:

  ubuntu-bug jockey-common

Tentando recuperar reiniciando a infra-estrutura.


Ñ seria melhor então pelo Synaptic mesmo?

alarcon

  • Visitante
Já tentou, pelo terminal, isso aqui:

sudo apt-get update

sudo apt-get install -f



Isso sem o Synaptic, Adicionar/Remover.... ou outra forma qualquer de instalação de pacotes .deb pelo Ubuntu, senão irá dar aquele erro de lock, pois vc só pode usar um de cada vez já que todos fazem a mesma coisa.

Depois dos comandos acima, vá no menu Sistema > Administração > Gerenciador de Atualizações e veja se tem algo a atualizar e se tiver, faça as atualizações.

Por fim tente novamente o menu Sistema > Administração > Drivers de Hardware
« Última modificação: 06 de Julho de 2009, 13:28 por alarcon »

Offline princess_br

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Alarcon,fiz exatamente como disse e ainda assim está dando o mesmo erro. A caixa de "baixando e instalando driver" fica eternamente no 0% e depois vem aquele erro.

alarcon

  • Visitante
Alarcon,fiz exatamente como disse e ainda assim está dando o mesmo erro. A caixa de "baixando e instalando driver" fica eternamente no 0% e depois vem aquele erro.


quando vc executou o comando:

sudo apt-get install -f

não apareceu nada de errado?

É que este comando serve para solucionar pacotes quebrados.

Após o comando:

sudo apt-get update

e indo no menu Sistema > Administração > Gerenciador de Atualizações não havia nenhuma atualização para ser feita?

Poderia ter algo relativo a esse pacote jockey-common para ser atualizado.

Offline princess_br

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Tinha umas 03 atualizações só...deveria ter anotado mas nem me liguei. E qdo fiz o sudo apt (...) ñ deu erro algum.

Farei novamente...ñ custa tentar.

===== EDITADO=========
 No sudo apt-get install -f :
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os seguintes pacotes foram automaticamente instalados e não são mais requeridos:
  linux-headers-2.6.28-11-generic linux-headers-2.6.28-11
Use 'apt-get autoremove' para removê-los.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
W: Duplicate sources.list entry cdrom://Ubuntu 9.04 _Jaunty Jackalope_ - Release amd64 (20090420.1) jaunty/main Packages (/var/lib/apt/lists/Ubuntu%209.04%20%5fJaunty%20Jackalope%5f%20-%20Release%20amd64%20(20090420.1)_dists_jaunty_main_binary-amd64_Packages)
W: Duplicate sources.list entry cdrom://Ubuntu 9.04 _Jaunty Jackalope_ - Release amd64 (20090420.1) jaunty/restricted Packages (/var/lib/apt/lists/Ubuntu%209.04%20%5fJaunty%20Jackalope%5f%20-%20Release%20amd64%20(20090420.1)_dists_jaunty_restricted_binary-amd64_Packages)
W: Você terá que executar apt-get update para corrigir estes problemas


Executei o apt-get update mas como era de se esperar ñ teve nenhuma nova atualização.
« Última modificação: 06 de Julho de 2009, 16:54 por princess_br »

alarcon

  • Visitante
Tinha umas 03 atualizações só...deveria ter anotado mas nem me liguei. E qdo fiz o sudo apt (...) ñ deu erro algum.

Farei novamente...ñ custa tentar.

===== EDITADO=========
 No sudo apt-get install -f :
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
Os seguintes pacotes foram automaticamente instalados e não são mais requeridos:
  linux-headers-2.6.28-11-generic linux-headers-2.6.28-11
Use 'apt-get autoremove' para removê-los.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
W: Duplicate sources.list entry cdrom://Ubuntu 9.04 _Jaunty Jackalope_ - Release amd64 (20090420.1) jaunty/main Packages (/var/lib/apt/lists/Ubuntu%209.04%20%5fJaunty%20Jackalope%5f%20-%20Release%20amd64%20(20090420.1)_dists_jaunty_main_binary-amd64_Packages)
W: Duplicate sources.list entry cdrom://Ubuntu 9.04 _Jaunty Jackalope_ - Release amd64 (20090420.1) jaunty/restricted Packages (/var/lib/apt/lists/Ubuntu%209.04%20%5fJaunty%20Jackalope%5f%20-%20Release%20amd64%20(20090420.1)_dists_jaunty_restricted_binary-amd64_Packages)
W: Você terá que executar apt-get update para corrigir estes problemas


Executei o apt-get update mas como era de se esperar ñ teve nenhuma nova atualização.

sua sources.list tem entradas duplicadas.

Abra um terminal e digite:

sudo gedit /etc/apt/sources.list

E no arquivo que aparecer comente as linhas (a linha inteira) que falam em ...cdrom://Ubuntu 9.04 _Jaunty Jackalope_ - Release amd64 (20090420.1)...

Comentar é colocar o símbolo # no início da linha para que ele seja ignorada.

Depois salve e saia do arquivo e no terminal digite:

sudo apt-get update
« Última modificação: 06 de Julho de 2009, 17:08 por alarcon »

Offline Versuri

  • Usuário Ubuntu
  • *
  • Mensagens: 912
  • Linux#436528 ● Ubuntu#9933 MacBook Pro SL 10.6.7
    • Ver perfil
princess_br,
Esse erro apareceu comigo também.
Cliquei em OK, fechei a janela, entrei novamente nos hardwares restritos, pedi para desinstalar e instalar novamente a placa de vídeo, funcionou sem problemas.

Abraços
Versuri

Offline princess_br

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: E: Não foi possível obter trava /var/cache/apt/archives/lock [RESOLVIDO]
« Resposta #9 Online: 06 de Julho de 2009, 17:43 »
CONSEGUIIIIIII,Alacorn!!!

MUITOOOO OBRIGADA! ;D

Pois é,Versuri...depois de fazer as modificações que o Alacorn falou consegui instalar a placa sem problemas pelo Driver de Hardware. Nem acredito que enfim,o Ubuntu tá no jeito que eu quero!! Aquela resolução 800x600 tava me matando. E também posso ouvir músicas!! 8)

Obrigada!Obrigada!Obrigada!



 

Offline SantiagoPD

  • Usuário Ubuntu
  • *
  • Mensagens: 56
    • Ver perfil
    • Além do que se vê
Re: [RESOLVIDO]E: Não foi possível obter trava /var/cache/apt/archives/lock -
« Resposta #10 Online: 21 de Abril de 2011, 12:27 »
Olá pessoal. Vou reabrir o post pois estou com o mesmo problema e não consigo resolver com as indicações que até então foram postadas.

Dei uma olhada no meu sourcelist e ele não possuí duplicações.

Alguma outra dica?
"Não tem nada de sadio em adaptar-se a uma sociedade completamente doente"

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.985
    • Ver perfil
Re: [RESOLVIDO]E: Não foi possível obter trava /var/cache/apt/archives/lock -
« Resposta #11 Online: 21 de Abril de 2011, 12:31 »
Olá pessoal. Vou reabrir o post pois estou com o mesmo problema e não consigo resolver com as indicações que até então foram postadas.

Dei uma olhada no meu sourcelist e ele não possuí duplicações.

Alguma outra dica?

Não seria interessante postar o erro que aparece?

[]'s

Offline SantiagoPD

  • Usuário Ubuntu
  • *
  • Mensagens: 56
    • Ver perfil
    • Além do que se vê
Re: [RESOLVIDO]E: Não foi possível obter trava /var/cache/apt/archives/lock -
« Resposta #12 Online: 21 de Abril de 2011, 12:43 »
Olá pessoal. Vou reabrir o post pois estou com o mesmo problema e não consigo resolver com as indicações que até então foram postadas.

Dei uma olhada no meu sourcelist e ele não possuí duplicações.

Alguma outra dica?

Não seria interessante postar o erro que aparece?

[]'s

Tota, claro que sim, sorry. Mas não será necessário. Provavelmente eu estava com algum programa aberto dentre os que seriam atualizados. Fechei tudo o que estava ativo e... pronto. resolvidaço.
Foi mal aí, bom feriado pra galera!
« Última modificação: 21 de Abril de 2011, 13:46 por platao »
"Não tem nada de sadio em adaptar-se a uma sociedade completamente doente"

Offline Alan Motta

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: [RESOLVIDO]E: Não foi possível obter trava /var/cache/apt/archives/lock -
« Resposta #13 Online: 21 de Maio de 2011, 11:06 »
Olá pessoal, reabri o tópico pois estou com o mesmo problema e não consegui resolver com as dicas acima.
Segue o erro:

alan@alan-STI:~$ sudo su
root@alan-STI:/home/alan# apt-get update
E: Não foi possível obter trava /var/lib/apt/lists/lock - open (11: Recurso temporariamente indisponível)
E: Impossível criar acesso exclusivo ao directório /var/lib/apt/lists/

No momento da execução do comando nenhum outro aplicativo estava aberto além do Firefox, contudo tbm tentei executar o comando com o Firefox fechado e ocorre o mesmo erro.

Desde já agradeço a ajuda de todos!

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.985
    • Ver perfil
Re: [RESOLVIDO]E: Não foi possível obter trava /var/cache/apt/archives/lock -
« Resposta #14 Online: 21 de Maio de 2011, 11:44 »
Se já solucionou, por favor poste aqui. ok?

[]'s