Autor Tópico: compartilhar internet (RESOLVIDO)  (Lida 1730 vezes)

Offline weltonpba

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
compartilhar internet (RESOLVIDO)
« Online: 24 de Agosto de 2009, 11:35 »
Galera sou novo no linux, preciso compartilhar internet no meu ubuntu 9.04 server com 2 placa de rede... sendo que na "eth0:(rede local) eth1:(ligada a internet)
não conssigo fazer compartilhar minha internet nem a custa de reza braba, podem me ajudar?  ja olhei varios tutos aki no forum mas não conssegui fazer funcionar alguem poder me ajudar....

segui minhas configurações:

:::::::::::::::::::configurações placa de rede::::::::::::::::::::::
# /etc/network/interfaces

auto lo eth0 eth1
iface lo inet loopback
iface eth0 inet static
address 192.168.1.1
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255

iface eth1 inet dhcp

::::::::::::::::::: compartilhando internet ::::::::::::::::::::::

#!/bin/sh
# /etc/rc.local
modprobe iptable_nat
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

::::::::::::::::::: configurações pc ligado na eth0 windows xp "MANUAL" ::::::::::::::::::::

endereço ip: 192.168.1.61
mascara de sub-rede: 255.255.255.0
gateway padrão: 192.168.1.1
servidor de Dns não cologuei nada..

Alguem poderia me ajudar no que eu to errando...
« Última modificação: 24 de Agosto de 2009, 15:58 por weltonpba »

Offline 3lson

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: compartilhar internet
« Resposta #1 Online: 24 de Agosto de 2009, 12:53 »
Cara, também sofri um pouquinho no começo, ois também sou iniciante. Mas consegui depois de muito pesquisar em fóruns como este.

Faz o seguinte: Configura sua intenet normalmente e verifica se o servidor está conectando à internet.
Feito isso vc saberá que sua conexzao vem pela ethx. Certo...
Adicione estas linhas no seu rc.local, reinicie a máquina e veja se funcionou.



#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

#!/bin/sh


# Compartilha a conexão
modprobe iptable_nat
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -o <interface de conexao com internet> -j MASQUERADE


# Abre para as portas especificadas
iptables -A INPUT -p tcp --dport 22 -j ACCEPT
iptables -A INPUT -p tcp --dport 80 -j ACCEPT
iptables -A INPUT -p tcp --dport 443 -j ACCEPT
iptables -A INPUT -p tcp --dport 8081 -j ACCEPT
iptables -A INPUT -p tcp --dport 3389 -j ACCEPT
iptables -A INPUT -p tcp --dport 1433 -j ACCEPT

#Caso queira usar o squid como proxy...
#direciona requisicoes vindas pela porta 80 para o proxy squid (lembre-se que o ethx é a sua interface de rede local)
# iptables -t nat -A PREROUTING -i ethX -p tcp --dport 80 -j REDIRECT --to-port 3128


#libera acesso outlook
iptables -A FORWARD -p tcp --dport 53 -j ACCEPT
iptables -A FORWARD -p udp --sport 53 -j ACCEPT
iptables -A FORWARD -p tcp --dport 25 -j ACCEPT
iptables -A FORWARD -p udp --sport 25 -j ACCEPT
iptables -A FORWARD -p tcp --dport 110 -j ACCEPT
iptables -A FORWARD -p udp --sport 110 -j ACCEPT


# Bloqueia pings e protege contra IP spoofing e pacotes inválidos
iptables -A INPUT -p icmp --icmp-type echo-request -j DROP
echo 1 > /proc/sys/net/ipv4/conf/default/rp_filter
iptables -A INPUT -m state --state INVALID -j DROP

# Abre para a interface de loopback e para a interface de rede local
iptables -A INPUT -i lo -j ACCEPT
iptables -A INPUT -i eth0 -j ACCEPT

# Bloqueia as demais conexões, deixando passar apenas pacotes de resposta
iptables -A INPUT -p tcp --syn -j DROP


exit 0

Offline weltonpba

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: compartilhar internet
« Resposta #2 Online: 24 de Agosto de 2009, 13:13 »
cara ja resolvi aki,

maior vuada na minha vida, e até vergonha eu contar como resolvi aki mas tudo bem..

na hora de configurar manual o notebook eu não coloquei as dns da minha localidade.. por isso não funcionava gente burra tem que ralar mesmo, tava tudo funcionando era so eu colocar, ae quando coloquei funcionou ehhehehehe

apanhando vivendo e aprendendo hehehehehe..

mas valew demais da conta, desde já agradecido...