Autor Tópico: Mplayer: "[AO_ALSA] Unable to find simple control 'PCM',0"  (Lida 2460 vezes)

Offline arsolto

  • Usuário Ubuntu
  • *
  • Mensagens: 625
  • Alea Jacta Est
    • Ver perfil
    • Por Ofício
Mplayer: "[AO_ALSA] Unable to find simple control 'PCM',0"
« Online: 10 de Janeiro de 2009, 14:38 »
Acredito que muitos dos usuários do Ubuntu 8.10 já devem ter passado pelo mesmo problema que eu. O Mplayer responde "[AO_ALSA] Unable to find simple control 'PCM',0" sempre que tento executar algum vídeo por meio dele, impedindo que os arquivos multimídia sejam reproduzidos.

Apesar de ter feito muitas buscas no fórum a procura de uma solução, não encontrei nada a respeito aqui. E em outros fóruns da Internet encontrei muitos usuários queixando-se do problema, porém, sem respostas salvadoras.

Acabei de fazer um upgrade da versão anterior para a versão mais nova do Ubuntu.

Solicito um suporte aos usuários on-line.

Offline glilco

  • Usuário Ubuntu
  • *
  • Mensagens: 80
  • Glilco Caneca
    • Ver perfil
Re: Mplayer: "[AO_ALSA] Unable to find simple control 'PCM',0"
« Resposta #1 Online: 15 de Abril de 2009, 10:45 »
Tive esse problema aqui também. Neste post http://ubuntuforums.org/showthread.php?t=1107520 (em inglês) explicam várias formas de resolver, mas apenas chamando o mplayer pela linha de comando.

Resolvi o problema, utilizando a interface gráfica, da seguinte forma: entrei nas preferências de áudio do mplayer (clique com o auxiliar, preferences, audio), selecionei o driver alsa e cliquei para configurar driver (configure driver). Em 'Mixer Channel', selecionei Master.

Offline Meire Rebouças

  • Usuário Ubuntu
  • *
  • Mensagens: 43
    • Ver perfil
Re: Mplayer: "[AO_ALSA] Unable to find simple control 'PCM',0"
« Resposta #2 Online: 02 de Setembro de 2009, 10:10 »
Obrigada pela dica. Simples mas muito eficaz e que nunca me passou pela cabeça.
Como não tinha ideia do que se passava, instalei todos os plugins multimidia que vi no Synaptic mas já estava sem esperanças que pudesse funcionar. Meu Mplayer agora está funcionando muito bem e já posso ver meus rmvb sem problema nenhum.