Autor Tópico: [Resolvido]Samba Erro no login com windows  (Lida 12393 vezes)

Offline rodfall

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
[Resolvido]Samba Erro no login com windows
« Online: 29 de Maio de 2009, 08:42 »
Galera... estou quebrando a cabeça já peguei uns 4 tutoriais

e agora estou tendo o erro que segue a baixo
Citar

[Global]
   netbios name = TUXSRV
   workgroup = VATICANO
   server string = Servidor Linux Samba
   log file = /var/log/samba/%m.log
   security = user
   encrypt passwords = yes
   socket options =
   os level = 100
   local master = yes
   preferred master = yes
   domain master = yes
   domain logons = yes
   logon script = %U.bat
   wins support = yes
   announce as = NT Server
   admin users = rodfall

[netlogon]
   comment = SScripts de Inicializacao
   path = /home/netlogon
   read only = yes
   guest ok = yes   
   browseable = no
   
[home]
   comment = Diretorio Privativo do usuario
   path = /home/%U
   browseable = yes
   writable = yes
   
[publico]
   comment = Diretorio Publico
   path = /home/publico
   browseable = yes
   writable = yes
   guest ok = yes
   create mask = 0644      
   


« Última modificação: 09 de Junho de 2009, 08:00 por rodfall »

Offline helionney

  • Usuário Ubuntu
  • *
  • Mensagens: 17
    • Ver perfil
Re: Samba Erro no login com windows
« Resposta #1 Online: 29 de Maio de 2009, 11:53 »
Caro amigo você adicionou o root no samba ? Se não faça isso:
# smbpasswd -a root, depois tente adcionar a sua máquina no seu dominio.

Offline sley

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
    • Campanha Uso *nix, logo existo! PARTICIPE!!!
Re: Samba Erro no login com windows
« Resposta #2 Online: 29 de Maio de 2009, 12:07 »
Instale o system-config-samba cara...
Fica muito mais fácil de você mexer...

Bye!
Notebook Itautec W7635  |  Ubuntu 9.10 (Karmic Koala)  |  GNOME  |  Kernel 2.6.31-14-generic :)

Campanha Uso *nix, logo existo! PARTICIPE!!!

Offline rodfall

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Re: Samba Erro no login com windows
« Resposta #3 Online: 29 de Maio de 2009, 14:31 »
Citar
Caro amigo você adicionou o root no samba ? Se não faça isso:
# smbpasswd -a root, depois tente adcionar a sua máquina no seu dominio.

eu o fiz e não alterou em nada a mensagem

Offline raidicar

  • Usuário Ubuntu
  • *
  • Mensagens: 576
  • Quad Shot of Ubuntu
    • Ver perfil
Re: Samba Erro no login com windows
« Resposta #4 Online: 29 de Maio de 2009, 18:16 »
Vc adicionou o nome do usuário no samba e no sistema? e o micro, cadastrou o nome do micro?
No link abaixo, expliquei passo a passo a outro usuário como fazer para que uma maquina windows logue no dominio linux, de uma lida com atenção e siga rigorosamente os passos pela ordem.
http://ubuntuforum-br.org/index.php/topic,47193.msg278733.html#msg278733.
Quem ama extremamente, deixa de viver em si e vive no que ama. Na vida três coisas são certas, o amor, a morte e o Linux !
Se Platão disse, então realmente sofremos de uma perigosa doença mental.

Offline rodfall

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Re: Samba Erro no login com windows
« Resposta #5 Online: 04 de Junho de 2009, 11:54 »
Consegui, esra o micro que não estava cadastrado no servidor...

GRACIAS

MMMMAAASSSSS

agora quando vou fazer loguin no windows ele me dizque não pode achar o usuário em questão e me irá liberar um usuário temporário.. tem como desfazaer esta opção?
segue o que me retorna o Windows
são duas mensagens:
Citar
O Windows não pode localizar a cópia do servidor do perfil móvel e está tentando fazer logon com o seu perfil local. As alterações no perfil não serão copiadas no servidor quando você fizer logoff. Dentre as causas possíveis de erro estão problemas com a rede ou direitos insuficientes de segurança. Se o problema persistir, contate o administrador da rede. 


DETAIL - O nome da rede não foi encontrado.

Citar
O Windows não pode localizar o perfil local e está fazendo seu logon com um perfil temporário. As alterações que você fizer nesse perfil serão perdidas quando você fizer logoff.


eu gostaria de ter usuários fixos em cada máquina, para que possa-se ter acesso a MeusDocumentos, OUTLOOK, sem precisar configura-lo para outro lugar... existe como se fazer isto?
« Última modificação: 04 de Junho de 2009, 13:45 por rodfall »

Offline raidicar

  • Usuário Ubuntu
  • *
  • Mensagens: 576
  • Quad Shot of Ubuntu
    • Ver perfil
Re: Samba Erro no login com windows
« Resposta #6 Online: 04 de Junho de 2009, 20:23 »
rodfall, no smb.conf, faça o seguinte:
Descomente a seguinte linha:
Código: [Selecionar]
;   logon path = \\%N\profiles\%U
Deixando-a sem o ";" ou "#" na frente e sem nada na frente do sinal de "=".
Código: [Selecionar]
   logon path =
Caso essa linha não exista, adicione na sessão Domains.

ok?
Se esta tudo OK, coloque [Resolvido] no titulo do tópico.
Quem ama extremamente, deixa de viver em si e vive no que ama. Na vida três coisas são certas, o amor, a morte e o Linux !
Se Platão disse, então realmente sofremos de uma perigosa doença mental.

Offline rodfall

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Re: Samba Erro no login com windows
« Resposta #7 Online: 05 de Junho de 2009, 16:18 »
raidicar, deves perdoar minha ignorancia...

essa linha vai juntamente com a parte do Global?

se sim, não foi sanado o problema. ele persiste.

meu smb.conf está assim:
Citar
[Global]
   netbios name = servLinux
   workgroup = VATICANO
   server string = Servidor Linux Samba
   log file = /var/log/samba/%m.log
   security = user
   encrypt passwords = yes
   socket options =
   os level = 100
   local master = yes
   preferred master = yes
   domain master = yes
   domain logons = yes
   logon script = %U.bat
   wins support = yes
   announce as = NT Server
   admin uers = root
   add machine script = /usr/sbin/adduser -n -r -g machines -d /dev/null -s bin/false %u
   logon path = \\%N\profiles\%U
   
[netlogon]
   comment = SScripts de Inicializacao
   path = /home/netlogon
   read only = yes
   guest ok = yes
   browseable = no

[home]
   comment = Diretorio Privativo do usuario
   path = /home/%U
   browseable = yes
   writable = yes

[publico]
   comment = Diretorio Publico
   path = /home/publico
   browseable = yes
   writable = yes
   guest ok = yes
   create mask = 0644
« Última modificação: 05 de Junho de 2009, 16:54 por rodfall »

Offline raidicar

  • Usuário Ubuntu
  • *
  • Mensagens: 576
  • Quad Shot of Ubuntu
    • Ver perfil
Re: Samba Erro no login com windows
« Resposta #8 Online: 05 de Junho de 2009, 20:05 »
OK, tenho uma duvida, tinha entendido que o perfil iria ser local, ou seja, nada no servidor, o usuário logaria no servidor mas seus dados estariam no micro, correto?
mas vendo o seu smb.conf, não sei exatamente como será o perfil do usuário.
Vi que não pretende trabalhar com impressora no servidor, mas não acho uma boa remover essa parte do smb.conf, poderia deixar comentado.
Abaixo, eu peguei o meu smb.conf padrão e fiz alterações, levando em conta o seu smb.conf, faça backup do se arquivo e teste esse smb.conf.


Citar
#======================= Global Settings =======================

[global]
   log file = /var/log/samba/log.%m
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   obey pam restrictions = yes
   map to guest = bad user
   encrypt passwords = yes
   passwd program = /usr/bin/passwd %u
   passdb backend = tdbsam
   dns proxy = no
   server string = %h server (Servidor Linux Samba)
   unix password sync = yes
   workgroup = VATICANO
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   usershare allow guests = yes
   max log size = 1000
   pam password change = yes

#### Networking ####

;   interfaces = 127.0.0.0/8 eth0

;   bind interfaces only = yes

#### Debugging/Accounting ####

#   syslog only = no

####### Authentication #######

#   security = user

########## Domains ###########

   domain logons = yes

   logon path =

;  logon drive = H:

#  logon home = \\%N\%U

;  logon script = logon.cmd

;  add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u

########## Printing ##########

#   load printers = yes

# printcap file
;   printing = bsd
;   printcap name = /etc/printcap

# CUPS printing.  See also the cupsaddsmb(8) manpage in the
# cupsys-client package.
;   printing = cups
;   printcap name = cups

############ Misc ############

;   include = /home/samba/etc/smb.conf.%m

# You may want to add the following on a Linux system:
#         SO_RCVBUF=8192 SO_SNDBUF=8192
#   socket options = TCP_NODELAY

;   message command = /bin/sh -c '/usr/bin/linpopup "%f" "%m" %s; rm %s' &

#   domain master = auto

# Some defaults for winbind (make sure you're not using the ranges
# for something else.)
;   idmap uid = 10000-20000
;   idmap gid = 10000-20000
;   template shell = /bin/bash

;   winbind enum groups = yes
;   winbind enum users = yes

;   usershare max shares = 100

#======================= Share Definitions =======================

;[homes]
;   comment = Home Directories
;   browseable = no

;   read only = yes

;   create mask = 0700

;   directory mask = 0700

;   valid users = %S

;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes
;   share modes = no

;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no

;   write list = root, @ntadmin

# A sample share for sharing your CD-ROM with others.
;[cdrom]
;   comment = Samba server's CD-ROM
;   read only = yes
;   locking = no
;   path = /cdrom
;   guest ok = yes

# The next two parameters show how to auto-mount a CD-ROM when the
#   cdrom share is accesed. For this to work /etc/fstab must contain
#   an entry like this:
#
#       /dev/scd0   /cdrom  iso9660 defaults,noauto,ro,user   0 0

;   preexec = /bin/mount /cdrom
;   postexec = /bin/umount /cdrom

[publico]
   comment = Diretorio Publico
   path = /home/publico
   browseable = yes
   writable = yes
   guest ok = yes
   create mask = 0644
Quem ama extremamente, deixa de viver em si e vive no que ama. Na vida três coisas são certas, o amor, a morte e o Linux !
Se Platão disse, então realmente sofremos de uma perigosa doença mental.

Offline rodfall

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Re: Samba Erro no login com windows
« Resposta #9 Online: 09 de Junho de 2009, 08:00 »
Raidicar...
Consegui resolver meu problema, eu tinha de alterar umas configurações NO WINDOWS
o meu samba estava correto também, apesar de incompleto...


"gpedit.msc"
"Configuração do computador > Modelos administrativos > Sistema > Perfis de usuário > Só permitir perfis de usuário locais" e mude a opção de "Não configurado" para "Ativado"

Lhe agradeço muito pelo auxílio  foi de grande importância.

Offline pauloleoni

  • Usuário Ubuntu
  • *
  • Mensagens: 43
    • Ver perfil
Re: [Resolvido]Samba Erro no login com windows
« Resposta #10 Online: 29 de Junho de 2009, 10:06 »
O meu problema é que quando tento ingressar a maquina no dominio (windows xp), dá um erro dizendo que o usuário ou a senha podem estar errados.

Ja add o usuario administrador no samba e no sistema
add passwd administrador
smbpasswd -a administrador


O que será que pode estar acontecendo?


Offline rodfall

  • Usuário Ubuntu
  • *
  • Mensagens: 32
    • Ver perfil
Re: [Resolvido]Samba Erro no login com windows
« Resposta #11 Online: 29 de Junho de 2009, 13:37 »
você deve setar atambém o usuário parra enable
smbpasswd -e conta_do_usuario

Offline Alex Lupi

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: [Resolvido]Samba Erro no login com windows
« Resposta #12 Online: 04 de Setembro de 2009, 16:26 »
Tente adicionar com o login root.

Ate mais