Autor Tópico: [Resolvido]Problema com a inicialização gráfica do ubuntu devido à placa de víde  (Lida 2788 vezes)

Offline dfmb

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Caros,

otro dia, por achar que minha placa de vídeo não estava devidamente configurada ( ATI Radeon 9200 SE), pesquisei na internet e encontrei algo sobre atualizar pacotes no sypaptic, e tal. Atualizei o tal pacote e no mesmo site mandava eu modificar algumas linhas do arquivo xorg.conf em /etc/X11/, e eu o fiz. Resultado: O ubuntu não inicia mais, ele chega na parte que seria a de login, e trava completamente, a tela fica com uns desenhos desfigurados e daí não passa.
Tentei entrar no recovery mode, usei o comando " sudo dpkg-reconfigure -phigh xserver-xorg " para poder restaurar o arquivo xorg.conf. A tarefa é realizada, mas o ubuntu continua sem inicializar.
Apelei por entrar no Live CD. Criei uma senha "su" e acessei a pasta X11 na partição que o ubuntu está instalado, e de fato ele está como estava antes de eu mexer, ou seja, era pra estar funcionando!
Não sei mais o que faço, alguem poderia me ajudar de alguma maneira?
Obrigado a todos,

Diogo.
« Última modificação: 02 de Outubro de 2009, 10:53 por dfmb »

Offline VB5

  • Usuário Ubuntu
  • *
  • Mensagens: 3.564
  • Liga dos Dinos
    • Ver perfil
Re: Problema com a inicialização gráfica do ubuntu devido à placa de vídeo
« Resposta #1 Online: 30 de Setembro de 2009, 22:05 »
Diogo,

o problema então parece estar no(s) pacote(s) que atualizou. Quais foram, e como o fez? Minha placa é nVidia, portanto não posso ajudar muito, mas alguém mais pode.

VB5
Ubuntu 10.04 - Semprom 2600+/Asus K8N/1.5 GB RAM DDR 400/GeForce 6200/HDs: 80MB + 320 GB

Offline dfmb

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Problema com a inicialização gráfica do ubuntu devido à placa de vídeo
« Resposta #2 Online: 30 de Setembro de 2009, 22:59 »
Cara, o nome eu não lembro não! O que eu fiz foi iniciar o "envy" pelo terminal e instalar um driver que ele tinha lá, e dpois disso modifiquei o arquivo xorg.conf! Será que nao tem jeito de restaurar a configuração anterior talvez autalizando o ubuntu pra kubuntu, sei lá, alguma coisa que mecha na parte grafica e substitua a besteira que eu fiz!

Offline VB5

  • Usuário Ubuntu
  • *
  • Mensagens: 3.564
  • Liga dos Dinos
    • Ver perfil
Re: Problema com a inicialização gráfica do ubuntu devido à placa de vídeo
« Resposta #3 Online: 30 de Setembro de 2009, 23:21 »
Tente postar seu xorg.conf aqui, pode ser que algum usuário de ATI possa dar uma dica... Quando acessou pelo LiveCD você montou corretamente a sua partição Ubuntu antes de verificar o xorg, suponho.

VB5
Ubuntu 10.04 - Semprom 2600+/Asus K8N/1.5 GB RAM DDR 400/GeForce 6200/HDs: 80MB + 320 GB

Offline velox256

  • Usuário Ubuntu
  • *
  • Mensagens: 1.915
  • Debian é Debian... :)
    • Ver perfil
    • Linux Inside
Re: Problema com a inicialização gráfica do ubuntu devido à placa de vídeo
« Resposta #4 Online: 01 de Outubro de 2009, 09:26 »
Vai ter que desinstalar, pelo Envy, o driver que vc colocou, entre em modo de recuperação, escolha no prompt "Drop to Root Shell e digite depois (sua conexão de internet deve estar ativa nesse meio tempo):

Citar
envy -t

Escolha desinstalar driver ATI, siga com a situação e, depois de desinstalado, mande rebutar a máquina e veja se o sistema entra. Se não funcionar, entre de novo no modo de recuperação e digite o comando "dpkg-reconfigure...", rebute o micro de novo e veja se funciona...

I hate ATI, hehehehehe!
Computador perereca, com disco perereca, monitor perereca e sistema super xuxu. Visitem a minha página em http://sidserra.k6.com.br ou meu blog em http://sidserra.blogspot.com.br.

Offline dfmb

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Problema com a inicialização gráfica do ubuntu devido à placa de vídeo
« Resposta #5 Online: 01 de Outubro de 2009, 12:10 »
Deu certo! Eu já tinha tentado fazer isso antes, porém eu digitava envy -t, mas na verdade é uma otra versão do envy que chama envyng, lembrei disso na hora que tava digitando o comando, e realmente funcionou! Valeu velox!
Agora ele removeu o driver de vídeo que estava atrapalhando a inicialização, porém ele não reconhece mais meu monitor, mas acho que isso pode ser o xorg.conf que agora está diferente do de antes. Agora não estou em casa mas quando chegar vo entrar no live cd e copiar o xorg.conf do sistema de arquivos que reconhece meu monitor e placa de video certinhos, e espero que dê tudo certo, qualquer coisa vou me recorrer a vocês denovo! Brigadão!

Offline dfmb

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Problema com a inicialização gráfica do ubuntu devido à placa de vídeo
« Resposta #6 Online: 02 de Outubro de 2009, 10:53 »
Problema resolvido!!
Valeu galera, foi só modificar o xorg.conf, tudo voltou ao normal!
valeu msm.

Abraço