Autor Tópico: Problema com atualizações [resolvido]  (Lida 2519 vezes)

Offline 7oninho

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Problema com atualizações [resolvido]
« Online: 25 de Outubro de 2009, 14:58 »
Deixei de poder fazer actualizações e aparece-me esta mensagem de erro:

"E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
 E: _cache->open() failed, please report."
 
Já fiz o "sudo dpkg --configure -a" no terminal mas não resolveu o problema.
Também já tentei actualizar para o novo 9.10 para ver se resolvia, mas também não consigui por esse lado.
Será que alguém conhece alguma maneira de ultrapassar este problema?
 
Desde já agradeço a ajuda que me puderem fornecer

António Rodrigues
« Última modificação: 27 de Outubro de 2009, 18:22 por 7oninho »

Offline Renato Krause

  • Usuário Ubuntu
  • *
  • Mensagens: 314
    • Ver perfil
Re: Problema com atualizações
« Resposta #1 Online: 26 de Outubro de 2009, 10:26 »
Acho que uma vez tive esse problema e corrigi com algo assim:

Código: [Selecionar]
sudo apt-get autoremove
Código: [Selecionar]
sudo apt-get autoclean
Depois disso roda o:

Código: [Selecionar]
sudo dpkg --configure -a
novamente...

Isso parece que você instalou um pacote e ele não foi perfeitamente configurado.
Testa aí depois me conta.

Abraço,

Offline 7oninho

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re: Problema com atualizações
« Resposta #2 Online: 27 de Outubro de 2009, 09:47 »
Obrigado Renato, mas não resultou. Com ambos os comandos a reposta é a mesma:

"E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem."

Se souber de outra forma...

Abraço,
António Rodrigues

Offline Renato Krause

  • Usuário Ubuntu
  • *
  • Mensagens: 314
    • Ver perfil
Re: Problema com atualizações
« Resposta #3 Online: 27 de Outubro de 2009, 09:55 »
Por acaso lembra-se do último pacote que você instalou?

Offline 7oninho

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re: Problema com atualizações
« Resposta #4 Online: 27 de Outubro de 2009, 09:58 »
Não. Penso que isto aconteceu numa actualização normal, daquelas diárias.

Offline Renato Krause

  • Usuário Ubuntu
  • *
  • Mensagens: 314
    • Ver perfil
Re: Problema com atualizações
« Resposta #5 Online: 27 de Outubro de 2009, 10:06 »
Tenta esses comandos. Se possível, posta o resultado completo de todos.

Código: [Selecionar]
sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get --fix-missing install
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get clean
sudo apt-get autoremove

Abraço,

Offline 7oninho

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re: Problema com atualizações
« Resposta #6 Online: 27 de Outubro de 2009, 10:33 »
Bom, aqui vai:

toninho@colombo:~$ sudo dpkg --configure -a
dpkg: erro de interpretação, no ficheiro `/var/lib/dpkg/updates/0000' perto da linha 1:
 campo do nome `#' tem de ser seguido de dois pontos
toninho@colombo:~$ sudo apt-get -f install
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
toninho@colombo:~$ sudo apt-get --fix-missing install
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
toninho@colombo:~$ sudo apt-get clean
toninho@colombo:~$ sudo apt-get update
Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release Candidate i386 (20091020.3) karmic/main Translation-pt_PT
Ign cdrom://Ubuntu 9.10 _Karmic Koala_ - Release Candidate i386 (20091020.3) karmic/restricted Translation-pt_PT
Obter:1 http://security.ubuntu.com jaunty-security Release.gpg [189B]         
Ign http://security.ubuntu.com jaunty-security/main Translation-pt_PT         
Ign http://security.ubuntu.com jaunty-security/restricted Translation-pt_PT   
Ign http://security.ubuntu.com jaunty-security/universe Translation-pt_PT     
Ign http://security.ubuntu.com jaunty-security/multiverse Translation-pt_PT   
Hit http://pt.archive.ubuntu.com jaunty Release.gpg                           
Ign http://pt.archive.ubuntu.com jaunty/main Translation-pt_PT                 
Obter:2 http://security.ubuntu.com jaunty-security Release [57,9kB]           
Ign http://pt.archive.ubuntu.com jaunty/restricted Translation-pt_PT           
Ign http://pt.archive.ubuntu.com jaunty/universe Translation-pt_PT             
Ign http://pt.archive.ubuntu.com jaunty/multiverse Translation-pt_PT           
Obter:3 http://pt.archive.ubuntu.com jaunty-updates Release.gpg [189B]         
Ign http://pt.archive.ubuntu.com jaunty-updates/main Translation-pt_PT
Ign http://pt.archive.ubuntu.com jaunty-updates/restricted Translation-pt_PT   
Ign http://pt.archive.ubuntu.com jaunty-updates/universe Translation-pt_PT     
Ign http://pt.archive.ubuntu.com jaunty-updates/multiverse Translation-pt_PT   
Hit http://pt.archive.ubuntu.com jaunty Release                               
Obter:4 http://dl.google.com stable Release.gpg [189B]                         
Ign http://dl.google.com stable/non-free Translation-pt_PT                     
Obter:5 http://pt.archive.ubuntu.com jaunty-updates Release [57,9kB]           
Obter:6 http://security.ubuntu.com jaunty-security/main Packages [120kB]       
Obter:7 http://dl.google.com stable Release [2540B]                           
Hit http://pt.archive.ubuntu.com jaunty/main Packages                         
Hit http://pt.archive.ubuntu.com jaunty/restricted Packages                   
Hit http://pt.archive.ubuntu.com jaunty/main Sources                           
Hit http://pt.archive.ubuntu.com jaunty/restricted Sources                     
Hit http://pt.archive.ubuntu.com jaunty/universe Packages                     
Hit http://pt.archive.ubuntu.com jaunty/universe Sources                       
Hit http://pt.archive.ubuntu.com jaunty/multiverse Packages                   
Hit http://pt.archive.ubuntu.com jaunty/multiverse Sources                     
Obter:8 http://pt.archive.ubuntu.com jaunty-updates/main Packages [197kB]     
Obter:9 http://security.ubuntu.com jaunty-security/restricted Packages [2599B]
Obter:10 http://security.ubuntu.com jaunty-security/main Sources [31,4kB]     
Obter:11 http://security.ubuntu.com jaunty-security/restricted Sources [509B] 
Obter:12 http://security.ubuntu.com jaunty-security/universe Packages [61,9kB]
Obter:13 http://dl.google.com stable/non-free Packages [1010B]                 
Obter:14 http://security.ubuntu.com jaunty-security/universe Sources [14,9kB] 
Obter:15 http://security.ubuntu.com jaunty-security/multiverse Packages [1662B]
Obter:16 http://security.ubuntu.com jaunty-security/multiverse Sources [588B] 
Obter:17 http://pt.archive.ubuntu.com jaunty-updates/restricted Packages [2599B]
Obter:18 http://pt.archive.ubuntu.com jaunty-updates/main Sources [55,4kB]
Obter:19 http://pt.archive.ubuntu.com jaunty-updates/restricted Sources [509B]
Obter:20 http://pt.archive.ubuntu.com jaunty-updates/universe Packages [83,2kB]
Obter:21 http://pt.archive.ubuntu.com jaunty-updates/universe Sources [23,6kB]
Obter:22 http://pt.archive.ubuntu.com jaunty-updates/multiverse Packages [8128B]
Obter:23 http://pt.archive.ubuntu.com jaunty-updates/multiverse Sources [2505B]
Obtidos 727kB em 2s (288kB/s)                         
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
toninho@colombo:~$ sudo apt-get upgrade
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
toninho@colombo:~$ sudo apt-get clean
toninho@colombo:~$ sudo apt-get autoremove
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
toninho@colombo:~$

ufa...

e continua sem resultar

Abraço

Offline Renato Krause

  • Usuário Ubuntu
  • *
  • Mensagens: 314
    • Ver perfil
Re: Problema com atualizações
« Resposta #7 Online: 27 de Outubro de 2009, 10:46 »
Vamos lá, posta:

cat /var/lib/dpkg/updates/0000

e também

ls /var/lib/dpkg/updates/

Offline 7oninho

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re: Problema com atualizações
« Resposta #8 Online: 27 de Outubro de 2009, 10:56 »
Aqui está:

toninho@colombo:~$ cat /var/lib/dpkg/updates/0000
# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda4 during installation
UUID=d9fafc21-5e7e-4f70-8c7c-8e29185f5bbe /               ext3    relatime,errors=remount-ro 0       1
/dev/sda2       none            swap    sw              0       0
/dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
usbfs         /proc/bus/usb      usbfs   devgid=14 0 0

toninho@colombo:~$ ls /var/lib/dpkg/updates/
0000  tmp.i

Offline Renato Krause

  • Usuário Ubuntu
  • *
  • Mensagens: 314
    • Ver perfil
Re: Problema com atualizações
« Resposta #9 Online: 27 de Outubro de 2009, 11:18 »
Tchê, daqui pra frente são apenas suposições que você só faz se quiser por sua conta e risco;)

EU tentaria:

Fazer backup da pasta /var/lib/dpkg/updates/
Código: [Selecionar]
sudo cp -R /var/lib/dpkg/updates /var/lib/dpkg/updates_bkp
Remover o arquivo 0000
Código: [Selecionar]
sudo rm /var/lib/dpkg/updates/0000
Rodar
Código: [Selecionar]
sudo dpkg --configure -a
Se desse erro, eu criar um arquivo 0000 vazio
Código: [Selecionar]
sudo touch /var/lib/dpkg/updates/0000
E tentaria de novo
Código: [Selecionar]
sudo dpkg --configure -a
Se desse erro eu restauraria o backup
Código: [Selecionar]
sudo rm -rf /var/lib/dpkg/updates
sudo mv /var/lib/dpkg/updates_bkp /var/lib/dpkg/updates

Se não desse erro eu tentaria instalar algo
Código: [Selecionar]
sudo apt-get update
sudo apt-get install qualquer coisa

Offline 7oninho

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
Re: Problema com atualizações
« Resposta #10 Online: 27 de Outubro de 2009, 12:15 »
Renato,

Aparentemente conseguis-te resolver o meu problema.
Fiz as entradas até à úlitma "sudo dpkg --configure -a", isto é, até antes de restaurar o backup e consegui fazer 97 actualizações.
O sistema está actualizado e, espero eu, prontinho para receber a nova distribuição.
Fico-te deveras gradecido e espero um dia poder retribuir-te, embora não esteja a ver como  :)

Um abraço e mais uma vez muito obrigado,

António Rodrigues

Offline Renato Krause

  • Usuário Ubuntu
  • *
  • Mensagens: 314
    • Ver perfil
Re: Problema com atualizações
« Resposta #11 Online: 27 de Outubro de 2009, 12:17 »
Feitoria! Fiquei muito feliz com isso...  ;D

Você irá me ajudar usando e ajudando o software livre sempre!

Se possível, edita o tópico e coloca [resolvido] no título.

Abraço,