Autor Tópico: Conexão wireless com problema intermitente (Perda de pacotes / Travando)  (Lida 21230 vezes)

Offline henrycv

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Olá Pessoal,

Estou com um problema em minha conexão wireless e não consigo descobrir a causa de jeito nenhum. Vou explicar o problema desde o princípio para que vocês possam entender.

No inicio o cenário aqui era o seguinte: Um roteador D-Link Xtreme N Gigabit (DIR-655) e três hosts, sendo um desktop Windows XP via cabo e dois notebooks Windows Vista via wireless e até então a LAN funcionava perfeitamente. A algum tempo atrás resolvi mudar de vez para o Linux e instalei no meu notebook (Vostro 1400 placa wireless Broadcom BCM4328 rev 03) o Ubuntu 9.04 Jaunty Jackalope e então começou o problema, pesquisei bastante e vi que muita gente tem problemas com placas Broadcom + Ubuntu e/ou com o NetworkManager, porém, nenhum desses casos é o meu, em 99% dos casos o problema ocorre após a instalação do Ubuntu porque ele não reconhece a placa e não instala o driver que este por sua vez é proprietário. No meu caso a placa wireless veio instalada e funcionando, o meu problema é que após mais ou menos 30 minutos a conexão começa a perder pacotes drásticamente (entre meu notebook e o roteador) onde até então a perda de pacotes era de 0% já que estou ao lado do roteador, a conexão fica travando e voltando, ela trava e volta, trava e volta... o curioso é que desconecto e conecto e tudo volta ao normal e daqui a 30 minutos... já sabe né?  >:(, saiu então a versão 9.10 Karmic Koala instalei (formatando) e o problema persiste, resolvi substituir o NetworkManager pelo Wicd e nada.

Ao meu ver existem três fatores que poderiam causar tal problema: roteador com problemas, defeito na placa wireless ou integração Ubuntu + placas Broadcom.

Roteador com problemas: Está fora já que os demais hosts não passam pelo mesmo problema.
Defeito na placa wireless: A pesar de que seria muita coincidêcia em dar problema exatamente quando mudo de SO é possível, mas esta opção está fora também porque não é preciso desligar e ligar o wireless e sim desconectar e conectar (para quem conhece o modelo OSI percebe-se que o problema não está na camada física).
Integração Ubuntu + placas Broadcom: Bom, muita gente tem esse tipo de problema.

Então é isso gente, não aguento mais ficar desconectando e conectando de meia em meia hora.
Será que alguem consegue resolver essa?

Grato a todos desde já.
[]'s

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Conexão wireless com problema intermitente (Perda de pacotes / Travando)
« Resposta #1 Online: 24 de Novembro de 2009, 10:33 »
Citar
para quem conhece o modelo OSI percebe-se que o problema não está na camada física
Não concordo contigo não. Eu conheço o modelo OSI a fundo, e acho que o problema é de hardware sim. Te dou uma dica: super-aquecimento. A reconfiguração da placa a desativaria por tempo suficiente pra ela resfriar e voltar a operar.

Problemas de memory leak (que seria a causa mais provável para um problema que se manifesta após meia hora) no driver não fariam a rede perder pacotes; o efeito mais provável seria sua máquina travar, ou você receber um "kernel panic".
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline henrycv

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: Conexão wireless com problema intermitente (Perda de pacotes / Travando)
« Resposta #2 Online: 24 de Novembro de 2009, 16:59 »
Humm, entendo... mas você acha que em 3 segundos (tempo para reconectar) dá para resfriar a placa o suficiente para operar por mais meia hora?

Uma forma de responder de vez se o problema é software ou hardware seria voltar ao Windows já que antes funcionava, porém isso me custaria muito tempo, coisa que não disponho no momento. Existe algum teste que possa comprovar que o problema é de hardware mesmo?

Assumindo que o problema seja mesmo de super-aquecimento da placa, existe solução ou reparo?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Conexão wireless com problema intermitente (Perda de pacotes / Travando)
« Resposta #3 Online: 24 de Novembro de 2009, 20:18 »
Se o super-aquecimento for causado por erro de programação, a atualização do driver vai resolver. Se for por falha de construção (como acontece com os notes HP do grupo do Recall), só consertando.

Já tentou usar o driver ndiswrapper dessa placa?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Conexão wireless com problema intermitente (Perda de pacotes / Travando)
« Resposta #4 Online: 24 de Novembro de 2009, 22:25 »
Afora este problema relatado ser de hardware muito factível, eu opinaria por tentar reduzir os MTU nas suas configurações.

Eu tenho broadcomm e não em meia hora, mas as vezes tinha problemas de conexão, caia, voltava, caia.... e vi aqui mesmo no forum relatos semelhantes que foram resolvidos com mudanças nos MTU.

para mim funcionou.

Porém para um problema persistente como o seu, concordo com a idéia do zekkerj


[],s

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Conexão wireless com problema intermitente (Perda de pacotes / Travando)
« Resposta #5 Online: 24 de Novembro de 2009, 23:26 »
MTU costuma dar sintoma de que as páginas abrem, mas as figuras não... mas, nesses casos "misteriosos", sempre vale um teste.

sudo ifconfig wlan0 mtu 1420
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline NPC

  • Usuário Ubuntu
  • *
  • Mensagens: 230
  • Bot
    • Ver perfil
Re: Conexão wireless com problema intermitente (Perda de pacotes / Travando)
« Resposta #6 Online: 25 de Novembro de 2009, 04:01 »
Se você usa torrent, limite o número de conexôes do seu client. O meu tava em 200, e meu roteadorzinho meiaboca ficava desconectando também, por causa do gargalo.
Googling since 1999.

Offline henrycv

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: Conexão wireless com problema intermitente (Perda de pacotes / Travando)
« Resposta #7 Online: 25 de Novembro de 2009, 14:03 »
Tota, o MTU não deu certo =/ mas valeu a tentativa.

NPC, não estou usando torrente mas valeu também, hehehehe.

zekkerj, ainda não tentei o ndiswarapper não, esse negocio de usar driver de windows em linux é muito gambiarration :P mas será o jeito, tentarei instalar ainda hoje! assim que tiver um tempinho eu instalo.


Offline henrycv

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: Conexão wireless com problema intermitente (Perda de pacotes / Travando)
« Resposta #8 Online: 01 de Dezembro de 2009, 23:36 »
Fala galera!

Primeiramente desculpa a demora mas é que eu andava um pouco atarefado. =/

Seguinte, o ndiswrapper resolveu o problema que relatei mas ainda não esta 100%. O probleminha agora é que o rate está trabalhando muito baixo, ele fica ocilando de 25 pra 130 Mbps em quanto que antes trabalhava a 270 direto, creio que ele esta trabalhando no padrão 802.11g mas minha placa é N.

Observem:

$ iwconfig wlan0
wlan0     IEEE 802.11g  ESSID:"*****" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: **: **: **: **: **: ** 
          Bit Rate=39 Mb/s   Tx-Power:32 dBm   
          RTS thr:2347 B   Fragment thr:2346 B   
          Power Management:off
          Link Quality:100/100  Signal level:-31 dBm  Noise level:-96 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

E ai pessoal? ajuda?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Conexão wireless com problema intermitente (Perda de pacotes / Travando)
« Resposta #9 Online: 02 de Dezembro de 2009, 00:10 »
Passou de 54Mbps não é mais 802.11g.

Agora, se vc diz que está variando, dá a impressão do problema estar relacionado com interferência. Há alguma fonte de interferência por perto?

Fontes de interferência: telefones sem-fio de 2.4GHz, fornos de micro-ondas <<em funcionamento>>, outros access points operando no mesmo canal que o seu, etc.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline henrycv

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: Conexão wireless com problema intermitente (Perda de pacotes / Travando)
« Resposta #10 Online: 02 de Dezembro de 2009, 01:22 »
Não é canal porque o roteador escolhe o melhor canal dentre 11 diferentes entre 2.412Ghtz até 2.462Ghtz, ou seja, ele fica variando mas o problema continua. Outra coisa, quando eu dou um iwconfig ele diz "wlan0     IEEE 802.11g" =/

Offline Deivid

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: Conexão wireless com problema intermitente (Perda de pacotes / Travando)
« Resposta #11 Online: 16 de Maio de 2011, 10:34 »
Estava tendo muitos problemas com a rede wireless no Linux, ficava sempre intermitente, tenho um D-Link Dir-600, fiz o seguinte:

Logue no seu roteador, clique em "Advanced" / "Advanced Wireless" / em Wireless Mode, escolha: "802.11 Mixed(g/b)".

Pra mim foi batata... problema resolvido.  :P

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Conexão wireless com problema intermitente (Perda de pacotes / Travando)
« Resposta #12 Online: 16 de Maio de 2011, 18:55 »
Não, não resolveu seu problema. Você o contornou, desativando o modo 802.11n.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Deivid

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: Conexão wireless com problema intermitente (Perda de pacotes / Travando)
« Resposta #13 Online: 26 de Dezembro de 2012, 18:33 »
Não, não resolveu seu problema. Você o contornou, desativando o modo 802.11n.

Modo 'n' que na vedade não existe, sendo apenas uma propaganda descaradamente enganosa deste equipamento...

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Conexão wireless com problema intermitente (Perda de pacotes / Travando)
« Resposta #14 Online: 26 de Dezembro de 2012, 19:24 »
Hein?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D