Autor Tópico: Instalação do Corretor Gramatical do OpenOffice  (Lida 6975 vezes)

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.369
  • @Ceará
    • Ver perfil
Instalação do Corretor Gramatical do OpenOffice
« Online: 05 de Maio de 2006, 15:44 »
Baixei o instalador do corretor gramatical do OpenOffice (não é o corretor ortográfico), mas ao tentar instalar dá o seguinte erro:
Código: [Selecionar]
root@glaydson:/home/glaydson/Desktop/o# ./cogroo_installer_linux.bin

CoGrOO Linux Installer 1.0


(.:9203): GdkPixbuf-CRITICAL **: gdk_pixbuf_new: assertion `width > 0' failed

** ERROR **: file ../../../src/libjava/jni/gtk-peer/gnu_java_awt_peer_gtk_GtkImage.c: line 572 (createRawData): assertion failed: (data_fid != 0)
aborting...
./cogroo_installer_linux.bin: line 34:  9203 Abortado                java -jar cogroo_installer_linux.jar
./cogroo_installer_linux.bin: line 41: /etc/init.d/cogroo: Arquivo ou diretório não encontrado

Alguém tem alguma dica?
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.369
  • @Ceará
    • Ver perfil
Instalação do Corretor Gramatical do OpenOffice
« Resposta #1 Online: 05 de Maio de 2006, 16:13 »
Descobri o problema:
Citar
2)Certifique-se de ter instalado as linguagens perl e java (infelizmente a CoGrOO ainda não roda com o gcj e gij; instale o JRE da Sun).

Precisei mudar o link simbólico de /usr/bin/java para o java baixado do site da Sun.
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline rbrazileiro

  • Usuário Ubuntu
  • *
  • Mensagens: 54
    • Ver perfil
    • http://www.geocities.com/rbrazileiro
Re: Instalação do Corretor Gramatical do OpenOffice
« Resposta #2 Online: 19 de Julho de 2006, 11:06 »
Quando tentei instalar o corretor apareceu o seguinte erro:

Código: [Selecionar]
CoGrOO Linux Installer 1.0

Exception in thread "main" java.awt.AWTError: Cannot load AWT toolkit: gnu.java.awt.peer.gtk.GtkToolkit
   at java.awt.Toolkit.getDefaultToolkit(libgcj.so.7)
   at java.awt.Font.tk(libgcj.so.7)
   at java.awt.Font.getPeerFromToolkit(libgcj.so.7)
   at java.awt.Font.<init>(libgcj.so.7)
   at javax.swing.plaf.FontUIResource.<init>(libgcj.so.7)
   at javax.swing.plaf.metal.DefaultMetalTheme.<clinit>(libgcj.so.7)
   at java.lang.Class.initializeClass(libgcj.so.7)
   at javax.swing.plaf.metal.MetalLookAndFeel.createDefaultTheme(libgcj.so.7)
   at javax.swing.plaf.metal.MetalLookAndFeel.<init>(libgcj.so.7)
   at javax.swing.UIManager.<clinit>(libgcj.so.7)
   at java.lang.Class.initializeClass(libgcj.so.7)
   at com.izforge.izpack.installer.GUIInstaller.loadLookAndFeel(GUIInstaller.java:274)
   at com.izforge.izpack.installer.GUIInstaller.<init>(GUIInstaller.java:116)
   at java.lang.Class.newInstance(libgcj.so.7)
   at com.izforge.izpack.installer.Installer.main(Installer.java:62)
Caused by: java.lang.ClassNotFoundException: gnu.java.awt.peer.gtk.GtkToolkit
   at java.lang.Class.forName(libgcj.so.7)
   at java.lang.Class.forName(libgcj.so.7)
   at java.awt.Toolkit.getDefaultToolkit(libgcj.so.7)
   ...14 more
./cogroo_installer_linux.bin: line 41: /etc/init.d/cogroo: Arquivo ou diretório não encontrado

O que pode ser? Eu tenho o Java instalado e criei o link simbólico.
Ricardo Brazileiro

"Eu acredito na liberdade"

Offline Lamego

  • Usuário Ubuntu
  • *
  • Mensagens: 1.943
    • Ver perfil
Re: Instalação do Corretor Gramatical do OpenOffice
« Resposta #3 Online: 19 de Julho de 2006, 11:34 »
Necessita do suporte GTK para Java.
Num terminal instala o pacote com:
Código: [Selecionar]
sudo apt-get install libgtk-java
João Luís Marques Pinto
Mais programs e jogos para o Ubuntu

Offline felipefoz

  • Usuário Ubuntu
  • *
  • Mensagens: 200
    • Ver perfil
Re: Instalação do Corretor Gramatical do OpenOffice
« Resposta #4 Online: 21 de Julho de 2006, 16:38 »
instalou aqui, mas não funciona, aparece o menu e tudo no programa, mas vc clica nele e nada acontece, alguém ai já passou pelo mesmo??

Offline mrbin

  • Usuário Ubuntu
  • *
  • Mensagens: 229
    • Ver perfil
    • somnium
Re: Instalação do Corretor Gramatical do OpenOffice
« Resposta #5 Online: 06 de Setembro de 2006, 17:36 »
eu passei. mas não sei como arruma. Alguém?
Ubuntu user nº 4141
Since 2004

Offline guilhermepso

  • Usuário Ubuntu
  • *
  • Mensagens: 14
  • Linux é a liberdade. Ame a Liberdade. Seja Linux
    • Ver perfil
Re: Instalação do Corretor Gramatical do OpenOffice
« Resposta #6 Online: 06 de Setembro de 2006, 17:40 »
no meu eu instalei esse corretor gramatical também e nao funcionou, e o ortografico tambem nao ta funcionando. >:(
windows
ja passei por todos atualmente extou utilizando o sistema superior.
linux ja passei por.
kurumin
fedora
ubuntu
vector
slackware
(passei por todas essas ditribuicoes em 1 mes hehehe)
Atualmente Kubunto :)

Offline hraposo

  • Usuário Ubuntu
  • *
  • Mensagens: 343
    • Ver perfil
    • Página Pessoal Hélder Raposo
Re: Instalação do Corretor Gramatical do OpenOffice
« Resposta #7 Online: 07 de Setembro de 2006, 05:10 »
Eu instalei, aparece o icon mas quando clico nele diz que não é possível conectar-se ao corrector gramatical... Porquê?

Offline ricardorrm

  • Usuário Ubuntu
  • *
  • Mensagens: 161
    • Ver perfil
Re: Instalação do Corretor Gramatical do OpenOffice
« Resposta #8 Online: 08 de Setembro de 2006, 12:21 »
Se for o CogrOO não irá funcionar no Ubuntu. Isso por causa de problemas com o UTF-8. Só funciona com ISO. A correção para esse problema está previsto para a versão 2.0.
Nossa Senhora Rosa Mística
Rogai por nós

Offline vinicius_aleao

  • Usuário Ubuntu
  • *
  • Mensagens: 1.275
    • Ver perfil
Re: Instalação do Corretor Gramatical do OpenOffice
« Resposta #9 Online: 02 de MAR?O de 2008, 22:53 »
Se for o CogrOO não irá funcionar no Ubuntu. Isso por causa de problemas com o UTF-8. Só funciona com ISO. A correção para esse problema está previsto para a versão 2.0.


Bom, o tempo passou e já estamos na versão 2.0. E agora, como faço? A instalação aqui foi perfeita, ele localizou sozinho o diretório do BrOffice, instalou beleza. Instalei o libgtk-java que foi recomendado, só não sei como fazer (se é que ainda é necessário) esse link simbólico para o java da sun. Alguém pode me ajudar?