Autor Tópico: DVD - Travando  (Lida 12068 vezes)

Offline Nandeira

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
DVD - Travando
« Online: 26 de Abril de 2005, 19:27 »
Ola Amigos,

Instalei um Leitor/gravador de DVD, mas quando coloco algum DVD para assistir com qualquer programa, vlc, totem. ela vai aos soquinhos, travando,
Será que tenho que instalar de novo o Ubuntu para ele reconhecer legal o DVD, ou é alguma outra coisa que não sei.

A proposito é um LG super multi 4163b

Obrigado pela ajuda

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.285
    • Ver perfil
DVD - Travando
« Resposta #1 Online: 26 de Abril de 2005, 23:02 »
ative o dma no dispositivo pra ver se funciona ...
sabendo qual o dispositivo faça o teste

Código: [Selecionar]
sudo hdparm -d1 /dev/seu_driver_DVD ¹
¹ seu_driver_DVD equivale a por exemplo /dev/hdc
caso dê resultado será necessário ativar isto no arquivo /etc/hdparm.conf

Código: [Selecionar]
sudo gedit /etc/hdparm.conf
adicione ao final do arquivo

Código: [Selecionar]
command_line {
hdparm -d1 /dev/seu_driver_DVD
}



Espero ter te ajudado , PS ativar DMA nos outros drivers também melhoram a performance do sistema :D
segue o final do meu /etc/hdparm.conf

Código: [Selecionar]
command_line {
hdparm -d1 -c1 -m16 /dev/hda
}
command_line {
hdparm -d1 -c1 -m16 /dev/hdb
}
command_line {
hdparm -d1 -c1 /dev/hdc
}
command_line {
hdparm -d1 -c1 /dev/hdd
}


d = dma
c = IO_Support 32bit
m = multicount

diferenças ????
sem ativar por exemplo no hda
Código: [Selecionar]
/dev/hda:
 Timing cached reads:   176 MB in  2.44 seconds =  72.05 MB/sec
 Timing buffered disk reads:    4 MB in  3.22 seconds =   1.24 MB/sec


Ativado com as flags acima.
Código: [Selecionar]
/dev/hda:
 Timing cached reads:   220 MB in  2.00 seconds = 109.85 MB/sec
 Timing buffered disk reads:   38 MB in  3.33 seconds =  11.40 MB/sec


Após as alterações feitas é necessário reiniciar o hdparm.

Código: [Selecionar]
sudo /etc/rcS.d/S07hdparm restart


Asta la vista.

Offline KubLin

  • Usuário Ubuntu
  • *
  • Mensagens: 428
    • Ver perfil
e ae
« Resposta #2 Online: 27 de Abril de 2005, 06:35 »
parabéns pelas explicações
vou ativar no meu....rs

Offline KubLin

  • Usuário Ubuntu
  • *
  • Mensagens: 428
    • Ver perfil
e ae
« Resposta #3 Online: 27 de Abril de 2005, 10:30 »
eu acho que é pra evitar da máquina travar ou algo parecido

Offline Nandeira

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
DVD - Travando
« Resposta #4 Online: 30 de Abril de 2005, 15:52 »
É isto aí Xterminator

resolveu!!!


Aquele abraço (já joguei o windows fora!)

Offline s3r8i0

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
DVD - Travando
« Resposta #5 Online: 18 de Agosto de 2005, 16:03 »
Oi Pessoal

Meu leitor de DVD LG está com o mesmo sintoma do drive do Nandeira, mas ao tentar o comando que o Xterminator sugeriu tenho a seguinte resposta:

xxx@xxxxxxx:/dev$ sudo hdparm -d1 /dev/dvd

/dev/dvd:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)

Estou usando o Kubuntu 5.04 com uma palca mãe Abit AN8 e o drive está como master na porta secundária.

Valeu
Sergio Luiz
=-=-=-=-=

Offline s3r8i0

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
DVD - Travando
« Resposta #6 Online: 18 de Agosto de 2005, 17:11 »
Oi xterminator

a resposta de meu sistema ao comando acima é:
xxx@xxxxxxxx:~$ ls -l /dev/dvd
lrwxrwxrwx  1 root root 3 2005-08-18 16:16 /dev/dvd -> hdc

Como vê, o link aponta para o hdc e também tentei o comando usando o hdc:

/dev/hdc:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)

infelizmente não surtiu efeito.

Espero por mais dicas, valeu.
Sergio Luiz
=-=-=-=-=

Offline s3r8i0

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
DVD - Travando
« Resposta #7 Online: 19 de Agosto de 2005, 17:34 »
O asterisco abaixo significa que o drive está em modo UDMA2, isso não é uma boa configuração?

xxx@xxxxxxx:~$ hdparm -i /dev/hdc

/dev/hdc:

 Model=HL-DT-STDVD-ROM GDR8163B, FwRev=0L23, SerialNo=
 Config={ Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic }
 RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
 BuffType=unknown, BuffSize=0kB, MaxMultSect=0
 (maybe): CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  sdma0 sdma1 sdma2 mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 *udma2
 AdvancedPM=no
 Drive conforms to: ATA/ATAPI-6 T13 1410D revision 3a:

 * signifies the current active mode
Sergio Luiz
=-=-=-=-=

Offline usphisics

  • Usuário Ubuntu
  • *
  • Mensagens: 98
    • Ver perfil
DVD - Travando
« Resposta #8 Online: 11 de Setembro de 2005, 01:58 »
Cara no meu caso tenho:
hda   é uma hd
hdb   é um DVD
hdc  é uma Gravadora de CD
hdd  é um ZIP

Como devo deixar o arquivo hdparm.conf ?????

Valeu

Offline LedStyle

  • Usuário Ubuntu
  • *
  • Mensagens: 1.347
    • Ver perfil
    • http://www.tuxresources.org
DVD - Travando
« Resposta #9 Online: 11 de Setembro de 2005, 03:25 »
Cara... aqui eu ativei o DMA e mesmo asism fica meio lento no Totem. Uma Bost... aquele player.

Instala o XINE ou Gxine pra tu ver se não fica rapido. Aqui ficou bala!


[]s

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.687
    • Ver perfil
DVD - Travando
« Resposta #10 Online: 11 de Setembro de 2005, 07:19 »
Citação de: "LedStyle"
Cara... aqui eu ativei o DMA e mesmo asism fica meio lento no Totem. Uma Bost... aquele player.

Instala o XINE ou Gxine pra tu ver se não fica rapido. Aqui ficou bala!


[]s


Aqui eu só uso o Xine para ver Filmes. É uma beleza.
Kubuntu 21.10 / Linux Mint XFCE 20.2