Autor Tópico: [Resolvido]Problema com gerenciador de energia do gnome  (Lida 14749 vezes)

Offline rato la

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
[Resolvido]Problema com gerenciador de energia do gnome
« Online: 22 de Janeiro de 2010, 01:19 »
ola....uso linux a pouco tempo e acho que essa foi a maior derma que eu ja fiz nesses tempos......olhando o menu Aplicativos de Sessao, pensei em desabilitar alguns programas que se iniciam com o sistema a fim de tornar o inicio do sistema mais rápido (faço isso sempre no windows)....porem dessa vez me dei mal.....desabilitei o gerenciamento de energia e agora (tenho quase certeza que foi isso, unica coisa diferente que fiz antes do problema) a sessao do meu usuario nao inicia, quando tento logar aparece uma mensagem do ubuntu com o seguinte conteudo:

Citar
Os padrões de configurações para o gerenciador de energia do gnome não foram instalados corretamente. Por favor entre em contato com o administrador do computador
consigo logar como root, no entanto preciso restaurar o meu login.......

pensei que se eu abrisse um terminal, logasse como usuario e tentasse abrir o menu Aplicativos de sessao eu conseguiria fazer tudo voltar ao normal, no entanto nao consegui fazer isso, alguns erros sao retornados...como root a janela abre normalmente, mais como usuario nao......

Citar
root@rato-desktop:/# su rato
rato@rato-desktop:/$ gnome-session-properties
No protocol specified

** (gnome-session-properties:6247): WARNING **: Unable to start: Não foi possível abrir a tela:
rato@rato-desktop:/$

se alguem puder me ajudar em alguma coisa fico grato...
« Última modificação: 25 de Janeiro de 2010, 00:18 por rato la »

Offline Hqxriven

  • Usuário Ubuntu
  • *
  • Mensagens: 1.456
    • Ver perfil
Re: Problema com gerenciador de energia do gnome
« Resposta #1 Online: 22 de Janeiro de 2010, 02:00 »
Vc já pensou em digitar startx
Sem distro Linux fixa - Kernel Omnislash
Meu objetivo nesse fórum é ajudar. Sou um mero humano mas desejo sempre aprender e melhorar em tudo o que faço em minha vida. Então, por favor, quando eu postar me notifique depois

Offline sistematico

  • Usuário Ubuntu
  • *
  • Mensagens: 576
  • Sistematico
    • Ver perfil
    • Sistematico.org
Re: Problema com gerenciador de energia do gnome
« Resposta #2 Online: 22 de Janeiro de 2010, 02:24 »
Código: [Selecionar]
nano $(grep -Rils "gerenciador de energia" ~)

Onde tem X-GNOME-Autostart-enabled=false, você coloca X-GNOME-Autostart-enabled=true.
Lucas Saliés Brum
Ubuntu User #27150
http://sistematico.org

Offline rato la

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Problema com gerenciador de energia do gnome
« Resposta #3 Online: 23 de Janeiro de 2010, 03:15 »
rodei o comando que voce deixou sistematico, no entanto nao achei nada a trocar, fiz algumas buscas com os nomes dos arquivos, por exemplo gnome-power-manager, e modifiquei um arquivo em
Citar
/usr/share/gdm/autostart/LoginWindow/gnome-power-manager.desktop
com o seguinte conteudo(ja modificado)
Citar
[Desktop Entry]
Name=Power Manager
Comment=Power management daemon
Icon=gnome-power-manager
Exec=gnome-power-manager
Terminal=false
Type=Application
Categories=
OnlyShowIn=GNOME;XFCE;
X-GNOME-Bugzilla-Bugzilla=GNOME
X-GNOME-Bugzilla-Product=gnome-power-manager
X-GNOME-Bugzilla-Component=gnome-power-manager
X-GNOME-Bugzilla-Version=@VERSION@
X-GNOME-Bugzilla-ExtraInfoScript=gnome-power-bugreport.sh
X-GNOME-AutoRestart=true
#edit line
X-GNOME-Autostart-enabled=true




X-Ubuntu-Gettext-Domain=gdm
e tambem editei um outro arquivo em
Citar
/etc/xdg/autostart/gnome-power-manager.desktop
no entanto depois de testes vi que esse nao foi o causador do resultado......

fiz essas mudanças e o aviso de que o gerenciador de energia nao tinha sido instalado nao apareceu mais, no entanto continua nao logando na conta de usuario.....quando entra naquela tela de loading, a tela da uma piscada e volta a tela de login, a vezes pisca mais de uma vez......se alguem tiver mais alguma sugestao......desde ja agradeço......

Offline coruja

  • Usuário Ubuntu
  • *
  • Mensagens: 96
  • O impossível é a medida da capacidade de cada um.
    • Ver perfil
Re: Problema com gerenciador de energia do gnome
« Resposta #4 Online: 23 de Janeiro de 2010, 04:40 »
Tente criar um outro usuário, se der certo, copie os seus arquivos (documento, fotos, musicas, etc) que estão no diretório home do usuário que não loga para o usuário novo.

Espero que funcione.

Offline Hqxriven

  • Usuário Ubuntu
  • *
  • Mensagens: 1.456
    • Ver perfil
Re: Problema com gerenciador de energia do gnome
« Resposta #5 Online: 23 de Janeiro de 2010, 05:01 »
Vc por acaso não atualizou o kernel e por causa disso o driver de vídeo deixou de funcionar???
Sem distro Linux fixa - Kernel Omnislash
Meu objetivo nesse fórum é ajudar. Sou um mero humano mas desejo sempre aprender e melhorar em tudo o que faço em minha vida. Então, por favor, quando eu postar me notifique depois

Offline rato la

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Problema com gerenciador de energia do gnome
« Resposta #6 Online: 24 de Janeiro de 2010, 00:55 »
fiz algumas tentativas e consegui abrir a janela de aplicativos de sessao como usuario......loguei no modo de segurança, ai fiz login como usuario, tentei rodar o x com startx e retornou erros, dai dei um
Citar
sudo startx
e funcionou, dai vi que o chrome tava com o tema que eu usava na conta do usuario, ai entao abri um terminal (loguei como usuario) e rodei o comando da janela aplicativos de sessao e abriu( o que nao acontecia antes, dava erros) dai fui e marquei tudo o que havia desmarcado....reiniciei todo alegre......no entanto....nada!!!! continua a mesma coisa, fiz um novo usuario e nada......nao loga tambem....aparece a tela de load, ela pisca, volta e depois volta a tela de login........pensei em pegar os erros que o startx gera, no entanto
Citar
startx > erros.txt
nao funciona...alguem tem alguma sugestao para pegas esses erros, eles nao ficam nos arquivos de log, ja procurei mais nao acho......

p.s.:ta tudo bagunçado desse jeito que eu consegui logar.....parece que misturou o perfil da conta do usuario com a conta root....estranho.....


Hqxriven....houve uma atualizaçao de kernel quando atualizei o sistema, mais isso ja faz algum tempo, e eu ja ate deletei as outras entradas dos outros kerneis antigos...porem isso me vem uma duvida, o sistema ja vem a alguns dias pedindo pra ser atualizado, porem uso internet 3g da claro e no começo do mes ela fica bem rapida, estava esperando isso pra atualizar, sera que tem alguma coisa a ver com isso....no mais, obrigado pela ajuda.....

Offline rato la

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Problema com gerenciador de energia do gnome
« Resposta #7 Online: 24 de Janeiro de 2010, 01:50 »
acho que minha odisseia acabou....

continuei fuçando...vai daqui vai dali, loga de um jeito loga de outro.....

fui la e apaguei o que eu tinha editado.....encerei a sessao e apareceu o tal aviso dinovo(o do começo), dai rebootei dinovo e entrei em modo de segurança, loguei como usuario, dei um sudo starx  e fui ver no menu se tinha desmarcado o gerenciador de energia, nao tinha....encerrei sessao dinovo, e tentei um startx....voilá!!!!! funcionou......loguei como usuario, o desktop, tudo normal, compiz funcionando, tudo redondo......rebootei dinovo e pronto, estou aqui escrevendo isso......fui olhar o arquivo que eu editei e ele nao foi mudado pelo sistema, continua sem a linha.....rodei o comando sugerido pelo sistematico no começo, mais nada, nao encontrei nada.......nao sei ao certo o que fiz que solucionou o problema, mais sei que foi causado pelo meu excesso de mexida........fica dica....nao mexa onde nao devem....

muito obrigado a todos que me ajudaram aqui..........

Offline coruja

  • Usuário Ubuntu
  • *
  • Mensagens: 96
  • O impossível é a medida da capacidade de cada um.
    • Ver perfil
Re: Problema com gerenciador de energia do gnome
« Resposta #8 Online: 24 de Janeiro de 2010, 02:19 »
Fico feliz por você, coloca um resolvido no titulo do tópico.

um abraço.

Offline timtonys

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: [Resolvido]Problema com gerenciador de energia do gnome
« Resposta #9 Online: 01 de Julho de 2010, 21:19 »
Olá,

Encontrei em dois fóruns a solução para esse erro. Aparentemente trata-se de partição de dados do Ubuntu cheia (Sem espaço livre). A solução é logar no terminal (CTRL + ALT + F1 na tela de logon >> Loga com seu usuário e senha e apaga dados desnecessários >> Reinicia o Ubuntu)

Só achei estranho a mensagem de erro! Nada a ver!

Seguem links para Soluções:

http://www.absolutelytech.com/2010/04/13/solved-unable-to-boot-due-to-gnome-power-manager-error/
http://under-linux.org/f140/ubuntu-10-04-erro-no-login-do-modo-grafico-gerenciador-de-energia-do-gnome-138778/index2.html

Espero ter ajudado,

TIM

Offline FAFUREMUSZKA

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: [Resolvido]Problema com gerenciador de energia do gnome
« Resposta #10 Online: 19 de Novembro de 2011, 19:21 »
Ola eu sou novo com as plataformas linux e to gostando muito mais na ultima sexta feira eu estava atualizando meu ubuntu 10.04 para o 11 e acabou a luz e quando religuei a o laptop o ubuntu não deu um erro `Os padrões de configurações para o gerenciador de energia do gnome não foram instalados corretamente. Por favor entre em contato com o administrador do computador`li alguns tópicos de apertar ctrl alt f1 e não esta rolando ele travou o teclado quando liguei um teclado externo consigo entrar no modo texto mais não consigo digitar nada, no desespero tentei instalar o ubuntu 10.04 de novo mais ele instalou lado a lado e agora tenho na mesma maquina 2 ubuntu e um windows e no caso do segundo ubuntu ele ta com pouca memoria para eu passar os arquivos do outro para o novo.
gostaria de saber se tem alguma maneira de restaurar o ubuntu 10.10 que estava sendo atualizado para o 11 ou se tem alguma maneira de instalar o ubuntu em cima do outro de maneira que ele substitua a outra versão.
por favor ajude me que ta sinistro.

Offline rato la

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: [Resolvido]Problema com gerenciador de energia do gnome
« Resposta #11 Online: 20 de Novembro de 2011, 12:58 »
 FAFUREMUSZKA provavelmente tem uma solução para seu problema, mas posso lhe dar uma ideia não muito elegante para resolver isso, que seria em rodar um linux em live, seja ubuntu 10.10, 10.04.. copiar seus arquivos dessas duas partições linux, rodar a instalação do 10.11, quando ele der as opções de instalação nas partições, entrar em avançado, e no gparted, excluir as partições linux(nesse momento, tenha certeza do que esta fazendo, um passo em falso aqui e seus arquivos serão apagados) e criar uma nova partição para receber o 10.11, instalar ele, rezar pra que a energia não acabe no meio disso e pronto.

porem, algum usuário mais experiente que eu pode te dar uma solução melhor que essa, sem formatar nada....



Offline FAFUREMUSZKA

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: [Resolvido]Problema com gerenciador de energia do gnome
« Resposta #12 Online: 20 de Novembro de 2011, 20:39 »
eu to pensando seriamente em fazer um backup de tudo pelo ubuntu que instalei e formata a maquina toda e re instalar tudo de novo, mais ainda tenho esperanças de conseguir recuperar o bendito.

Offline rato la

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: [Resolvido]Problema com gerenciador de energia do gnome
« Resposta #13 Online: 20 de Novembro de 2011, 23:17 »
bom, para resolver isso sem formatar nada, a primeira coisa é entender porque seu teclado nao ta funfando, esse teclado externo que vc arrumou, porque ele tambem nao ta funcionando....eles nao digitam nada??.....bom.....resolver isso primeiro, depois, ctrl+alt+f1, logar e digitar "sudo dpkg --configure -a" pra ele continuar a instalaçao, caso nao de certo, mande um startx e cole os erros aqui....

Offline FAFUREMUSZKA

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: [Resolvido]Problema com gerenciador de energia do gnome
« Resposta #14 Online: 21 de Novembro de 2011, 13:46 »
o teclado do laptop trava totalmente, ja o externo ele funciona so o crtl + alt +f1, crtl + alt +f7, crtl + alt +f8 e o crtl + alt +del para sair, na tela de texto fica o cursor pequeno piscando.