Autor Tópico: Alguém explica melhor esses sistemas de som ????  (Lida 29448 vezes)

Offline enceladus

  • Usuário Ubuntu
  • *
  • Mensagens: 107
    • Ver perfil
Re: Funcionou! ou quase...
« Resposta #45 Online: 02 de Dezembro de 2005, 18:07 »
Citação de: "Perícope"
Segui as dicas, e, no teste, havia som (que surpresa desagradável ter o mesmo sonzinho do rwindows  :? ), mas no Totem, Rhythmbox, gxine e no MPlayer, não, bem como continuam mudos os vídeos da internet (no jornal do Terra, nem os vídeos são reproduzidos). Testei com os joguinhos online do Terra, também tudo mudo



Olha, esquece o Totem, o Rhythmbox e o MPlayer. Abra o gxine e nas preferências, seleciona a aba audio e selecione o mesmo driver que está no xmms (deve ser o ALSA, certo?). Feche o programa e reabra. Beleza?
Tô no trabalho, faz isso aí e depois me conta. O KDE tem algumas vantagens sobre o Gnome, é mais completo, o próprio Mark Shuttleworth usa o Kubuntu, vá devagar, vc. vai conseguir, já que tem som no Teste do Centro de Controle, certo? (é lá que vc. testou, não?)

Saúde
Nevermore! Nevermore! - Poe

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Re: Funcionou! ou quase...
« Resposta #46 Online: 03 de Dezembro de 2005, 11:37 »
Citação de: "enceladus"
Olha, esquece o Totem, o Rhythmbox e o MPlayer. Abra o gxine e nas preferências, seleciona a aba audio e selecione o mesmo driver que está no xmms (deve ser o ALSA, certo?). Feche o programa e reabra. Beleza?


neca! :x

no gnome, tudo mudo, com exceção do xmms. ainda não testei no KDE.

desculpe a encasquetação, mas
1. como pode haver som em um programa e não em outro?
2. idem em um ambiente gráfico e não em outro?
3. por que o Ubuntu tem de ser complicado com esse negócio de som?

Citar
Tô no trabalho, faz isso aí e depois me conta. O KDE tem algumas vantagens sobre o Gnome, é mais completo, o próprio Mark Shuttleworth usa o Kubuntu, vá devagar, vc. vai conseguir, já que tem som no Teste do Centro de Controle, certo? (é lá que vc. testou, não?)


ê dureza! eu gostei mais do gnome... mas vou testar o KDE.

mas será que só eu tenho problema de som no gnome?  :cry:
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Alguém explica melhor esses sistemas de som ????
« Resposta #47 Online: 03 de Dezembro de 2005, 17:09 »
no kde também não funcionou. tem som no início do sistema, mas neca de som no gxine, só no xmms.  :x
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

Offline enceladus

  • Usuário Ubuntu
  • *
  • Mensagens: 107
    • Ver perfil
Alguém explica melhor esses sistemas de som ????
« Resposta #48 Online: 04 de Dezembro de 2005, 14:36 »
Citação de: "Perícope"
no kde também não funcionou. tem som no início do sistema, mas neca de som no gxine, só no xmms.  :x


Perícope,
vamos por partes, como diria o esquartejador:
1 - me corrija se estou errado: revendo esse à essa altura enoooooooooooooorme post, reparei que vc. tem dois sons, certo? Um veio com o micro, mas as caixinhas eram pequenininhas, então vc. não usa elas. Então vc. quer usar o outro (talvez o Ensonique PCI), ligado ao micro pela porta USB ou por pelos meios convencionais. E é aí que o bicho pega, vc. não tem nada.
Mas se a coisa for assim mesmo, VC NA VERDADE TEM SOM MAS NÃO SABE!!!! Experimenta ligar as caixinhas pequenininhas ou um microfone no micro e rode um desses jogos aí e me diga: funcionou?
Depois me conta e continuamos o esquartejamento...

PS - Andradas (extremo sul de Minas) a BH : + de 600km > eta cafezinho difícil!!!

Saúde
Nevermore! Nevermore! - Poe

Offline enceladus

  • Usuário Ubuntu
  • *
  • Mensagens: 107
    • Ver perfil
Alguém explica melhor esses sistemas de som ????
« Resposta #49 Online: 04 de Dezembro de 2005, 16:44 »
Perícope,

Independentemente do que escrevi acima, faça o seguinte no KDE:

1 - Olha prá extrema direita, embaixo, perto do relógio: tem mu alto-falante? Se não tiver, vamos colocar o KMix aÍ: clique com o botão direito na barra de menus e clique em Adicionar aplicativo ao paianel, depois clique em Multimídia > KMix
2 - Agora, clica com o botão direito no alto-falante e em Mostar janela do mixer. Vê se em Current mixer tem seus dois sons, o Ensonique e o outro 82...alguma-coisa (tem uma setinha do lado direito, clica nela prá ver tudo). Deixa no que vc. quer (não que isso vá fazer muita diferença, mas...)
3 - Abre o XMMS > Opções > Preferências, se não estiver escolha o ALSA e clique em Configurar.
4 -  Em Dispositivo de Audio escolha aquele correspondente àquele cujo som vc. quer que seja o padrão (por exemplo, o Ensonique)
5 - Anote num papel qualquer o nome do dispositivo (ex: hw:1,0); se teve de mudar alguma coisa, clique em OK e depois em Aplicar, fecha e reabra o xmms e vê se continua com som
6 - Agora vá no KMenu e clique em Configuraçãoes do Sistema; em Personal clique em Som&Multimidia
7 - Clique em Sistema de Som, do lado esquerdo
8 - Do lado direito estarão duas abas: General e Hardware; clique em Hardware
9 - Em Select the audio device, deixe em Advanced Linux Sound Architeture (isto é, ALSA)
10 - Selecione Override Device location e na caixa à direita escreva o mixer que vc. anotou no papel que te falei (aquele hw:1,0 ou hw:0,0 ou hw:0,1 etc, que vc. encontrou no XMMS
11 - Clique em Apply (lá embaixo, à direita)
12 - Agora, clique na aba General e selecione a opção Enable the sound system, se ainda não estiver selecionada
13 - Logo embaixo, em Auto-Suspend, selecione auto-suspend if idle after e diminua o valor para 0 (zero), deve estar 60 seconds
14 - Clique em Apply
15 - Clique em Test Sound. Beleza?
16 - Feche tudo

Se não funcionar, me suicido-me!!!!
Aproveita e teste os outros programas multimídia que vêm junto com o KDE, o Amarok é legal, mas tem um lugar lá onde vc. precisa digitar também o driver (não sei onde é porque não uso ele). E por falar nisso, aqui o xmms funciona com o Arts, não com o ALSA. Assim, se vc. não tiver som, muda pro Arts (acho que vc. vai ter de instalar os pacotes correspondentes pois acho que não estão instalados. É só instalar os pacotes arts, artsbuilder e xmms-arts, que é o plugin).
Instale também o xine (eu sei que vc. tem o gxine, mas instale o xine). Abra ele, clica com o botão direto, vá em Settings > Setup, em Configuration experience level passe para Advanced e na aba Audio, em driver de selecione o driver que vc. usa no xmms, isto é, alsa ou arts (o que tiver dado certo lá).
Acho que vc. já pegou o espírito da coisa.
Aproveite e atualize o KDE prá versão 3.5, que saiu esta semana:

      sudo wget http://people.ubuntu.com/~jriddell/kubuntu-packages-jriddell-key.gpg
      sudo apt-key add kubuntu-packages-jriddell-key.gpg
      sudo kedit /etc/apt/sources.list (inclua a linha abaixo no final, salve e feche o kedit)
      deb http://kubuntu.org/packages/kde35 breezy main
      sudo apt-get update
      sudo apt-get dist-upgrade


Saúde
Nevermore! Nevermore! - Poe

Offline cyberideias

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
    • http://www.cyberideias.com.br
Alguém explica melhor esses sistemas de som ????
« Resposta #50 Online: 05 de Dezembro de 2005, 00:40 »
boa noite pessoal.

resolvi instalar o kubuntu em outro micro que tenho aki para dar uma olhada.

bem, achei ele muito bom, o kde parece ser mais organizado que o gnome, da acesso mais fácil a algumas configurações avançadas, parece ser mais rápido e ainda é mais bonito.

bem, o único problema é que para variar - vejam tenho 3 micros e to com o mesmo problema nos 3, o som dah algum erro.

agora aparentemente tudo funciona, se colocar um Cd ele toca novalmente, tocou MP3, o Kaffeine toca aparentemente tudo, só não funcionam os sons de eventos no Kopete, Gaim ou Mercury... (para variar)

já segui todos os passos descritos pelo enceladus.

alguma alma caridosa e iluminada sabe porque somente os sons dos mensengers não são tocados?

abraços
Não entendo nada de Linux, e dai? Quem precisa para poder usar o Ubuntu?!?!

Offline cyberideias

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
    • http://www.cyberideias.com.br
sons simultâneos com ALSA
« Resposta #51 Online: 05 de Dezembro de 2005, 00:45 »
ah, os feras ai por favor me expliquem se isso aqui é valido...

dando uma furungada na internet encontrei este site explicando que é possível sim que através do ALSA se tenham eventos de som simultâneos. não testei ainda... assim que fizer digo o resultado.

quem quiser já vai testando: http://movabletripe.com/archive/simultaneous-sound-streams-with-alsa/
Não entendo nada de Linux, e dai? Quem precisa para poder usar o Ubuntu?!?!

Offline cyberideias

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
    • http://www.cyberideias.com.br
deve ser magia negra ou voodooo!
« Resposta #52 Online: 05 de Dezembro de 2005, 00:56 »
bem, do nada, pois nao fiz nada, aboslutamente nada, o kopete passou a emitir os avisos de chegada de mensagens. porém para ficar mais entranho ainda, afinal se no kopete funciona no Gaim deveria funcionar tbém (presumo isso cá com a minha ingorância), o Gaim não emite som algum. Fecho o Gaim e abro o Kopete e tenho som. Fecho o kopete e abro o gaim e nada.

abro a janela e cogito pular ou ainda restam esperanças?
Não entendo nada de Linux, e dai? Quem precisa para poder usar o Ubuntu?!?!

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Alguém explica melhor esses sistemas de som ????
« Resposta #53 Online: 05 de Dezembro de 2005, 14:30 »
prezado enceladus, vamos à próxima rodada de esquartejamento:

Citar
corrija se estou errado: revendo esse à essa altura enoooooooooooooorme post, reparei que vc. tem dois sons, certo? Um veio com o micro, mas as caixinhas eram pequenininhas, então vc. não usa elas. Então vc. quer usar o outro (talvez o Ensonique PCI), ligado ao micro pela porta USB ou por pelos meios convencionais. E é aí que o bicho pega, vc. não tem nada.
Mas se a coisa for assim mesmo, VC NA VERDADE TEM SOM MAS NÃO SABE!!!! Experimenta ligar as caixinhas pequenininhas ou um microfone no micro e rode um desses jogos aí e me diga: funcionou?


Não funcionou.
O som onboard, até onde sei, está desabilitado. Tanto no Kurumin quanto no rwindows sempre usei a outra placa, off-board, que estou tentando usar agora. É a placa em que o xmms funciona.

Citar
PS - Andradas (extremo sul de Minas) a BH : + de 600km > eta cafezinho difícil!!!


Qué isso, cumpadre?! Má vontade sua...  :wink:  :lol:

Vamos ao próximo capítulo.

Paz e bem!
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
Alguém explica melhor esses sistemas de som ????
« Resposta #54 Online: 05 de Dezembro de 2005, 14:42 »
Citação de: "enceladus"
16 - Feche tudo

Fiz, tudo; algumas orientações você já havia dado em mensagem anterior, mas nada mudou. Ou melhor, agora o pouco som que eu tinha sumiu. No Kmix, em que a placa escolhida era VIA alguma coisa, enquanto no xmms era Ensoniq, eu alterei e o som sumiu. Voltei para a VIA, mas continua sem som. Agora, o Xmms dá a nota: Por favor, verifique se: Sua placa de som está cofigurada corretamente Você selecionou o plugin de saída correto Nenhum outro programa está bloqueando a placa de som
Como explicar que o negócio só funciona se estiver com configurações diferentes em lugares diferentes e se colocar tudo igual... emudece? E se se volta para o estado anterior não volta a funcionar?

Citar
Se não funcionar, me suicido-me!!!!


Não faça isso! Dá muita dor de cabeça...

Citar
Aproveita e teste os outros programas multimídia que vêm junto com o KDE, o Amarok é legal, mas tem um lugar lá onde vc. precisa digitar também o driver (não sei onde é porque não uso ele). E por falar nisso, aqui o xmms funciona com o Arts, não com o ALSA. Assim, se vc. não tiver som, muda pro Arts (acho que vc. vai ter de instalar os pacotes correspondentes pois acho que não estão instalados. É só instalar os pacotes arts, artsbuilder e xmms-arts, que é o plugin).


Se entendi direito disso tudo que não entendi, tenho de ir testando as diferentes combinações, até alguma coisa, lógica ou não, dar certo. É isso? :wink:

Citar
Instale também o xine (eu sei que vc. tem o gxine, mas instale o xine). Abra ele, clica com o botão direto, vá em Settings > Setup, em Configuration experience level passe para Advanced e na aba Audio, em driver de selecione o driver que vc. usa no xmms, isto é, alsa ou arts (o que tiver dado certo lá).


Esse é o mais mal-educado de todos: é só eu escolher o arquivo... e ele fecha sozinho!

Citar
Acho que vc. já pegou o espírito da coisa.


Sim: sai do Gnome, vai pro KDE, abre, fuça, fecha, testa, frustra-se, abre de novo, abre outro, fuça, muda, iguala, desiguala, tenta, aperta, recomeça, desiste, recomeça... e por aí vai! :wink:

Citar
Aproveite e atualize o KDE prá versão 3.5, que saiu esta semana:


Jä fi-lo. Mas eu prefiro o Gnome, respeitando a opinião do cyberideas.

No fórum americano do Ubuntu, encontrei algumas dicas também. Impressiona-me a quantidade de pessoas com problema com som, o fato de isso ser resolvido sem dificuldades no rwindows, o grande número de diferentes dicas... Numa destas mensagens, alguém pediu o resultado de uma série de comandos: lsmod | grep snd, /etc/modprobe.d/alsa-base, lsof /dev/snd/*, lsof /dev/dsp, lspci. Ajuda se eu postar os resultados aqui?

E agora, hummm, o dedão do pé...

Paz e bem!
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

Offline enceladus

  • Usuário Ubuntu
  • *
  • Mensagens: 107
    • Ver perfil
Alguém explica melhor esses sistemas de som ????
« Resposta #55 Online: 05 de Dezembro de 2005, 20:52 »
Perícope,

infelizmente cheguei ao fim de meus conhecimentos.
não posso mais te ajudar.
tudo que relatei prá vc. eu fiz aqui em casa e funcionou perfeitamente com o Ubuntu e com o Kubuntu 5.10 (Breezy). Não sei porque com vc. não dá. Mas isso é assim mesmo. O Kurumin 5.0, que saiu na PC Master e não era 5.0 nada, era só a versão 4.2 com umas otimizações, funcionou beleza aqui, mas a versão 5.0 final, que peguei no site do Guia do Hardware nem reconheceu minha placa off-board e nem deu som na on-board. Já o Kanotix, que é legal pacas, sempre reconhece minha off-board e apenas às vezes reconhece a on-board.
Como vc. vê, é complicado, mas eu ainda cho que vc. vai conseguir. Só o fato de suas placas terem sido reconhecidas pelo Ubuntu já é indicativo disto. Aquela mensagem que o xmms deu, pedindo prá vc. verificar se estava com o driver correto etc, é porque vc. mudou de alsa prá arts ou prá outra coisa qualquer, isso é normal, é só voltar para o que funcionaca antes.
Eu ainda acho que funciona no Kubuntu do jeito que te falei, aquele é o jeito clássico de ter som no KDE. Faça uma última tentativa: ao invés disso:
9 - Em Select the audio device, deixe em Advanced Linux Sound Architeture (isto é, ALSA) ,
deixe em auto-detectar
Veja também se o KMIx não tá mudo ou se o PCM não tá mudo. O PCM sempre fica habilitado por default, é só desabilitá-lo, clica naquela bolinha que fica acima dele, seja curioso, faça experiências, seu micro não vai quebrar por isso.
Vai tentando aí e quando vc. conseguir, me manda um post.
Quanto a gostar mais do Gnome que do KDE, isso até eu gosto, mas isso não é motivo prá abandonar o KDE, vá estudando ele, que ele tem muitas alegrias prá te dar, inclusive essa coisa de som nele é mais fácil. Dá uma olhada no forum do kurumin e, se vc. se virar no inglês, no forum do Kanotix, nesses lugares tem muita dica sobre som. Não desista. Tudo que aprendi foi pesquisando nesses forums por aí, até nos do Slackware e Fedora (que tem muito mais dificuldade que o (K)Ubuntu em matéria de som) e estudando sozinho.
Fico triste por não ter resolvido seu problema, but such is life...

Saúde
Nevermore! Nevermore! - Poe

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.285
    • Ver perfil
Re: deve ser magia negra ou voodooo!
« Resposta #56 Online: 05 de Dezembro de 2005, 21:55 »
Citação de: "cyberideias"
bem, do nada, pois nao fiz nada, aboslutamente nada, o kopete passou a emitir os avisos de chegada de mensagens. porém para ficar mais entranho ainda, afinal se no kopete funciona no Gaim deveria funcionar tbém (presumo isso cá com a minha ingorância), o Gaim não emite som algum. Fecho o Gaim e abro o Kopete e tenho som. Fecho o kopete e abro o gaim e nada.

abro a janela e cogito pular ou ainda restam esperanças?


Já experimentou modificar o método para tocar sons do gaim ?
fica nas preferências, se vc está usando o KDE tente utilizar ARTS.

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
e a luta continua...
« Resposta #57 Online: 08 de Dezembro de 2005, 12:58 »
enceladus, grato por toda a ajuda. vou continuar fuçando por aí até fazer essa encrenca  :evil:  ter som em todo o sistema e em todos os programas.

pesquisei no fórum americano, e lá há mais trocentas e quarenta dicas. é um tanto de trem para tentar que nem sei por onde continuar... mas vou continuar.

aqui no fórum, numa dica do xterminator, e lá nos gringos, foram pedidos os resultados de alguns comandos. a lista ficou enorme, mas será que ela pode ajudar vocês a me ajudarem? será que no meio dessas informações não está a solução para mim?  :?  :?:

aí estão:

lsmod | grep snd
snd_usb_audio          68160  2
snd_usb_lib            13824  1 snd_usb_audio
snd_hwdep               8608  1 snd_usb_audio
snd_ens1371            22240  4
snd_via82xx            25792  2
gameport               14472  2 snd_ens1371,snd_via82xx
snd_ac97_codec         72188  2 snd_ens1371,snd_via82xx
snd_pcm_oss            46368  0
snd_mixer_oss          16128  4 snd_pcm_oss
snd_pcm                78344  6 snd_usb_audio,snd_ens1371,snd_via82xx,snd_ac97_c                    odec,snd_pcm_oss
snd_page_alloc         10120  2 snd_via82xx,snd_pcm
snd_mpu401_uart         6784  1 snd_via82xx
snd_seq_dummy           3844  0
snd_seq_oss            29440  0
snd_seq_midi            8608  0
snd_rawmidi            22816  4 snd_usb_lib,snd_ens1371,snd_mpu401_uart,snd_seq_                    midi
snd_seq_midi_event      6656  2 snd_seq_oss,snd_seq_midi
snd_seq                44688  7 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_m                    idi_event
snd_timer              21764  2 snd_pcm,snd_seq
snd_seq_device          8204  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmi                    di,snd_seq
snd                    48644  24 snd_usb_audio,snd_hwdep,snd_ens1371,snd_via82xx                    ,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_mpu401_uart,snd_seq_oss,sn                    d_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               9184  4 snd
usbcore               104316  4 snd_usb_audio,snd_usb_lib,uhci_hcd

/etc/modprobe.d/alsa-base
# autoloader aliases
install sound-slot-0 modprobe snd-card-0
install sound-slot-1 modprobe snd-card-1
install sound-slot-2 modprobe snd-card-2
install sound-slot-3 modprobe snd-card-3
install sound-slot-4 modprobe snd-card-4
install sound-slot-5 modprobe snd-card-5
install sound-slot-6 modprobe snd-card-6
install sound-slot-7 modprobe snd-card-7
# Load optional modules above their base modules
install snd modprobe --ignore-install snd && { modprobe --quiet snd-ioctl32 ; : ; }
install snd-pcm modprobe --ignore-install snd-pcm && { modprobe --quiet snd-pcm-oss ; : ; }
install snd-mixer modprobe --ignore-install snd-mixer && { modprobe --quiet snd-mixer-oss ; : ; }
install snd-seq modprobe --ignore-install snd-seq && { modprobe --quiet snd-seq-midi ; modprobe --quiet snd-seq-oss ; : ; }
install snd-emu10k1 modprobe --ignore-install snd-emu10k1 && { /lib/alsa/modprobe-post-install snd-emu10k1 ; modprobe --quiet snd-emu10k1-synth ; }
install snd-via82xx modprobe --ignore-install snd-via82xx && { /lib/alsa/modprobe-post-install snd-via82xx ; modprobe --quiet snd-seq ; }
# Cause a script to be run after *-synth module initialization
install snd-emu8000-synth modprobe --ignore-install snd-emu8000-synth && /lib/alsa/modprobe-post-install snd-emu8000-synth
install snd-emu10k1-synth modprobe --ignore-install snd-emu10k1-synth && /lib/alsa/modprobe-post-install snd-emu10k1-synth
# Cause a script to be run after card driver module initialization
install snd-ad1816a modprobe --ignore-install snd-ad1816a && /lib/alsa/modprobe-post-install snd-ad1816a
install snd-ad1848 modprobe --ignore-install snd-ad1848 && /lib/alsa/modprobe-post-install snd-ad1848
install snd-ali5451 modprobe --ignore-install snd-ali5451 && /lib/alsa/modprobe-post-install snd-ali5451
install snd-als100 modprobe --ignore-install snd-als100 && /lib/alsa/modprobe-post-install snd-als100
install snd-als4000 modprobe --ignore-install snd-als4000 && /lib/alsa/modprobe-post-install snd-als4000
install snd-armaaci modprobe --ignore-install snd-armaaci && /lib/alsa/modprobe-post-install snd-armaaci
install snd-asihpi modprobe --ignore-install snd-asihpi && /lib/alsa/modprobe-post-install snd-asihpi
install snd-atiixp modprobe --ignore-install snd-atiixp && /lib/alsa/modprobe-post-install snd-atiixp
install snd-au1x00 modprobe --ignore-install snd-au1x00 && /lib/alsa/modprobe-post-install snd-au1x00
install snd-au8810 modprobe --ignore-install snd-au8810 && /lib/alsa/modprobe-post-install snd-au8810
install snd-au8820 modprobe --ignore-install snd-au8820 && /lib/alsa/modprobe-post-install snd-au8820
install snd-au8830 modprobe --ignore-install snd-au8830 && /lib/alsa/modprobe-post-install snd-au8830
install snd-azt2320 modprobe --ignore-install snd-azt2320 && /lib/alsa/modprobe-post-install snd-azt2320
install snd-azt3328 modprobe --ignore-install snd-azt3328 && /lib/alsa/modprobe-post-install snd-azt3328
install snd-ca0106 modprobe --ignore-install snd-ca0106 && /lib/alsa/modprobe-post-install snd-ca0106
install snd-cmi8330 modprobe --ignore-install snd-cmi8330 && /lib/alsa/modprobe-post-install snd-cmi8330
install snd-cmipci modprobe --ignore-install snd-cmipci && /lib/alsa/modprobe-post-install snd-cmipci
install snd-cs4231 modprobe --ignore-install snd-cs4231 && /lib/alsa/modprobe-post-install snd-cs4231
install snd-cs4232 modprobe --ignore-install snd-cs4232 && /lib/alsa/modprobe-post-install snd-cs4232
install snd-cs4236 modprobe --ignore-install snd-cs4236 && /lib/alsa/modprobe-post-install snd-cs4236
install snd-cs4281 modprobe --ignore-install snd-cs4281 && /lib/alsa/modprobe-post-install snd-cs4281
install snd-cs46xx modprobe --ignore-install snd-cs46xx && /lib/alsa/modprobe-post-install snd-cs46xx
install snd-darla20 modprobe --ignore-install snd-darla20 && /lib/alsa/modprobe-post-install snd-darla20
install snd-darla24 modprobe --ignore-install snd-darla24 && /lib/alsa/modprobe-post-install snd-darla24
install snd-dt019x modprobe --ignore-install snd-dt019x && /lib/alsa/modprobe-post-install snd-dt019x
install snd-echo3g modprobe --ignore-install snd-echo3g && /lib/alsa/modprobe-post-install snd-echo3g
install snd-emu10k1x modprobe --ignore-install snd-emu10k1x && /lib/alsa/modprobe-post-install snd-emu10k1x
install snd-ens1370 modprobe --ignore-install snd-ens1370 && /lib/alsa/modprobe-post-install snd-ens1370
install snd-ens1371 modprobe --ignore-install snd-ens1371 && /lib/alsa/modprobe-post-install snd-ens1371
install snd-es1688 modprobe --ignore-install snd-es1688 && /lib/alsa/modprobe-post-install snd-es1688
install snd-es18xx modprobe --ignore-install snd-es18xx && /lib/alsa/modprobe-post-install snd-es18xx
install snd-es1938 modprobe --ignore-install snd-es1938 && /lib/alsa/modprobe-post-install snd-es1938
install snd-es1968 modprobe --ignore-install snd-es1968 && /lib/alsa/modprobe-post-install snd-es1968
install snd-es968 modprobe --ignore-install snd-es968 && /lib/alsa/modprobe-post-install snd-es968
install snd-fm801 modprobe --ignore-install snd-fm801 && /lib/alsa/modprobe-post-install snd-fm801
install snd-fm801-tea575x modprobe --ignore-install snd-fm801-tea575x && /lib/alsa/modprobe-post-install snd-fm801-tea575x
install snd-gina20 modprobe --ignore-install snd-gina20 && /lib/alsa/modprobe-post-install snd-gina20
install snd-gina24 modprobe --ignore-install snd-gina24 && /lib/alsa/modprobe-post-install snd-gina24
install snd-gusclassic modprobe --ignore-install snd-gusclassic && /lib/alsa/modprobe-post-install snd-gusclassic
install snd-gusextreme modprobe --ignore-install snd-gusextreme && /lib/alsa/modprobe-post-install snd-gusextreme
install snd-gusmax modprobe --ignore-install snd-gusmax && /lib/alsa/modprobe-post-install snd-gusmax
install snd-harmony modprobe --ignore-install snd-harmony && /lib/alsa/modprobe-post-install snd-harmony
install snd-hda-intel modprobe --ignore-install snd-hda-intel && /lib/alsa/modprobe-post-install snd-hda-intel
install snd-hdsp modprobe --ignore-install snd-hdsp && /lib/alsa/modprobe-post-install snd-hdsp
install snd-hdspm modprobe --ignore-install snd-hdspm && /lib/alsa/modprobe-post-install snd-hdspm
install snd-ice1712 modprobe --ignore-install snd-ice1712 && /lib/alsa/modprobe-post-install snd-ice1712
install snd-ice1724 modprobe --ignore-install snd-ice1724 && /lib/alsa/modprobe-post-install snd-ice1724
install snd-indigo modprobe --ignore-install snd-indigo && /lib/alsa/modprobe-post-install snd-indigo
install snd-indigodj modprobe --ignore-install snd-indigodj && /lib/alsa/modprobe-post-install snd-indigodj
install snd-indigoio modprobe --ignore-install snd-indigoio && /lib/alsa/modprobe-post-install snd-indigoio
install snd-intel8x0 modprobe --ignore-install snd-intel8x0 && /lib/alsa/modprobe-post-install snd-intel8x0
install snd-interwave modprobe --ignore-install snd-interwave && /lib/alsa/modprobe-post-install snd-interwave
install snd-interwave-stb modprobe --ignore-install snd-interwave-stb && /lib/alsa/modprobe-post-install snd-interwave-stb
install snd-korg1212 modprobe --ignore-install snd-korg1212 && /lib/alsa/modprobe-post-install snd-korg1212
install snd-layla20 modprobe --ignore-install snd-layla20 && /lib/alsa/modprobe-post-install snd-layla20
install snd-layla24 modprobe --ignore-install snd-layla24 && /lib/alsa/modprobe-post-install snd-layla24
install snd-maestro3 modprobe --ignore-install snd-maestro3 && /lib/alsa/modprobe-post-install snd-maestro3
install snd-mia modprobe --ignore-install snd-mia && /lib/alsa/modprobe-post-install snd-mia
install snd-miro modprobe --ignore-install snd-miro && /lib/alsa/modprobe-post-install snd-miro
install snd-mixart modprobe --ignore-install snd-mixart && /lib/alsa/modprobe-post-install snd-mixart
install snd-mona modprobe --ignore-install snd-mona && /lib/alsa/modprobe-post-install snd-mona
install snd-mpu401 modprobe --ignore-install snd-mpu401 && /lib/alsa/modprobe-post-install snd-mpu401
install snd-msnd-pinnacle modprobe --ignore-install snd-msnd-pinnacle && /lib/alsa/modprobe-post-install snd-msnd-pinnacle
install snd-mtpav modprobe --ignore-install snd-mtpav && /lib/alsa/modprobe-post-install snd-mtpav
install snd-nm256 modprobe --ignore-install snd-nm256 && /lib/alsa/modprobe-post-install snd-nm256
install snd-opl3sa2 modprobe --ignore-install snd-opl3sa2 && /lib/alsa/modprobe-post-install snd-opl3sa2
install snd-opti92x-ad1848 modprobe --ignore-install snd-opti92x-ad1848 && /lib/alsa/modprobe-post-install snd-opti92x-ad1848
install snd-opti92x-cs4231 modprobe --ignore-install snd-opti92x-cs4231 && /lib/alsa/modprobe-post-install snd-opti92x-cs4231
install snd-opti93x modprobe --ignore-install snd-opti93x && /lib/alsa/modprobe-post-install snd-opti93x
install snd-pc98-cs4232 modprobe --ignore-install snd-pc98-cs4232 && /lib/alsa/modprobe-post-install snd-pc98-cs4232
install snd-pcsp modprobe --ignore-install snd-pcsp && /lib/alsa/modprobe-post-install snd-pcsp
install snd-pcxhr modprobe --ignore-install snd-pcxhr && /lib/alsa/modprobe-post-install snd-pcxhr
install snd-pdaudiocf modprobe --ignore-install snd-pdaudiocf && /lib/alsa/modprobe-post-install snd-pdaudiocf
install snd-pdplus modprobe --ignore-install snd-pdplus && /lib/alsa/modprobe-post-install snd-pdplus
install snd-portman2x4 modprobe --ignore-install snd-portman2x4 && /lib/alsa/modprobe-post-install snd-portman2x4
install snd-powermac modprobe --ignore-install snd-powermac && /lib/alsa/modprobe-post-install snd-powermac
install snd-pxa2xx-ac97 modprobe --ignore-install snd-pxa2xx-ac97 && /lib/alsa/modprobe-post-install snd-pxa2xx-ac97
install snd-rme32 modprobe --ignore-install snd-rme32 && /lib/alsa/modprobe-post-install snd-rme32
install snd-rme96 modprobe --ignore-install snd-rme96 && /lib/alsa/modprobe-post-install snd-rme96
install snd-rme9652 modprobe --ignore-install snd-rme9652 && /lib/alsa/modprobe-post-install snd-rme9652
install snd-s3c2410 modprobe --ignore-install snd-s3c2410 && /lib/alsa/modprobe-post-install snd-s3c2410
install snd-sa11xx-uda1341 modprobe --ignore-install snd-sa11xx-uda1341 && /lib/alsa/modprobe-post-install snd-sa11xx-uda1341
install snd-sb16 modprobe --ignore-install snd-sb16 && /lib/alsa/modprobe-post-install snd-sb16
install snd-sb8 modprobe --ignore-install snd-sb8 && /lib/alsa/modprobe-post-install snd-sb8
install snd-sbawe modprobe --ignore-install snd-sbawe && /lib/alsa/modprobe-post-install snd-sbawe
install snd-serialmidi modprobe --ignore-install snd-serialmidi && /lib/alsa/modprobe-post-install snd-serialmidi
install snd-serial-u16550 modprobe --ignore-install snd-serial-u16550 && /lib/alsa/modprobe-post-install snd-serial-u16550
install snd-sgalaxy modprobe --ignore-install snd-sgalaxy && /lib/alsa/modprobe-post-install snd-sgalaxy
install snd-sonicvibes modprobe --ignore-install snd-sonicvibes && /lib/alsa/modprobe-post-install snd-sonicvibes
install snd-sscape modprobe --ignore-install snd-sscape && /lib/alsa/modprobe-post-install snd-sscape
install snd-sun-amd7930 modprobe --ignore-install snd-sun-amd7930 && /lib/alsa/modprobe-post-install snd-sun-amd7930
install snd-sun-cs4231 modprobe --ignore-install snd-sun-cs4231 && /lib/alsa/modprobe-post-install snd-sun-cs4231
install snd-sun-dbri modprobe --ignore-install snd-sun-dbri && /lib/alsa/modprobe-post-install snd-sun-dbri
install snd-trident modprobe --ignore-install snd-trident && /lib/alsa/modprobe-post-install snd-trident
install snd-usb-audio modprobe --ignore-install snd-usb-audio && /lib/alsa/modprobe-post-install snd-usb-audio
install snd-usb-usx2y modprobe --ignore-install snd-usb-usx2y && /lib/alsa/modprobe-post-install snd-usb-usx2y
install snd-vx222 modprobe --ignore-install snd-vx222 && /lib/alsa/modprobe-post-install snd-vx222
install snd-vxp440 modprobe --ignore-install snd-vxp440 && /lib/alsa/modprobe-post-install snd-vxp440
install snd-vxpocket modprobe --ignore-install snd-vxpocket && /lib/alsa/modprobe-post-install snd-vxpocket
install snd-wavefront modprobe --ignore-install snd-wavefront && /lib/alsa/modprobe-post-install snd-wavefront
install snd-ymfpci modprobe --ignore-install snd-ymfpci && /lib/alsa/modprobe-post-install snd-ymfpci
# Prevent abnormal drivers from grabbing index 0
options snd-bt87x index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2

lsof /dev/snd/*
lsof: WARNING: can't stat() reiserfs file system /dev/.static/dev
      Output information may be incomplete.
COMMAND   PID USER   FD   TYPE DEVICE SIZE NODE NAME
kmix    14963 xico   10u   CHR  116,0      6900 /dev/snd/controlC0
kmix    14963 xico   11u   CHR 116,32      7230 /dev/snd/controlC1
kmix    14963 xico   12u   CHR 116,64      7615 /dev/snd/controlC2
xmms    15474 xico  mem    CHR 116,48      7139 /dev/snd/pcmC1D0p
xmms    15474 xico    8u   CHR 116,32      7230 /dev/snd/controlC1
xmms    15474 xico   11u   CHR 116,48      7139 /dev/snd/pcmC1D0p

lsof /dev/dsp
lsof: WARNING: can't stat() reiserfs file system /dev/.static/dev
      Output information may be incomplete.

lspci
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 03)
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
0000:00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
0000:00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1a)
0000:00:07.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 1a)
0000:00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
0000:00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 50)
0000:00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:00:0b.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)
0000:00:0c.0 Communication controller: Conexant: Unknown device 2f10 (rev 01)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)

cat /proc/asound/cards
0 [rev50          ]: VIA686A - VIA 82C686A/B rev50
                     VIA 82C686A/B rev50 with STAC9700,83,84 at 0xcc00, irq 5
1 [AudioPCI       ]: ENS1371 - Ensoniq AudioPCI
                     Ensoniq AudioPCI ENS1371 at 0xe000, irq 5
2 [Camera         ]: USB-Audio - Camera
                     Camera at usb-0000:00:07.2-1, full speed

lspci | grep Multi
0000:00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 50)
0000:00:0b.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 02)


enquanto escrevo, ouço a sinfonia n. 100 de joseph haydn, usando streamtuner e xmms no gnome. é todo o som que tenho no 5.10.
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |

IsoreHalav

  • Visitante
e a luta continua...
« Resposta #58 Online: 09 de Janeiro de 2006, 13:49 »
Perícope,

Sou novo neste Forum e agora que li seu post, não sei se é tarde demais para isso, mas creio que ainda há algo a tentar.

Normalmente os sons onboard são detectados no linux mesmo quando marcados como disabled na BIOS. (não me pergunte pq)

VIA = Onboard
Ensoniq = Offboard

Aparentemente estão sendo carregados os 2 módulos de som pelo kernel:

snd_via82xx - VIA
snd_ens1371 - Ensoniq

Tente modificar seu arquivo /etc/modprobe.d/sound e remover as entradas para o snd-via82xx

Dessa forma deve solucionar seu problema.

[]'s

G.

Offline Perícope

  • Vivendo e aprendendo... Liga dos Dinos
  • Usuário Ubuntu
  • *
  • Mensagens: 299
    • Ver perfil
não achei...
« Resposta #59 Online: 26 de Janeiro de 2006, 17:39 »
Isore, grato pela dica, mas não achei esse arquivo que você mencionou.
Usuário Linux n. 414104 - Usuário Ubuntu n. 3048
| Não tenha pressa: pesquise no fórum primeiro! |