Autor Tópico: Ubuntu 9.10 detecta rede wireless mas não navega.  (Lida 21836 vezes)

Offline Winthorp

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Ubuntu 9.10 detecta rede wireless mas não navega.
« Online: 26 de Fevereiro de 2010, 21:41 »
Pessoal, instalei o ubuntu 9.10 no meu note para finalmente aprender a usar de verdade e depois atualizei.
Mas não estou conseguindo conexão wireless. Olhei alguns tópicos, mas não consegui aplicar ao meu caso.
A rede sem fio é detectada, eu clico nela, digito a senha de acesso à rede, fica carregando e após um tempo, solicita a senha novamente e nunca conecta.
A senha que digito está correta.
O roteador é um DLink DI-524
Quando plugo o cabo a conexão é estabelecida imediatamente, mas na sem fio não dá, as "tomadinhas" que indicam que está conectado ficam separadas.
Como resolvo isso? Obrigado.

Offline entaotoloko

  • Usuário Ubuntu
  • *
  • Mensagens: 102
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #1 Online: 26 de Fevereiro de 2010, 22:44 »
Para podermos ajudar, poste por gentileza, o modelo da sua placa de rede wireless, com o comando lspci, digitado no terminal, e qual o tipo de criptografia utiliza (WPA, WPA2, etc...).
Amazon PC
Optimum - Turion X2 1.60Ghz 4GB de RAM HD de 250GB

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #2 Online: 27 de Fevereiro de 2010, 03:43 »
Citar
Quando plugo o cabo a conexão é estabelecida imediatamente, mas na sem fio não dá, as "tomadinhas" que indicam que está conectado ficam separadas.
Como resolvo isso? Obrigado.
Instala de novo o Ubuntu, dessa vez com o cabo conectado. Várias pessoas disseram que deu certo (não necessariamente com o cabo conectado, mas com certeza reinstalaram e resolveu).
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Winthorp

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #3 Online: 27 de Fevereiro de 2010, 07:37 »
Olá, segue o resultado do comando lspci
A segurança é WPA-PSK/WPA2-PSK
Antes detectava a rede, mas agora aparece a mensagem, "O dispositivo não é gerenciável"
Fazendo algumas tentativas vistas em alguns fóruns, eu tentei o comando "sudo pppoeconf wlan0", será por isso que não detecta mais a rede?

Citar
Instala de novo o Ubuntu, dessa vez com o cabo conectado. Várias pessoas disseram que deu certo (não necessariamente com o cabo conectado, mas com certeza reinstalaram e resolveu).
Antes de tentar instalar novamente, tenterei resolver com a ajuda do fórum, é até bom pra aprender. vlw

:~$lspci
00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
00:01.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (Internal gfx)
00:04.0 PCI bridge: ATI Technologies Inc Device 7914
00:05.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 1)
00:06.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 2)
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 01)
0e:00.0 Network controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)
14:06.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
14:06.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
14:06.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
14:06.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
14:06.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)
« Última modificação: 27 de Fevereiro de 2010, 07:57 por Winthorp »

Offline Falco90

  • Usuário Ubuntu
  • *
  • Mensagens: 669
  • mais um desocupado à procura de ajudar quase todos
    • Ver perfil
    • Blog de Tecnologia
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #4 Online: 27 de Fevereiro de 2010, 08:06 »
Talvez você tenha colocando a senha errada, ou o protocolo de segurança está errado. Veja se no campo Segurança que fica em cima de onde você coloca a senha da rede wireless é o mesmo que você escolheu na hora de escolher a senha da rede wireless.

Offline Winthorp

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #5 Online: 27 de Fevereiro de 2010, 10:04 »
Citar
Talvez você tenha colocando a senha errada, ou o protocolo de segurança está errado. Veja se no campo Segurança que fica em cima de onde você coloca a senha da rede wireless é o mesmo que você escolheu na hora de escolher a senha da rede wireless
.
A senha está correta, na dúvida, ainda fui checar nas configurações do roteador. O vista conecta normalmente.


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #6 Online: 27 de Fevereiro de 2010, 15:17 »
Citar
Antes detectava a rede, mas agora aparece a mensagem, "O dispositivo não é gerenciável"
Fazendo algumas tentativas vistas em alguns fóruns, eu tentei o comando "sudo pppoeconf wlan0", será por isso que não detecta mais a rede?

Essa mensagem "O dispositivo não é gerenciável" acontece por causa do "pppoeconf". Vc só deve usar esse comando se for conectar a uma conexão ADSL, ou se o seu provedor de rádio pedir autenticação PPPoE.

Isso está impedindo o NM de fazer as configurações necessárias pro seu wireless funcionar, mas não é por isso que não detecta: não detectava antes pq o NetworkManager (NM) não estava funcionando direito.

Pra reverter, apague todas as linhas referentes a "ppp" e "wlan0" no arquivo "/etc/network/interfaces". Depois, reinicie o NetworkManager ou o computador.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Winthorp

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #7 Online: 27 de Fevereiro de 2010, 19:34 »
Citar
Pra reverter, apague todas as linhas referentes a "ppp" e "wlan0" no arquivo "/etc/network/interfaces". Depois, reinicie o NetworkManager ou o computador.
Blz, agora está como antes, detecta a rede mas fica sempre pedindo a senha e não conecta na rede sem fio.
O que fazer?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #8 Online: 27 de Fevereiro de 2010, 20:28 »
32 ou 64 bits?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Winthorp

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #9 Online: 27 de Fevereiro de 2010, 21:49 »
Citar
32 ou 64 bits?
32

Offline Winthorp

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #10 Online: 27 de Fevereiro de 2010, 23:18 »
Tentei seguir o tópico do pintinho, mas não deu certo.
neste link, baixei o driver de wi-fi para o modelo do meu note. driver_wifi_atheros_os2007314c.exe
Descompactando, não tem nenhum arquivo .inf
http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/modelContent.jsp?ct=SB&os=&category=&moid=1852729&rpn=PSAFGU&modelFilter=A215-S7444&selCategory=3&selFamily=1073768663

No cd de instalação do vista o único .inf é o autorun.inf que dá erro quando tento instalar através do comando "sudo ndisgtk"

Segue o resultado dos comandos.
marcio@marcio-notebook:~$ sudo lshw -C network
[sudo] password for marcio:
  *-network               
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: eth0
       version: 01
       serial: 00:a0:d1:84:6a:02
       size: 100MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.0.100 latency=0 link=yes multicast=yes port=MII speed=100MB/s
       resources: irq:27 ioport:a000(size=256) memory:f8300000-f8300fff memory:80000000-8001ffff(prefetchable)
  *-network
       description: Wireless interface
       product: AR5008 Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:0e:00.0
       logical name: wmaster0
       version: 01
       serial: 00:1b:9e:5b:5d:e4
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=ath9k latency=0 multicast=yes wireless=IEEE 802.11abgn
       resources: irq:18 memory:f8200000-f820ffff

marcio@marcio-notebook:~$ sudo apt-get install ndisgtk
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os seguintes pacotes foram automaticamente instalados e não são mais requeridos:
  linux-headers-2.6.31-14 linux-headers-2.6.31-14-generic
Use 'apt-get autoremove' para removê-los.
Os pacotes extra a seguir serão instalados:
  ndiswrapper-common ndiswrapper-utils-1.9
Pacotes sugeridos:
  ndiswrapper-source
Os NOVOS pacotes a seguir serão instalados:
  ndisgtk ndiswrapper-common ndiswrapper-utils-1.9
0 pacotes atualizados, 3 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 79,8kB de arquivos.
Depois desta operação, 676kB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? s
Obter:1 http://br.archive.ubuntu.com karmic/main ndiswrapper-common 1.54-2ubuntu1 [21,7kB]
Obter:2 http://br.archive.ubuntu.com karmic/main ndiswrapper-utils-1.9 1.54-2ubuntu1 [36,5kB]
Obter:3 http://br.archive.ubuntu.com karmic/main ndisgtk 0.8.4-1 [21,7kB]
Baixados 79,8kB em 0s (113kB/s)
Selecionando pacote previamente não selecionado ndiswrapper-common.
(Lendo banco de dados ... 136097 arquivos e diretórios atualmente instalados).
Desempacotando ndiswrapper-common (de .../ndiswrapper-common_1.54-2ubuntu1_all.deb) ...
Selecionando pacote previamente não selecionado ndiswrapper-utils-1.9.
Desempacotando ndiswrapper-utils-1.9 (de .../ndiswrapper-utils-1.9_1.54-2ubuntu1_i386.deb) ...
Selecionando pacote previamente não selecionado ndisgtk.
Desempacotando ndisgtk (de .../ndisgtk_0.8.4-1_i386.deb) ...
Processando gatilhos para man-db ...
Processando gatilhos para desktop-file-utils ...
Processando gatilhos para hicolor-icon-theme ...
Configurando ndiswrapper-common (1.54-2ubuntu1) ...
Configurando ndiswrapper-utils-1.9 (1.54-2ubuntu1) ...
Configurando ndisgtk (0.8.4-1) ...

marcio@marcio-notebook:~$ ndiswrapper -l
marcio@marcio-notebook:~$ sudo depmod -a
marcio@marcio-notebook:~$ sudo modprobe ndiswrapper
marcio@marcio-notebook:~$ sudo ndiswrapper -m

adding "alias wlan0 ndiswrapper" to /etc/modprobe.d/ndiswrapper ...
marcio@marcio-notebook:~$ sudo gedit /etc/modules  acrescentei ndiswrapper
marcio@marcio-notebook:~$ sudo ndisgtk
[/color]
/usr/sbin/ndisgtk:127: Warning: g_object_ref: assertion `G_IS_OBJECT (object)' failed
  gtk.main()

(ndisgtk:2402): GLib-GIO-CRITICAL **: g_mount_get_volume: assertion `G_IS_MOUNT (mount)' failed

(ndisgtk:2402): GLib-GIO-CRITICAL **: g_mount_get_root: assertion `G_IS_MOUNT (mount)' failed
/usr/sbin/ndisgtk:127: Warning: g_object_unref: assertion `G_IS_OBJECT (object)' failed
  gtk.main()

(ndisgtk:2402): GLib-GIO-CRITICAL **: g_mount_get_volume: assertion `G_IS_MOUNT (mount)' failed

(ndisgtk:2402): GLib-GIO-CRITICAL **: g_mount_get_root: assertion `G_IS_MOUNT (mount)' failed
/usr/sbin/ndisgtk:127: Warning: instance of invalid non-instantiatable type `(null)'
  gtk.main()
/usr/sbin/ndisgtk:127: Warning: g_signal_emit_by_name: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
  gtk.main()
Falha de segmentação
marcio@marcio-notebook:~$ sudo ndisgtk tentei novamente, mas não consigo instalar o driver que baixei.



Não sei mais o que fazer, não queria instalar de novo.

Offline jomafras

  • Usuário Ubuntu
  • *
  • Mensagens: 2.009
  • 17.04 Zesty Zapus
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #11 Online: 28 de Fevereiro de 2010, 00:26 »
Veja se vc consegue baixando o driver do XP da sua placa desse link.
O Ubuntu sem dúvida é a melhor Distro.
Pesquise primeiro... só depois abra um tópico.
Canal do YouTube - Blog

Offline Winthorp

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #12 Online: 28 de Fevereiro de 2010, 01:24 »
Pintinho, baixei o driver e parece que consegui instalar, pois agora aparece netathwx no "drivers windows atualmente instalados". Tirei o cabo de rede e tentei a conexão wireless, mas não rolou, digitei a senha da rede, mas continuou solicitando. Há algo que deixei de fazer?

Offline Winthorp

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #13 Online: 28 de Fevereiro de 2010, 08:47 »
Citar
Instala de novo o Ubuntu, dessa vez com o cabo conectado. Várias pessoas disseram que deu certo (não necessariamente com o cabo conectado, mas com certeza reinstalaram e resolveu).
Que droga, vou fazer como o zekkerj  sugeriu, vou ter que reinstalar o ubuntu. Tá com muito pau essa instalação. Quando eu desligo fica eternamente em uma tela escura com um logo branco do ubuntu e só desliga quando aperto o power.
Quando instalei, ficou muito tempo nessa mesma tela escura com o logo ubuntu até entrar na instalação propriamente dita, isso é normal?

Offline Winthorp

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: Ubuntu 9.10 detecta rede wireless mas não navega.
« Resposta #14 Online: 28 de Fevereiro de 2010, 12:25 »
Instalei novamente o ubuntu 9.10 com o cabo de rede conectado, fiz as atualizações e segui o tuto do pintinho, mas não conecta na rede wireless, tentei instalar outros drivers referentes a minha placa e nada. Agora, nem mostra mais a rede wireless.
To realmente ficando desanimado, já fiz de tudo mas não funciona e ainda por cima, quando dou shutdown, a máquina só desliga quando aperto o power.

http://ubuntuforum-br.org/index.php/topic,63309.0.html


marcio@marcio-desktop:~$ sudo apt-get install ndisgtk
[sudo] password for marcio:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os seguintes pacotes foram automaticamente instalados e não são mais requeridos:
  linux-headers-2.6.31-14 linux-headers-2.6.31-14-generic
Use 'apt-get autoremove' para removê-los.
Os pacotes extra a seguir serão instalados:
  ndiswrapper-common ndiswrapper-utils-1.9
Pacotes sugeridos:
  ndiswrapper-source
Os NOVOS pacotes a seguir serão instalados:
  ndisgtk ndiswrapper-common ndiswrapper-utils-1.9
0 pacotes atualizados, 3 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 79,8kB de arquivos.
Depois desta operação, 676kB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? s
Obter:1 http://br.archive.ubuntu.com karmic/main ndiswrapper-common 1.54-2ubuntu1 [21,7kB]
Obter:2 http://br.archive.ubuntu.com karmic/main ndiswrapper-utils-1.9 1.54-2ubuntu1 [36,5kB]
Obter:3 http://br.archive.ubuntu.com karmic/main ndisgtk 0.8.4-1 [21,7kB]
Baixados 79,8kB em 0s (96,4kB/s)
Selecionando pacote previamente não selecionado ndiswrapper-common.
(Lendo banco de dados ... 135844 arquivos e diretórios atualmente instalados).
Desempacotando ndiswrapper-common (de .../ndiswrapper-common_1.54-2ubuntu1_all.deb) ...
Selecionando pacote previamente não selecionado ndiswrapper-utils-1.9.
Desempacotando ndiswrapper-utils-1.9 (de .../ndiswrapper-utils-1.9_1.54-2ubuntu1_i386.deb) ...
Selecionando pacote previamente não selecionado ndisgtk.
Desempacotando ndisgtk (de .../ndisgtk_0.8.4-1_i386.deb) ...
Processando gatilhos para man-db ...
Processando gatilhos para desktop-file-utils ...
Processando gatilhos para hicolor-icon-theme ...
Configurando ndiswrapper-common (1.54-2ubuntu1) ...
Configurando ndiswrapper-utils-1.9 (1.54-2ubuntu1) ...
Configurando ndisgtk (0.8.4-1) ...

marcio@marcio-desktop:~$ ndiswrapper -l
marcio@marcio-desktop:~$ sudo depmod -a
marcio@marcio-desktop:~$ sudo modprobe ndiswrapper
marcio@marcio-desktop:~$ sudo gedit /etc/modules
marcio@marcio-desktop:~$ sudo ndisgtk

module configuration information is stored in /etc/modprobe.d/ndiswrapper
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
module configuration information is stored in /etc/modprobe.d/ndiswrapper
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.



# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
ndiswrapper