Autor Tópico: mais um ubuntu 9.1 sem wi fi  (Lida 16131 vezes)

Offline luisffaria

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
mais um ubuntu 9.1 sem wi fi
« Online: 04 de MAR?O de 2010, 17:14 »
Boa tarde.

Comecei no Linux hoje, baixei a versão ubuntu 9.10.

Tenho o windows 7 ultimate instalado e fiz dual boot com o ubuntu.
Meu notebook é um Acer 2920z.

Além daqui do fórum, pesquisei em outros sites e não consegui conectar o unbuntu por wifi, apenas por cabo. (por isso que coloquei o nome do tópico "mais um..."

Vi um tópico aqui ensinando a instalar o ndiswrapper, e utilizar o driver do windows. Foi o que eu fiz. instalei o ndiswrapper e deu certo. Então baixei do site da acer os drivers wifi do xp e do vista (não tem do 7, mas o 7 instala sozinho e no site diz que o notebook é totalmente compatível com o 7.

Não sei se driver que o win7 instala é o mesmo que está disponível do vista no site ou se é outro, se for outro como descobrir e conseguir esse driver? pode ser que ele dê certo se o problema for mesmo os drivers do xp e do vista)

Instalei os dois, quando vou em Sistema > Administração > Drivers Windows para placas de rede sem fio aparece os dois instalados (bcmwl5 [xp]) e (bcmwl6 [vista])

E diz que o hardware está presente.

Porém, mesmo após reiniciar o unbuntu ele não detecta nenhuma rede sem fio (tem umas 50 próximas aqui que aparecem quando vou conectar na minha com o windows). Clico no icone na barra de notificação ao lado do relógio e só tem a opção Habilitar Rede (li em um forum que tinha uma especifica para wifi) e está habilitada.

Inclusive a luz indicativa de ativação do wifi do notebook não acende com o linux.

Bom segue as informações da minha placa (sudo lshw -C NetWork)

  *-network              
       description: Ethernet interface
       product: NetLink BCM5787M Gigabit Ethernet PCI Express
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 02
       serial: 00:1d:72:2d:f5:c0
       size: 100MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.99 duplex=full firmware=5787m-v3.23 ip=10.0.0.100 latency=0 link=yes multicast=yes port=twisted pair speed=100MB/s
       resources: irq:28 memory:f6000000-f600ffff
  *-network
       description: Network controller
       product: BCM4312 802.11b/g
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: driver=b43-pci-bridge latency=0
       resources: irq:17 memory:f8000000-f8003fff
luis@Lampiao:~$



estou gostando de mexer no linux, apesar dele parecer um pouco confuso, rs

Obrigado!

Obs: o wifi está funcionando normalmente no windows 7


Informação Adicional:

Digito no terminal iwconfig e diz:

luis@Lampiao:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.
« Última modificação: 04 de MAR?O de 2010, 17:28 por luisffaria »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: mais um ubuntu 9.1 sem wi fi
« Resposta #1 Online: 04 de MAR?O de 2010, 17:57 »

Inclusive a luz indicativa de ativação do wifi do notebook não acende com o linux.

Nos meus notes, se a luz indicativa não acende, a placa está conectada ao sistema mas não está ativa

Acredito que já tenha tentado ativar pelo teclado, ok?

Já tentou pelo ifconfig?

[],s

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: mais um ubuntu 9.1 sem wi fi
« Resposta #2 Online: 04 de MAR?O de 2010, 21:23 »
Placa broadcom, vi hoje mesmo um caso igual no site Guia do Hardware. O cara disse que se ativar a rede wireless pelo windows, ela funciona no Linux.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luisffaria

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: mais um ubuntu 9.1 sem wi fi
« Resposta #3 Online: 05 de MAR?O de 2010, 01:07 »
1 - Já tentei ativar a luz do wi fi pelo botão do teclado sim.

2 - A rede wireless já esta ativada no windows.
-----------------------------------------------------

3 - Testei baixando no synaptic o "bcmwl-kernel-source" (para placa broadcom que é o meu caso) que vi em outro tópico e também não deu.

4 - Testei apagando todos os dados do arquivo "etc/network/interface" e reiniciando a maquina e também também não resolveu
----------------------------------------------------

Como assim pelo "ifconfig"? digitei e saiu isto:

luis@Lampiao:~$ ifconfig
eth0      Link encap:Ethernet  Endereço de HW 00:1d:72:2d:f5:c0  
          inet end.: 10.0.0.101  Bcast:10.0.0.255  Masc:255.255.255.0
          endereço inet6: fe80::21d:72ff:fe2d:f5c0/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:2281 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:1963 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:2227974 (2.2 MB) TX bytes:316871 (316.8 KB)
          IRQ:16

lo        Link encap:Loopback Local  
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:4 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:4 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

luis@Lampiao:~$

« Última modificação: 05 de MAR?O de 2010, 01:15 por luisffaria »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: mais um ubuntu 9.1 sem wi fi
« Resposta #4 Online: 05 de MAR?O de 2010, 07:44 »
posta a saída do comando "lsmod | grep b43".
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luisffaria

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: mais um ubuntu 9.1 sem wi fi
« Resposta #5 Online: 05 de MAR?O de 2010, 12:00 »
luis@Lampiao:~$ lsmod|grep 43
snd_seq_midi            6432  0
luis@Lampiao:~$



obs: estou usando o linux conectado pelo cabo no momento. Influi nesse e em outros comandos que eu for testar? (de qualquer forma todos os outros eu testei sem internet por cabo)
« Última modificação: 05 de MAR?O de 2010, 12:02 por luisffaria »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: mais um ubuntu 9.1 sem wi fi
« Resposta #6 Online: 05 de MAR?O de 2010, 12:11 »
mesmo apenas conectado por cabo, o módulo da wireless deveria estar carregado. Execute os comandos abaixo, então.

sudo modprobe b43
ifconfig

iwconfig wlan0
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luisffaria

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: mais um ubuntu 9.1 sem wi fi
« Resposta #7 Online: 05 de MAR?O de 2010, 15:56 »
ta os comandos:

demorei a responder porque tive que reinstalar o ubuntu.

lf@lf-laptop:~$ sudo modprobe b43
[sudo] password for lf:
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
lf@lf-laptop:~$ ifconfig
eth0      Link encap:Ethernet  Endereço de HW 00:1d:72:2d:f5:c0  
          inet end.: 10.0.0.101  Bcast:10.0.0.255  Masc:255.255.255.0
          endereço inet6: fe80::21d:72ff:fe2d:f5c0/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1
          pacotes RX:169 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:223 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:40230 (40.2 KB) TX bytes:31668 (31.6 KB)
          IRQ:16

lo        Link encap:Loopback Local  
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:4 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:4 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

lf@lf-laptop:~$ iwconfig wlan0
wlan0     No such device

lf@lf-laptop:~$


Valeu pela ajuda. Tem que ter algum jeito ne? Tenho que conseguir! hehe

PS:
antes de usar estes comandos eu baixei novamente o ndiwrapper e instalei novamente o driver do vista.
« Última modificação: 05 de MAR?O de 2010, 16:12 por luisffaria »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: mais um ubuntu 9.1 sem wi fi
« Resposta #8 Online: 06 de MAR?O de 2010, 00:19 »
Cara, que estranho. A máquina tinha que responder ao módulo criando a interface, mesmo que desativada.

Pode postar a saída do comando "dmesg | tail -n 20"?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luisffaria

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: mais um ubuntu 9.1 sem wi fi
« Resposta #9 Online: 06 de MAR?O de 2010, 01:43 »
Claro!!

lf@lf-laptop:~$ dmesg | tail -n 20
[   14.323970] ppdev: user-space parallel port driver
[   17.370558] [drm] TV-14: set mode NTSC 480i 0
[   17.510645] [drm] TV-14: set mode NTSC 480i 0
[   17.808617] [drm] TV-14: set mode NTSC 480i 0
[   17.948832] [drm] TV-14: set mode NTSC 480i 0
[   20.353417] [drm] TV-14: set mode NTSC 480i 0
[   20.493726] [drm] TV-14: set mode NTSC 480i 0
[   20.765180] [drm] TV-14: set mode NTSC 480i 0
[   20.905283] [drm] TV-14: set mode NTSC 480i 0
[   21.191666] [drm] TV-14: set mode NTSC 480i 0
[   21.332012] [drm] TV-14: set mode NTSC 480i 0
[   21.588014] eth0: no IPv6 routers present
[   35.397984] [drm] TV-14: set mode NTSC 480i 0
[   35.537944] [drm] TV-14: set mode NTSC 480i 0
[   35.807423] [drm] TV-14: set mode NTSC 480i 0
[   35.950925] [drm] TV-14: set mode NTSC 480i 0
[   36.220418] [drm] TV-14: set mode NTSC 480i 0
[   36.361219] [drm] TV-14: set mode NTSC 480i 0
[   38.496431] [drm] TV-14: set mode NTSC 480i 0
[   38.636495] [drm] TV-14: set mode NTSC 480i 0
lf@lf-laptop:~$




Ps: to gostando muito do linux, é muito bom a quantidade de personalizações que podemos fazer

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: mais um ubuntu 9.1 sem wi fi
« Resposta #10 Online: 06 de MAR?O de 2010, 01:49 »
... logo depois de carregar o módulo da rede wireless?

sudo modprobe -r b43
sudo modprobe b43
dmesg | tail -n 20
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luisffaria

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: mais um ubuntu 9.1 sem wi fi
« Resposta #11 Online: 06 de MAR?O de 2010, 01:59 »
agora deu um sinal de vida!!  :D

mas parece que não suporta  ???
---------------------------------------------------
lf@lf-laptop:~$ sudo modprobe -r b43
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
lf@lf-laptop:~$ sudo modprobe b43
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
lf@lf-laptop:~$ dmesg | tail -n 20
[ 1109.040646] b43-phy0: Broadcom 4312 WLAN found (core revision 15)
[ 1109.084235] b43-phy0 ERROR: FOUND UNSUPPORTED PHY (Analog 6, Type 5, Revision 1)
[ 1109.084364] b43: probe of ssb0:0 failed with error -95
[ 1109.084427] Broadcom 43xx driver loaded [ Features: PL, Firmware-ID: FW13 ]
[ 1134.076395] b43-pci-bridge 0000:04:00.0: PCI INT A disabled
[ 1140.073174] cfg80211: Calling CRDA to update world regulatory domain
[ 1140.109778] b43-pci-bridge 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[ 1140.109803] b43-pci-bridge 0000:04:00.0: setting latency timer to 64
[ 1140.111935] cfg80211: World regulatory domain updated:
[ 1140.111940]    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 1140.111944]    (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1140.111947]    (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 1140.111950]    (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 1140.111953]    (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1140.111957]    (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1140.176368] ssb: Sonics Silicon Backplane found on PCI device 0000:04:00.0
[ 1140.187797] b43-phy0: Broadcom 4312 WLAN found (core revision 15)
[ 1140.229239] b43-phy0 ERROR: FOUND UNSUPPORTED PHY (Analog 6, Type 5, Revision 1)
[ 1140.229319] b43: probe of ssb0:0 failed with error -95
[ 1140.229379] Broadcom 43xx driver loaded [ Features: PL, Firmware-ID: FW13 ]
lf@lf-laptop:~$


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: mais um ubuntu 9.1 sem wi fi
« Resposta #12 Online: 06 de MAR?O de 2010, 09:25 »
Um-hum.

Joguei a mensagem de dispositivo não suportado no google, e achei relatos de que é um bug em aberto no driver das placas Broadcomm.
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/376259

Vamos tentar liberar o dispositivo, descarregando todos os módulos relacionados e carregando o driver NDISwrapper:

sudo modprobe -r b43
sudo modprobe ndiswrapper
dmesg | tail -n 20

Ah! Confirma pra mim, também, a versão do seu kernel:

uname -r
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luisffaria

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: mais um ubuntu 9.1 sem wi fi
« Resposta #13 Online: 06 de MAR?O de 2010, 19:47 »
Ta aí os comandos.

lf@lf-laptop:~$ sudo modprobe -r b43
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
----------------------------------------------------------------------------------
lf@lf-laptop:~$ sudo modprobe ndiswrapper
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.
----------------------------------------------------------------------------------
lf@lf-laptop:~$ dmesg | tail -n 20
[  637.725591] VFS: busy inodes on changed media or resized disk sr0
[  637.744508] VFS: busy inodes on changed media or resized disk sr0
[  639.715474] VFS: busy inodes on changed media or resized disk sr0
[  639.724971] VFS: busy inodes on changed media or resized disk sr0
[  639.734414] VFS: busy inodes on changed media or resized disk sr0
[  641.714965] VFS: busy inodes on changed media or resized disk sr0
[  641.724457] VFS: busy inodes on changed media or resized disk sr0
[  641.733863] VFS: busy inodes on changed media or resized disk sr0
[  643.715779] VFS: busy inodes on changed media or resized disk sr0
[  643.725246] VFS: busy inodes on changed media or resized disk sr0
[  643.734698] VFS: busy inodes on changed media or resized disk sr0
[  645.715324] VFS: busy inodes on changed media or resized disk sr0
[  645.724912] VFS: busy inodes on changed media or resized disk sr0
[  645.744212] VFS: busy inodes on changed media or resized disk sr0
[  647.715167] VFS: busy inodes on changed media or resized disk sr0
[  647.724861] VFS: busy inodes on changed media or resized disk sr0
[  647.745164] VFS: busy inodes on changed media or resized disk sr0
[  649.715182] VFS: busy inodes on changed media or resized disk sr0
[  649.724709] VFS: busy inodes on changed media or resized disk sr0
[  649.734115] VFS: busy inodes on changed media or resized disk sr0
----------------------------------------------------------------------------------
lf@lf-laptop:~$ uname -r
2.6.31-14-generic



Ps: da outra vez eu atualizei pelo gerenciador de atualizações e criou uma nova entrada no boot com final 20, mas o pc trabou e não consegui entrar em nenhuma das partições, ai reinstalei e não atualizei de novo.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: mais um ubuntu 9.1 sem wi fi
« Resposta #14 Online: 06 de MAR?O de 2010, 20:20 »
vc chegou a instalar os drivers do windows, depois reinstalar o Ubuntu?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D