Autor Tópico: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x  (Lida 27046 vezes)

Offline franzisk

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Online: 09 de MAR?O de 2010, 10:03 »
De repente meu cdrom/dvd parou de montar a unidade quando insere um disco, ele até lê um pouco (fica piscando a luz do driver) mas não monta, já tentei montar na linha de comando mas também não monta:
sudo mount /media/cdrom0 -o unhide
mount: no medium found on /dev/sr0


Meu fstab está assim:
# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda1 during installation
UUID=bb679f37-4a3c-4cf8-89b1-244a43913868 /               ext3    relatime,errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=71300f7d-9151-4083-8057-1d9d395e69ff none            swap    sw              0       0
################### /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec 0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

# Para ativar o iPod
#/dev/sdb1 /mnt/ipod vfat noauto,user 0 0


Alguém pode me dar alguma ajuda? Tenho pouca experiência em Linux.
Obrigado.

Offline franzisk

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Resposta #1 Online: 09 de MAR?O de 2010, 12:16 »
O ruim de Linux é isso, ou você sabe muito e resolve seus problemas ou depende de alguma alma caridosa disposta a te ajudar, mesmo assim estou preferindo ficar no meu Ubuntu mesmo.

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Resposta #2 Online: 09 de MAR?O de 2010, 14:04 »
Na verdade observando seu fstab, dá claramente para ver que o ponto de montagem está errado
experimente.
sudo mount /dev/sr0 /media/cdrom0

Esta é a sua linha:
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0

E esta é como deveria estar.

/dev/sr0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0

PS:Não faça comentários injustos, pois só observando seu próprio post, você descobriria o que está errado.
« Última modificação: 09 de MAR?O de 2010, 14:42 por Xterminator »

Offline franzisk

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Resposta #3 Online: 09 de MAR?O de 2010, 14:29 »
Me perdoe quem foi injustiçado com meu comentário, mas, não funcionou.

Coloquei um DVD-RW novinho no driver, fechei, a unidade não foi montada, executei:
sudo mount /dev/sr0 /dev/cdrom0
mount: o ponto de montagem /dev/cdrom0 não existe


Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Resposta #4 Online: 09 de MAR?O de 2010, 14:41 »
Sorry brother, eu passei o comando errado.

sudo mount /dev/sr0 /media/cdrom0

mais uma vez, era só observar seu fstab  ;-)

Quanto ao que eu disse sobre o comentário, no stress só peço que seja um pouco mais paciente às vezes a respostas demoram a chegar, e a pesquisa é a sua melhor amiga.
tenta agora e veja no que dá.
« Última modificação: 09 de MAR?O de 2010, 15:20 por Xterminator »

Offline franzisk

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Resposta #5 Online: 09 de MAR?O de 2010, 16:02 »
Agora deu uma mensagem diferente:
mount: /dev/sr0: dispositivo de blocos desconhecido

Quando eu olho no Utilitário de Disco e clico em cima do Unidade CD/DVD aparece:
Tamanho desconhecido
Nenhuma mídia detectada
O SMART não está disponível
/dev/sr0


Porém tem um DVD-RW novinho na unidade.

Obrigado pela ajuda (eu pesquiso, é que as vezes só lendo o que já tem me deixa mais confuso - mas na maioria das vezes resolve).

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Resposta #6 Online: 09 de MAR?O de 2010, 16:15 »
Rapaz aí complicou rs rs
o que pode estar ocorrendo, é que o dispositivo esteja sendo reconhecido errado.

experimenta

sudo mount -a

e pega a mensagem de erro, a algum tempo atrás eu tive um probleminha pois os dispositivos sr,scd são dispositivos SCSI, e eu tive que deixar a linha do fstab para dispositivos IDE, ex hdd,hdc etc... mas aí fica dificil saber se o teu caso é o mesmo que o meu, se for você teria que saber em qual interface da placa mãe o DVD está conectado.

Offline franzisk

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Resposta #7 Online: 09 de MAR?O de 2010, 16:20 »
Com sudo mount -a não mostrou nenhuma mensagem de erro.

O estranho é que tava funcionando normal e de repende começou a não montar mais quando eu insiro um dvd.

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Resposta #8 Online: 09 de MAR?O de 2010, 16:25 »
digite

df -h

e veja se aparece alguma referência ao drive de DVD

Offline franzisk

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Resposta #9 Online: 09 de MAR?O de 2010, 16:30 »
Sist. Arq.            Tam   Usad Disp  Uso% Montado em
/dev/sda1             285G   43G  228G  16% /
udev                  1,5G  264K  1,5G   1% /dev
none                  1,5G  1,6M  1,5G   1% /dev/shm
none                  1,5G  496K  1,5G   1% /var/run
none                  1,5G     0  1,5G   0% /var/lock
none                  1,5G     0  1,5G   0% /lib/init/rw

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Resposta #10 Online: 09 de MAR?O de 2010, 16:44 »
Já inseriu um DVD normal sem ser RW para testar?
tá muito esquisito, as mensagens de erro não estão de acordo.

a 1ªdiz que não existe mídia em sr0, quando no fstab está discriminado scd0:

sudo mount /media/cdrom0 -o unhide
mount: no medium found on /dev/sr0

a 2ª diz que sr0 não é um dispositivo de blocos válido quando a 1ª diz que o dispositivo existe

mount: /dev/sr0: dispositivo de blocos desconhecido:

quando você digita

mount /dev/scd0 /media/cdrom0

o que ele diz?

e

hwinfo --cdrom

o que diz?
« Última modificação: 09 de MAR?O de 2010, 16:59 por Xterminator »

Offline franzisk

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Resposta #11 Online: 09 de MAR?O de 2010, 17:05 »
Resultado para esse último comando (mount /dev/scd0 /media/cdrom0): mount: /dev/sr0: dispositivo de blocos desconhecido

Quando coloco um DVD-W por exemplo, dá o mesmo problema.

Offline Xterminator

  • Usuário Ubuntu
  • *
  • Mensagens: 1.279
    • Ver perfil
Re: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Resposta #12 Online: 09 de MAR?O de 2010, 17:18 »
digite:
sudo hwinfo --cdrom

Tipo assim, na pior das hipoteses, faça o teste do drive rodando um live-cd a partir dele
e veja se ele tem algum comportamento estranho.

Offline franzisk

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Resposta #13 Online: 09 de MAR?O de 2010, 17:22 »
Diz que esse comando hwinfo não existe.

Offline franzisk

  • Usuário Ubuntu
  • *
  • Mensagens: 53
    • Ver perfil
Re: CD/DVD parou de montar quando insere um DVD no Ubuntu 9.x
« Resposta #14 Online: 09 de MAR?O de 2010, 17:26 »
digite:
sudo hwinfo --cdrom

Tipo assim, na pior das hipoteses, faça o teste do drive rodando um live-cd a partir dele
e veja se ele tem algum comportamento estranho.

Saída:
8: SCSI 300.0: 10602 CD-ROM (DVD)                             
  [Created at block.247]
  UDI: /org/freedesktop/Hal/devices/storage_model_CDDVDW_SH_S223F
  Unique ID: KD9E.+o0IDY85DU5
  Parent ID: w7Y8.tBwwt1mPXq2
  SysFS ID: /class/block/sr0
  SysFS BusID: 3:0:0:0
  SysFS Device Link: /devices/pci0000:00/0000:00:1f.2/host3/target3:0:0/3:0:0:0
  Hardware Class: cdrom
  Model: "TSSTcorp CDDVDW SH-S223F"
  Vendor: "TSSTcorp"
  Device: "CDDVDW SH-S223F"
  Revision: "SB02"
  Driver: "ata_piix", "sr"
  Device File: /dev/sr0 (/dev/sg1)
  Device Files: /dev/sr0, /dev/block/11:0, /dev/scd0, /dev/disk/by-path/pci-0000:00:1f.2-scsi-1:0:0:0, /dev/cdrom, /dev/cdrw, /dev/dvd, /dev/dvdrw
  Device Number: block 11:0 (char 21:1)
  Features: CD-R, CD-RW, DVD, DVD-R, DVD-RW, DVD+R, DVD+RW, DVD+DL, DVDRAM
  Drive status: no medium
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #14 (IDE interface)
  Drive Speed: 48