Autor Tópico: Meu Ubuntu não inicia [Resolvido]  (Lida 17512 vezes)

Offline ptkrr

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
    • PTKGames.com
Meu Ubuntu não inicia [Resolvido]
« Online: 13 de Maio de 2010, 14:19 »
Olá eu estou com um grande problema no ubuntu (9.10)....
ontem ocorreu uma queda de energia na rua da minha casa... eu estava usando meu computador na internet normalmente quando isso aconteceu.
Quando voltou a energia eu fui ligar meu computador, iniciou normalmente com a logo do ubuntu... mas na hora de carregar o ambiente gráfico começa a carregar um monte de erro, como 1024x768 e pede para eu colocar a senha do root ou pressionar Ctrl+D, mas se eu fizer isso não acontece nada...
alguem sabe como eu faço para ter acesso aos meu arquivos (que estão bloqueados) pelo live para que eu possa fazer backup deles antes de reinstalar o sistema?
« Última modificação: 15 de Maio de 2010, 13:04 por ptkrr »

Offline HugoSalvador

  • Usuário Ubuntu
  • *
  • Mensagens: 41
    • Ver perfil
Re: Meu Ubuntu não inicia
« Resposta #1 Online: 13 de Maio de 2010, 14:29 »
Se você iniciar pelo liveCD vai ter acesso ao seu HD normalmente. Aí coloca um pendrive ou HD externo e puxa tudo que quiser.

Se ao iniciar por liveCD você não achar seu HD usa o "sudo fdisk -l" para visualizar seu HD (/dev/sda1, por exemplo) e usa o "mount" para montar e acessar o HD.

Mas uma dica, se deu pau apenas no seu modo gráfico, entra no modo terminal e dá o seguinte comando: "sudo apt-get install ubuntu-desktop". Isso vai reinstalar o Gnome.... vai que dá certo :-)

Offline ptkrr

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
    • PTKGames.com
Re: Meu Ubuntu não inicia
« Resposta #2 Online: 13 de Maio de 2010, 15:11 »
Eu estou usnado o live, mas eu meus arquivos estão bloqueados só quem tem acesso a esses arquivos é [ 1000 - user #1000 ]
é estranho isso pois eu não consigo nem executa-lo e copiar....
tem como mudar o acesso a esses arquivos?
eu já tentei utilizar o chmod 700 /media/4fa2f4e8-7d00-4795-ae28-f513013b4967/home/smti -R
mas não muda nada eu continuo sem acesso....

Offline ptkrr

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
    • PTKGames.com
Re: Meu Ubuntu não inicia
« Resposta #3 Online: 13 de Maio de 2010, 15:53 »
Para ser expecifico ao invés de iniciar aparece o seguinte na minha tela:

Código: [Selecionar]
usplash: Setting mode 1152x864 failed
usplash: Using mode 1024x768
General error mounting filesystems.
A maintenance shell will now be started.
CONTROL-D will terminate this shell and re-try.
Give root password for maintenance
(or type Control-D to continue):
« Última modificação: 13 de Maio de 2010, 18:44 por ptkrr »

Offline overlock@

  • Usuário Ubuntu
  • *
  • Mensagens: 261
    • Ver perfil
Meu Ubuntu não inicia
« Resposta #4 Online: 14 de Maio de 2010, 08:08 »
Você mexeu na resolução do usplash ? pelo que entendi, ele está reclamando de resolução
Código: [Selecionar]
usplash: Setting mode 1152x864 failed

e pede para você alterar para ;
Código: [Selecionar]
usplash: Using mode 1024x768

Você mexeu em algum arquivo de inicialização ?
Código: [Selecionar]
General error mounting filesystems.
A maintenance shell will now be started.
CONTROL-D will terminate this shell and re-try.
Give root password for maintenance
"Linux User" # 480186 

Kubuntu 11.04 kernel 2.6.38.8-ck3 kde 4.6.4

Offline ptkrr

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
    • PTKGames.com
Re: Meu Ubuntu não inicia
« Resposta #5 Online: 14 de Maio de 2010, 10:47 »
Não mexi em nada... O computador apagou e apereceu isso despois que eu liguei....
pq tem como arrumar ???  ???

Offline overlock@

  • Usuário Ubuntu
  • *
  • Mensagens: 261
    • Ver perfil
Meu Ubuntu não inicia
« Resposta #6 Online: 14 de Maio de 2010, 10:53 »
Você tem acesso ao modo texto quando inicia ?
"Linux User" # 480186 

Kubuntu 11.04 kernel 2.6.38.8-ck3 kde 4.6.4

Offline ptkrr

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
    • PTKGames.com
Re: Meu Ubuntu não inicia
« Resposta #7 Online: 14 de Maio de 2010, 10:56 »
sim...
aparece isso que eu escrevi e pedi eu digitar a senha do root eu digito mais eu naum sei comando nehum para fazer ele voltar ao normal....

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Meu Ubuntu não inicia
« Resposta #8 Online: 14 de Maio de 2010, 11:39 »
Ola amigos.

Modo Zen ligado------

Falta  de energia com hd rodando = hd corrompido

Então, live cd carregado

terminal aberto
Código: [Selecionar]
sudo fsck /dev/sda1
quando terminar experimente um boot normal.

Modo Zen desligado-----

Só depois de ter certeza que seus dados estão íntegros, teste outras opções.

[],s

Offline ptkrr

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
    • PTKGames.com
Re: Meu Ubuntu não inicia
« Resposta #9 Online: 14 de Maio de 2010, 13:34 »
No ubuntu LiveCD ficou assim:
Código: [Selecionar]
ubuntu@ubuntu:~$ sudo fsck /dev/sda1
fsck de util-linux-ng 2.16
fsck: fsck.swap: não encontrado
fsck: Error 2 while executing fsck.swap for /dev/sda1

No sistema ficou assim:
Código: [Selecionar]
root@smtirr:~# sudo fsck /dev/sda1
fsck: fsck util-linux-ng 2.16
fsck: fsck.swap: not found
fsck: Error 2 while executing fsck.swap for /dev/sda1

não aconteceu nada? pq?

Offline overlock@

  • Usuário Ubuntu
  • *
  • Mensagens: 261
    • Ver perfil
Meu Ubuntu não inicia
« Resposta #10 Online: 14 de Maio de 2010, 13:45 »
Citação de: ptkrr
não aconteceu nada? pq?

Provavelmente você está colocando o parição errada, poste a saida do comando ;
Código: [Selecionar]
sudo fdisk -l

Obs: o l é em minúsculo ok
"Linux User" # 480186 

Kubuntu 11.04 kernel 2.6.38.8-ck3 kde 4.6.4

Offline clcampos

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 10.790
  • .:: User Linux #439596 ::.
    • Ver perfil
Re: Meu Ubuntu não inicia
« Resposta #11 Online: 14 de Maio de 2010, 14:26 »
Também acho que a partição /dev/sda1 é sua swap. Faça o que disse o colega overlock@ para podermos ajudar melhor.
Cristiano/Timóteo - MG
.: Como Fazer Perguntas de Forma Inteligente :.                
Com dúvida? pesquise!

Offline ptkrr

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
    • PTKGames.com
Re: Meu Ubuntu não inicia
« Resposta #12 Online: 15 de Maio de 2010, 12:35 »
Apareceu isso:

Código: [Selecionar]
ubuntu@ubuntu:~$ sudo fdisk -l

Disco /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador do disco: 0xfe8afe8a

Dispositivo Boot Início Fim Blocos Id Sistema
/dev/sda1   *           1         365     2931831   82  Linux swap / Solaris
/dev/sda2             366        9729    75216330    5  Estendida
/dev/sda5             366        9729    75216298+  83  Linux

Disco /dev/sdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador do disco: 0xde65ccee

Dispositivo Boot Início Fim Blocos Id Sistema
/dev/sdb1               1        9729    78148161    b  W95 FAT32

« Última modificação: 15 de Maio de 2010, 12:40 por ptkrr »

Offline ptkrr

  • Usuário Ubuntu
  • *
  • Mensagens: 10
    • Ver perfil
    • PTKGames.com
Re: Meu Ubuntu não inicia
« Resposta #13 Online: 15 de Maio de 2010, 12:41 »
Código: [Selecionar]
ubuntu@ubuntu:~$ sudo fsck /dev/sda5
fsck de util-linux-ng 2.16
e2fsck 1.41.9 (22-Aug-2009)
/dev/sda5 is mounted.  

WARNING!!!  Running e2fsck on a mounted filesystem may cause
SEVERE filesystem damage.

Do you really want to continue (y/n)? yes

/dev/sda5: recuperando 'journal'
/dev/sda5 contains a file system with errors, check forced.
Pass 1: Checking inodes, blocks, and sizes
Inodes that were part of a corrupted orphan linked list found.  Corrigir<y>? yes

Inode 233824 was part of the orphaned inode list.  Fixo.
Inode 235559 was part of the orphaned inode list.  Fixo.
Inode 236344 was part of the orphaned inode list.  Fixo.
Inode 236372 was part of the orphaned inode list.  Fixo.
Inode 236461 was part of the orphaned inode list.  Fixo.
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Block bitmap differences:  -1025600 -1150135 -(1150138--1150145) -(1150320--1150327) -1445670 -(1445672--1445679) -(1445767--1445770) -(1445789--1445796)
Corrigir<y>? yes

Free blocks count wrong for group #31 (26334, counted=26335).
Corrigir<y>? yes

Free blocks count wrong for group #35 (23499, counted=23516).
Corrigir<y>? yes

Free blocks count wrong for group #44 (13777, counted=13798).
Corrigir<y>? yes

Free blocks count wrong for group #208 (24231, counted=24232).
Corrigir<y>? yes

Free blocks count wrong for group #209 (21362, counted=21522).
Corrigir<y>? yes

Free blocks count wrong (13403847, counted=13404047).
Corrigir<y>? yes

Inode bitmap differences:  -233824 -235559 -236344 -236372 -236461 -236764 -236839 -236875 -236877 -236889 -236911 -236913 -237043 -237155
Corrigir<y>? yes

Free inodes count wrong for group #28 (9, counted=23).
Corrigir<y>? yes

Free inodes count wrong for group #208 (8028, counted=8039).
Corrigir<y>? yes

Directories count wrong for group #208 (50, counted=49).
Corrigir<y>? yes

Free inodes count wrong (4463138, counted=4463163).
Corrigir<y>? yes


/dev/sda5: ***** FILE SYSTEM WAS MODIFIED *****
/dev/sda5: 239045/4702208 files (0.3% non-contiguous), 5400027/18804074 blocks

Funcionando!  :D

Obrigado!
« Última modificação: 15 de Maio de 2010, 13:09 por ptkrr »