Autor Tópico: 3G com modem ONDA MSA501HS no 10.4  (Lida 3952 vezes)

Offline miracco

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
3G com modem ONDA MSA501HS no 10.4
« Online: 30 de Maio de 2010, 10:59 »
Olá pessoal,
A respeito do  modem ONDA MSA501HS para conectar a rede 3G utilizando a versão  10.4 do Ubuntu...
utilizei esse modem sem problemas no 9,04 e também, com algumas alterações no 8,04.
Já no 10.4 o sistema nem mesmo detecta o modem.
Alguma dica?
Abraços,

Offline dtomadon

  • Usuário Ubuntu
  • *
  • Mensagens: 591
  • Fatec SCS,Segurança da Informação, BackTrack5
    • Ver perfil
    • Computação Forense e suas Leis
Re: 3G com modem ONDA MSA501HS no 10.4
« Resposta #1 Online: 30 de Maio de 2010, 11:33 »
Mano ,meu modem é o mesmo que o seu , tive problema também  tentei seguir o mine tuto que o zekkerj criou e nada
ainda tenho probemas , tenho que iniciar o micro com ele plugado aí rola, tnta o que ele propos o tuto tá nessa mesma seção só que modem ms401 ou 405 não me lembro bem, se não funcionar retorna aí.
BacKTrack5 64 bits com Vídeo SIS

kernel omnislash 1.4.4 64 bits , Que venha o 5º Semestre !!!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: 3G com modem ONDA MSA501HS no 10.4
« Resposta #2 Online: 30 de Maio de 2010, 11:41 »
http://ubuntuforum-pt.org/index.php/topic,62590.msg372284.html#msg372284

Pra não dizer que vai às mil maravilhas, estou com postando dele agora, mas pelo wvdial...

Não sei se já ficou claro pra galera, mas eu uso Kubuntu, e não o Ubuntu. Na migração pro Lucid, também tive problemas pra ativar o modem (no link acima vem a solução pra isso).

Como frontend, eu usava o "knetworkmanager", mas ele começou a me dar vários problemas, ontem resolvi trocá-lo pelo "plasma-widget-networkmanager" --- e daí o modem não conecta mais  >:( ---. Só na base do wvdial, até eu descobrir o pq. :-[

Mas tá conectando, e isso tá salvando minha vida, pois estou fora de casa...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline dtomadon

  • Usuário Ubuntu
  • *
  • Mensagens: 591
  • Fatec SCS,Segurança da Informação, BackTrack5
    • Ver perfil
    • Computação Forense e suas Leis
Re: 3G com modem ONDA MSA501HS no 10.4
« Resposta #3 Online: 30 de Maio de 2010, 12:16 »
http://ubuntuforum-pt.org/index.php/topic,62590.msg372284.html#msg372284

Pra não dizer que vai às mil maravilhas, estou com postando dele agora, mas pelo wvdial...

Não sei se já ficou claro pra galera, mas eu uso Kubuntu, e não o Ubuntu. Na migração pro Lucid, também tive problemas pra ativar o modem (no link acima vem a solução pra isso).

Como frontend, eu usava o "knetworkmanager", mas ele começou a me dar vários problemas, ontem resolvi trocá-lo pelo "plasma-widget-networkmanager" --- e daí o modem não conecta mais  >:( ---. Só na base do wvdial, até eu descobrir o pq. :-[

Mas tá conectando, e isso tá salvando minha vida, pois estou fora de casa...

Zekkerj , uso gnome no 10.04 e o mesmo problema não descobri porque ainda o network manager funciona a hora que quer,
inicio com o modem plugado aí rola, as vezes nem isso , mas pelo dmesg vejo a emulação do modem, tô  procura da solução mas tá difícil, ainda não tive que recorrer ao wvdial , mas se necessário farei.
BacKTrack5 64 bits com Vídeo SIS

kernel omnislash 1.4.4 64 bits , Que venha o 5º Semestre !!!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: 3G com modem ONDA MSA501HS no 10.4
« Resposta #4 Online: 30 de Maio de 2010, 12:48 »
Esse é o script do wvdial que eu estou usando:

Código: [Selecionar]
[Dialer Defaults]

[Dialer TimWeb]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Baud = 9600
New PPPD = yes
Modem = /dev/ttyUSB2
ISDN = 0
; Phone = <Target Phone Number>
; Password = <Your Password>
; Username = <Your Login Name>
Phone = *99***1#
Username = Tim
Password = tim

Ele ainda está incompleto, eu tinha outro que estava mais completo mas foi perdido junto com a partição do Kubuntu 9.10 numa barbeiragem que fiz, na hora de atualizar o sistema...  >:( :-[ :'(
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline dtomadon

  • Usuário Ubuntu
  • *
  • Mensagens: 591
  • Fatec SCS,Segurança da Informação, BackTrack5
    • Ver perfil
    • Computação Forense e suas Leis
Re: 3G com modem ONDA MSA501HS no 10.4
« Resposta #5 Online: 30 de Maio de 2010, 13:03 »
Esse é o script do wvdial que eu estou usando:

Código: [Selecionar]
[Dialer Defaults]

[Dialer TimWeb]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = Analog Modem
Baud = 9600
New PPPD = yes
Modem = /dev/ttyUSB2
ISDN = 0
; Phone = <Target Phone Number>
; Password = <Your Password>
; Username = <Your Login Name>
Phone = *99***1#
Username = Tim
Password = tim

Ele ainda está incompleto, eu tinha outro que estava mais completo mas foi perdido junto com a partição do Kubuntu 9.10 numa barbeiragem que fiz, na hora de atualizar o sistema...  >:( :-[ :'(

Já tentou usar o comando testdisk esse programinha é porreta pra recuperar dados inclusive partições perdidas. tenta aí depois retorna
BacKTrack5 64 bits com Vídeo SIS

kernel omnislash 1.4.4 64 bits , Que venha o 5º Semestre !!!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: 3G com modem ONDA MSA501HS no 10.4
« Resposta #6 Online: 30 de Maio de 2010, 13:17 »
Inês é morta e enterrada, e a partição já está em uso de novo.

Melhor investir no chaveamento do modem, pq depois de virado, ele pode conectar tanto pelo NM quanto pelo wvdial.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline dtomadon

  • Usuário Ubuntu
  • *
  • Mensagens: 591
  • Fatec SCS,Segurança da Informação, BackTrack5
    • Ver perfil
    • Computação Forense e suas Leis
Re: 3G com modem ONDA MSA501HS no 10.4
« Resposta #7 Online: 30 de Maio de 2010, 13:30 »
Inês é morta e enterrada, e a partição já está em uso de novo.

Melhor investir no chaveamento do modem, pq depois de virado, ele pode conectar tanto pelo NM quanto pelo wvdial.

Apaguei minha partição do linux e uma fat32 , recuperi muita coisa com ele , mas sei lá se for algo muito importante vale a pena..!!
BacKTrack5 64 bits com Vídeo SIS

kernel omnislash 1.4.4 64 bits , Que venha o 5º Semestre !!!

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: 3G com modem ONDA MSA501HS no 10.4
« Resposta #8 Online: 30 de Maio de 2010, 15:50 »
Peguei umas dicas aqui e acolá, e agora estou usando o wvdial.conf assim:

Código: [Selecionar]
[Dialer Default]
Modem = /dev/ttyUSB2
Init1 = ATZ
Init2 = AT+CGDCONT=1,"IP","www.tim.com.br"
Init3 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Baud = 3600000
Phone = *99***1#
New PPPD = yes
Dial Command = ATD
Username = tim
Password = tim
Dial Command = ATDT
Stupid Mode = 1
ISDN = 0

A conexão está bem mais ágil.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D