Autor Tópico: Notebook da CCE - quase 100%  (Lida 5763 vezes)

Offline daigorobr

  • Usuário Ubuntu
  • *
  • Mensagens: 27
    • Ver perfil
Notebook da CCE - quase 100%
« Online: 17 de Outubro de 2007, 09:36 »
Esta mensagem foi postada ontem por mim no fórum do Clube do Hardware, mas acho que terá mais relevância aqui.

Uso um notebook CCE C2H4, equivalente ao L41ii da Uniwill, Olidata e ao Superlight Phantom da Gericom. Uso a BIOS deste último (procurando neste thread se encontra o link).

Instalando o Ubuntu Gutsy Gibbon (7.10 - será lançado oficialmente em dois dias, mas já dá pra baixar o Release Candidate), quase tudo funciona "da caixa", só faltam alguns ajustes finos:

1. Apesar do wireless funcionar direto (via rt73usb), a instabilidade ainda me joga a usar o ndiswrapper. Lembrar de adicionar as seguintes linhas de configuração:
Em "/etc/modprobe.d/blacklist":
Código: [Selecionar]
blacklist rt73usbE em "/etc/modules":
Código: [Selecionar]
ndiswrapper
2. Para o som funcionar 100%, insiro a seguinte linha no arquivo "/etc/modprobe.d/alsa-base":
Código: [Selecionar]
options snd-hda-intel model=acer-aspire
3. O vídeo já instala com os drivers corretos e a resolução de 1280x800.Para TV-out e VGA-out, deve ser acrescida a seguinte configuração:
Adicionar a seguinte linha à subseção "Screen -> Display" do arquivo "/etc/X11/xorg.conf":
Código: [Selecionar]
Virtual       2048      2048E usar os seguintes comandos de shell:
Para TV-out:
Código: [Selecionar]
xrandr --output TV --mode 640x480 --right-of LVDS(notar que a resolução pode ir até 1024x768 e a TV não precisa estar necessariamente à direita do notebook)

Para VGA-out:
Código: [Selecionar]
xrandr --output VGA --mode 1024x768 --below LVDS(por limitações de hardware, o tamanho virtual máximo é 2048x2048 e o VGA só funciona em Xinerama com o Compiz ligado se estiver abaixo ou acima do LVDS - virtualmente, é claro)

Outros comandos podem ser aprendidos na página de manual do xrandr:
Código: [Selecionar]
man xrandr
Faltam 3 coisas para ficar perfeito:
1. Ainda não testei o firewire, mas relatos por aí dizem que este chipset funciona redondo;
2. Ainda não me dediquei a fazer o winmodem funcionar, mas já achei até mesmo as discussões do cara da Insigne com o pessoal do driver sl-modem, provavelmente da época que eles estavam preparando o Insigne - com certeza dá pra fazer;
3. O leitor de cartões ainda só lê MMC e SD. Os drivers para a leitura de MS e xD ainda estão pré-alpha e sem funcionalidade.

Bem, tirando o modem e o leitor de cartões, tudo funciona redondo. O tempo de configuração total é de uns 15 minutos se você estiver em uma rede lenta (para baixar o ndiswrapper e editar os 4 arquivos de configurações citados ali em cima). E praticamente tudo é funcional durante este serviço.
Só pra baixar os drivers de windows, o cara vai levar a noite toda se estiver em uma rede ruim. Além de que absolutamente nada vai funcionar de cara, sem instalar drivers.

Bem bom, me parece...

Offline nyex

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
    • Forsit
Re: Notebook da CCE - quase 100%
« Resposta #1 Online: 01 de Dezembro de 2007, 12:36 »
eu estou com um cce aqui, e tudo funciona lindo e tal. mas a rede sem fio está muito instável. vez ou outra ela morre e eu tenho que reiniciar pra voltar tudo ao normal (aliás, tenho que desligar e ligar, nem reiniciar serve).

a rede sem fio foi reconhecida automaticamente pelo gutsy e eu não precisei fazer nada para ela funcionar. desse jeito que está funcionando.

não sei qual é a placa porque quando faço o lspci não aparece nada de Network.

será que você não sabe como resolver isso? :D
E quando tudo mais falhar, finja de morto.

Offline alexmatos

  • Usuário Ubuntu
  • *
  • Mensagens: 792
  • Arch Linux / Ubuntu 7.04
    • Ver perfil
Re: Notebook da CCE - quase 100%
« Resposta #2 Online: 01 de Dezembro de 2007, 13:24 »
eu estou com um cce aqui, e tudo funciona lindo e tal. mas a rede sem fio está muito instável. vez ou outra ela morre e eu tenho que reiniciar pra voltar tudo ao normal (aliás, tenho que desligar e ligar, nem reiniciar serve).

a rede sem fio foi reconhecida automaticamente pelo gutsy e eu não precisei fazer nada para ela funcionar. desse jeito que está funcionando.

não sei qual é a placa porque quando faço o lspci não aparece nada de Network.

será que você não sabe como resolver isso? :D

Você instalou a wireless via NDISwrapper?

Offline daigorobr

  • Usuário Ubuntu
  • *
  • Mensagens: 27
    • Ver perfil
Re: Notebook da CCE - quase 100%
« Resposta #3 Online: 04 de Dezembro de 2007, 20:06 »
Eu usei ndis por um motivo básico: o módulo rt73usb *não reconecta* quando a rede wifi cai por algum motivo qualquer, tenho de dar boot ou usar um rmmod seguido de um novo modprobe.

Outra coisa: esquci de dizer ali que tem de instalar o pacote linux-backported-modules pro som funcionar 110%

Offline Pierre

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Notebook da CCE - quase 100%
« Resposta #4 Online: 02 de Janeiro de 2008, 14:11 »
eu estou com um cce aqui, e tudo funciona lindo e tal. mas a rede sem fio está muito instável. vez ou outra ela morre e eu tenho que reiniciar pra voltar tudo ao normal (aliás, tenho que desligar e ligar, nem reiniciar serve).

a rede sem fio foi reconhecida automaticamente pelo gutsy e eu não precisei fazer nada para ela funcionar. desse jeito que está funcionando.

não sei qual é a placa porque quando faço o lspci não aparece nada de Network.

será que você não sabe como resolver isso? :D

Você instalou a wireless via NDISwrapper?

Alguém tem a solução disso?
tenho um CCE e não usei o NDISwrapper, pois ele reconheceu a rede sozinho.
acontece que não fica no as mais de 5min.
logo cai e não volta mais.

Alguém sabe se usando o NDISwrapper pode resolver? e qual o driver devo usar?

TKX