Autor Tópico: Problema com pacote não totalmente instalados ou removidos  (Lida 2801 vezes)

Offline _4NDV_

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Problema com pacote não totalmente instalados ou removidos
« Online: 18 de Junho de 2010, 16:15 »
Sempre aparece isso quando eu tento fazer o apt-get upgrade.

Existe alguma forma de arrumar?


~$ sudo apt-get upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0B adicionais de espaço em disco serão usados.
Você quer continuar [S/n]?
Configurando linux-image-2.6.32-22-generic (2.6.32-22.36) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.32-22-generic
Not updating initrd symbolic links since we are being updated/reinstalled
(2.6.32-22.33 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(2.6.32-22.33 was configured last, according to dpkg)
Could not find postinst hook script [update-grub].
Looked in: '/bin', '/sbin', '/usr/bin', '/usr/sbin'
dpkg: erro processando linux-image-2.6.32-22-generic (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 2
Erros foram encontrados durante o processamento de:
 linux-image-2.6.32-22-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)



Offline web2000

  • Usuário Ubuntu
  • *
  • Mensagens: 360
  • Rafael A. de Almeida
    • Ver perfil
    • Meu canal no YouTube
Re: Problema com pacote não totalmente instalados ou removidos
« Resposta #1 Online: 19 de Junho de 2010, 05:55 »
Tenta isso:
Código: [Selecionar]
sudo apt-get install -f

Offline _4NDV_

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Problema com pacote não totalmente instalados ou removidos
« Resposta #2 Online: 19 de Junho de 2010, 12:23 »
Olá, web2000.

Grato pela resposta.

executei o comando e apareceu isso:

Citar
~$ sudo apt-get install -f
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0B adicionais de espaço em disco serão usados.
Configurando linux-image-2.6.32-22-generic (2.6.32-22.36) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.32-22-generic
Not updating initrd symbolic links since we are being updated/reinstalled
(2.6.32-22.33 was configured last, according to dpkg)
Not updating image symbolic links since we are being updated/reinstalled
(2.6.32-22.33 was configured last, according to dpkg)
Could not find postinst hook script [update-grub].
Looked in: '/bin', '/sbin', '/usr/bin', '/usr/sbin'
dpkg: erro processando linux-image-2.6.32-22-generic (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 2
Erros foram encontrados durante o processamento de:
 linux-image-2.6.32-22-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

e continua do mesmo jeito, dá a mesma mensagem de antes quando eu faço o sudo apt-get upgrade