Autor Tópico: Problema com wireless, Realtek RTL8187B.  (Lida 14988 vezes)

Offline _bruninha

  • Usuário Ubuntu
  • *
  • Mensagens: 65
    • Ver perfil
Problema com wireless, Realtek RTL8187B.
« Online: 21 de Junho de 2010, 02:08 »
Tenho ubuntu 10.04 64bits instalado em dual boot no meu notebook.

E quando eu uso o Ubuntu só consigo me conectar a internet se eu estiver do lado do roteador wireless, se eu ficar 5 metros longe do roteador ele não conecta mais, ele detecta a rede mas fica tentando conectar e não consegue mesmo o sinal do wireless ficando sempre acima dos 90%. E no windows isso não acontece consigo usar o wireless na minha casa inteira.

A placa do notebook é uma Realtek RTL8187B.

Como posso fazer para resolver esse problema ? Alguém pode me dar uma ajuda?

bejo a todos.

Ubuntu 10.04 \o/

Offline web2000

  • Usuário Ubuntu
  • *
  • Mensagens: 360
  • Rafael A. de Almeida
    • Ver perfil
    • Meu canal no YouTube
Re: Problema com wireless, Realtek RTL8187B.
« Resposta #1 Online: 21 de Junho de 2010, 05:29 »

libonati

  • Visitante
Re: Problema com wireless, Realtek RTL8187B.
« Resposta #2 Online: 21 de Junho de 2010, 09:06 »
Tenho a impressão que o pessoal da Microssoft está fazendo isso de propósito pra você tentar desinstalar o ubuntu. Ainda bem que você não conseguiu..heehehh. Posta os comandos:
lspci
modelo do modem
modelo do roteador
internet cabo? adsl? (pelo modem dá pra descobrir, mas pode estar errado)

Quer saber mais? Acho que você vai se apaixonar pelo pinguim...rrsrsr

Offline _bruninha

  • Usuário Ubuntu
  • *
  • Mensagens: 65
    • Ver perfil
Re: Problema com wireless, Realtek RTL8187B.
« Resposta #3 Online: 21 de Junho de 2010, 17:53 »
Essa dica deu certo para muita gente:
http://ubuntuforum-br.org/index.php/topic,51025.msg365358.html#msg365358

Segui a dica do tópico acima só que não funcinou não, agora parou de reconhecer a minha rede sem fio.
Como eu volto as confifuração anteriores?

mais alguma ideia de como fazer funcionar?
Ubuntu 10.04 \o/

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.425
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema com wireless, Realtek RTL8187B.
« Resposta #4 Online: 22 de Junho de 2010, 01:57 »
Você chegou a instalar o driver ndiswrapper? Reiniciou o sistema após fazer isso?

Pode postar a saída dos comandos abaixo?

lsmod | egrep -i "ndis|8187"
sudo lshw -C network
nm-tool
iwconfig wlan0
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline _bruninha

  • Usuário Ubuntu
  • *
  • Mensagens: 65
    • Ver perfil
Re: Problema com wireless, Realtek RTL8187B.
« Resposta #5 Online: 22 de Junho de 2010, 03:52 »
Você chegou a instalar o driver ndiswrapper? Reiniciou o sistema após fazer isso?

Pode postar a saída dos comandos abaixo?

lsmod | egrep -i "ndis|8187"
sudo lshw -C network
nm-tool
iwconfig wlan0


Instalei sim o driver com ndiswrapper e reiniciei o sitema.

Aqui estão as saidas dos comandos acima.

Código: [Selecionar]
ubuntu@ubuntu:~$ lsmod | egrep -i "ndis|8187"
rtl8187                50680  0
mac80211              204922  1 rtl8187
cfg80211              126485  2 rtl8187,mac80211
eeprom_93cx6            1333  1 rtl8187
led_class               2864  2 rtl8187,sdhci
ubuntu@ubuntu:~$


ubuntu@ubuntu:~$ sudo lshw -C network
  *-network              
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:0a:00.0
       logical name: eth0
       version: 02
       serial: 00:03:0d:ea:ea:8a
       size: 10MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half latency=0 link=no multicast=yes port=MII speed=10MB/s
       resources: irq:30 ioport:6000(size=256) memory:fa000000-fa000fff memory:f4000000-f400ffff(prefetchable) memory:f4020000-f403ffff(prefetchable)
  *-network
       description: Wireless interface
       physical id: 4
       logical name: wlan0
       serial: 70:1a:04:85:06:5d
       capabilities: ethernet physical wireless
       configuration: broadcast=yes multicast=yes wireless=IEEE 802.11bg
ubuntu@ubuntu:~$


ubuntu@ubuntu:~$ nm-tool

NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        00:03:0D:EA:EA:8A

  Capabilities:
    Carrier Detect:  yes
    Speed:           10 Mb/s

  Wired Properties
    Carrier:         off


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            rtl8187
  State:             disconnected
  Default:           no
  HW Address:        70:1A:04:85:06:5D

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points
    Local_Brunaa:    Infra, 00:23:CD:F4:CF:32, Freq 2437 MHz, Rate 54 Mb/s, Strength 62 WPA2
    SUPERNET:        Infra, 00:15:6D:FC:01:19, Freq 2412 MHz, Rate 54 Mb/s, Strength 60 WPA

ubuntu@ubuntu:~$ iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:"Local_Bruna"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated  
          Tx-Power=20 dBm  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

Mas ainda não consigo fazer funcionar, só funciona se eu estiver do lado do roteador.
« Última modificação: 22 de Junho de 2010, 03:55 por _bruninha »
Ubuntu 10.04 \o/

libonati

  • Visitante
Re: Problema com wireless, Realtek RTL8187B.
« Resposta #6 Online: 22 de Junho de 2010, 08:05 »
zekkerj, isso aconteceu com meu vizinho. Desconfio que ela não está com modem/roteador apropriado para suporte de internet dela (cable/modem - adsl). Mesmo por que perto a internet funciona.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.425
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema com wireless, Realtek RTL8187B.
« Resposta #7 Online: 22 de Junho de 2010, 10:15 »
Citar
Instalei sim o driver com ndiswrapper e reiniciei o sitema.

Aqui estão as saidas dos comandos acima.
Código: [Selecionar]
ubuntu@ubuntu:~$ lsmod | egrep -i "ndis|8187"
rtl8187                50680  0
mac80211              204922  1 rtl8187
cfg80211              126485  2 rtl8187,mac80211
eeprom_93cx6            1333  1 rtl8187
led_class               2864  2 rtl8187,sdhci
ubuntu@ubuntu:~$
Não, o driver ndis não está carregado... e quem está carregado é o driver nativo.

Provavelmente vc pulou o passo onde vc bloqueia o driver nativo, adicionando o nome do módulo ("rtl8187") ao arquivo "/etc/modprobe.d/blacklist.conf". Vc também não forçou a carga do driver ndiswrapper, adicionando esse módulo ao arquivo "/etc/modules".

Citar
Desconfio que ela não está com modem/roteador apropriado para suporte de internet dela
Não acredito que seja isso não, libonati. Até porque não tem muito o que fugir, ou o roteador é 802.11g, e tem que funcionar com qualquer outro produto 802.11g (mesmo sendo algum desses produtos de 108 ou 150Mbps), ou é 802.11n, e tem que funcionar em modo de compatibilidade.

No máximo o que poderia se ter seriam alguns produtos ruins, como o DLink DI-524 de 54Mbps, que tem sinal muito fraco. Mas nesse caso, ela perceberia o problema tanto no linux quanto no windows, e já teria deixado isso claro.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

libonati

  • Visitante
Re: Problema com wireless, Realtek RTL8187B.
« Resposta #8 Online: 22 de Junho de 2010, 14:43 »
Uma referência para ajudar no que possa, embora tenha sido para o 9.4 ( pessoalmente não tive a oportunidade de testar).

"Para fazer funcionar a placa de rede wireless RTL8187SE, deve-se usar o driver da RTL8187b emulado pelo ndiswrapper / ndisgtl (GUI)".

Referência:
http://www.vivaolinux.com.br/artigo/Configurando-a-placa-de-rede-wireless-RTL8187-no-Ubuntu-9.04?pagina=2

Offline _bruninha

  • Usuário Ubuntu
  • *
  • Mensagens: 65
    • Ver perfil
Re: Problema com wireless, Realtek RTL8187B.
« Resposta #9 Online: 22 de Junho de 2010, 14:47 »
Olá, zekkerj eu segui exatamente todos os passos abaixo.

Pra fazer o teste é simples, instale o ndiswrapper com um
Código: [Selecionar]
sudo apt-get install ndiswrapper-utils-1.9Adquira o driver do windows .inf e instale com o ndiswrapper
Código: [Selecionar]
sudo ndiswrapper -i RTL8187B.INFRemover o driver nativo do linux
Código: [Selecionar]
sudo rmmod rtl8187Carregar o ndiswrapper com o driver do windows
Código: [Selecionar]
sudo modprobe ndiswrapper
Como eu faço então para desabilitar o driver nativo do linux, e carregar o novo driver?

O meu roteador wireless é um TP-LINK TL-WR541G / TL-WR542G.

obrigado pela ajuda meninos.
Ubuntu 10.04 \o/

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.425
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema com wireless, Realtek RTL8187B.
« Resposta #10 Online: 22 de Junho de 2010, 14:57 »
Citar
Como eu faço então para desabilitar o driver nativo do linux, e carregar o novo driver?

Como eu disse antes...
Código: [Selecionar]
Provavelmente vc pulou o passo onde vc bloqueia o driver nativo, adicionando o nome do módulo ("rtl8187") ao arquivo "/etc/modprobe.d/blacklist.conf". Vc também não forçou a carga do driver ndiswrapper, adicionando esse módulo ao arquivo "/etc/modules".
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline _bruninha

  • Usuário Ubuntu
  • *
  • Mensagens: 65
    • Ver perfil
Re: Problema com wireless, Realtek RTL8187B.
« Resposta #11 Online: 22 de Junho de 2010, 15:14 »
oie zekkerj

 poderia me ajudar com um passo-a-passo de como eu faço isso, é a primeira vez que vou fazer isso eu não sei como.

Código: [Selecionar]
Provavelmente vc pulou o passo onde vc bloqueia o driver nativo, adicionando o nome do módulo ("rtl8187") ao arquivo "/etc/modprobe.d/blacklist.conf". Vc também não forçou a carga do driver ndiswrapper, adicionando esse módulo ao arquivo "/etc/modules".
desculpa pedir tanto.
Ubuntu 10.04 \o/

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.425
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema com wireless, Realtek RTL8187B.
« Resposta #12 Online: 22 de Junho de 2010, 15:50 »
Bruna, o passo-a-passo está lá, nas minhas duas últimas mensagens:

1. Adicionar o nome do módulo "rtl8187" ao arquivo /etc/modprobe.d/blacklist.conf.
2. Adicionar o módulo ndiswrapper ao arquivo /etc/modules.

Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline _bruninha

  • Usuário Ubuntu
  • *
  • Mensagens: 65
    • Ver perfil
Re: Problema com wireless, Realtek RTL8187B.
« Resposta #13 Online: 22 de Junho de 2010, 16:02 »
não consegui fazer a segunda parte

Código: [Selecionar]
2. Adicionar o módulo ndiswrapper ao arquivo /etc/modules.
Ubuntu 10.04 \o/

Offline _bruninha

  • Usuário Ubuntu
  • *
  • Mensagens: 65
    • Ver perfil
Re: Problema com wireless, Realtek RTL8187B.
« Resposta #14 Online: 22 de Junho de 2010, 16:50 »
Muito obrigado a todos que me ajudaram aqui. Com a ajuda de vocês consegui resolver o problema, agora está funcionando perfeitamente. \o/

Um obrigado especial para o zekkerj e libonati.
Ubuntu 10.04 \o/