Autor Tópico: Instalando o Ubuntu usando placas de Vídeo ATI Radeon  (Lida 33056 vezes)

Offline edurm

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Online: 06 de Junho de 2006, 10:21 »
Instalando o Ubuntu 6.06 com ATI Radeons


Após vários problemas para fazer o Ubuntu funcionar na minha radeon X800GTO eu finalmente consegui resolver todos os problemas


*Esses passos vão servir para todas as radeons X200 X300 X500 X550 X600 X700 X800 X850 series ou mesmo as mais novas X1300 X1600 X1800 X1900 series, e também outras placas de vídeo que não conseguirem iniciar o ambiente gráfico


Se você ao bootar o cd do ubuntu chegou nessa tela:



que eu chamo de:
"Ubuntu Xserver Screen of Death"


Isso aconteçe por incompatilidade de drives, para resolver esse problema é relativamente simples:


1) digite: sudo nano /etc/X11/xorg.conf  (lembre-se que o linux é case sensitive)

2) Onde está driver "ati" mude para "vesa" e aperte Ctrl+x, dê enter para sobrescrever o arquivo

agora você vai conseguir carregar o "X", para isto basta digitar: startx

3) Se vc estiver usando o cd do ubuntu 6.06 no desktop vai ter um ícone chamado install, a partir desse ícone vocÊ pode dar inicio a intalação do linux no seu hd. *Como o GDM não terminou de carregar corretamente ao clicar para reiniciar o sistema após a instalação você vai voltar para o terminal, basta digitar sudo shutdown -r "now" o sistema vai re-iniciar e depois vc nao vai mais ter esse problema




Instalando os novos drives fglx para as placas ati e corrigindo o problema com o refresh rate

Se você é o "feliz" proprietário de uma ATI nesse momento seu vídeo está configurado para "vesa" que é mais ou menos o mesmo padrão gráfico dos primeiros computadores 386, não precisa nem falar nada ... seu refresh rate vai estar travado em 60hz


para instalar os drives próprios e atualizados da ati faça os seguintes passos:


1. Abra o synaptic
2. Procure por fglrx
3. Marque xorg-driver-fglrx e fglrx-control
4. Aplique as mudancas (ira baixar os pacotes e instalar)
5. Abra um terminal
6. sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup (fazer um backup por seguranca)
7. sudo gedit /etc/X11/xorg.conf
8. Na secao "device" troque driver = "vesa" ou "ATI" para driver = "fglrx"
9. Salve
10. ctrl+alt+backspace (reiniciar o X)

depois disso rodei o dpkg-reconfigure xserver-xorg e setei as resolucoes corretas

*dica encontrada no forum pt-br

*É imprescindivel fazer um backup do xorg.conf, no meu caso eu tive que restaurar os valores do keybord pois depois de rodar o dpkg-reconfigure xserver-xorg meu teclado abtn2 deixou de funcionar a "/" e ai foi só restaurar os valores e deu tudo certo


Agora aqui está rodando tudo redondinho com os drives fglrx e 1024x768 @85HZ


**Creio que o próximo passo agora que você conseguiu instalar o linux é instalar o Automatix que vai instalar ABSOLUTAMENTE TUDO o que você vai precisar em apenas alguns cliques

***Click here for see this topic in English

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.663
    • Ver perfil
Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Resposta #1 Online: 06 de Junho de 2006, 12:03 »
Movido para Dicas e Truques!
Kubuntu 19.04 64bits

Offline Pereirão

  • Usuário Ubuntu
  • *
  • Mensagens: 46
    • Ver perfil
Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Resposta #2 Online: 09 de Junho de 2006, 10:03 »
Essa dica serve também para a ATI Radeon 9600 pro ?

Estive tentando instalar o driver 3d da ATI por esse tutorial: http://wiki.cchtml.com/index.php/Ubuntu_Dapper_Installation_Guide, mas até agora não consegui fazer funcionar.
"Embora seja loucura, há método nela." (William Shakespeare)

Offline Pereirão

  • Usuário Ubuntu
  • *
  • Mensagens: 46
    • Ver perfil
Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Resposta #3 Online: 09 de Junho de 2006, 10:49 »
Tentei a sua dica e não funciona de jeito nenhum. Quando digito no termial fglrxinfo recebo:

Código: [Selecionar]
andre@andre-desktop:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)


Vi no forum gringo que algumas pessoas també tiveram esse problema. Tentei desinstalar e reinstalar, mas o resultado foi o mesmo. Minha placa é uma ATI RAdeon 9600 256 MB 128 bits. O meu processador é um Athlon 64 3000+, mas uso o Dapper 32 bits.
 
Você tem alguma idéia do que pode ser que está dando errado ?
"Embora seja loucura, há método nela." (William Shakespeare)

Offline sysop

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Resposta #4 Online: 12 de Junho de 2006, 01:13 »
Citação de: "Pereirão"
Tentei a sua dica e não funciona de jeito nenhum. Quando digito no termial fglrxinfo recebo:

Código: [Selecionar]
andre@andre-desktop:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)


Vi no forum gringo que algumas pessoas també tiveram esse problema. Tentei desinstalar e reinstalar, mas o resultado foi o mesmo. Minha placa é uma ATI RAdeon 9600 256 MB 128 bits. O meu processador é um Athlon 64 3000+, mas uso o Dapper 32 bits.
 
Você tem alguma idéia do que pode ser que está dando errado ?



Estou com o mesmo problema...só aparece este raio de Mesa !!!!

Ja testei todas as dicas aqui no forum e nada...e pior..preciso rodar aplicativos no meu notebook que precisar do driver bem instalado (tô rodando eles que nem uma lesma)

Eu tenho uma placa ATI 9000 IGP


Será que alguem ainda vai aparecer com uma solucao definitiva ?????????

Offline edurm

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Resposta #5 Online: 19 de Junho de 2006, 09:02 »
Eu achei um tópico no forum em inglês que parece resolver o problema do fglrx nas ATI 9XXX http://www.ubuntuforums.org/showthread.php?t=197471

Offline sysop

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Resposta #6 Online: 19 de Junho de 2006, 11:19 »
Citação de: "edurm"
Eu achei um tópico no forum em inglês que parece resolver o problema do fglrx nas ATI 9XXX http://www.ubuntuforums.org/showthread.php?t=197471


Eu vou tentar...pq acabei de crashar o meu ubuntu, tentando arrumar mais uma vez a aceleração 3D....

Offline cristo&oxalá

  • Usuário Ubuntu
  • *
  • Mensagens: 109
    • Ver perfil
Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Resposta #7 Online: 20 de Junho de 2006, 01:03 »
Citação de: "edurm"
Eu achei um tópico no forum em inglês que parece resolver o problema do fglrx nas ATI 9XXX http://www.ubuntuforums.org/showthread.php?t=197471


boa Edu...
a única coisa foi que tive que baixar o arquivo em http://www.ground-impact.com/libGL.so.1.2,
pois pegando da versão anterior, conforme indicado, não funcionou.

Offline jozecs

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Resposta #8 Online: 18 de Agosto de 2006, 09:01 »
Instalei o Dapper num AMD 64 com ATI RAdeon X300SE (PCI express) e não tive problema algum. A instalação reconheceu automaticamente a placa de vídeo sem precisar fazer qualquer alteração.
kubuntu 8.0.6 - AMD 64 3,2Ghz, Asus, ATI RAdeon X300SE PCI express 128Mb, 4Gb RAM.

Offline RaphaelSantos

  • Usuário Ubuntu
  • *
  • Mensagens: 89
    • Ver perfil
Re: Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Resposta #9 Online: 22 de Novembro de 2006, 11:09 »
Instalei o Dapper num AMD 64 com ATI RAdeon X300SE (PCI express) e não tive problema algum. A instalação reconheceu automaticamente a placa de vídeo sem precisar fazer qualquer alteração.
reconhecer a placa de video ele reconhece, mas ele usa os drivers open sources e nao tem aceleração 3D ativada...

Offline Shawn1355

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Resposta #10 Online: 18 de Dezembro de 2006, 05:47 »
eu fazendo a dica, qdo do startx meu pc praticamente morre, o monitor apAga e ele nao da nenhum sinal de vida :<

Offline Gilson Miranda

  • Usuário Ubuntu
  • *
  • Mensagens: 69
  • Temido pelos homens, amado pelas mulheres
    • Ver perfil
    • HARDPLUS
Re: Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Resposta #11 Online: 18 de Janeiro de 2007, 21:09 »
Oi pessoal,

Tenho uma Radeon X700 PCI-Express, também tive este problema ao instalar o ubuntu 6.10 64 bits, também segui a sugestão do edurm, mas o erro persistia, então, após voltar com o vídeo on-board, baixei e instalei os drivers fglrx e voltei novamente com o video X700. Ao invés de editar o xorg.conf, executei o $ sudo dpkg-reconfigure xserver-xorg, ai sim, deu para reconfigurar sem problemas o vídeo.

Agora que estou com os drivers 3D, como faço para usar os efeitos 3D do ubuntu desktop?
Temido pelos homens, amado pelas mulheres

Offline CharlesNoronha

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Resposta #12 Online: 06 de Fevereiro de 2007, 11:55 »
Eu também tenho uma x700, mais n tenho video onboard, eu segui todas as intruções descritas nesse topico.
Mais quando digito "startx", o monitor vai pra standby, e só reiniciando a tela volta ao normal, como faço pra resolver isso?

Offline Gilson Miranda

  • Usuário Ubuntu
  • *
  • Mensagens: 69
  • Temido pelos homens, amado pelas mulheres
    • Ver perfil
    • HARDPLUS
Re: Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Resposta #13 Online: 20 de Fevereiro de 2007, 13:02 »
Eu também tenho uma x700, mais n tenho video onboard, eu segui todas as intruções descritas nesse topico.
Mais quando digito "startx", o monitor vai pra standby, e só reiniciando a tela volta ao normal, como faço pra resolver isso?

Oi Charles,

quando você ligar o computador, antes de entrar no linux, pressione a tecla ESC para você cair em um menu de opções de boot, escolha a segunda opção e depois entre com a senha root (caso não tenha, não será necessário porque já cai no usuário root) ai você digita o comando: sudo dpkg-reconfigure xserver-xorg

Observação:

   BusID      "PCI:1:0:0" # <== caso o seu vídeo seja PCI-Express
Temido pelos homens, amado pelas mulheres

Offline talarico2

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: Instalando o Ubuntu usando placas de Vídeo ATI Radeon
« Resposta #14 Online: 28 de MAR?O de 2007, 22:57 »
desculpe amigos sou novo no forum e tambem no linux tenho uma ati x800GTO e nao compreendi uma coisa no tutorial onde é que eu digito o comando sudo nano... pois chego na tela que nosso amigo mencionou e pronto ?? por favor me ajudem quero começar a contribuir para a comunidade linux desde de ja agradeço a todos