Autor Tópico: [resolvido]problemas de conexão com modem 3G  (Lida 34820 vezes)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: [resolvido]problemas de conexão com modem 3G
« Resposta #60 Online: 29 de Junho de 2011, 10:58 »
É pq o daemon PPP precisa ser executado como root pra funcionar. Isso pode ser resolvido (perdendo segurança, diga-se de passagem) com o comando abaixo:

sudo chmod +s /usr/sbin/pppd

Mas vc não deve ter como objetivo final conectar pelo gnome-ppp, e sim conectar pelo Gerenciador de Redes.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Thiago_S

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: [resolvido]problemas de conexão com modem 3G
« Resposta #61 Online: 29 de Junho de 2011, 11:09 »
Está bem. Como resolver o problema frente o Gerenciador de Redes?
« Última modificação: 29 de Junho de 2011, 11:12 por Thiago_S »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: [resolvido]problemas de conexão com modem 3G
« Resposta #62 Online: 29 de Junho de 2011, 11:38 »
Primeiro temos que fazer os dispositivos do modem serem reconhecidos "do jeito certo", ou seja, como "ttyUSB0", "ttyUSB1", etc

Talvez isso passe por instalar uma nova versão do usb-modeswitch.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Thiago_S

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: [resolvido]problemas de conexão com modem 3G
« Resposta #63 Online: 29 de Junho de 2011, 12:42 »
A versão atual costa aqui http://www.draisberghof.de/usb_modeswitch/#download. Efetuei o download. Como instalar? Lhe agradeço pelo auxílio.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: [resolvido]problemas de conexão com modem 3G
« Resposta #64 Online: 29 de Junho de 2011, 13:25 »
E um arquivo ".tar.gz", você tem que compactá-lo e executar o comando "sudo make install" dentro da pasta descompactada. Mas pra instalação funcionar, você precisa de um arquivo que vem dentro do pacote "linux-headers-generic" da sua versão do kernel.

Outra coisa que você vai precisar é do pacote "usb-modeswitch-data", que você baixa no mesmo lugar. O procedimento de instalação é o mesmo.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Thiago_S

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: [resolvido]problemas de conexão com modem 3G
« Resposta #65 Online: 29 de Junho de 2011, 13:40 »
Mas pra instalação funcionar, você precisa de um arquivo que vem dentro do pacote "linux-headers-generic" da sua versão do kernel.

Instalei o  arquivo libusb-dev 0.1.12 e após o usb_modeswitch e  usb_modeswitch-data como sugerido. No entanto, não consta na Central de Programas e no Synaptic, as versões instaladas. :( Fiz algo de errado? Encontrei o pacote .deb (Debian) aqui http://packages.debian.org/sid/usb-modeswitch(Obs. Não o utilizei.).
« Última modificação: 29 de Junho de 2011, 14:02 por Thiago_S »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: [resolvido]problemas de conexão com modem 3G
« Resposta #66 Online: 29 de Junho de 2011, 14:42 »
Citar
No entanto, não consta na Central de Programas e no Synaptic, as versões instaladas.
É pq essas instalações não foram feitas pelo gerenciador de pacotes, e sim em pacote avulso.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Thiago_S

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: [resolvido]problemas de conexão com modem 3G
« Resposta #67 Online: 29 de Junho de 2011, 14:52 »
É pq essas instalações não foram feitas pelo gerenciador de pacotes, e sim em pacote avulso.

Compreendi. Meu modem não foi reconhecido via Gerenciador de Redes. :(

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: [resolvido]problemas de conexão com modem 3G
« Resposta #68 Online: 29 de Junho de 2011, 15:17 »
Continua funcionando via gnome-ppp?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Thiago_S

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: [resolvido]problemas de conexão com modem 3G
« Resposta #69 Online: 29 de Junho de 2011, 15:42 »
Desisti em fazer uso do gnome-ppp devido o que foi relatado por você (segurança). Via terminal (sudo wvdial) funciona normalmente.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: [resolvido]problemas de conexão com modem 3G
« Resposta #70 Online: 29 de Junho de 2011, 16:21 »
O problema de segurança não é no gnome-ppp, é no uso do daemon ppp em modo SUID. O wvdial faz uso do mesmo daemon, então ele é afetado do mesmo jeito.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Thiago_S

  • Usuário Ubuntu
  • *
  • Mensagens: 21
    • Ver perfil
Re: [resolvido]problemas de conexão com modem 3G
« Resposta #71 Online: 30 de Junho de 2011, 04:13 »
Compreendo. Continuarei a fazer uso do wvdial via terminal.