Autor Tópico: [Dica] Gnome Subtitles não reproduz / executa vídeo no XUbuntu 14.04  (Lida 5179 vezes)

Offline Sampayu

  • Usuário Ubuntu
  • *
  • Mensagens: 454
  • "Não é possível semear de mãos fechadas"
    • Ver perfil
    • YouTube
Após atualizar meu XUbuntu 32 bits da versão 12.04 para a 14.04, descobri que o aplicativo Gnome Subtitles parou de executar vídeos corretamente. Por exemplo: ao abrir um arquivo AVI, ele executa o áudio mas não executa o vídeo.

Esse problema ocorreu até 15/10/2014, porque o Gnome Subtitles presente nos repositórios oficiais da versão 14.04 do Ubuntu e variantes (XUbuntu, KUbuntu etc.) adotam o Gnome Subtitles versão 1.2, que depende do plugin ffmpeg para o GStreamer (pacote gstreamer0.10-ffmpeg), que no entanto não está presente nos repositórios da versão 14.04 do *Ubuntu.

No entanto, em 16/10/2014 o Pedro Castro (desenvolvedor do Gnome Subtitles) adicionou ao PPA oficial dele um pacote DEB do Gnome Subtitles versão 1.3 para sistemas GNU/Linux *Ubuntu 14.04. Eu já testei essa nova versão e ela está funcionando perfeitamente. :D

Segue o passo-a-passo para desinstalar o Gnome Subtitles que você porventura tenha instalado em seu sistema e em seguida adicionar o repositório oficial e instalar a versão mais nova desse aplicativo:

1) Entre no terminal ou (emulador de terminal) do shell e execute o comando abaixo, para desinstalar a versão antiga do Gnome Subtitles:
Código: [Selecionar]
sudo apt-get remove gnome-subtitles gstreamer0.10-ffmpeg
2) Adicione ao seu sistema o repositório PPA do Pedro Castro:
Código: [Selecionar]
sudo apt-add-repository ppa:pedrocastro/ppa
3) Agora atualize o cache do sistema de pacotes e instale a versão mais recente do Gnome Subtitles para *Ubuntu 14.04:
Código: [Selecionar]
sudo apt-get update && sudo apt-get check && sudo apt-get install gnome-subtitles
O PROCEDIMENTO ACABA AQUI. Só continue lendo caso queira tentar fazer funcionar o Gnome Subtitles "velho" que veio no repositório oficial da sua distribuição Linux!

>>>Nota: se por qualquer motivo você preferir usar a versão 1.2 (ou anterior) do Gnome Subtitles que consta no repositório oficial do seu sistema GNU/Linux, não siga os procedimentos acima. Ao invés disso, siga os procedimentos abaixo para tentar fazer o Gnome Subtitles funcionar com o ffmpeg para GStreamer:

1) Caso ainda não tenha instalado o Gnome Subtitles, instale-o com este comando:
Código: [Selecionar]
sudo apt-get update && sudo apt-get check && sudo apt-get install gnome-subtitles
2) Acesse este URL e faça download do arquivo gstreamer0.10-ffmpeg_0.10.13-5ubuntu1~trusty2_i386.deb (caso o seu sistema seja de 32 bits) ou então faça download do arquivo gstreamer0.10-ffmpeg_0.10.13-5ubuntu1~trusty2_amd64.deb (caso o seu sistema seja de 64 bits).

PS: um repositório alternativo é este, mantido pelo Jon Severinsson, um dos desenvolvedores que contribuem para os projetos Ubuntu e ffmpeg. Nesse repositório você verá os pacotes gstreamer0.10-ffmpeg_0.10.13-5~precise1_i386.deb (para sistemas de 32 bits) e gstreamer0.10-ffmpeg_0.10.13-5~precise1_amd64.deb (para sistemas de 64 bits). O primeiro repositório que informei está mais atualizado, mas este segundo tem maior reputação. Fica a seu critério ;)

3) Após o download, instale aquele pacote .DEB por intermédio do aplicativo GDebi: execute o GDebi, então clique em File (Arquivo), daí clique em Open (Abrir), selecione o arquivo .DEB que você acabou de obter, clique no botão Open (Abrir) e então clique no botão Install Package (Instalar Pacote). O GDebi irá pedir a senha do superusuário. Informe a senha e dê Enter: pronto, o pacote será instalado.

4) Agora feche o Gnome Subtitles (caso ele esteja aberto) e execute-o novamente. Tente abrir e executar um vídeo. Se tanto o áudio quanto o vídeo forem executados corretamente, o procedimento funcionou.

Caso você não possua o aplicativo GDebi instalado, execute este comando no terminal do shell e o GDebi será instalado:
Código: [Selecionar]
sudo apt-get install gdebi
Caso você não queria instalar o GDebi e/ou prefira instalar o pacote .DEB diretamente via terminal do shell, tudo o que você precisa fazer é executar o dpkg. Exemplo: digamos que você tenha feito download do pacote DEB para sistemas de 32 bits e que esse arquivo-pacote haja sido gravado em /home/bogus/Download/gstreamer0.10-ffmpeg_0.10.13-5ubuntu1~trusty2_i386.deb. Neste caso, para instalar esse pacote basta executar este comando, no terminal do shell:

Código: [Selecionar]
sudo dpkg -i /home/bogus/Download/gstreamer0.10-ffmpeg_0.10.13-5ubuntu1~trusty2_i386.deb
Agora feche o Gnome Subtitles (caso ele esteja aberto) e execute-o novamente. Tente abrir e executar um vídeo. Se tanto o áudio quanto o vídeo forem executados corretamente, o procedimento funcionou.

CASO A DICA ACIMA NÃO FUNCIONE

Se a dica acima não funcionar, uma alternativa é ver se este comando dá certo, no terminal do shell:

Código: [Selecionar]
sudo apt-get build-dep gnome-subtitles
O comando acima verificará todos os pacotes .DEB cuja instalação é indicada juntamente com o Gnome Subtitles. Quando o APT perguntar se deseja efetuar download e instalar todos os pacotes indicados, informe que sim (S). Espere o procedimento ser concluído e então veja se funcionou.

Se nada do que foi aqui exposto funcionar, é provável que haja alguma inconsistência dentro da sua distribuição Linux: talvez a versão do Gnome Subtitles requeira arquivos que não estão todos disponíveis nos repositórios da sua distribuição. Será necessário você investigar as versões dos arquivos. Por exemplo: acesse o website oficial do Gnome Subtitles, veja qual é a mais recente versão do aplicativo e confronte-a com a versão que está instalada no seu sistema.

O Gnome Subtitles depende do GStreamer para funcionar. Caso queira investigar se algum plugin ou biblioteca ffmpeg necessário para o GStreamer está faltando, execute este comando no terminal do shell:

Código: [Selecionar]
sudo apt-get build-dep gstreamer0.10 gstreamer1.0 --assume-no |grep ffmpeg
Se esse comando retornar alguma linha contendo a palavra ffmpeg, anote o nome do pacote .DEB que tem aquela palavra e instale-o. Exemplo fictício: digamos que no resultado do comando acima apareça o pacote gstreamer-plugin-ffmpeg. Neste caso, instale-o com este comando:

Código: [Selecionar]
sudo apt-get install gstreamer-plugin-ffmpeg
Caso o comando

Código: [Selecionar]
sudo apt-get build-dep gstreamer0.10 gstreamer1.0 --assume-no |grep ffmpeg
...não retorne resultado nenhum, mas seu Gnome Subtitles continue não executando vídeos e por isto você queira mesmo assim instalar todas as dependências indicadas para o GStreamer, retorne ao terminal do shell e execute este comando:

Código: [Selecionar]
sudo apt-get build-dep gstreamer0.10 gstreamer1.0 -y
Se isso também não funcionou, reinstale o gnome-subtitles:

Código: [Selecionar]
sudo apt-get install gnome-subtitles --reinstall
SE O PROCEDIMENTO ACIMA TAMBÉM NÃO FUNCIONOU

Ok, vamos ser um pouco mais radicais: adicione o repositório ffmpeg mantido pelo Jon Severinsson e atualize (ou instale) o ffmpeg em seu sistema. Primeiro execute este comando para adicionar o repositório PPA:

Código: [Selecionar]
sudo add-apt-repository ppa:jon-severinsson/ffmpeg -y
Agora execute este supercomando para atualizar o cache de repositórios e então verificar e atualizar seu sistema:

Código: [Selecionar]
sudo apt-get update && sudo apt-get check && sudo apt-get upgrade -y && sudo apt-get dist-upgrade -y
O ffmpeg será atualizado. Pronto, agora finalize com este supercomando de limpeza:

Código: [Selecionar]
sudo apt-get autoremove && sudo apt-get clean
Por fim, tente novamente fazer o Gnome Subtitles funcionar com o seu arquivo de vídeo. 8)

Se nada disso adiantou, :'( o problema que você está enfrentando não é tão trivial, por isto será necessário investigá-lo mais a fundo. Você pode usar o Synaptic (sudo apt-get install synaptic) para investigar a versão do seu pacote gnome-subtitles, os arquivos que esse pacote instalou e quais são as dependências desse pacote.

Enquanto faz isso, considere a possibilidade de instalar a versão mais recente do Gnome Subtitles, conforme eu explico no topo desta página. Lembre-se de que se você está usando um sistema GNU/Linux *Ubuntu 14.04 Trusty Tahr, portanto pode usar o procedimento do topo desta página para remover a versão velha do Gnome Subtitles e instalar a mais recente, que está disponível no repositório PPA mantido pelo desenvolvedor do aplicativo. ;)
« Última modificação: 17 de Outubro de 2014, 23:59 por Sampayu »
Yuri Sucupira ("Sampayu")