Autor Tópico: [RESOLVIDO] Problema HD Sata  (Lida 16315 vezes)

Offline bred81

  • Usuário Ubuntu
  • *
  • Mensagens: 971
  • HAN?!
    • Ver perfil
Re: Problema HD Sata
« Resposta #15 Online: 02 de Agosto de 2010, 01:41 »
Esse teste eu descobri pesquisando no Google. Ele já vem instalado no Linux e só faz uma leitura de cada setor, sem escrever nele. O número de vezes que a leitura é feita pode também ser especificada no comando.


Agora que você sitou, eu lembro de um stresstest do Kurumin que fazia algo parecido.
Mas ele era pro computador inteiro.
Computadores que tinham um defeito, eu colocava ele pra passar 5x e o computador não respondia nem depois de 1 dia inteiro.
Só depois desse teste eu começava a usar o Ultimate Boot CD...
O que o Mario foi fazer no pscicólogo?
- Ele estava passando por uma fase difícil...

Offline promurilo

  • Usuário Ubuntu
  • *
  • Mensagens: 185
    • Ver perfil
Re: Problema HD Sata
« Resposta #16 Online: 02 de Agosto de 2010, 16:19 »
Os estalos do HD desapareceram nesses últimos dias. Não sei se algum dos comandos que eu usei pode ter corrigido um eventual problema.

Será que o SMART monitora somente a superfície do disco? Por exemplo, como saber se o problema no HD não é mecânico, opr exemplo, no motor?

Offline promurilo

  • Usuário Ubuntu
  • *
  • Mensagens: 185
    • Ver perfil
Re: Problema HD Sata
« Resposta #17 Online: 02 de Agosto de 2010, 21:32 »
Agora a partição Linux ficou em um estado crítico!

Hoje a tarde eu mal consegui trabalhar no Linux. O HD emitia estalos a cada vez que eu tentava acessar os arquivos. O sistema começou a ficar cada vez mais lento. Decidi, então, passar meus arquivos pessoais para um outro HD menor que eu tenho. Usei para isso o live CD do Ubuntu.

Desliguei o computador por algumas horas. Quando fui acessar o Ubuntu, simplesmente não consegui. Uma mensagem na tela diz que o sistema não consegue montar as partições e o Linux não inicia. O interessante é que esses problemas não ocorrem na partição Windows, tanto é que nesse HD eu consigo usar o computador sem problema algum.

Os travamentos ocorrem só no Ubuntu (ou melhor, Kubuntu).

Agora eu vou ter que zerar totalmente esse HD no próximo fim de semana, testando-o exaustivamente para ver se ainda pode ser aproveitado.


Offline bred81

  • Usuário Ubuntu
  • *
  • Mensagens: 971
  • HAN?!
    • Ver perfil
Re: Problema HD Sata
« Resposta #18 Online: 03 de Agosto de 2010, 00:12 »
Agora a partição Linux ficou em um estado crítico!

Hoje a tarde eu mal consegui trabalhar no Linux. O HD emitia estalos a cada vez que eu tentava acessar os arquivos. O sistema começou a ficar cada vez mais lento. Decidi, então, passar meus arquivos pessoais para um outro HD menor que eu tenho. Usei para isso o live CD do Ubuntu.

Desliguei o computador por algumas horas. Quando fui acessar o Ubuntu, simplesmente não consegui. Uma mensagem na tela diz que o sistema não consegue montar as partições e o Linux não inicia. O interessante é que esses problemas não ocorrem na partição Windows, tanto é que nesse HD eu consigo usar o computador sem problema algum.

Os travamentos ocorrem só no Ubuntu (ou melhor, Kubuntu).

Agora eu vou ter que zerar totalmente esse HD no próximo fim de semana, testando-o exaustivamente para ver se ainda pode ser aproveitado.


Faz um teste "chato".
Aproveita que tu têm seus dados em outro lugar, formata essa partição em ntfs e tenta usa-la através do windows.
Se der problema, joga o HD fora, se não der, ext4 não é pra você...
O que o Mario foi fazer no pscicólogo?
- Ele estava passando por uma fase difícil...

Offline promurilo

  • Usuário Ubuntu
  • *
  • Mensagens: 185
    • Ver perfil
Re: Problema HD Sata
« Resposta #19 Online: 03 de Agosto de 2010, 11:54 »
Eu estava desconfiando mesmo do sistema de arquivos ext4, bred81.

Será que o problema está justamente em usar ext4? Será que esse sistema de arquivos não é seguro? Qual o melhor sistema de arquivos para o Linux, atualmente?

Obrigado pela força.
« Última modificação: 03 de Agosto de 2010, 11:56 por promurilo »

Offline bred81

  • Usuário Ubuntu
  • *
  • Mensagens: 971
  • HAN?!
    • Ver perfil
Re: Problema HD Sata
« Resposta #20 Online: 03 de Agosto de 2010, 14:35 »
Eu estava desconfiando mesmo do sistema de arquivos ext4, bred81.

Será que o problema está justamente em usar ext4? Será que esse sistema de arquivos não é seguro? Qual o melhor sistema de arquivos para o Linux, atualmente?

Obrigado pela força.
Eu acho:
- Ext4 = Ext3++

Brincadeiras a parte:
http://www.vivaolinux.com.br/topico/Kernel-Linux/EXT3-EXT4-qual-a-diferenca
http://pt.wikipedia.org/wiki/Ext4
http://andrem.wordpress.com/2008/12/26/ext4/
http://www.guiadohardware.net/tutoriais/formatacao-sistemas-arquivo/ext3.html

Eu não vou falar sobre reiserfs por um motivo:
Li em algum lugar na internet que o mantedor do raiserfs foi preso em 2008 ou 2009.

Não estou dizendo que é melhor ou pior, apenas que não está tão atualizado como o projeto ext.

Agora, se você realmente quiser entrar nesse mérito, vai encontrar gente que dirá que raiserfs é melhor se você quiser ter um linux para um uso tal, e extN é melhor se você quiser usar para tal².

Eu sugiro que você tente formatar em ntfs e veja se o disco funciona normalmente. Se funcionar, tenta ext3, raiserfs e o resto.
Agora, eu acho pouco provável que funcione com ntfs/fat32 e não funcione com ext4. Além de ser mais atual, a partir do ext3, a tabela de alocação tenta resolver os problemas encontrados no disco, nem sempre consegue, mas já usei hd com badblocks (sim, eu sei que é ruim) durante um tempo, por falta de espaço no servidor.
O que o Mario foi fazer no pscicólogo?
- Ele estava passando por uma fase difícil...

Offline promurilo

  • Usuário Ubuntu
  • *
  • Mensagens: 185
    • Ver perfil
Re: Problema HD Sata
« Resposta #21 Online: 03 de Agosto de 2010, 20:37 »
Então não é mesmo problema do ext4.

A partição  Linux fica no início do disco (pelo menos eu acho que é assim, porque é a sequência mostrada no particionador). Vou mudar a ordem das partições, colocando a partição Windows primeiro. Se aparecer um problema, então é essa a área que apresenta mesmo um defeito. Se for o caso, talvez eu tente isolar a área, deixando só a parte boa do HD, isso se aparecer badblocks, porque até agora não achei nenhum.

Offline bred81

  • Usuário Ubuntu
  • *
  • Mensagens: 971
  • HAN?!
    • Ver perfil
Re: Problema HD Sata
« Resposta #22 Online: 03 de Agosto de 2010, 22:00 »
Então não é mesmo problema do ext4.

A partição  Linux fica no início do disco (pelo menos eu acho que é assim, porque é a sequência mostrada no particionador). Vou mudar a ordem das partições, colocando a partição Windows primeiro. Se aparecer um problema, então é essa a área que apresenta mesmo um defeito. Se for o caso, talvez eu tente isolar a área, deixando só a parte boa do HD, isso se aparecer badblocks, porque até agora não achei nenhum.
Eu acho pouco provável que a partição do linux seja a primeira. Principalmente tendo uma instalação do WXP. Me lembro (da época que instalava Windows no meus computadores com dual boot) que para o XP funcionar, deveria estar instalado na primeira partição física (sda1 ou hda1) do disco. Não lembro se era permitido instala-lo em uma partição lógica (se não entender muito de particionamento, avise, isso sei um pouco).

Agora, independete do que vá fazer, muito cuidado. Salve tudo que puder antes pois a chance de perder os dados é enorme!
O que o Mario foi fazer no pscicólogo?
- Ele estava passando por uma fase difícil...

Offline promurilo

  • Usuário Ubuntu
  • *
  • Mensagens: 185
    • Ver perfil
Re: Problema HD Sata
« Resposta #23 Online: 04 de Agosto de 2010, 16:22 »
De fato ela é a última. É que eu tenho quatro partições primárias.

Acabei de confirmar isso no Gparted do Ubuntu.

Offline promurilo

  • Usuário Ubuntu
  • *
  • Mensagens: 185
    • Ver perfil
Re: Problema HD Sata
« Resposta #24 Online: 10 de Agosto de 2010, 21:36 »
Desculpem recolocar esse tópico, é que achei importante finalizar a discussão.

Terminei de formatar a máquina no fim de semana. Não notei mais nenhum estalo. Acho que o problema todo era a temperatura, que estava sempre a 47°. Comprei então um cooler para HD. Só depois é que eu vim saber que ele oxida a placa lógica! Fiz então uma "gambiarra": ao invés de parafusar ele na parte onde tem a placa lógica, coloquei ele em cima, onde tem os adesivos. Como não dava para fixar no próprio HD, apenas encaixei na baia de cima, bem próximo ao HD, fixando ele no próprio gabinete. Assim ele não tem contato com o HD, evitando assim a vibração, e o resfria.

Com isso, consegui diminuir em 10° a temperatura. Agora não passa de 37°.

Mudei as partições, reinstalei o Linux e o Windows. No Windows fiz a formatação completa durante a instalação. Não detectei um badblock sequer. Nem mesmo no SMART. Então, para minha felicidade o HD está em ótimo estado.

O fato é que, pelo que vi em muitos sites, esses HDs maxtor estalam bastante, geralmente devido ao processo de recalibração térmica dos HDs. Mas como não sei realmente se aquilo é a recalibração térmica, fiz backup de segurança de todos os meus arquivos em um outro HD menor que tenho.

Acho que isso tudo que aconteceu me ajudou a entender melhor o computador e o próprio Linux. Compreendi melhor o SMART e as ferramentas de manutenção do Linux. Compreendo melhor as diferenças entre os sistemas de arquivos, como usar o smartctl, o badblocks e tudo o mais. As vezes, na busca pela solução de um problema, aprendemos muito.

Muito obrigado ao bred81 e a todos os amigos do fórum pela ajuda.

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.052
    • Ver perfil
Re: [RESOLVIDO] Problema HD Sata
« Resposta #25 Online: 10 de Agosto de 2010, 22:06 »
Ola eu tenho uma Maxxtor Diamond Plus 9 veião e eles estalam mesmo principalmente ao iniciar a maquina, nao sei dizer se e um problema mas desde que o hd era novo sempre estalou e funciona ate hj. 
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline promurilo

  • Usuário Ubuntu
  • *
  • Mensagens: 185
    • Ver perfil
Re: [RESOLVIDO] Problema HD Sata
« Resposta #26 Online: 11 de Agosto de 2010, 09:36 »
Esses estalos devem ser uma característica desses HDs Maxtor. Acredito que me preocupei à toa.

De qualquer forma, não faz mal sempre ter um backup, para qualquer eventualidade.

Offline bred81

  • Usuário Ubuntu
  • *
  • Mensagens: 971
  • HAN?!
    • Ver perfil
Re: [RESOLVIDO] Problema HD Sata
« Resposta #27 Online: 11 de Agosto de 2010, 11:03 »
Tenho 2 Maxtor e 1 Seagate. 1 Maxtor 250GB e o Seagate 1TB estão dentro do computador e o outro Maxtor 1TB está numa gaveta, ligado USB.
Nunca ouvi um estalo e a temperatura do maxtor é acima dos 40 graus...
Mas, realmente, a Seagate a temperatura média é 35...
(E eu achando que o fato da Seagate ter comprado a Maxtor ia alterar a qualidade pra melhor...)

Mas, nunca ouvi estalos desses 3 HDs...
O que o Mario foi fazer no pscicólogo?
- Ele estava passando por uma fase difícil...

Offline Maureti

  • Usuário Ubuntu
  • *
  • Mensagens: 88
    • Ver perfil
Re: [RESOLVIDO] Problema HD Sata
« Resposta #28 Online: 11 de Agosto de 2010, 15:13 »
promurilo
cara comigo aconteceu o mesmo, sua experiência é muito parecida com a minha a não ser pelo HD que o meu era um Segate de 80 Giga, aconteceu a mesma coisa que vc, só que eu não tive nem tempo de salvar meus arquivos, quando vi já era tarde demais.
o HD pifou e eu perdi tudo, e problema disso é a temperatura, eu não tinha ideia que precisa de uma refrigeração adequada para o pc, pois quando vc compra um pc nas lojas o único cooler que vem é o da CPU, mas agora eu estou precavido, instalei um cooler embaixo do HD e outro na frente da placa mãe, agora meu HD trabalha tranquilo, hoje mesmo ele não chega nem a 30° graus, eu moro no oeste do Paraná (só para esclarecer).

falow.

Offline promurilo

  • Usuário Ubuntu
  • *
  • Mensagens: 185
    • Ver perfil
Re: [RESOLVIDO] Problema HD Sata
« Resposta #29 Online: 12 de Agosto de 2010, 16:02 »
Caro amigo, Maureti!

Esses cooleres podem empoeirar e oxidar a placa lógica do HD. Verifique se você não colocou o cooler na direção da placa lógica. Se for assim, não é recomendado, a menos que sua região seja de clima seco.

Veja este tópico: http://www.guiadohardware.net/comunidade/cooler-hd/676079/

O cooler realmente diminui (e muito) a temperatura do HD. Aqui eu coloquei aquele cooler duplo da Akasa, mas na posição de cima, ou seja, na parte onde tem a tampa metálica com os adesivos. Faz quase o mesmo efeito. Dimuiu a temperatura em uns 10°.