Autor Tópico: (Resolvido) Ubuntu 10.04 acessa rede wireless mas nao conecta a internet  (Lida 44628 vezes)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 10.04 acessa rede wireless mas nao conecta a internet
« Resposta #60 Online: 26 de Agosto de 2010, 10:53 »
Sim, tente isso. Ou se quiser tentar um "sudo modprobe -v ath9k", é melhor ainda --- cole a saída aqui.

Ah, não deixe de executar aquele "lspci -vv -s 0000:02:00:0", pra gente ver exatamente que modelo de placa Atheros é esse.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline psyduck

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Ubuntu 10.04 acessa rede wireless mas nao conecta a internet
« Resposta #61 Online: 26 de Agosto de 2010, 11:03 »
Lá vai o resultado dos comandos todos:

root@marcos-laptop:/home/marcos# sudo modprobe -v ath9k
insmod /lib/modules/2.6.32-24-generic-pae/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/2.6.32-24-generic-pae/kernel/drivers/net/wireless/ath/ath.ko
insmod /lib/modules/2.6.32-24-generic-pae/kernel/net/mac80211/mac80211.ko
insmod /lib/modules/2.6.32-24-generic-pae/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko

root@marcos-laptop:/home/marcos# dmesg | tail
[   16.285159] ppdev: user-space parallel port driver
[   25.828119] eth0: no IPv6 routers present
[  130.257161] cfg80211: Calling CRDA to update world regulatory domain
[  130.362795] cfg80211: World regulatory domain updated:
[  130.362800]    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  130.362805]    (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  130.362810]    (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  130.362814]    (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  130.362818]    (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  130.362822]    (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

root@marcos-laptop:/home/marcos# nm-tool

NetworkManager Tool

State: connected

- Device: eth0  [Auto eth0] ----------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             connected
  Default:           yes
  HW Address:        70:71:BC:0F:00:3C

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.0.123
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             200.165.132.154
    DNS:             200.165.132.148
    DNS:             192.168.0.1



root@marcos-laptop:/home/marcos# lspci -vv -s 0000:02:00.0
02:00.0 Network controller: Atheros Communications Inc. Device 002c (rev 01)
   Subsystem: Device 1a3b:1112
   Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 0, Cache Line Size: 32 bytes
   Interrupt: pin A routed to IRQ 5
   Region 0: Memory at fdff0000 (64-bit, non-prefetchable) [size=64K]
   Capabilities: [40] Power Management version 3
      Flags: PMEClk- DSI- D1+ D2- AuxCurrent=375mA PME(D0+,D1+,D2-,D3hot+,D3cold-)
      Status: D0 PME-Enable- DSel=0 DScale=0 PME-
   Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
      Address: 00000000  Data: 0000
   Capabilities: [60] Express (v2) Legacy Endpoint, MSI 00
      DevCap:   MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
         ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
      DevCtl:   Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
         RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
         MaxPayload 128 bytes, MaxReadReq 512 bytes
      DevSta:   CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr- TransPend-
      LnkCap:   Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
         ClockPM- Suprise- LLActRep- BwNot-
      LnkCtl:   ASPM L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
         ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
      LnkSta:   Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
   Capabilities: [100] Advanced Error Reporting <?>
   Capabilities: [140] Virtual Channel <?>
   Capabilities: [160] Device Serial Number 12-14-24-ff-ff-17-15-00
   Capabilities: [170] Power Budgeting <?>

root@marcos-laptop:/home/marcos#

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 10.04 acessa rede wireless mas nao conecta a internet
« Resposta #62 Online: 26 de Agosto de 2010, 11:28 »
É, eu devia ter pedido esse "lspci" turbinado desde o início. Achei 2 links interessantes:
https://answers.launchpad.net/ubuntu/+source/netbook-meta/+question/112715
Aqui diz pra instalar o pacote "compat-wireless Linux modules (backported versions)".

sudo apt-get install linux-backports-modules-wireless-lucid-generic

Você encontra esse pacote no repositório principal, e atualizações dele nos repositórios "lucid-updates" e "lucid-security".

O outro link:
http://ubuntuforums.org/showthread.php?p=9142140#post9142140
Aqui diz pra baixar o código fonte do driver e compilá-lo.

Em ambos os casos, você vai usar, no final, o driver "ath9k". Não o original da distribuição, mas o modificado.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline psyduck

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Ubuntu 10.04 acessa rede wireless mas nao conecta a internet
« Resposta #63 Online: 26 de Agosto de 2010, 12:05 »
zekkerj, cara!!!! Tou Felizaço!! - heheheh

Estou escrevendo esta resposta via wireless!!!!! yhuuuuu!!!

Então, vamos lá:
1. Segui a segunda opção

O outro link:
http://ubuntuforums.org/showthread.php?p=9142140#post9142140
Aqui diz pra baixar o código fonte do driver e compilá-lo.

Em ambos os casos, você vai usar, no final, o driver "ath9k". Não o original da distribuição, mas o modificado.

2. Fiz diretinho do jeito que o cara lá escreveu. Baixei o driver mais atualizado, no caso foi o compat-wireless-2010-08-25.
3. Depois de executar todos os comandos indicados e fazer o sudo modprobe ath9k O Ubuntu reconheceu a placa ligeirinho não somente a rede mas a conexão com o roteador e está tudo funcionando (em letras maiusculas!!!).

Veja aí:

marcos@marcos-laptop:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan1     IEEE 802.11bg  ESSID:"redecasa" 
          Mode:Managed  Frequency:2.427 GHz  Access Point: 00:26:5A:60:3A:4E   
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=62/70  Signal level=-48 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

marcos@marcos-laptop:~$


Detalhe: - ficou melhor do que eu imaginava. Está funcionando sem o adaptador usb wireless!!!

zekkerj, muito obrigado por sua paciência e sapiência! - hehehe. Você me guiou direto (depois de um looongo caminho) pra solução! Muito massa!

Sempre Ubuntu!!!!

Muito, mas muito obrigado mesmo!
Valeu

Offline psyduck

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
(Resolvido) Re: Ubuntu 10.04 acessa rede wireless mas nao conecta a internet
« Resposta #64 Online: 26 de Agosto de 2010, 17:52 »
Estou colocando o tópico como resolvido!!
Mais uma vez obrigado!

A solução foi apenas a instalação da placa de rede wireless atheros do note. O adaptador usb wireless que comprei não está sendo usado!
O Ubuntu reconheceu a rede wireless aqui de casa sem nenhum problema. Conecto a internet tranquilamente. O acesso é estável em qualquer lugar aqui.

Mais um usuário Ubuntu satisfeito!!
abraço

Offline fer411

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: (Resolvido) Ubuntu 10.04 acessa rede wireless mas nao conecta a internet
« Resposta #65 Online: 01 de Setembro de 2010, 12:01 »
Olá!
Estou com um problema parecido... Mas meu roteador é Tenda W311r+ e eu sei que está funcionando pq os dois desktops estão conectando normalmente (com fio) e o videogame também (wireless), mas não consigo conectar do notebook que atualizei com o 10.04!

Os comandos solicitados ao outro usuário deram o seguinte resultado:

fer411@laptop411:~$ ping 8.8.8.8
connect: Network is unreachable

fer411@laptop411:~$ ping www.google.com
ping: unknown host www.google.com

fer411@laptop411:~$ ifconfig
eth0      Link encap:Ethernet  Endereço de HW 00:90:f5:77:f1:c9 
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          IRQ:19 Endereço de E/S:0xdead

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:12 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:12 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:720 (720.0 B) TX bytes:720 (720.0 B)

fer411@laptop411:~$ route -n
Tabela de Roteamento IP do Kernel
Destino         Roteador        MáscaraGen.    Opções Métrica Ref   Uso Iface
fer411@laptop411:~$

Só não consigo acessar sem fio, mas qndo eu ligo o cabo no note ele funciona direitinho!

Não aparece na barra lá em cima a rede sem fio, eu tentei editar conexões e adicionar uma sem fio mas ainda assim não conectou, daí apague essa conexão que eu tinha criado!

PS. sou iniciante e não entendo nada de nada! mas eu tentei aquela linha de comando que termina em generic (que resolveu o problema do outro usuário) o apt instalou uns pacotes mas ainda assim não resolveu o problema!
« Última modificação: 01 de Setembro de 2010, 18:01 por fer411 »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: (Resolvido) Ubuntu 10.04 acessa rede wireless mas nao conecta a internet
« Resposta #66 Online: 01 de Setembro de 2010, 12:14 »
poste a saída dos comandos abaixo:

sudo lshw -C network
iwconfig wlan0
nm-tool
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline fer411

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: (Resolvido) Ubuntu 10.04 acessa rede wireless mas nao conecta a internet
« Resposta #67 Online: 01 de Setembro de 2010, 17:41 »
fer411@laptop411:~$ sudo lshw -C network
[sudo] password for fer411:
  *-network               
       description: Ethernet interface
       product: 191 Gigabit Ethernet Adapter
       vendor: Silicon Integrated Systems [SiS]
       physical id: 4
       bus info: pci@0000:00:04.0
       logical name: eth0
       version: 02
       serial: 00:90:f5:77:f1:c9
       size: 10MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.3 duplex=half latency=0 link=no multicast=yes port=MII speed=10MB/s
       resources: irq:19 memory:d8407000-d840707f ioport:1000(size=128)
fer411@laptop411:~$ iwconfig wlan0
wlan0     No such device

fer411@laptop411:~$ nm-tool

NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            sis190
  State:             unavailable
  Default:           no
  HW Address:        00:90:F5:77:F1:C9

  Capabilities:
    Carrier Detect:  yes
    Speed:           10 Mb/s

  Wired Properties
    Carrier:         off


fer411@laptop411:~$

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: (Resolvido) Ubuntu 10.04 acessa rede wireless mas nao conecta a internet
« Resposta #68 Online: 01 de Setembro de 2010, 19:24 »
Sua rede wireless não foi reconhecida nem pelo "lshw", o que é um péssimo sinal. Esse notebook é novo? O adaptador wireless dele é interno ou externo?

De qq jeito, posta a saída dos comandos abaixo. Se o adaptador wireless for externo/usb, plugue-o antes.

lspci
lsusb
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline fer411

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: (Resolvido) Ubuntu 10.04 acessa rede wireless mas nao conecta a internet
« Resposta #69 Online: 01 de Setembro de 2010, 21:03 »
O note deve ter 1 ano... O adaptador wireless é interno e eu não sei nada mas eu acho que pode ser algo como os drivers, pq antes funcionava!

Resultados:

fer411@laptop411:~$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter (rev 02)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
00:06.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:07.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
00:1f.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)
03:00.0 System peripheral: JMicron Technology Corp. SD/MMC Host Controller
03:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller
03:00.3 System peripheral: JMicron Technology Corp. MS Host Controller
fer411@laptop411:~$ lsusb
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 5986:0200 Acer, Inc OrbiCam
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
fer411@laptop411:~$

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: (Resolvido) Ubuntu 10.04 acessa rede wireless mas nao conecta a internet
« Resposta #70 Online: 02 de Setembro de 2010, 01:17 »
Bem, achei alguma coisa relativa à sua placa.

Essa SiS 190 parece ser integrada de Gigabit com Wireless 802.11g. Como sua wireless não aparece, é provável que ela esteja desativada; veja se há algum botão nas laterais do aparelho, ou alguma sequência de teclas (tipo, Fn+F2) para ativar a wireless.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline fer411

  • Usuário Ubuntu
  • *
  • Mensagens: 15
    • Ver perfil
Re: (Resolvido) Ubuntu 10.04 acessa rede wireless mas nao conecta a internet
« Resposta #71 Online: 02 de Setembro de 2010, 01:36 »
Graaaaaande Zekkerj!  ;)

Era isso mesmo, agora conectou que é uma beleza! E o "problema" era bem mais simples do q eu imaginava! hehehe

Obrigadíssima!!!
« Última modificação: 02 de Setembro de 2010, 01:39 por fer411 »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: (Resolvido) Ubuntu 10.04 acessa rede wireless mas nao conecta a internet
« Resposta #72 Online: 02 de Setembro de 2010, 01:50 »
A gente acaba tão acostumado aos problemas "cabeludos" que demora a pensar na solução mais simples... :P
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D