Autor Tópico: ubuntu nao inicia depois da tela de login  (Lida 52539 vezes)

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: ubuntu nao inicia depois da tela de login
« Resposta #15 Online: 15 de Agosto de 2010, 15:52 »
Como vimos, Seu problema pode estar no Grub mas não é o grub, são argumentos passados ao sistema que alterara a forma como o kernel está configurando seu sistema.

É isso aí zekkerj, chegamos num ponto comum. Como eu postei um /etc/defaults/grub original, o dex19dt pode até copiar usar ele como teste.

[]'s

Offline dex19dt

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Re: ubuntu nao inicia depois da tela de login
« Resposta #16 Online: 15 de Agosto de 2010, 17:49 »
muito bem,
um problema resolvido!
alterei a linha no grub.cfg e agora a tela do modo texto aparece normal sem imagem distorcida nem nada.
Mas o problema principal ainda persiste.
O ubuntu nao entra depois que digito a senha.

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: ubuntu nao inicia depois da tela de login
« Resposta #17 Online: 15 de Agosto de 2010, 17:55 »
no Gnome ou no kde ?

aparece alguma mensagem de erro?

[]'s

Offline dex19dt

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Re: ubuntu nao inicia depois da tela de login
« Resposta #18 Online: 15 de Agosto de 2010, 18:08 »
Eu tenhos os dois, mas sempre trabalhei com o KDE.

Mas quando inicio o Ubuntu ele exibe a tela de login e qndo digito a senha ele aceita e parece q vai entrar no sistema, fica tudo escuro e alguns segundos depois ele volta pra tela de login de novo (como se o boot tivesse "falhado").
Isso ocorre independentemente do tipo de sessão que eu escolho (KDE, Gnome e até a "A Prova de falhas"). O unico resultado diferente acontece quando eu escolho a opção "Fazer o login do console". Ele mostra o terminal mas os caracteres aparecem completamente irreconheciveis (como manchas, eu diria até q seria defeito da placa de video se nao fosse o fato de tudo funcionar normalmente usando o Windows). Mesmo sem conseguir ler o q aparece na tela, eu consegui me logar usando o modo texto e dei o comando "startx". Funcionou e ele iniciou o Gnome. uma vez dentro do sistema pude ver q parece estar tudo normal, acessei as Configurações do Sistema e fui a Gerenciador de Inicio de Sessão, coloquei as configurações padrão e tentei reiniciar mas nada mudou.
Também tentei utilizar o Gparted através do livecd mas quando eu selecionava a partição do Linux a opção Corrigir estava desabilitada. O fato é q o Livecd q eu tenho aqui ainda é do Karmic, nao sei se tem alguma coisa a ver, nao tenho o cd do Lucid. Além do mais eu acho q o problema nao é propriamente na partição, nao sei bem.

Outro fato que talvez seja importante. Semana passada eu instalei o programa StartUp Manager para alterar a tela de inicialização do Ubuntu (o "splash"), nao gostei do resultado e entao desinstalei o programa de novo. Desde então o splash aparece todo estranho, com a imagem cheia de quadrinhos piscando, similar ao q acontece quando entro no modo texto. Mas mesmo assim o sistema iniciava sem problemas. O problema da inicialização do Ubuntu ocorreu mesmo depois q mexi naquela opção do Gerenciador de Inicio de Sessão e defini um outro tema para o splash.

Portanto, tenho 2 problemas: o Ubuntu nao inicia de jeito nenhum. E a questão do splash e modo texto estarem com a imagem completamente desconfigurada e irreconhecivel. O segundo problema nao afetava o uso do sistema uma vez q eu estava dentro dele, e nao me importo se nao resolver agora. O ruim é nao poder iniciar o sistema.

Bom, gostaria de saber quais os arquivos responsaveis pela inicialização do Ubuntu e como eu faço para "resetar" eles ao padrão.
Ou qualquer outra coisa q me ajude rs

Mais uma vez obrigado

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.617
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: ubuntu nao inicia depois da tela de login
« Resposta #19 Online: 15 de Agosto de 2010, 18:16 »
Se vc usa mais o KDE, deveria ter instalado o Kubuntu, não o Ubuntu. Detalhes...

A tela gráfica abre normalmente, ainda que no Gnome?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline dex19dt

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Re: ubuntu nao inicia depois da tela de login
« Resposta #20 Online: 15 de Agosto de 2010, 18:33 »
sim, tudo normal, todas as funcionalidades do sistema e programas funcionam.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.617
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: ubuntu nao inicia depois da tela de login
« Resposta #21 Online: 15 de Agosto de 2010, 19:04 »
Qual é o seu problema atual, então? Não iniciar automaticamente em modo gráfico, ou não entrar no KDE?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline dex19dt

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Re: ubuntu nao inicia depois da tela de login
« Resposta #22 Online: 15 de Agosto de 2010, 19:13 »
Mas quando inicio o Ubuntu ele exibe a tela de login e qndo digito a senha ele aceita e parece q vai entrar no sistema, fica tudo escuro e alguns segundos depois ele volta pra tela de login de novo (como se o boot tivesse "falhado").
Isso ocorre independentemente do tipo de sessão que eu escolho (KDE, Gnome e até a "A Prova de falhas").O unico resultado diferente acontece quando eu escolho a opção "Fazer o login do console". Aí consigo me logar usando o modo texto usando o comando "startx"

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.617
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: ubuntu nao inicia depois da tela de login
« Resposta #23 Online: 15 de Agosto de 2010, 19:33 »
Crie outro usuário e tente se logar com ele. Se funcionar, o problema está na sua pasta Home.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline dex19dt

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Re: ubuntu nao inicia depois da tela de login
« Resposta #24 Online: 15 de Agosto de 2010, 20:29 »
Criei um novo usuário "teste" e quando fui me logar com ele aconteceu exatamente a mesma coisa.
O problema parece ser com aquela tela q aparece logo depois q vc faz o login e antes de aparecer o desktop.

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: ubuntu nao inicia depois da tela de login
« Resposta #25 Online: 15 de Agosto de 2010, 21:34 »
em terminal digite este comando
Código: [Selecionar]
sudo update-rc.d gdm defaults

e tente iniciar o Gnome ( depois vemos o kde)

poste o resultado

Offline dex19dt

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Re: ubuntu nao inicia depois da tela de login
« Resposta #26 Online: 16 de Agosto de 2010, 00:26 »
Executei o comando e depois tentei inciar o Gnome e nao deu certo. Continua voltando para a tela de login.
Uma coisa q consegui agora:
Antes eu nao consegui enxergar o q digitava na linha de comando por causa daquele outro problema ja resolvido.
Eu tentava usar o comando "startkde" e nao dava certo. Por isso eu usei o "startx" (que dá certo).
Agora q consigo ler o q aparece no modo texto, tentei o startkde de novo e apareceu uma mensagem dizendo mais ou menos.
"Display cannot connect to the X Server"

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.617
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: ubuntu nao inicia depois da tela de login
« Resposta #27 Online: 16 de Agosto de 2010, 02:22 »
O comando startkde depende do Xserver/Xorg já estar ativo. Ele não inicia o servidor X.

Já viu nos logs do sistema se tem alguma pista do problema? Outra boa pista seria o arquivo "~/.xsession-errors".
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline dex19dt

  • Usuário Ubuntu
  • *
  • Mensagens: 76
    • Ver perfil
Re: ubuntu nao inicia depois da tela de login
« Resposta #28 Online: 16 de Agosto de 2010, 08:42 »
A unica linha do arquivo de log que me parece poder ter algum problema é essa:
Código: [Selecionar]
16-08-2010 08:29:40 jonathan-desktop kdm_greet[1415] Cannot load /usr/share/kde4/apps/kdm/faces/.default.face: Arquivo ou diretório não encontrado

nao tem nenhum arquivo .xsession-errors

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.617
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: ubuntu nao inicia depois da tela de login
« Resposta #29 Online: 16 de Agosto de 2010, 10:12 »
Esse arquivo é oculto, você levou isso em conta, não?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D