Autor Tópico: Sem conexão com a internet Ubuntu10.04.1  (Lida 19860 vezes)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Sem conexão com a internet Ubuntu10.04.1
« Resposta #45 Online: 18 de Setembro de 2010, 18:35 »
O "20100604" parece indicar que é um release de junho, passado. Pode não ser o mais recente, mas com certeza é bem recente.

Mãos à obra, então... descompacte o arquivo num diretório, e procure por um arquivo "README" e/ou "INSTALL" dentro, lá vai ter as instruções de como compilar e instalar.

Falar nisso... compilar... vc precisa instalar alguns pacotes pra poder compilar. :-\
Vc não tem mesmo como ativar uma conexão alternativa, por cabo, né?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline emersoul

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: Sem conexão com a internet Ubuntu10.04.1
« Resposta #46 Online: 18 de Setembro de 2010, 21:06 »
Zekkerj, tenho um amigo aqui proximo que tem velox. Levei meu note la uma vez e pegou legal, nem precisei configurar nada. Era com o Suse. Acho que com Ubuntu dá certo...Mas vou tentar aqui mesmo. Se não der certo vou lá. Vou fazer aqui, depois posto se deu certo ;)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Sem conexão com a internet Ubuntu10.04.1
« Resposta #47 Online: 18 de Setembro de 2010, 21:26 »
Só por precaução... procure instalar o pacote "build-essential", antes de compilar o driver.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline emersoul

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: Sem conexão com a internet Ubuntu10.04.1
« Resposta #48 Online: 18 de Setembro de 2010, 21:53 »
Já havia descompactado, então depois só entrei e compilei. Os resultados deram certos??
root@emersoul-laptop:/home/emersoul/Download/DPO_RT3070_LinuxSTA_V2.3.0.4_20100604# make
make -C tools
make[1]: Entrando no diretório `/home/emersoul/Download/DPO_RT3070_LinuxSTA_V2.3.0.4_20100604/tools'
gcc -g bin2h.c -o bin2h
make[1]: Saindo do diretório `/home/emersoul/Download/DPO_RT3070_LinuxSTA_V2.3.0.4_20100604/tools'
/home/emersoul/Download/DPO_RT3070_LinuxSTA_V2.3.0.4_20100604/tools/bin2h
cp -f os/linux/Makefile.6 /home/emersoul/Download/DPO_RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux/Makefile
make -C /lib/modules/2.6.32-24-generic/build SUBDIRS=/home/emersoul/Download/DPO_RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux modules
make[1]: Entrando no diretório `/usr/src/linux-headers-2.6.32-24-generic'
  CC [M]  /home/emersoul/Download/DPO_RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux/../../common/rtmp_mcu.o
  LD [M]  /home/emersoul/Download/DPO_RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux/rt3070sta.o
  Building modules, stage 2.
  MODPOST 1 modules
  LD [M]  /home/emersoul/Download/DPO_RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux/rt3070sta.ko
make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.32-24-generic'
cp -f /home/emersoul/Download/DPO_RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux/rt3070sta.ko /tftpboot

Pra copiar, tive que digitar o diretorio de copiar, seguido do de colar. É assim mesmo, né?? Pois tentei de outra forma, como está no READ ME e não consegui...
# cp /home/emersoul/Download/DPO_RT3070_LinuxSTA_V2.3.0.4_20100604/RT2870STA.dat /etc/Wireless/RT2870STA/RT2870STA.dat

E quanto ao diretorio /os, não o encontrei.... O READ ME diz que tenho que ir lá, mas...
root@emersoul-laptop:/etc/Wireless# cd /os/linux
bash: cd: /os/linux: Arquivo ou diretório não encontrado
« Última modificação: 18 de Setembro de 2010, 21:57 por emersoul »

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.068
    • Ver perfil
    • Alexsandro Felix
Re: Sem conexão com a internet Ubuntu10.04.1
« Resposta #49 Online: 19 de Setembro de 2010, 02:15 »
Bah... sábado a noite e eu aqui apanhando desse coisa.

Meu Kernel:
2.6.32-25-generic #44-Ubuntu SMP Fri Sep 17 20:26:08 UTC 2010 i686 GNU/Linux

saida do comando lsusb:
Citar

$ lsusb
Bus 005 Device 002: ID 1c4f:0003 SiGma Micro
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 148f:2070 Ralink Technology, Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

saída do comando lsmod
Citar

$ lsmod
Module                  Size  Used by
binfmt_misc             6587  1
ppdev                   5259  0
snd_hda_codec_via      27111  1
snd_hda_intel          22037  2
snd_hda_codec          74201  2 snd_hda_codec_via,snd_hda_intel
snd_hwdep               5412  1 snd_hda_codec
snd_pcm_oss            35308  0
snd_mixer_oss          13746  1 snd_pcm_oss
snd_pcm                70694  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy           1338  0
fbcon                  35102  71
tileblit                2031  1 fbcon
font                    7557  1 fbcon
bitblit                 4707  1 fbcon
softcursor              1189  1 bitblit
vga16fb                11385  0
snd_seq_oss            26726  0
snd_seq_midi            4557  0
vgastate                8961  1 vga16fb
snd_rawmidi            19056  1 snd_seq_midi
snd_seq_midi_event      6003  2 snd_seq_oss,snd_seq_midi
snd_seq                47263  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
i915                  286079  2
drm_kms_helper         29297  1 i915
snd_timer              19098  2 snd_pcm,snd_seq
snd_seq_device          5700  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
drm                   162409  3 i915,drm_kms_helper
i2c_algo_bit            5028  1 i915
snd                    54148  15 snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
video                  17375  1 i915
lp                      7060  0
output                  1871  1 video
soundcore               6620  1 snd
intel_agp              24119  2 i915
snd_page_alloc          7076  2 snd_hda_intel,snd_pcm
atl2                   22383  0
agpgart                31724  2 drm,intel_agp
parport                32635  2 ppdev,lp
ndiswrapper           184677  0
usbhid                 36110  0
hid                    67032  1 usbhid

material que já segui em minhas tentativas (além dos que já existem aqui em nosso forum)
http://ubuntuforums.org/showthread.php?t=1285828
http://victorazzi.wordpress.com/2010/09/18/instalando-e-configurando-dispositivo-usb-para-linux-ubuntu-10-04/

saída que tenho ao executar o make (com todos os erros)
http://pastebin.com/mLCzSGHC

Offline emersoul

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: Sem conexão com a internet Ubuntu10.04.1
« Resposta #50 Online: 19 de Setembro de 2010, 11:44 »
Tentei os comandos daqui:http://victorazzi.wordpress.com/2010/09/18/instalando-e-configurando-dispositivo-usb-para-linux-ubuntu-10-04/, mas deu um erro quando compilei:
# make
make -C tools
make[1]: Entrando no diretório `/home/emersoul/RT3070_LinuxSTA_V2.3.0.4_20100604/tools'
gcc -g bin2h.c -o bin2h
make[1]: Saindo do diretório `/home/emersoul/RT3070_LinuxSTA_V2.3.0.4_20100604/tools'
/home/emersoul/RT3070_LinuxSTA_V2.3.0.4_20100604/tools/bin2h
cp -f os/linux/Makefile.6 /home/emersoul/RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux/Makefile
make -C /lib/modules/2.6.32-24-generic/build SUBDIRS=/home/emersoul/RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux modules
make[1]: Entrando no diretório `/usr/src/linux-headers-2.6.32-24-generic'
  CC [M]  /home/emersoul/RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux/../../common/rtmp_mcu.o
  CC [M]  /home/emersoul/RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux/../../common/rtusb_dev_id.o
/home/emersoul/RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux/../../common/rtusb_dev_id.c:43: error: stray ‘\303’ in program
/home/emersoul/RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux/../../common/rtusb_dev_id.c:43: error: stray ‘\227’ in program
/home/emersoul/RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux/../../common/rtusb_dev_id.c:43: error: expected ‘)’ before numeric constant
make[2]: ** [/home/emersoul/RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux/../../common/rtusb_dev_id.o] Erro 1
make[1]: ** [_module_/home/emersoul/RT3070_LinuxSTA_V2.3.0.4_20100604/os/linux] Erro 2
make[1]: Saindo do diretório `/usr/src/linux-headers-2.6.32-24-generic'
make: ** [LINUX] Erro 2

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Sem conexão com a internet Ubuntu10.04.1
« Resposta #51 Online: 21 de Setembro de 2010, 19:55 »
emersol, vc deve ter errado na edição que foi recomendada no blog do victorazzi.

Minha sugestão: repita o procedimento do início, criando novamente o diretório. Quando chegar na parte da edição, antes de alterar o arquivo, crie uma cópia dele:

cp rtusb_dev_id.c rtusb_dev_id.c.original

Assim, se vc errar de novo a edição, é só copiar de volta e tentar novamente.
PS: Fiz um questionamento lá no blog do Victorazzi, se essa edição é mesmo necessária. Vamos ver se ele responde...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Sem conexão com a internet Ubuntu10.04.1
« Resposta #52 Online: 22 de Setembro de 2010, 11:33 »
Opa, ele respondeu.

A edição desse arquivo "rtusb_dev_id.c" não é necessária, pois ele já inclui o chipset rt2070 na lista.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline PhoenixWings

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Problema em reconhecimento de dispositivo USB wireless no Lynx
« Resposta #53 Online: 22 de Setembro de 2010, 22:00 »
Boa noite a todos. Estou tentando configurar um dispositivo WA-54U Pro2 da Kaiomy no Lucid Lynx seguindo o seguinte tutorial:

http://victorazzi.wordpress.com/2010/09/18/instalando-e-configurando-dispositivo-usb-para-linux-ubuntu-10-04/

Eu cheguei até a parte relacionada à compilação do código com make mas, mesmo estando dentro da pasta, não consigo executar o make e me é retornado algum problema relacionado ao build tools (pelo menos é o que parece):

Código: [Selecionar]
root@phoenix-laptop:/home/phoenix/Download/RT3070_LinuxSTA_V2.3.0.4_20100604 # make
make -C tools
make[1]: Entrando no diretório `/home/phoenix/Download/RT3070_LinuxSTA_V2.3.0.4_20100604 /tools'
gcc -g bin2h.c -o bin2h
make[1]: Saindo do diretório `/home/phoenix/Download/RT3070_LinuxSTA_V2.3.0.4_20100604 /tools'
/home/phoenix/Download/RT3070_LinuxSTA_V2.3.0.4_20100604 /tools/bin2h
make: /home/phoenix/Download/RT3070_LinuxSTA_V2.3.0.4_20100604: Comando não encontrado
make: ** [build_tools] Erro 127
root@phoenix-laptop:/home/phoenix/Download/RT3070_LinuxSTA_V2.3.0.4_20100604 #

O que pode ser isso?  obrigado pela ajuda.

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.068
    • Ver perfil
    • Alexsandro Felix
Re: Sem conexão com a internet Ubuntu10.04.1
« Resposta #54 Online: 28 de Setembro de 2010, 19:23 »
Caro PhoenixWings

Por tratar-se de mesmo hardware, uni seu tópico a este já existente a mais tempo e com maiores informações. Talvez lendo-o você consiga solucionar o seu problema.

Lembre-se de sempre fazer uma Pesquisa antes de abrir um tópico novo, pois geralmente a solução é encontrada mais rapidamente desta forma.

Grato pela compreensão.

Felix

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Sem conexão com a internet Ubuntu10.04.1
« Resposta #55 Online: 29 de Setembro de 2010, 05:04 »
PhoenixWings, está me parecendo que vc criou o nome do diretório com um espaço no final (não faço idéia de como :o).

Tente criar novamente o diretório, seguindo o tutorial do victorazzi do início.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D