Autor Tópico: [Resolvido] Não consigo mudar permissões de arquivos pelo Nautilus!  (Lida 4373 vezes)

Offline pichorra

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
[Resolvido] Não consigo mudar permissões de arquivos pelo Nautilus!
« Online: 01 de Novembro de 2010, 12:23 »
Olá, gente, meu problema é bem simples, porém, MUITO chato. Eu não consigo mudar permissões de arquivos pelo nautilus, sendo eles executáveis ou não. Quando eu mudo lá nas propriedades do arquivo, ele volta como estava antes, ex: eu clico em "Permitir execução do arquivo como um programa" e rapidamente ele automaticamente desmarca! Isto acontece com todas as outras opções! Já tentei o $ Sudo Nautius, porém o problema é o mesmo.
Versão do Ubuntu: 10.10.
« Última modificação: 06 de Novembro de 2010, 10:27 por pichorra »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Não consigo mudar permissões de arquivos pelo Nautilus!
« Resposta #1 Online: 01 de Novembro de 2010, 12:35 »
Ola,

O melhor a fazer é baixar o guia foca Linux disponivel gratuitamente na rede.

Pesquise por permissões de Arquivos ou pelo comando chown ( de CHange OWNer )

Com o sudo nautilus voce altera as permissões mas elas só irão ter efetividade depois de fechar o nautilus e abri-lo novamente.

O melhor mesmo é o comando chown.

[]'s

Offline RonaldoRG

  • Usuário Ubuntu
  • *
  • Mensagens: 659
    • Ver perfil
    • Twitter: @rafas_andrade
Re: Não consigo mudar permissões de arquivos pelo Nautilus!
« Resposta #2 Online: 01 de Novembro de 2010, 12:47 »
Esse arquivo que você quer dar permissão de execução está na partição do sistema ou em outra?
Copiar ele para a sua pasta pessoal no ubuntu e tenta mudar pra ver.
T+.
Ubuntu 12.04

Offline irtigor

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.344
  • Delete, delete, delete!
    • Ver perfil
Re: Não consigo mudar permissões de arquivos pelo Nautilus!
« Resposta #3 Online: 01 de Novembro de 2010, 14:03 »
Acho que nesse seu caso não vai fazer diferença, mas no lugar do sudo, use gksudo para aplicativos gráficos (sudo só para o que roda no terminal).

--------
Se alguém ficou curioso:
http://www.psychocats.net/ubuntu/graphicalsudo
https://help.ubuntu.com/community/RootSudo#Graphical%20sudo
« Última modificação: 01 de Novembro de 2010, 14:52 por irtigor »

Offline pichorra

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Não consigo mudar permissões de arquivos pelo Nautilus!
« Resposta #4 Online: 02 de Novembro de 2010, 11:07 »
Bem, essa dica de mover o programa para a pasta virtual quebrou o galho, porém, tive que mover todas as pastas do programa e usar na pasta pessoal, porque senão não funciona. (ele volta as configurações originais quando copio de volta). Tambem tentei esse negócio do gksudo. mesma coisa. O programa esta em outra partição, NTFS.

Offline RonaldoRG

  • Usuário Ubuntu
  • *
  • Mensagens: 659
    • Ver perfil
    • Twitter: @rafas_andrade
Re: Não consigo mudar permissões de arquivos pelo Nautilus!
« Resposta #5 Online: 02 de Novembro de 2010, 11:17 »
Citar
Bem, essa dica de mover o programa para a pasta virtual quebrou o galho, porém, tive que mover todas as pastas do programa e usar na pasta pessoal, porque senão não funciona. (ele volta as configurações originais quando copio de volta). Tambem tentei esse negócio do gksudo. mesma coisa. O programa esta em outra partição, NTFS.
Eu desconfiava dessa partição NTFS. Ela deve tá sendo montada com opção de não execução. Como você tá montando esta partição?
Se for pelo fstab, posta ele aqui.
T+.
Ubuntu 12.04

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Não consigo mudar permissões de arquivos pelo Nautilus!
« Resposta #6 Online: 03 de Novembro de 2010, 10:48 »
Você não deveria tentar executar programas Linux a partir de uma partição que não é nativa. Pra isso há a opção "noexec" na montagem de partições. Há uma boa chance dela ser assumida automaticamente na montagem de partições ntfs.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline pichorra

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Re: Não consigo mudar permissões de arquivos pelo Nautilus!
« Resposta #7 Online: 03 de Novembro de 2010, 15:31 »
aparentemente, ele não monta pelo fstab, e eu não tenho a mínima ideia de como monta :P

meu fstab:

Código: [Selecionar]
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda3 during installation
UUID=472d6f3f-c309-465d-a9b6-bf759ea58cf8 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda4 during installation
UUID=af168bb1-fcce-4bbe-b61c-65d3744140da none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

Offline RonaldoRG

  • Usuário Ubuntu
  • *
  • Mensagens: 659
    • Ver perfil
    • Twitter: @rafas_andrade
Re: Não consigo mudar permissões de arquivos pelo Nautilus!
« Resposta #8 Online: 03 de Novembro de 2010, 15:48 »
Pra abrir essa partição você vai em Locais e clica na sua partição NTFS né?
Aqui eu fiz com que ela apareça montada automaticamente na inicialização do sistema através do fstab assim:
Código: [Selecionar]
/dev/sda5 /media/Dados    ntfs defaults 0 2Assim eu consigo executar programas nela.
T+.
Ubuntu 12.04

Offline pichorra

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
[Resolvido] Não consigo mudar permissões de arquivos pelo Nautilus!
« Resposta #9 Online: 06 de Novembro de 2010, 10:26 »
Obrigado! isso resolveu meu problema.

[Resolvido]