Autor Tópico: Modem huawei e173, vivo 3g, ubu10.04  (Lida 45824 vezes)

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #15 Online: 17 de Novembro de 2010, 16:01 »
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 009: ID 12d1:1c0b Huawei Technologies Co., Ltd.
Bus 001 Device 003: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter
Bus 001 Device 002: ID 0402:5602 ALi Corp. Video Camera Controller
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

eis o comando lsusb

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #16 Online: 17 de Novembro de 2010, 16:04 »
usuario@ubuntu:~$ lsmod | grep usbserial
usbserial              33019  1 option
usuario@ubuntu:~$


E o outro comando

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #17 Online: 17 de Novembro de 2010, 16:19 »
sudo modprobe -r usbserial

sudo modprobe -v usbserial vendor=0x12d1 product=0x1c0b

dmesg | grep usb | tail
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #18 Online: 17 de Novembro de 2010, 16:28 »
usuario@ubuntu:~$ sudo modprobe -r usbserial
FATAL: Module usbserial is in use.
usuario@ubuntu:~$
 1o. comando

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #19 Online: 17 de Novembro de 2010, 16:31 »
usuario@ubuntu:~$ sudo modprobe -v usbserialvendor=0x12d1 product=0x1c0b
FATAL: Module usbserialvendor=0x12d1 not found.
usuario@ubuntu:~$

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #20 Online: 17 de Novembro de 2010, 16:33 »
usuario@ubuntu:~$ dmesg | grep usb | tall
Comando 'tall' não encontrado, você quis dizer:
 Comando 'tail' do pacote 'coreutils' (main)
 Comando 'wall' do pacote 'bsdutils' (main)
 Comando 'tdll' do pacote 'tdl' (universe)
 Comando 'talk' do pacote 'ytalk' (universe)
 Comando 'talk' do pacote 'talk' (universe)
 Comando 'talk' do pacote 'inetutils-talk

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #21 Online: 17 de Novembro de 2010, 16:37 »
a atualização possível está no site do desenvolvedor:
http://www.draisberghof.de/usb_modeswitch/#download

Como instalo?

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #22 Online: 17 de Novembro de 2010, 16:38 »
usuario@ubuntu:~$ dmesg | grep usb | tail
[  932.982490] usb 2-7: GSM modem (1-port) converter now attached to ttyUSB1
[  934.031306] usb 2-7: USB disconnect, address 6
[  950.688046] usb 1-7: new high speed USB device using ehci_hcd and address 9
[  951.209385] usb 1-7: configuration #1 chosen from 1 choice
[  951.245539] usb-storage: device found at 9
[  951.245547] usb-storage: waiting for device to settle before scanning
[  951.260809] usb-storage: device found at 9
[  951.260817] usb-storage: waiting for device to settle before scanning
[  956.244584] usb-storage: device scan complete
[  956.285492] usb-storage: device scan complete

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #23 Online: 17 de Novembro de 2010, 17:16 »
usuario@ubuntu:~$ sudo modprobe -v usbserialvendor=0x12d1 product=0x1c0b
FATAL: Module usbserialvendor=0x12d1 not found.
usuario@ubuntu:~$
Você não separou "usbserial" e "vendor", por isso não funcionou. Repita por favor, na sequência que eu passei.

a atualização possível está no site do desenvolvedor:
http://www.draisberghof.de/usb_modeswitch/#download

Como instalo?

Baixe os pacotes, descompacte no seu diretório HOME, entre no diretório criado, execute o comando "sudo make install" (sem "make" antes).
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #24 Online: 17 de Novembro de 2010, 17:30 »
usuario@ubuntu:~$ sudo modprobe -v usbserialvendor=0x12d1 product=0x1c0b
FATAL: Module usbserialvendor=0x12d1 not found.
usuario@ubuntu:~$
Você não separou "usbserial" e "vendor", por isso não funcionou. Repita por favor, na sequência que eu passei.

a atualização possível está no site do desenvolvedor:
http://www.draisberghof.de/usb_modeswitch/#download

Como instalo?

Baixe os pacotes, descompacte no seu diretório HOME, entre no diretório criado, execute o comando "sudo make install" (sem "make" antes).

sudo make install (qual arquivo?) .  Tentei alguns e deram mensagens de erro.

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #25 Online: 17 de Novembro de 2010, 17:34 »
falstaff@ubuntu:~$ sudo modprobe -v usbserial vendor-0x12d1 product=0x1c0b
insmod /lib/modules/2.6.32-25-generic/kernel/drivers/usb/serial/usbserial.ko vendor-0x12d1 product=0x1c0b
FATAL: Error inserting usbserial (/lib/modules/2.6.32-25-generic/kernel/drivers/usb/serial/usbserial.ko): Unknown symbol in module, or unknown parameter (see dmesg)
falstaff@ubuntu:~$


Está correto agora?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #26 Online: 17 de Novembro de 2010, 18:27 »
Cuervo, é essencial que vc verifique os comandos a serem digitados. Uma vírgula a mais ou a menos faz diferença. No caso, o comando tinha um sinal de "=" após a palavra "vendor", não um traço ("-").
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #27 Online: 17 de Novembro de 2010, 18:38 »
Cuervo, é essencial que vc verifique os comandos a serem digitados. Uma vírgula a mais ou a menos faz diferença. No caso, o comando tinha um sinal de "=" após a palavra "vendor", não um traço ("-").

falstaff@ubuntu:~$ sudo modprobe -v usbserial vendor=0x12d1 product=0x1c0b
[sudo] password for falstaff:
insmod /lib/modules/2.6.32-25-generic/kernel/drivers/usb/serial/usbserial.ko vendor=0x12d1 product=0x1c0b
falstaff@ubuntu:~$
 

 ::)
ok, desculpe.  defeito do operador

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #28 Online: 17 de Novembro de 2010, 18:47 »
Repita o comando "dmesg | grep usb | tail".
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #29 Online: 17 de Novembro de 2010, 18:50 »
Repita o comando "dmesg | grep usb | tail".

falstaff@ubuntu:~$ dmesg | grep usb | tail
[ 2802.508451] usb usb5: root hub lost power or was reset
[ 2802.508510] usb usb6: root hub lost power or was reset
[ 2802.744061] PM: resume of drv:usb dev:usb2 complete after 131.978 msecs
[ 2802.860066] usb 2-5: reset high speed USB device using ehci_hcd and address 2
[ 2803.044551] PM: resume of drv:usb dev:2-5 complete after 294.548 msecs
[ 2804.740064] usb 2-2: reset high speed USB device using ehci_hcd and address 3
[ 2804.875087] PM: resume of drv:usb dev:2-2 complete after 246.186 msecs
[ 4477.117270] usbcore: registered new interface driver usbserial
[ 4477.119382] usbcore: registered new interface driver usbserial_generic
[ 4477.119387] usbserial: USB Serial Driver core
falstaff@ubuntu:~$