Autor Tópico: Modem huawei e173, vivo 3g, ubu10.04  (Lida 46248 vezes)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #30 Online: 17 de Novembro de 2010, 19:17 »
O modem está plugado, correto? Vc chegou a instalar e/ou configurar o wvdial pro seu modem (ou pra algum outro) ?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #31 Online: 17 de Novembro de 2010, 19:19 »
O modem está plugado, correto? Vc chegou a instalar e/ou configurar o wvdial pro seu modem (ou pra algum outro) ?

me enganei.  Tentei usar uma configuração q consegui na net - copiei do arquivo baixado e colei no wvdial.conf e não deu certo.  tenho o wvdial instalado aki.

O modem continua plugado

falstaff@ubuntu:~$ sudo wvdial
[sudo] password for falstaff:
--> WvDial: Internet dialer version 1.60
--> Warning: section [Dialer Defaults] does not exist in wvdial.conf.
--> Cannot open /dev/modem: No such file or directory
--> Cannot open /dev/modem: No such file or directory
--> Cannot open /dev/modem: No such file or directory
falstaff@ubuntu:~$ sudo wvdial 3g
--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory
--> Cannot open /dev/ttyUSB0: No such file or directory

« Última modificação: 17 de Novembro de 2010, 19:31 por Cuervo »

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #32 Online: 17 de Novembro de 2010, 19:44 »
Abaixo a configuração do wvdial




 [Dialer 3g]
Modem = /dev/ttyUSB0
Baud = 921600
DialCommand = ATDT
Check Def Route = on
FlowControl = Hardware(CRTSCTS)
Username = vivo
Password = vivo
Phone = *99#
Stupid mode = 1
Auto Reconnect = off
Auto DNS = on
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Init3 = AT+CGDCONT=1,"IP","zap.vivo.com.br"
ISDN = 0
Modem Type = Analog Modem

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #33 Online: 17 de Novembro de 2010, 20:06 »
Citar
Modem = /dev/ttyUSB0
Tente mudar para "ttyUSB1".

Depois, para discar:

sudo wvdial 3g
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #34 Online: 17 de Novembro de 2010, 20:11 »
Citar
Modem = /dev/ttyUSB0
Tente mudar para "ttyUSB1".

Depois, para discar:

sudo wvdial 3g

falstaff@ubuntu:~$ sudo gedit
[sudo] password for falstaff:
falstaff@ubuntu:~$ sudo wvdial 3g
--> WvDial: Internet dialer version 1.60
--> Cannot open /dev/ttyUSB1: No such file or directory
--> Cannot open /dev/ttyUSB1: No such file or directory
--> Cannot open /dev/ttyUSB1: No such file or directory

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #35 Online: 17 de Novembro de 2010, 21:59 »
execute o comando abaixo, desplugue seu modem e plugue novamente.

chmod -x /usr/sbin/usb_modeswitch

Aguarde 1 ou 2 minutos, após plugar o modem de volta, depois execute o comando

dmesg | tail

Isso vai mostrar como seu modem é reconhecido, antes do usb-modeswitch tentar "virá-lo" em modem.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #36 Online: 17 de Novembro de 2010, 22:30 »
execute o comando abaixo, desplugue seu modem e plugue novamente.

chmod -x /usr/sbin/usb_modeswitch

Aguarde 1 ou 2 minutos, após plugar o modem de volta, depois execute o comando

dmesg | tail

Isso vai mostrar como seu modem é reconhecido, antes do usb-modeswitch tentar "virá-lo" em modem.



falstaff@ubuntu:~$ chmod -x /usr/sbin/usb_modeswitch
chmod: alterando permissões de `/usr/sbin/usb_modeswitch': Operação não permitida
falstaff@ubuntu:~$ sudo su
[sudo] password for falstaff:
root@ubuntu:/home/falstaff# chmod -x /usr/sbin/usb_modeswitch
root@ubuntu:/home/falstaff# dmesg | tail
[  221.930713] usb-storage: waiting for device to settle before scanning
[  226.928391] usb-storage: device scan complete
[  226.928418] usb-storage: device scan complete
[  226.929258] scsi 8:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
[  226.929324] scsi 9:0:0:0: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2
[  226.932729] sd 9:0:0:0: Attached scsi generic sg1 type 0
[  226.937718] sd 9:0:0:0: [sdb] Attached SCSI removable disk
[  226.938456] sr0: scsi-1 drive
[  226.938910] sr 8:0:0:0: Attached scsi CD-ROM sr0
[  226.939147] sr 8:0:0:0: Attached scsi generic sg2 type 5

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #37 Online: 17 de Novembro de 2010, 22:54 »
Isso!

Execute agora o comando abaixo, pra gente confirmar a mudança do modem.

sudo eject sr0

dmesg | tail
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #38 Online: 17 de Novembro de 2010, 22:57 »
Isso!

Execute agora o comando abaixo, pra gente confirmar a mudança do modem.

sudo eject sr0

dmesg | tail


falstaff@ubuntu:~$ sudo su
[sudo] password for falstaff:
root@ubuntu:/home/falstaff# sudo eject sr0

root@ubuntu:/home/falstaff# dmesg | tail
[ 1136.241413] wlan0: direct probe to AP 00:25:86:c6:7f:a0 (try 1)
[ 1136.244480] wlan0: direct probe responded
[ 1136.244485] wlan0: authenticate with AP 00:25:86:c6:7f:a0 (try 1)
[ 1136.247534] wlan0: authenticated
[ 1136.247553] wlan0: associate with AP 00:25:86:c6:7f:a0 (try 1)
[ 1136.444055] wlan0: associate with AP 00:25:86:c6:7f:a0 (try 2)
[ 1136.448662] wlan0: RX AssocResp from 00:25:86:c6:7f:a0 (capab=0x431 status=0 aid=3)
[ 1136.448667] wlan0: associated
[ 1136.449112] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1147.280053] wlan0: no IPv6 routers present
root@ubuntu:/home/falstaff#

root@ubuntu:/home/falstaff# dmesg |tail
[ 1136.241413] wlan0: direct probe to AP 00:25:86:c6:7f:a0 (try 1)
[ 1136.244480] wlan0: direct probe responded
[ 1136.244485] wlan0: authenticate with AP 00:25:86:c6:7f:a0 (try 1)
[ 1136.247534] wlan0: authenticated
[ 1136.247553] wlan0: associate with AP 00:25:86:c6:7f:a0 (try 1)
[ 1136.444055] wlan0: associate with AP 00:25:86:c6:7f:a0 (try 2)
[ 1136.448662] wlan0: RX AssocResp from 00:25:86:c6:7f:a0 (capab=0x431 status=0 aid=3)
[ 1136.448667] wlan0: associated
[ 1136.449112] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1147.280053] wlan0: no IPv6 routers present
root@ubuntu:/home/falstaff#
« Última modificação: 17 de Novembro de 2010, 23:00 por Cuervo »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #39 Online: 18 de Novembro de 2010, 13:21 »
Não, não funcionou. :-[

Vamos voltar o "usb_modeswitch" ao normal.

sudo chmod +x /usr/sbin/usb_modeswitch

Vc chegou a baixar os pacotes de atualização do site do desenvolvedor do usb-modeswitch?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #40 Online: 19 de Novembro de 2010, 06:01 »
Não, não funcionou. :-[

Vamos voltar o "usb_modeswitch" ao normal.

sudo chmod +x /usr/sbin/usb_modeswitch

Vc chegou a baixar os pacotes de atualização do site do desenvolvedor do usb-modeswitch?

Oba!

Estou num outro micro onde enfrento o mesmo problema. Uma vez baixados os pacotes, quais os comandos seguintes?
« Última modificação: 19 de Novembro de 2010, 06:10 por Cuervo »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #41 Online: 19 de Novembro de 2010, 10:53 »
Vc deve descompactar os pacotes baixados, entrar no diretório criado ao descompactar, e executar o comando

sudo make install
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #42 Online: 19 de Novembro de 2010, 12:08 »
Vc deve descompactar os pacotes baixados, entrar no diretório criado ao descompactar, e executar o comando

sudo make install

Sem citar qualquer arquivo em especial após o comando?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #43 Online: 19 de Novembro de 2010, 12:09 »
Sim, sem citar mais nada.

Também não é pra tentar compilar nada, portanto nada de "sudo make" ou "make"; é pra ir direto ao "sudo make install" mesmo.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Cuervo

  • Usuário Ubuntu
  • *
  • Mensagens: 51
    • Ver perfil
Re: Modem huawei e173, vivo 3g, ubu10.04
« Resposta #44 Online: 19 de Novembro de 2010, 12:19 »
root@ubuntu:/home/a/a114# sudo make install
gcc -o usb_modeswitch usb_modeswitch.c -Wall -l usb
usb_modeswitch.c:56:17: error: usb.h: Arquivo ou diretório não encontrado
usb_modeswitch.c: In function ‘main’:
usb_modeswitch.c:342: warning: implicit declaration of function ‘usb_init’
usb_modeswitch.c:345: warning: implicit declaration of function ‘usb_set_debug’
usb_modeswitch.c:347: warning: implicit declaration of function ‘usb_find_busses’
usb_modeswitch.c:348: warning: implicit declaration of function ‘usb_find_devices’
usb_modeswitch.c:391: error: dereferencing pointer to incomplete type
usb_modeswitch.c:392: error: dereferencing pointer to incomplete type
usb_modeswitch.c:394: warning: implicit declaration of function ‘usb_open’
usb_modeswitch.c:394: warning: assignment makes pointer from integer without a cast
usb_modeswitch.c:401: error: dereferencing pointer to incomplete type
usb_modeswitch.c:403: error: dereferencing pointer to incomplete type
usb_modeswitch.c:405: error: dereferencing pointer to incomplete type
usb_modeswitch.c:555: warning: implicit declaration of function ‘usb_close’
usb_modeswitch.c: In function ‘deviceDescription’:
usb_modeswitch.c:569: error: dereferencing pointer to incomplete type
usb_modeswitch.c:570: warning: implicit declaration of function ‘usb_get_string_simple’
usb_modeswitch.c:570: error: dereferencing pointer to incomplete type
usb_modeswitch.c:579: error: dereferencing pointer to incomplete type
usb_modeswitch.c:580: error: dereferencing pointer to incomplete type
usb_modeswitch.c:589: error: dereferencing pointer to incomplete type
usb_modeswitch.c:590: error: dereferencing pointer to incomplete type
usb_modeswitch.c: In function ‘deviceInquire’:
usb_modeswitch.c:622: warning: implicit declaration of function ‘usb_claim_interface’
usb_modeswitch.c:627: warning: implicit declaration of function ‘usb_clear_halt’
usb_modeswitch.c:629: warning: implicit declaration of function ‘usb_bulk_write’
usb_modeswitch.c:635: warning: implicit declaration of function ‘usb_bulk_read’
usb_modeswitch.c:662: warning: implicit declaration of function ‘usb_release_interface’
usb_modeswitch.c: In function ‘resetUSB’:
usb_modeswitch.c:678: warning: implicit declaration of function ‘sleep’
usb_modeswitch.c:680: warning: implicit declaration of function ‘usb_reset’
usb_modeswitch.c: In function ‘switchSendMessage’:
usb_modeswitch.c:732: warning: implicit declaration of function ‘usleep’
usb_modeswitch.c: In function ‘switchConfiguration’:
usb_modeswitch.c:797: warning: implicit declaration of function ‘usb_set_configuration’
usb_modeswitch.c: In function ‘switchAltSetting’:
usb_modeswitch.c:813: warning: implicit declaration of function ‘usb_set_altinterface’
usb_modeswitch.c: In function ‘switchHuaweiMode’:
usb_modeswitch.c:830: warning: implicit declaration of function ‘usb_control_msg’
usb_modeswitch.c:830: error: ‘USB_TYPE_STANDARD’ undeclared (first use in this function)
usb_modeswitch.c:830: error: (Each undeclared identifier is reported only once
usb_modeswitch.c:830: error: for each function it appears in.)
usb_modeswitch.c:830: error: ‘USB_RECIP_DEVICE’ undeclared (first use in this function)
usb_modeswitch.c:830: error: ‘USB_REQ_SET_FEATURE’ undeclared (first use in this function)
usb_modeswitch.c: In function ‘switchSonyMode’:
usb_modeswitch.c:916: warning: assignment makes pointer from integer without a cast
usb_modeswitch.c: In function ‘detachDriver’:
usb_modeswitch.c:952: warning: implicit declaration of function ‘usb_get_driver_np’
usb_modeswitch.c:968: warning: implicit declaration of function ‘usb_detach_kernel_driver_np’
usb_modeswitch.c: In function ‘checkSuccess’:
usb_modeswitch.c:1055: warning: assignment makes pointer from integer without a cast
usb_modeswitch.c:1061: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1061: error: dereferencing pointer to incomplete type
usb_modeswitch.c: In function ‘search_devices’:
usb_modeswitch.c:1174: warning: implicit declaration of function ‘usb_get_busses’
usb_modeswitch.c:1174: warning: assignment makes pointer from integer without a cast
usb_modeswitch.c:1174: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1176: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1176: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1178: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1178: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1179: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1200: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1207: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1207: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1209: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1219: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1228: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1230: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1233: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1234: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1261: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1261: error: dereferencing pointer to incomplete type
usb_modeswitch.c: In function ‘find_first_bulk_output_endpoint’:
usb_modeswitch.c:1283: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1286: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1287: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1288: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1288: error: ‘USB_ENDPOINT_TYPE_MASK’ undeclared (first use in this function)
usb_modeswitch.c:1288: error: ‘USB_ENDPOINT_TYPE_BULK’ undeclared (first use in this function)
usb_modeswitch.c:1289: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1289: error: ‘USB_ENDPOINT_DIR_MASK’ undeclared (first use in this function)
usb_modeswitch.c:1290: error: dereferencing pointer to incomplete type
usb_modeswitch.c: In function ‘find_first_bulk_input_endpoint’:
usb_modeswitch.c:1301: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1304: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1305: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1306: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1306: error: ‘USB_ENDPOINT_TYPE_MASK’ undeclared (first use in this function)
usb_modeswitch.c:1306: error: ‘USB_ENDPOINT_TYPE_BULK’ undeclared (first use in this function)
usb_modeswitch.c:1307: error: dereferencing pointer to incomplete type
usb_modeswitch.c:1307: error: ‘USB_ENDPOINT_DIR_MASK’ undeclared (first use in this function)
usb_modeswitch.c:1308: error: dereferencing pointer to incomplete type
make: ** [usb_modeswitch] Erro 1
root@ubuntu:/home/a/a114#


Este foi o usb modeswitch.  tentei também. com o nome original da pasta.  Renomeei-a para 'a114' para evitar erros de digitação.