Autor Tópico: mexi na configuração do ip no ubuntu 10.10 e a internet parou. Resolvido!  (Lida 3283 vezes)

Offline LUIZ FILIPE

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Boa tarde, sou novo no ubuntu! Instalei o ubuntu 10.10 já à algum tempo e tudo estava normal até que fui mexer nas configurações de rede sem fio. coloquei no modo manual e alterei para o endereço que uso no windows. ai parou de conectar a internet e de enxergar a rede windows dos outro pcs da rede. "antes funcionava tudo normal" depois coloquei no modo automático e não resolveu também.

o ip no windows fica assim:

 Configuração de IP do Windows

        Nome do host . . . . . . . . . . . : FILIPE
        Sufixo DNS primário. . . . . . . . :
        Tipo de nó . . . . . . . . . . . . : desconhecido
        Roteamento de IP ativado . . . . . : não
        Proxy WINS ativado . . . . . . . . : não

Adaptador Ethernet Conexão de rede sem fio 2:

        Sufixo DNS específico de conexão  . :
        Descrição . . . . . . . . . . . . . : D-Link Wireless G DWA-510 Desktop
Adapter #2
        Endereço físico . . . . . . . . . . : 00-1B-11-B0-AF-20
        DHCP ativado. . . . . . . . . . . . : Sim
        Configuração automática ativada . . : Sim
        Endereço IP . . . . . . . . . . . . : 192.168.2.108
        Máscara de sub-rede . . . . . . . . : 255.255.255.0
        Gateway padrão. . . . . . . . . . . : 192.168.2.1
        Servidor DHCP . . . . . . . . . . . : 192.168.2.1
        Servidores DNS. . . . . . . . . . . : 192.168.2.1
        Concessão obtida. . . . . . . . . . : terça-feira, 30 de novembro de 201
0 10:27:33
        Concessão expira. . . . . . . . . . : sexta-feira, 27 de novembro de 202
0 10:27:33

Adaptador Ethernet Conexão local 2:

        Sufixo DNS específico de conexão  . :
        Descrição . . . . . . . . . . . . . : Microsoft TV/Video Connection
        Endereço físico . . . . . . . . . . : 00-00-00-00-00-00
        DHCP ativado. . . . . . . . . . . . : Sim
        Configuração automática ativada . . : Sim
        Endereço IP de config. automática . : 0.1.0.4
        Máscara de sub-rede . . . . . . . . : 255.255.255.255
        Gateway padrão. . . . . . . . . . . :

..........................................................................................
no ubuntu eu coloquei assim:

192.168.2.108
255.255.255.0
192.168.2.1
192.168.2.1
nesta ordem.

peço a ajuda de todos para resolver sem ter que reinstalar o ubuntu, pois eu já coloque várias coisa para funcionar "fazer o cubo girar e tudo" e não queria perder.
agradeço a todos do fórum de ante-mão  pelo espaço.
 
« Última modificação: 01 de Dezembro de 2010, 09:34 por LUIZ FILIPE »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: mexi na configuração do ip no ubuntu 10.10 e a internet parou de funcionar.
« Resposta #1 Online: 30 de Novembro de 2010, 14:12 »
Ative novamente a configuração por IP automático, pois é assim que está configurado no windows.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline LUIZ FILIPE

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: mexi na configuração do ip no ubuntu 10.10 e a internet parou de funcionar.
« Resposta #2 Online: 30 de Novembro de 2010, 16:20 »
Caro zekkerj, boa tarde. Eu já coloquei no modo automático e  não conectou.

equipamentos que uso em minha rede:
Roteador 3g edmax modelo: 3g-6200n. Ip = 192.168.2.1
placa de rede D`link DWA-510

no ubuntu ele conecta na rede, só que não entra na internet e nem aparece os pcs da rede, como antes aparecia. (rede winsows)
 
eu acabei de retirar a placa e coloquei um adaptador usb (Pacific Network Pn-Usb54g) e continua com o mesmo sintoma.
acho que é alguma configuração inerente ao ip usado que esta "bloqueando a transferência de dados".
Ps. Se tiver algum comando que mostre como o ubuntu esta enxergando a rede e facilite a compreenção do probléma me diga que faço o teste e posto o resultado.
sem mais obrigado. 

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: mexi na configuração do ip no ubuntu 10.10 e a internet parou de funcionar.
« Resposta #3 Online: 30 de Novembro de 2010, 16:46 »
Retorne o adaptador original, re-crie a conexão (automática). Depois execute os comandos abaixo e cole o resultado aqui.

sudo lshw -C network

iwconfig wlan0

ifconfig -a

nm-tool

ping -c 4 8.8.8.8

ping -c 4 www.google.com
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline LUIZ FILIPE

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: mexi na configuração do ip no ubuntu 10.10 e a internet parou de funcionar.
« Resposta #4 Online: 30 de Novembro de 2010, 17:41 »
não sei se executei corretamente mais ai esta o resultado (colei tudo)
percebi que mesmo colocando automatico as configurações ela continua com o ip que coloquei.

luiz@luiz-GA-MA785GM-US2H:~$ sudo lshw -C network

[sudo] password for luiz:

  *-network               

       description: Ethernet interface

       product: RTL8111/8168B PCI Express Gigabit Ethernet controller

       vendor: Realtek Semiconductor Co., Ltd.

       physical id: 0

       bus info: pci@0000:02:00.0

       logical name: eth0

       version: 02

       serial: 00:24:1d:dc:e8:5e

       size: 10MB/s

       capacity: 1GB/s

       width: 64 bits

       clock: 33MHz

       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation

       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half ip=192.168.2.8 latency=0 link=no multicast=yes port=MII speed=10MB/s

       resources: irq:41 ioport:de00(size=256) memory:fdaff000-fdafffff memory:fdae0000-fdaeffff memory:fda00000-fda0ffff

  *-network

       description: Wireless interface

       product: RT2561/RT61 rev B 802.11g

       vendor: RaLink

       physical id: 6

       bus info: pci@0000:03:06.0

       logical name: wlan0

       version: 00

       serial: 00:1b:11:b0:af:20

       width: 32 bits

       clock: 33MHz

       capabilities: pm bus_master cap_list ethernet physical wireless

       configuration: broadcast=yes driver=rt61pci driverversion=2.6.35-22-generic firmware=N/A ip=192.168.2.108 latency=32 link=yes multicast=yes wireless=IEEE 802.11bg

       resources: irq:20 memory:fdcf0000-fdcf7fff

luiz@luiz-GA-MA785GM-US2H:~$ sudo lshw -C network

  *-network               

       description: Ethernet interface

       product: RTL8111/8168B PCI Express Gigabit Ethernet controller

       vendor: Realtek Semiconductor Co., Ltd.

       physical id: 0

       bus info: pci@0000:02:00.0

       logical name: eth0

       version: 02

       serial: 00:24:1d:dc:e8:5e

       size: 10MB/s

       capacity: 1GB/s

       width: 64 bits

       clock: 33MHz

       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation

       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half ip=192.168.2.8 latency=0 link=no multicast=yes port=MII speed=10MB/s

       resources: irq:41 ioport:de00(size=256) memory:fdaff000-fdafffff memory:fdae0000-fdaeffff memory:fda00000-fda0ffff

  *-network

       description: Wireless interface

       product: RT2561/RT61 rev B 802.11g

       vendor: RaLink

       physical id: 6

       bus info: pci@0000:03:06.0

       logical name: wlan0

       version: 00

       serial: 00:1b:11:b0:af:20

       width: 32 bits

       clock: 33MHz

       capabilities: pm bus_master cap_list ethernet physical wireless

       configuration: broadcast=yes driver=rt61pci driverversion=2.6.35-22-generic firmware=N/A ip=192.168.2.108 latency=32 link=yes multicast=yes wireless=IEEE 802.11bg

       resources: irq:20 memory:fdcf0000-fdcf7fff

luiz@luiz-GA-MA785GM-US2H:~$

luiz@luiz-GA-MA785GM-US2H:~$ iwconfig wlan0

wlan0     IEEE 802.11bg  ESSID:"SPIDER LAN HOUSE" 

          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:1F:1F:5C:3B:60   

          Bit Rate=1 Mb/s   Tx-Power=10 dBm   

          Retry  long limit:7   RTS thr:off   Fragment thr:off

          Power Management:off

          Link Quality=70/70  Signal level=-38 dBm 

          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0

          Tx excessive retries:0  Invalid misc:0   Missed beacon:0



luiz@luiz-GA-MA785GM-US2H:~$

luiz@luiz-GA-MA785GM-US2H:~$ ifconfig -a

eth0      Link encap:Ethernet  Endereço de HW 00:24:1d:dc:e8:5e 

          inet end.: 192.168.2.8  Bcast:192.168.1.255  Masc:255.255.255.0

          UP BROADCAST MULTICAST  MTU:1500  Métrica:1

          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0

          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0

          colisões:0 txqueuelen:1000

          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

          IRQ:41 Endereço de E/S:0x6000



lo        Link encap:Loopback Local 

          inet end.: 127.0.0.1  Masc:255.0.0.0

          endereço inet6: ::1/128 Escopo:Máquina

          UP LOOPBACK RUNNING  MTU:16436  Métrica:1

          pacotes RX:30 erros:0 descartados:0 excesso:0 quadro:0

          Pacotes TX:30 erros:0 descartados:0 excesso:0 portadora:0

          colisões:0 txqueuelen:0

          RX bytes:2450 (2.4 KB) TX bytes:2450 (2.4 KB)



wlan0     Link encap:Ethernet  Endereço de HW 00:1b:11:b0:af:20 

          inet end.: 192.168.2.108  Bcast:192.168.2.255  Masc:255.255.255.0

          endereço inet6: fe80::21b:11ff:feb0:af20/64 Escopo:Link

          UP BROADCAST RUNNING MULTICAST  MTU:1500  Métrica:1

          pacotes RX:57 erros:0 descartados:0 excesso:0 quadro:0

          Pacotes TX:50 erros:0 descartados:0 excesso:0 portadora:0

          colisões:0 txqueuelen:1000

          RX bytes:11765 (11.7 KB) TX bytes:11433 (11.4 KB)



luiz@luiz-GA-MA785GM-US2H:~$

luiz@luiz-GA-MA785GM-US2H:~$ nm-tool



NetworkManager Tool



State: connected



- Device: eth0 -----------------------------------------------------------------

  Type:              Wired

  Driver:            r8169

  State:             unmanaged

  Default:           no

  HW Address:        00:24:1D:DC:E8:5E



  Capabilities:

    Carrier Detect:  yes

    Speed:           10 Mb/s



  Wired Properties

    Carrier:         off





- Device: wlan0  [Auto SPIDER LAN HOUSE] ---------------------------------------

  Type:              802.11 WiFi

  Driver:            rt61pci

  State:             connected

  Default:           yes

  HW Address:        00:1B:11:B0:AF:20



  Capabilities:

    Speed:           1 Mb/s



  Wireless Properties

    WEP Encryption:  yes

    WPA Encryption:  yes

    WPA2 Encryption: yes



  Wireless Access Points (* = current AP)

    *SPIDER LAN HOUSE: Infra, 00:1F:1F:5C:3B:60, Freq 2462 MHz, Rate 54 Mb/s, Strength 100 WPA



  IPv4 Settings:

    Address:         192.168.2.108

    Prefix:          24 (255.255.255.0)

    Gateway:         192.168.2.1



    DNS:             192.168.2.1





luiz@luiz-GA-MA785GM-US2H:~$

luiz@luiz-GA-MA785GM-US2H:~$ ping -c 4 8.8.8.8

PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.



--- 8.8.8.8 ping statistics ---

4 packets transmitted, 0 received, 100% packet loss, time 3024ms



luiz@luiz-GA-MA785GM-US2H:~$

luiz@luiz-GA-MA785GM-US2H:~$ ping -c 4 www.google.com

Usage: ping [-LRUbdfnqrvVaAD] [-c count] [-i interval] [-w deadline]

            [-p pattern] [-s packetsize] [-t ttl] [-I interface]

            [-M pmtudisc-hint] [-m mark] [-S sndbuf]

            [-T tstamp-options] [-Q tos] [hop1 ...] destination

luiz@luiz-GA-MA785GM-US2H:~$

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: mexi na configuração do ip no ubuntu 10.10 e a internet parou de funcionar.
« Resposta #5 Online: 01 de Dezembro de 2010, 00:28 »
Acho que já sei o que acontece. Em algum momento, vc configurou o endereço "192.168.2.8" na interface eth0. Você não pode configurar endereços da mesma rede em interfaces diferentes, ou a máquina se perde.

Encontre onde esse endereço está configurado, e remova-o. Pode ser no próprio gerenciador de rede, ou no arquivo "/etc/network/interfaces".
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline LUIZ FILIPE

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Re: mexi na configuração do ip no ubuntu 10.10 e a internet parou de funcionar.
« Resposta #6 Online: 01 de Dezembro de 2010, 08:02 »
boas novas caro zekker, foi isso mesmo que vc falou! eu fui no setup e desabilitei a rede onboard e a internet voltou a funcionar. muito obrigado pela orientação que vc me deu. resolvido!!!  :D

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: mexi na configuração do ip no ubuntu 10.10 e a internet parou. Resolvido!
« Resposta #7 Online: 01 de Dezembro de 2010, 10:23 »
Procure pela configuração que está associada à interface eth0, e retire-a. Assim vc pode deixar essa interface ativa novamente. Nunca se sabe quando vc pode precisar dela ativa, pra se conectar num lugar onde não haja rede wireless.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D