Autor Tópico: problemas com instalação  (Lida 7361 vezes)

Offline ubuntu-br

  • Usuário Ubuntu
  • *
  • Mensagens: 235
  • Viva a Liberdade
    • Ver perfil
problemas com instalação
« Online: 02 de Dezembro de 2010, 19:27 »
boa noite estou tentando instalar o ubuntu 10.4 LTS em meu hd externo uso um hd de notbook em um case
a instalação rola, mas quando acabe de instalar e reinicia quando volta esta mensagem aparece
error: no such partition
grub rescue >
como corrigir?

Offline R.C.S.L.

  • Usuário Ubuntu
  • *
  • Mensagens: 80
  • Xubuntu 12.04 LTS
    • Ver perfil
Re: problemas com instalação
« Resposta #1 Online: 02 de Dezembro de 2010, 21:41 »
boa noite estou tentando instalar o ubuntu 10.4 LTS em meu hd externo uso um hd de notbook em um case
a instalação rola, mas quando acabe de instalar e reinicia quando volta esta mensagem aparece
error: no such partition
grub rescue >
como corrigir?


Antes de instalar, chegaste a criar partições para o seu sistema?


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com instalação
« Resposta #2 Online: 03 de Dezembro de 2010, 00:53 »
Deve ser pq o dispositivo do HD muda "de posição" após o boot, assim, o sistema procura por ele e não o encontra.

O kernel do ubuntu reconhece todas as unidades como unidades "sd": sda, sdb, sdc, etc, independente de serem IDE/ATA, SATA, ou USB. Basicamente, então, vc instala o sistema como "sdc", e ele boota como "sda". Nem sempre isso vai funcionar.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline ubuntu-br

  • Usuário Ubuntu
  • *
  • Mensagens: 235
  • Viva a Liberdade
    • Ver perfil
Re: problemas com instalação
« Resposta #3 Online: 03 de Dezembro de 2010, 03:23 »
Antes de instalar, chegaste a criar partições para o seu sistema?

sim criei as partições
« Última modificação: 04 de Dezembro de 2010, 09:22 por ubuntu-br »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: problemas com instalação
« Resposta #4 Online: 03 de Dezembro de 2010, 06:58 »
E onde instalou o grub ?

Não sei qual seu nivel de conhecimento do sistema, mas para não se perder caso conheça pouco, desconecte os hds fixos de sua maquina, deixe conectado apenas o cd rom.

Dê o boot pelo live cd do Ubuntu e faça a instalação do sistema no unico hd disponivel ( o removivel ) e o Ubuntu irá instalar o grub lá.

Depois de instalado faça o teste escolhendo (geralmente F8) nas opções de boot de sua Bios a unidade USB.

Se bootar e funcionar a contento, basta desligar, reconectar os Hd's e fim.

[]'s

Offline ubuntu-br

  • Usuário Ubuntu
  • *
  • Mensagens: 235
  • Viva a Liberdade
    • Ver perfil
Re: problemas com instalação
« Resposta #5 Online: 03 de Dezembro de 2010, 18:21 »
Tota eu fiz isso para instalar.


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com instalação
« Resposta #6 Online: 03 de Dezembro de 2010, 19:05 »
vc consegue chegar à tela do GRUB, na instalação desse HD móvel? Se conseguir, tente anotar a linha de chamada do Kernel correspondente.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline ubuntu-br

  • Usuário Ubuntu
  • *
  • Mensagens: 235
  • Viva a Liberdade
    • Ver perfil
Re: problemas com instalação
« Resposta #7 Online: 04 de Dezembro de 2010, 09:20 »
vc consegue chegar à tela do GRUB, na instalação desse HD móvel? Se conseguir, tente anotar a linha de chamada do Kernel correspondente.

cara eu não sei como fazer essas coisas. pode me ajudar?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com instalação
« Resposta #8 Online: 04 de Dezembro de 2010, 12:46 »
Sua máquina está em dual boot, ou apenas com o Linux?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline ubuntu-br

  • Usuário Ubuntu
  • *
  • Mensagens: 235
  • Viva a Liberdade
    • Ver perfil
Re: problemas com instalação
« Resposta #9 Online: 04 de Dezembro de 2010, 13:48 »
dual boot
o hd interno esta com windows e o meu portátil esta particionado parte esta formatado com ubuntu 10.4 e a outra com sistema ntfs para continuar usando como pendrive.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com instalação
« Resposta #10 Online: 04 de Dezembro de 2010, 15:15 »
Vc consegue fazer a máquina bootar diretamente do HD externo, certo? Chega a ver alguma tela de boot, dele?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline ubuntu-br

  • Usuário Ubuntu
  • *
  • Mensagens: 235
  • Viva a Liberdade
    • Ver perfil
Re: problemas com instalação
« Resposta #11 Online: 04 de Dezembro de 2010, 15:19 »
cara a pois a instalação ele reinicia e quando volta aparece a tela preta com a mensagem que eu falei e só
nada acontece.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: problemas com instalação
« Resposta #12 Online: 04 de Dezembro de 2010, 16:13 »
Aparece uma tela pra vc escolher o boot normal ou alternativo?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline ubuntu-br

  • Usuário Ubuntu
  • *
  • Mensagens: 235
  • Viva a Liberdade
    • Ver perfil
Re: problemas com instalação
« Resposta #13 Online: 04 de Dezembro de 2010, 17:18 »
consegui instalar e fazer funcionar, eu retirei o hd do case e liguei na placa mãe pelo cabo sata
o problema agora é que só funciona desta forma, quando coloquei o hd dentro do case novamente ele apresenta o mesmo problema a tela fica preta e a mensagem citada aparece e nada funciona.

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: problemas com instalação
« Resposta #14 Online: 04 de Dezembro de 2010, 21:11 »
Ok,

Vamos tentar para ver no que dá:

Dê o boot pelo live cd do Ubuntu.

Escolha experimentar sem instalar

Conecte seu Hd externo.

Monte o hd em => locais

Entre no HD e vá até => /etc/fstab

Abra o arquivo fstab, copie e cole aqui.

Entre em terminal e digite
Código: [Selecionar]
sudo blkid
Copie e cole aqui

ainda em terminal digite
Código: [Selecionar]
sudo fdisk-lcom "éle" minusculo

com isto postado vamos analisar.

Tem win seven aí, e funcionando? ( veja abaixo )

Aproveite e leia( só para voce entender, não use as dicas dos topicos
)  :

Se quiser usar as dicas, desconecte os hd's internos para não estragar o sistema ( windows )

http://ubuntuforums.org/showthread.php?t=1583881
http://ubuntuforums.org/showthread.php?t=1359802
 
[]'s