Autor Tópico: MODEM 3G ZTE MF645 VIVO - Como instalar no Ubuntu 10.10  (Lida 43819 vezes)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: MODEM 3G ZTE MF645 VIVO - Como instalar no Ubuntu 10.10
« Resposta #30 Online: 25 de Janeiro de 2011, 13:46 »
Citar
[   23.486685] usb 1-4: GSM modem (1-port) converter now attached to ttyUSB0
[   23.486873] usb 1-4: GSM modem (1-port) converter now attached to ttyUSB1
[   23.487075] usb 1-4: GSM modem (1-port) converter now attached to ttyUSB2
[   23.487243] usb 1-4: GSM modem (1-port) converter now attached to ttyUSB3
[   23.487428] usb 1-4: GSM modem (1-port) converter now attached to ttyUSB4
O modem foi reconhecido e já "virou". O negócio agora é descobrir qual dessas 5 (!!!) portas é a que deve ser usada pra conexão.

Recomendo que vc tente usá-lo pelo Gerenciador de Redes, não pelo wvdial nem pelo programa da Vivo.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline JefJr2504

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: MODEM 3G ZTE MF645 VIVO - Como instalar no Ubuntu 10.10
« Resposta #31 Online: 25 de Janeiro de 2011, 14:14 »
O modem foi reconhecido e já "virou". O negócio agora é descobrir qual dessas 5 (!!!) portas é a que deve ser usada pra conexão.

Recomendo que vc tente usá-lo pelo Gerenciador de Redes, não pelo wvdial nem pelo programa da Vivo.
É, na verdade o notebook que estou usando é um Positivo V146 e só tem 3 portas usb...
Eu só consigo conectar pelo Gerenciador de Redes mesmo, mas ele só conecta de vez em quando, às vezes (poucas) o modem tá plugado, eu ligo o ubuntu e ele já está conectado, aí eu logo como outro usuário ele desconecta e não conecta mais, nem reiniciando. Queria saber o que se passa.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: MODEM 3G ZTE MF645 VIVO - Como instalar no Ubuntu 10.10
« Resposta #32 Online: 25 de Janeiro de 2011, 14:35 »
Citar
É, na verdade o notebook que estou usando é um Positivo V146 e só tem 3 portas usb...
Não confunda as portas do modem com as portas USB da máquina. Essas não são numeradas, pelo menos não da forma como apareceu lá em cima.

Citar
Eu só consigo conectar pelo Gerenciador de Redes mesmo, mas ele só conecta de vez em quando, às vezes (poucas) o modem tá plugado, eu ligo o ubuntu e ele já está conectado, aí eu logo como outro usuário ele desconecta e não conecta mais, nem reiniciando. Queria saber o que se passa.
O Gerenciador de redes trata as conexões como um recurso pessoal. Tradução: ele cria as conexões pro seu usuário. Com outro usuário, vc tem que criar as conexões todas novamente.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline JefJr2504

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: MODEM 3G ZTE MF645 VIVO - Como instalar no Ubuntu 10.10
« Resposta #33 Online: 25 de Janeiro de 2011, 15:35 »
Citar
Não confunda as portas do modem com as portas USB da máquina. Essas não são numeradas, pelo menos não da forma como apareceu lá em cima.
Ah, certo.
Citar
O Gerenciador de redes trata as conexões como um recurso pessoal. Tradução: ele cria as conexões pro seu usuário. Com outro usuário, vc tem que criar as conexões todas novamente.
Mas eu tinha configurado lá pra exibir para todos os usuários, ela aparece do mesmo jeito pros outros usuários. Mas mesmo só no meu usuário onde eu configurei, é muito difícil ela conectar. Normalmente só o que aparece quase todas as vezes é a mensagem do Gerenciador de Redes dizendo
Citar
Rede GSM
Desconectado - você está desconectado
Eu preciso conseguir configurar essa conexão da vivo nesse modem pra minha mãe usar no netbook dela com o ubuntu 10.10 e pra isso tem que estar conectando normalmente pra ela não ter dor de cabeça pra usar.

Offline JoeLinux

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re: MODEM 3G ZTE MF645 VIVO - Como instalar no Ubuntu 10.10
« Resposta #34 Online: 06 de Fevereiro de 2011, 16:45 »
Olá JefJr2504

Alguém aí em cima nesta pilha de postings disse que infelizmente a ZTE só produziu drivers para o Ubuntu até a versão 8.04.  
Se eu ainda estivesse com paciência e tempo, instalaria aquela versão do Ubuntu só para testar.  Se o Modem funcionasse com a 8.04, ficaria tudo bem, porque o seu caso é o mesmo que o meu, ou seja, eu também estou testando para o Netbook da minha esposa.  E garanto que tanto a sua mãe quanto a minha esposa estão pouco se importando se a versão do Ubuntu é X ou Y.  Elas só querem navegar na Internet e mandar e receber e-mails. E para isso a 8.04 é mais que perfeita. Quem sabe vc ainda está com pique para esta experiência?   Ficarei na moita observando e vendo se você posta alguma resposta.  Se der certo, faço também. Com isso ficará também claro que o problema não é o Modem e sim a versão 10.10.

[ ]s
JoeLinux
« Última modificação: 06 de Fevereiro de 2011, 19:30 por JoeLinux »

Offline Link77

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: MODEM 3G ZTE MF645 VIVO - Como instalar no Ubuntu 10.10
« Resposta #35 Online: 11 de Fevereiro de 2011, 13:07 »
Eu tenho um modem 3G da VIVO model Nokia CS11.
No Windows e ubuntu 8.10 funciona perfeitamente tanto como 3G l. É só espetar na USB e ele já se oferece para instalar o programa que vem dentro dele próprio.  Voce não precisa baixar nada.

Ja no Ubuntu.........     Hein?  O modem tem lá dentro até uma pasta para Linux.   Mas quando uso no  Ubuntu 10.10, o o moden  não é reconhecido .

Eu pesso ajuda por favor.

Obrigado!

Offline Julio Viana

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: MODEM 3G ZTE MF645 VIVO - Como instalar no Ubuntu 10.10
« Resposta #36 Online: 12 de Abril de 2011, 16:31 »
Olá a todos!
Depois de bater cabeça, ler todos os tópicos disponíveis sobre a questão, sem resolver o problema da conexão do ZTE MF 645. Como eu fiz a instalação do 10.10 por cima do 10.04 (onde o modem funcionava bem), verifiquei os procedimentos que havia utilizado para ativar o modem na versão anterior. Lembrei que para versão anterior, a ativação do modem era com o comando: sudo /usr/sbin/usb_modeswitch -W -c /etc/usb_modeswitch.conf. Com a mudanças ocorridas na estrutura de arquivos do Ubuntu 10.10, o usb_mdeswitch também foi alterada, então o comando precisava ser alterado. Para ir logo ao finalmente, o comando de ativação do modem é:

sudo /usr/sbin/usb_modeswitch -W -c /etc/usb_modeswitch.d/19d2\:2000

Depois disso, foi só entrar em "Editar conexões" > "Banda Larga Móvel" e adicionar a conexão.

Espero que ajude e outros possam desfrutar disso...


Offline Levi Ubuntu

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: MODEM 3G ZTE MF645 VIVO - Como instalar no Ubuntu 10.10
« Resposta #37 Online: 15 de Abril de 2011, 23:34 »
Olá a todos!
Depois de bater cabeça, ler todos os tópicos disponíveis sobre a questão, sem resolver o problema da conexão do ZTE MF 645. Como eu fiz a instalação do 10.10 por cima do 10.04 (onde o modem funcionava bem), verifiquei os procedimentos que havia utilizado para ativar o modem na versão anterior. Lembrei que para versão anterior, a ativação do modem era com o comando: sudo /usr/sbin/usb_modeswitch -W -c /etc/usb_modeswitch.conf. Com a mudanças ocorridas na estrutura de arquivos do Ubuntu 10.10, o usb_mdeswitch também foi alterada, então o comando precisava ser alterado. Para ir logo ao finalmente, o comando de ativação do modem é:

sudo /usr/sbin/usb_modeswitch -W -c /etc/usb_modeswitch.d/19d2\:2000

Depois disso, foi só entrar em "Editar conexões" > "Banda Larga Móvel" e adicionar a conexão.

Espero que ajude e outros possam desfrutar disso...



Cara, se eu ganhasse na mega sena eu te daria uma parte do premio! Você salvou minha vida! rsrsrs. Eu uso o modem há 8 meses e sempre conectei pelo wvdial com o arquivo '/etc/wvdial.conf' todo configurado configurado e todas as vezes que tentava conectar pelo NetworkManager eu não conseguia, já tinha tentado de tudo. Eu nunca tinha pensado no usb_modeswitch - nas versões anteriores do ubuntu eu configurei uma vez este arquivo - e não me lembrava mais. Valeu mesmo. E viva a liberdade! Viva o Linux e seu usuário experts. ;D ;D 8)
Usuário livre!

Offline chicao11

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: MODEM 3G ZTE MF645 VIVO - Como instalar no Ubuntu 10.10
« Resposta #38 Online: 21 de Abril de 2011, 12:49 »
Fiz tudo o que foi falado no tópico mas o programa fica Inicializando eternamente e n me deixa conectar... alguma luz?
Obs: consegui abrir o "discador" e conectar, mas daí fui digitar o último comando citado no terminal e daí n consegui mais nada... fica inicializando.....
Tem como reverter este último comando?
« Última modificação: 21 de Abril de 2011, 12:57 por chicao11 »

Offline Levi Ubuntu

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: MODEM 3G ZTE MF645 VIVO - Como instalar no Ubuntu 10.10
« Resposta #39 Online: 23 de Junho de 2011, 22:50 »
Instalei o Natty (11.04) e o modem só conectou uma vez e nunca mais. Então 'surfando' na pasta do discador da Vivo (LinuxUI>VivoBra_LinuxUI>Vivo_3G>Data>etc) vi o arquivo 'wvdial.conf', abri-o e, para minha surpresa eram as configurações do discador. Simplesmente copiei para o 'meu' arquivo do wvdial em '/etc/wvdial.conf', conectei o modem, aguardei o led ficar azul e piscando, entrei no terminal e digitei sudo wvdial, digitei minha senha e pronto estava conectado. Sem mais problemas com o Networkmanager e o Vivo_3G.
« Última modificação: 26 de Junho de 2011, 15:03 por Levi Ubuntu »
Usuário livre!

Offline nomade

  • O negócio não tem alma
  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.192
  • O negócio não tem alma
    • Ver perfil
Re: MODEM 3G ZTE MF645 VIVO - Como instalar no Ubuntu 10.10
« Resposta #40 Online: 25 de Dezembro de 2012, 18:17 »
Sei que esse tópico já tá parado faz tempo, mas tenho esse modem e tive a curiosidade de usar o software que vem nele pra ver se funcionava (apesar de usá-lo já pelo wvdial) e não me arrependí.
Pra quem tem esse modem e quer usar o software que vem nele (tanto da vivo quanto da claro), funciona numa boa e com muita estabilidade, só faltou a galera fazer uma coisa depois de instalar o software "discador".
O discador usa o wvdial, por isso se não rodar a configuração do wvdial antes de usar o software não vai funcionar, pois o software não vai enxergar o modem. Então depois de instalar o discador dê o seguinte comando:
Código: [Selecionar]
sudo wvdialconf
pronto, agora o modem vai ser reconhecido pelo "discador" e poderá clicar em conectar.

Obs.: Pra quem usa Ubuntu 64Bits terá que instalar o ia32-libs pelo synaptic antes de instalar o discador, se não vai dar erro com as dependências.
« Última modificação: 25 de Dezembro de 2012, 20:21 por nomade »
Ubuntu Studio 22.04 LTS

Offline nunesbm

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re: MODEM 3G ZTE MF645 VIVO - Como instalar no Ubuntu 10.10
« Resposta #41 Online: 02 de Fevereiro de 2013, 14:18 »
Boa Tarde nomade,
Fiz este procedimento que vc comentou (sudo wvdialconf) porem ainda assim o "discador" acusa que o modem não está na máquina.
Sabe o que pode ser?

(Só para situar, estou tentando usar o Modem 3G no Ubuntu 12.04 de um Aspire One)

Obrigado

Offline nomade

  • O negócio não tem alma
  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.192
  • O negócio não tem alma
    • Ver perfil
Re: MODEM 3G ZTE MF645 VIVO - Como instalar no Ubuntu 10.10
« Resposta #42 Online: 02 de Fevereiro de 2013, 20:02 »
Então, observei esse problema num notebook samsung recetemente, não descobri o porquê.

Então, configura o wvdial como é explicado nesse tópico
Citar
http://ubuntuforum-br.org/index.php/topic,65919.60.html
, por alguns usuários e inicie o modem pelo terminal. Ele vai funcionar com certeza com o wvdial, com toda estabilidade, melhor que com o software proprietário.

Interessante é que depois de iniciado uma vez pelo wvdial o modem passa a ser reconhecido pelo software. Mas... depois de reiniciar dá o mesmo problema novamente. Então, fique só com o wvdial.
Ubuntu Studio 22.04 LTS